rebuilt in devel [release 0.5-2mamba;Tue Aug 30 2011]
This commit is contained in:
parent
1692d53699
commit
7419bd4726
@ -1,2 +1,6 @@
|
|||||||
# spacenavd
|
# spacenavd
|
||||||
|
|
||||||
|
Spacenavd, is a free software replacement user-space driver (daemon), for 3Dconnexion's space-something 6dof input devices. It's compatible with the original 3dxsrv proprietary daemon provided by 3Dconnexion, and works perfectly with any program that was written for the 3Dconnexion driver.
|
||||||
|
|
||||||
|
For more info on the spacenav project, visit: http://spacenav.sourceforge.net
|
||||||
|
|
||||||
|
21
spacenavd-0.5-Makefile_in.patch
Normal file
21
spacenavd-0.5-Makefile_in.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
--- Makefile.in 2010-06-07 02:47:02.000000000 +0200
|
||||||
|
+++ Makefile.in-gil 2011-02-02 15:40:09.000000000 +0100
|
||||||
|
@@ -1,3 +1,5 @@
|
||||||
|
+DESTDIR =
|
||||||
|
+
|
||||||
|
src = $(wildcard src/*.c) $(wildcard src/serial/*.c)
|
||||||
|
hdr = $(wildcard src/*.h) $(wildcard src/serial/*.h)
|
||||||
|
obj = $(src:.c=.o)
|
||||||
|
@@ -24,9 +26,9 @@
|
||||||
|
|
||||||
|
.PHONY: install
|
||||||
|
install: $(bin)
|
||||||
|
- $(INSTALL) -d $(PREFIX)/bin
|
||||||
|
- $(INSTALL) -m 755 $(bin) $(PREFIX)/bin/$(bin)
|
||||||
|
- $(INSTALL) -m 755 $(srcdir)/$(ctl) $(PREFIX)/bin/$(ctl)
|
||||||
|
+ $(INSTALL) -d $(DESTDIR)$(PREFIX)/bin
|
||||||
|
+ $(INSTALL) -m 755 $(bin) $(DESTDIR)$(PREFIX)/bin/$(bin)
|
||||||
|
+ $(INSTALL) -m 755 $(srcdir)/$(ctl) $(DESTDIR)$(PREFIX)/bin/$(ctl)
|
||||||
|
cd $(srcdir) && ./setup_init --no-install
|
||||||
|
|
||||||
|
# [ -d /etc/hal/fdi/policy ] && \
|
80
spacenavd.spec
Normal file
80
spacenavd.spec
Normal file
@ -0,0 +1,80 @@
|
|||||||
|
Name: spacenavd
|
||||||
|
Version: 0.5
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: Spacenav Daemon
|
||||||
|
Group: System/Tools
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: gil <puntogil@libero.it>
|
||||||
|
URL: http://spacenav.sourceforge.net/
|
||||||
|
Source: http://downloads.sourceforge.net/project/spacenav/spacenav%20daemon/spacenavd%20%{version}/spacenavd-%{version}.tar.gz
|
||||||
|
Patch0: spacenavd-0.5-Makefile_in.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%description
|
||||||
|
Spacenavd, is a free software replacement user-space driver (daemon), for 3Dconnexion's space-something 6dof input devices. It's compatible with the original 3dxsrv proprietary daemon provided by 3Dconnexion, and works perfectly with any program that was written for the 3Dconnexion driver.
|
||||||
|
|
||||||
|
For more info on the spacenav project, visit: http://spacenav.sourceforge.net
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}-%{version}
|
||||||
|
%patch0 -p0
|
||||||
|
|
||||||
|
sed -i "s|DAEMON=/usr/local/bin/spacenavd|DAEMON=%{_bindir}/spacenavd|" init_script
|
||||||
|
|
||||||
|
%build
|
||||||
|
%configure
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
%makeinstall
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_initrddir}
|
||||||
|
install -pm 0755 init_script %{buildroot}%{_initrddir}/spacenavd
|
||||||
|
|
||||||
|
mkdir -p %{buildroot}%{_sysconfdir}
|
||||||
|
install -pm 644 doc/example-spnavrc %{buildroot}%{_sysconfdir}/spnavrc
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%pre
|
||||||
|
/usr/sbin/groupadd spacenavd -g 66 2>/dev/null
|
||||||
|
/usr/sbin/useradd -u 66 -c 'Spacenav Daemon' -d /dev/null \
|
||||||
|
-g spacenavd -s /bin/false spacenavdn 2>/dev/null
|
||||||
|
|
||||||
|
%post
|
||||||
|
if [ $1 -eq 1 ]; then
|
||||||
|
/sbin/chkconfig --add spacenavd
|
||||||
|
/sbin/service spacenavd start
|
||||||
|
fi
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
%preun
|
||||||
|
if [ $1 -eq 0 ]; then
|
||||||
|
%{_initrddir}/spacenavd stop 2>/dev/null
|
||||||
|
/sbin/chkconfig --del spacenavd
|
||||||
|
/usr/sbin/userdel spacenavd 2>/dev/null
|
||||||
|
fi
|
||||||
|
exit 0
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%config(noreplace) %{_sysconfdir}/spnavrc
|
||||||
|
%{_initrddir}/spacenavd
|
||||||
|
%{_bindir}/spacenavd
|
||||||
|
%{_bindir}/spnavd_ctl
|
||||||
|
%doc AUTHORS COPYING README
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Tue Aug 30 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5-2mamba
|
||||||
|
- rebuilt in devel
|
||||||
|
|
||||||
|
* Wed Feb 02 2011 gil <puntogil@libero.it> 0.5-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user