rebuilt by autoport with build requirements: libx265-devel>=0:4.0-1mamba [release 2.8.1-3mamba;Sun Nov 10 2024]
This commit is contained in:
parent
b881d2d794
commit
0aacd26590
23
avidemux-2.8.1-x265-4.0.patch
Normal file
23
avidemux-2.8.1-x265-4.0.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff -ru avidemux_2.8.1.orig/avidemux_plugins/ADM_videoEncoder/x265/ADM_x265.cpp avidemux_2.8.1/avidemux_plugins/ADM_videoEncoder/x265/ADM_x265.cpp
|
||||
--- avidemux_2.8.1.orig/avidemux_plugins/ADM_videoEncoder/x265/ADM_x265.cpp 2024-10-12 10:07:58.005741891 +0200
|
||||
+++ avidemux_2.8.1/avidemux_plugins/ADM_videoEncoder/x265/ADM_x265.cpp 2024-10-12 11:12:13.519781376 +0200
|
||||
@@ -205,8 +205,8 @@
|
||||
//
|
||||
x265_nal *nal;
|
||||
uint32_t nbNal = 0;
|
||||
- x265_picture pic_out;
|
||||
- api->picture_init(¶m,&pic_out);
|
||||
+ x265_picture *pic_out;
|
||||
+ api->picture_init(¶m,pic_out);
|
||||
out->flags = 0;
|
||||
|
||||
int er;
|
||||
@@ -236,7 +236,7 @@
|
||||
|
||||
|
||||
// 3-encode
|
||||
- if(false==postAmble(out,nbNal,nal,&pic_out))
|
||||
+ if(false==postAmble(out,nbNal,nal,pic_out))
|
||||
{
|
||||
ADM_warning("[x265] postAmble failed\n");
|
||||
return false;
|
@ -1,7 +1,7 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: avidemux
|
||||
Version: 2.8.1
|
||||
Release: 2mamba
|
||||
Release: 3mamba
|
||||
Summary: Graphical video editing tool
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
@ -11,9 +11,14 @@ URL: http://fixounet.free.fr/avidemux/
|
||||
Source: http://downloads.sourceforge.net/project/avidemux/avidemux/%{version}/avidemux_%{version}.tar.gz
|
||||
Source1: avidemux-2.8.1-binutils-2.41.patch
|
||||
Patch0: avidemux-2.8.1-dont_hide_build_output.patch
|
||||
Patch1: avidemux-2.8.1-x265-4.0.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libQt5Core
|
||||
BuildRequires: libQt5Gui
|
||||
BuildRequires: libQt5Network
|
||||
BuildRequires: libQt5Widgets
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXv-devel
|
||||
@ -46,9 +51,8 @@ BuildRequires: libx264-devel
|
||||
BuildRequires: libx265-devel
|
||||
BuildRequires: libxvidcore-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libx265-devel >= 3.6-1mamba
|
||||
BuildRequires: libx265-devel >= 0:4.0-1mamba
|
||||
BuildRequires: automake
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: gcc
|
||||
@ -116,14 +120,17 @@ This package contains static libraries and header files needed for development.
|
||||
%prep
|
||||
%setup -q -n avidemux_%{version}
|
||||
%patch 0 -p1 -b .dont_hide_build_output
|
||||
%patch 1 -p1 -b .x265-4.0
|
||||
# From Arch
|
||||
sed -i 's|../avidemux/qt4|../avidemux/qt4 -DLRELEASE_EXECUTABLE=/usr/bin/lrelease-qt5|' bootStrap.bash
|
||||
sed -e 's|0.19|1.0|' -i avidemux_plugins/ADM_videoFilters6/ass/CMakeLists.txt
|
||||
# FIXME: build fails if nvenc detected
|
||||
sed -i 's|USE_NVENC True|USE_NVENC False|' cmake/admCheckNvEnc.cmake
|
||||
|
||||
cp %{SOURCE1} avidemux_core/ffmpeg_package/patches/upstream
|
||||
|
||||
%build
|
||||
sh ./bootStrap.bash --with-cli --with-plugins
|
||||
sh ./bootStrap.bash --with-core --with-cli --with-plugins
|
||||
|
||||
for f in build*; do
|
||||
%make -C $f
|
||||
@ -229,6 +236,9 @@ ln -s avidemux3_qt5 %{buildroot}%{_bindir}/avidemux
|
||||
#%doc README
|
||||
|
||||
%changelog
|
||||
* Sun Nov 10 2024 Automatic Build System <autodist@mambasoft.it> 2.8.1-3mamba
|
||||
- rebuilt by autoport with build requirements: libx265-devel>=0:4.0-1mamba
|
||||
|
||||
* Sat May 04 2024 Automatic Build System <autodist@mambasoft.it> 2.8.1-2mamba
|
||||
- rebuilt by autoport with build requirements: libx265-devel>=3.6-1mamba
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user