rebuilt by autoport with build requirements: libx265-devel>=3.6-1mamba [release 2.8.1-2mamba;Sat May 04 2024]
This commit is contained in:
parent
1a804cbe8a
commit
b881d2d794
@ -1,40 +0,0 @@
|
||||
diff -ur avidemux_2.4.3.orig/avidemux/ADM_codecs/ADM_x264.cpp avidemux_2.4.3/avidemux/ADM_codecs/ADM_x264.cpp
|
||||
--- avidemux_2.4.3.orig/avidemux/ADM_codecs/ADM_x264.cpp 2008-10-09 01:45:06.048940024 -0700
|
||||
+++ avidemux_2.4.3/avidemux/ADM_codecs/ADM_x264.cpp 2008-10-09 01:49:07.606940126 -0700
|
||||
@@ -109,8 +109,14 @@
|
||||
MKPARAM(i_bframe,MaxBFrame);
|
||||
MKPARAM(i_bframe_bias,Bias);
|
||||
MKPARAM( b_bframe_pyramid,BasReference );
|
||||
+#if X264_BUILD < 65
|
||||
MKPARAM(analyse. b_bidir_me,BidirME );
|
||||
+#endif
|
||||
+#if X264_BUILD >= 63
|
||||
+ MKPARAM( i_bframe_adaptive, Adaptative);
|
||||
+#else
|
||||
MKPARAM( b_bframe_adaptive, Adaptative);
|
||||
+#endif
|
||||
MKPARAM( analyse.b_weighted_bipred, Weighted);
|
||||
MKPARAM( b_cabac , CABAC);
|
||||
MKPARAM( analyse.i_trellis, Trellis);
|
||||
@@ -118,12 +124,16 @@
|
||||
#define MIN_RDO 6
|
||||
if(zparam->PartitionDecision+1>=MIN_RDO)
|
||||
{
|
||||
- int rank,parity;
|
||||
- rank=((zparam->PartitionDecision+1-MIN_RDO)>>1)+MIN_RDO;
|
||||
- parity=(zparam->PartitionDecision+1-MIN_RDO)&1;
|
||||
+#if X264_BUILD >= 65
|
||||
+ param.analyse.i_subpel_refine = zparam->PartitionDecision + 1;
|
||||
+#else
|
||||
+ int rank,parity;
|
||||
+ rank=((zparam->PartitionDecision+1-MIN_RDO)>>1)+MIN_RDO;
|
||||
+ parity=(zparam->PartitionDecision+1-MIN_RDO)&1;
|
||||
|
||||
- param.analyse.i_subpel_refine=rank;
|
||||
- param.analyse.b_bframe_rdo=parity;
|
||||
+ param.analyse.i_subpel_refine=rank;
|
||||
+ param.analyse.b_bframe_rdo=parity;
|
||||
+#endif
|
||||
}
|
||||
MKPARAM(analyse.b_chroma_me,ChromaME);
|
||||
MKPARAM(b_deblocking_filter,DeblockingFilter);
|
@ -1,170 +0,0 @@
|
||||
--- avidemux_2.5.0/avidemux/ADM_core/include/ADM_misc.h.ark 2009-06-21 16:50:12.412942889 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_core/include/ADM_misc.h 2009-06-21 16:50:18.760943176 +0200
|
||||
@@ -10,7 +10,7 @@
|
||||
#define ADM_MISC_H
|
||||
|
||||
#include "ADM_coreConfig.h"
|
||||
-
|
||||
+#include <stdint.h>
|
||||
|
||||
typedef struct
|
||||
{
|
||||
--- avidemux_2.5.0/avidemux/ADM_core/src/ADM_fileio.cpp.ark 2009-06-21 16:35:38.140135807 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_core/src/ADM_fileio.cpp 2009-06-21 16:35:51.867969517 +0200
|
||||
@@ -681,7 +681,7 @@ void ADM_PathStripName(char *str)
|
||||
*/
|
||||
const char *ADM_GetFileName(const char *str)
|
||||
{
|
||||
- char *filename;
|
||||
+ const char *filename;
|
||||
char *filename2;
|
||||
|
||||
#ifndef __WIN32
|
||||
--- avidemux_2.5.0/avidemux/ADM_coreUI/include/DIA_coreToolkit.h.ark 2009-06-21 16:57:14.895092062 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_coreUI/include/DIA_coreToolkit.h 2009-06-21 16:57:23.752111783 +0200
|
||||
@@ -19,6 +19,8 @@
|
||||
#ifndef ADM_COREUI_TOOLKIT__
|
||||
#define ADM_COREUI_TOOLKIT__
|
||||
|
||||
+#include <stdint.h>
|
||||
+
|
||||
typedef enum
|
||||
{
|
||||
ADM_LOG_NONE=0,
|
||||
--- avidemux_2.5.0/avidemux/ADM_coreUI/include/DIA_enter.h.ark 2009-06-21 16:55:46.188973629 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_coreUI/include/DIA_enter.h 2009-06-21 16:55:53.465409726 +0200
|
||||
@@ -15,6 +15,7 @@
|
||||
***************************************************************************/
|
||||
#ifndef DIA_ENTER_H
|
||||
#define DIA_ENTER_H
|
||||
+#include <stdint.h>
|
||||
|
||||
// Get a float value
|
||||
uint8_t DIA_GetFloatValue(float *value, float min, float max, const char *title, const char *legend);
|
||||
--- avidemux_2.5.0/avidemux/ADM_coreUI/include/DIA_fileSel.h.ark 2009-06-21 16:55:31.471073751 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_coreUI/include/DIA_fileSel.h 2009-06-21 16:55:39.379067926 +0200
|
||||
@@ -15,6 +15,7 @@
|
||||
|
||||
#ifndef DIA_FILESEL_H
|
||||
#define DIA_FILESEL_H
|
||||
+#include <stdint.h>
|
||||
typedef void SELFILE_CB(const char *);
|
||||
|
||||
// Associated functions type
|
||||
--- avidemux_2.5.0/avidemux/ADM_inputs/ADM_mpegdemuxer/dmx_io.cpp.ark 2009-06-21 16:40:22.066196323 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_inputs/ADM_mpegdemuxer/dmx_io.cpp 2009-06-21 16:40:29.289001011 +0200
|
||||
@@ -71,7 +71,7 @@ fileParser::~fileParser()
|
||||
*/
|
||||
uint8_t fileParser::open( const char *filename,FP_TYPE *multi )
|
||||
{
|
||||
- char *dot = NULL; // pointer to the last dot in filename
|
||||
+ const char *dot = NULL; // pointer to the last dot in filename
|
||||
uint8_t decimals = 0; // number of decimals
|
||||
char *left = NULL, *number = NULL, *right = NULL; // parts of filename (after splitting)
|
||||
|
||||
--- avidemux_2.5.0/avidemux/ADM_libraries/ADM_libmpeg2enc/yuv4mpeg_ratio.cc.ark 2009-06-21 16:42:15.574312778 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_libraries/ADM_libmpeg2enc/yuv4mpeg_ratio.cc 2009-06-21 16:42:18.926951396 +0200
|
||||
@@ -104,7 +104,7 @@ void y4m_ratio_reduce(y4m_ratio_t *r)
|
||||
|
||||
int y4m_parse_ratio(y4m_ratio_t *r, const char *s)
|
||||
{
|
||||
- char *t = strchr(s, ':');
|
||||
+ const char *t = strchr(s, ':');
|
||||
if (t == NULL) return Y4M_ERR_RANGE;
|
||||
r->n = atoi(s);
|
||||
r->d = atoi(t+1);
|
||||
--- avidemux_2.5.0/avidemux/ADM_libraries/ADM_mplex/lpcmstrm_in.cpp.ark 2009-06-21 16:43:15.988362511 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_libraries/ADM_mplex/lpcmstrm_in.cpp 2009-06-21 16:43:19.560943520 +0200
|
||||
@@ -53,7 +53,7 @@ LPCMStream::LPCMStream(IBitStream &ibs,
|
||||
|
||||
bool LPCMStream::Probe(IBitStream &bs )
|
||||
{
|
||||
- char *last_dot = strrchr( bs.StreamName(), '.' );
|
||||
+ const char *last_dot = strrchr( bs.StreamName(), '.' );
|
||||
return
|
||||
last_dot != NULL
|
||||
&& strcmp( last_dot+1, "lpcm") == 0;
|
||||
--- avidemux_2.5.0/avidemux/ADM_UIs/ADM_QT4/src/T_threadCount.h.ark 2009-06-21 16:48:26.935280369 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_UIs/ADM_QT4/src/T_threadCount.h 2009-06-21 16:48:38.041943420 +0200
|
||||
@@ -7,6 +7,7 @@
|
||||
#include <QtGui/QRadioButton>
|
||||
#include <QtGui/QSpinBox>
|
||||
#include <QtGui/QWidget>
|
||||
+#include <stdint.h>
|
||||
|
||||
namespace ADM_qt4Factory
|
||||
{
|
||||
--- avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_commonUI/ADM_tray.h.ark 2009-06-21 17:06:07.032249029 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_commonUI/ADM_tray.h 2009-06-21 17:06:13.612069717 +0200
|
||||
@@ -17,6 +17,7 @@
|
||||
|
||||
#ifndef ADM_TRAY_H
|
||||
#define ADM_TRAY_H
|
||||
+#include <stdint.h>
|
||||
|
||||
class ADM_tray
|
||||
{
|
||||
--- avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_dialog/DIA_color.cpp.ark 2009-06-21 17:00:29.869950030 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_dialog/DIA_color.cpp 2009-06-21 17:00:36.084898982 +0200
|
||||
@@ -1,4 +1,5 @@
|
||||
#include <QtGui/QColorDialog>
|
||||
+#include <stdint.h>
|
||||
|
||||
#include "ADM_toolkitQt.h"
|
||||
|
||||
@@ -17,4 +18,4 @@ int DIA_colorSel(uint8_t *r, uint8_t *g,
|
||||
}
|
||||
|
||||
return 0;
|
||||
-}
|
||||
\ No newline at end of file
|
||||
+}
|
||||
--- avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_dialog/Q_jobs.cpp.ark 2009-06-21 16:54:38.555192979 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_dialog/Q_jobs.cpp 2009-06-21 16:54:44.176068089 +0200
|
||||
@@ -6,6 +6,7 @@
|
||||
#include "Q_jobs.h"
|
||||
#include "DIA_coreToolkit.h"
|
||||
#include "ADM_toolkitQt.h"
|
||||
+#include <cstdio>
|
||||
|
||||
static void updateStatus(void);
|
||||
extern bool parseECMAScript(const char *name);
|
||||
--- avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_dialog/Q_license.cpp.ark 2009-06-21 16:53:15.590997514 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_dialog/Q_license.cpp 2009-06-21 16:53:23.719993769 +0200
|
||||
@@ -17,6 +17,7 @@
|
||||
|
||||
#include "Q_license.h"
|
||||
#include "ADM_toolkitQt.h"
|
||||
+#include <stdint.h>
|
||||
|
||||
Ui_licenseWindow::Ui_licenseWindow(QWidget *parent) : QDialog(parent)
|
||||
{
|
||||
--- avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_gui/ADM_qslider.cpp.ark 2009-06-21 17:04:44.617943090 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_gui/ADM_qslider.cpp 2009-06-21 17:04:50.589943463 +0200
|
||||
@@ -14,6 +14,7 @@ Custom slider
|
||||
|
||||
#include <QtGui/QPainter>
|
||||
#include <QtGui/QSlider>
|
||||
+#include <cstdio>
|
||||
|
||||
#include "ADM_qslider.h"
|
||||
|
||||
--- avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_gui/ADM_qslider.h.ark 2009-06-21 17:01:19.298477728 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_gui/ADM_qslider.h 2009-06-21 17:01:25.233500616 +0200
|
||||
@@ -1,5 +1,6 @@
|
||||
#ifndef ADM_Q_SLIDER_H
|
||||
#define ADM_Q_SLIDER_H
|
||||
+#include <stdint.h>
|
||||
|
||||
class ADM_QSlider : public QSlider
|
||||
{
|
||||
--- avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_gui/gui_none.cpp.ark 2009-06-21 17:04:07.237197461 +0200
|
||||
+++ avidemux_2.5.0/avidemux/ADM_userInterfaces/ADM_QT4/ADM_gui/gui_none.cpp 2009-06-21 17:04:14.105432535 +0200
|
||||
@@ -9,6 +9,7 @@
|
||||
//
|
||||
|
||||
#include "config.h"
|
||||
+#include <stdint.h>
|
||||
|
||||
#include <QtGui/QApplication>
|
||||
#include <QtGui/QDesktopWidget>
|
73
avidemux-2.8.1-binutils-2.41.patch
Normal file
73
avidemux-2.8.1-binutils-2.41.patch
Normal file
@ -0,0 +1,73 @@
|
||||
From effadce6c756247ea8bae32dc13bb3e6f464f0eb Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?R=C3=A9mi=20Denis-Courmont?= <remi@remlab.net>
|
||||
Date: Sun, 16 Jul 2023 18:18:02 +0300
|
||||
Subject: [PATCH] avcodec/x86/mathops: clip constants used with shift
|
||||
instructions within inline assembly
|
||||
|
||||
Fixes assembling with binutil as >= 2.41
|
||||
|
||||
Signed-off-by: James Almer <jamrial@gmail.com>
|
||||
---
|
||||
libavcodec/x86/mathops.h | 26 +++++++++++++++++++++++---
|
||||
1 file changed, 23 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/libavcodec/x86/mathops.h b/libavcodec/x86/mathops.h
|
||||
index 6298f5ed1983b..ca7e2dffc1076 100644
|
||||
--- a/libavcodec/x86/mathops.h
|
||||
+++ b/libavcodec/x86/mathops.h
|
||||
@@ -35,12 +35,20 @@
|
||||
static av_always_inline av_const int MULL(int a, int b, unsigned shift)
|
||||
{
|
||||
int rt, dummy;
|
||||
+ if (__builtin_constant_p(shift))
|
||||
__asm__ (
|
||||
"imull %3 \n\t"
|
||||
"shrdl %4, %%edx, %%eax \n\t"
|
||||
:"=a"(rt), "=d"(dummy)
|
||||
- :"a"(a), "rm"(b), "ci"((uint8_t)shift)
|
||||
+ :"a"(a), "rm"(b), "i"(shift & 0x1F)
|
||||
);
|
||||
+ else
|
||||
+ __asm__ (
|
||||
+ "imull %3 \n\t"
|
||||
+ "shrdl %4, %%edx, %%eax \n\t"
|
||||
+ :"=a"(rt), "=d"(dummy)
|
||||
+ :"a"(a), "rm"(b), "c"((uint8_t)shift)
|
||||
+ );
|
||||
return rt;
|
||||
}
|
||||
|
||||
@@ -113,19 +121,31 @@ __asm__ volatile(\
|
||||
// avoid +32 for shift optimization (gcc should do that ...)
|
||||
#define NEG_SSR32 NEG_SSR32
|
||||
static inline int32_t NEG_SSR32( int32_t a, int8_t s){
|
||||
+ if (__builtin_constant_p(s))
|
||||
__asm__ ("sarl %1, %0\n\t"
|
||||
: "+r" (a)
|
||||
- : "ic" ((uint8_t)(-s))
|
||||
+ : "i" (-s & 0x1F)
|
||||
);
|
||||
+ else
|
||||
+ __asm__ ("sarl %1, %0\n\t"
|
||||
+ : "+r" (a)
|
||||
+ : "c" ((uint8_t)(-s))
|
||||
+ );
|
||||
return a;
|
||||
}
|
||||
|
||||
#define NEG_USR32 NEG_USR32
|
||||
static inline uint32_t NEG_USR32(uint32_t a, int8_t s){
|
||||
+ if (__builtin_constant_p(s))
|
||||
__asm__ ("shrl %1, %0\n\t"
|
||||
: "+r" (a)
|
||||
- : "ic" ((uint8_t)(-s))
|
||||
+ : "i" (-s & 0x1F)
|
||||
);
|
||||
+ else
|
||||
+ __asm__ ("shrl %1, %0\n\t"
|
||||
+ : "+r" (a)
|
||||
+ : "c" ((uint8_t)(-s))
|
||||
+ );
|
||||
return a;
|
||||
}
|
||||
|
12
avidemux-2.8.1-dont_hide_build_output.patch
Normal file
12
avidemux-2.8.1-dont_hide_build_output.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -u -r avidemux_2.7.4/bootStrap.bash avidemux_2.7.4-fix/bootStrap.bash
|
||||
--- avidemux_2.7.4/bootStrap.bash 2019-08-15 07:25:40.000000000 +0000
|
||||
+++ avidemux_2.7.4-fix/bootStrap.bash 2020-06-05 13:40:10.633140851 +0000
|
||||
@@ -66,7 +66,7 @@
|
||||
fi
|
||||
cd $BUILDDIR
|
||||
cmake $COMPILER $PKG $FAKEROOT $QT_FLAVOR -DCMAKE_EDIT_COMMAND=vim $INSTALL_PREFIX $EXTRA $BUILD_QUIRKS $ASAN $DEBUG -G "$BUILDER" $SOURCEDIR || fail cmakeZ
|
||||
- make $PARAL >& /tmp/log$BUILDDIR || fail "make, result in /tmp/log$BUILDDIR"
|
||||
+ make $PARAL || fail make
|
||||
if [ "x$PKG" != "x" ] ; then
|
||||
$FAKEROOT_COMMAND make package DESTDIR=$FAKEROOT_DIR/tmp || fail package
|
||||
fi
|
@ -1,7 +1,7 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: avidemux
|
||||
Version: 2.8.1
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: Graphical video editing tool
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
@ -9,13 +9,11 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://fixounet.free.fr/avidemux/
|
||||
Source: http://downloads.sourceforge.net/project/avidemux/avidemux/%{version}/avidemux_%{version}.tar.gz
|
||||
Patch0: avidemux-2.4.3-x264.patch
|
||||
Patch1: avidemux-2.5.0-gcc-4.4.patch
|
||||
Patch2: avidemux2-2.6.11-x86-fix-impossible-asm-constraints.patch
|
||||
Source1: avidemux-2.8.1-binutils-2.41.patch
|
||||
Patch0: avidemux-2.8.1-dont_hide_build_output.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXv-devel
|
||||
@ -30,6 +28,7 @@ BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libfribidi-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglu-devel
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libjack-devel
|
||||
BuildRequires: liblame-devel
|
||||
@ -42,13 +41,14 @@ BuildRequires: libtwolame-devel
|
||||
BuildRequires: libva-devel
|
||||
BuildRequires: libvdpau-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libvpx6-devel
|
||||
BuildRequires: libvpx-devel
|
||||
BuildRequires: libx264-devel
|
||||
BuildRequires: libx265-devel
|
||||
BuildRequires: libxvidcore-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: qt5-qtbase-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libx265-devel >= 3.6-1mamba
|
||||
BuildRequires: automake
|
||||
BuildRequires: desktop-file-utils
|
||||
BuildRequires: gcc
|
||||
@ -109,15 +109,18 @@ Obsoletes: libavidemux2-devel <= 2.7.8-1mamba
|
||||
Avidemux2 is a graphical tool to edit AVI. It allows you to multiplex and demultiplex audio to/from video.
|
||||
It is able to cut video, import BMP, MJPEG and MPEG video, and encode them.
|
||||
You can also process video with included filters. It requires a DivX compatible encoder and the Gimp Toolkit (GTK) libraries.
|
||||
This package contains static libraries and header files need for development.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n avidemux_%{version}
|
||||
#%ifarch %{ix86}
|
||||
#%patch2 -p1
|
||||
#%endif
|
||||
%patch 0 -p1 -b .dont_hide_build_output
|
||||
# From Arch
|
||||
sed -i 's|../avidemux/qt4|../avidemux/qt4 -DLRELEASE_EXECUTABLE=/usr/bin/lrelease-qt5|' bootStrap.bash
|
||||
sed -e 's|0.19|1.0|' -i avidemux_plugins/ADM_videoFilters6/ass/CMakeLists.txt
|
||||
|
||||
cp %{SOURCE1} avidemux_core/ffmpeg_package/patches/upstream
|
||||
|
||||
%build
|
||||
sh ./bootStrap.bash --with-cli --with-plugins
|
||||
@ -226,6 +229,9 @@ ln -s avidemux3_qt5 %{buildroot}%{_bindir}/avidemux
|
||||
#%doc README
|
||||
|
||||
%changelog
|
||||
* Sat May 04 2024 Automatic Build System <autodist@mambasoft.it> 2.8.1-2mamba
|
||||
- rebuilt by autoport with build requirements: libx265-devel>=3.6-1mamba
|
||||
|
||||
* Sun Sep 18 2022 Automatic Build System <autodist@mambasoft.it> 2.8.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- avidemux_2.6.11/cmake/admFFmpegBuild.cmake.orig 2016-02-02 11:05:13.698634486 +0100
|
||||
+++ avidemux_2.6.11/cmake/admFFmpegBuild.cmake 2016-02-02 11:06:17.123634605 +0100
|
||||
@@ -29,7 +29,7 @@
|
||||
set(FFMPEG_PARSERS ac3 h263 h264 hevc mpeg4video)
|
||||
set(FFMPEG_PROTOCOLS file)
|
||||
set(FFMPEG_BSFS h264_mp4toannexb aac_adtstoasc)
|
||||
-xadd("--enable-shared --disable-static --disable-everything --disable-avfilter --enable-hwaccels --enable-postproc --enable-gpl")
|
||||
+xadd("--disable-optimizations --enable-shared --disable-static --disable-everything --disable-avfilter --enable-hwaccels --enable-postproc --enable-gpl")
|
||||
xadd("--enable-runtime-cpudetect --disable-network ")
|
||||
xadd("--enable-swscale --disable-swresample")
|
||||
xadd("--disable-doc --disable-programs")
|
Loading…
Reference in New Issue
Block a user