automatic version update by autodist [release 1.7.17-1mamba;Sun Apr 27 2014]
This commit is contained in:
parent
7d08a69b68
commit
2b829499c1
@ -1,2 +1,8 @@
|
||||
# wine
|
||||
|
||||
While Wine is usually thought of as a Windows(TM) emulator, the Wine developers would prefer that users thought of Wine as a Windows compatibility layer for UNIX.
|
||||
Wine does not require MS Windows, but it can use native system .dll files if they are available.
|
||||
|
||||
In openmamba wine is a meta-package which will install everything needed for wine to work smoothly.
|
||||
Smaller setups can be achieved by installing some of the wine-* sub packages.
|
||||
|
||||
|
12
wine-1.1.42-INQUIRY_undeclared.patch
Normal file
12
wine-1.1.42-INQUIRY_undeclared.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- wine-1.1.42/dlls/ntdll/cdrom.c.orig 2010-04-12 22:15:41.000000000 +0200
|
||||
+++ wine-1.1.42/dlls/ntdll/cdrom.c 2010-04-12 22:18:09.000000000 +0200
|
||||
@@ -2675,6 +2675,9 @@
|
||||
static NTSTATUS GetInquiryData(int fd, PSCSI_ADAPTER_BUS_INFO BufferOut, DWORD OutBufferSize)
|
||||
{
|
||||
#ifdef HAVE_SG_IO_HDR_T_INTERFACE_ID
|
||||
+# ifndef INQUIRY
|
||||
+# define INQUIRY 0x12
|
||||
+# endif
|
||||
PSCSI_INQUIRY_DATA pInquiryData = NULL;
|
||||
UCHAR sense_buffer[32];
|
||||
int iochk, version;
|
45
wine-1.5.30-restore-shared-lib.patch
Normal file
45
wine-1.5.30-restore-shared-lib.patch
Normal file
@ -0,0 +1,45 @@
|
||||
commit ce4b6451aabbe83809c7483c748cfa009cc090d6
|
||||
Author: Alexandre Julliard <julliard@winehq.org>
|
||||
Date: Fri May 10 22:01:44 2013 +0200
|
||||
|
||||
configure: Add explicit install targets in libs/wine for make_makefiles.
|
||||
|
||||
diff --git a/configure b/configure
|
||||
index d4c1f8e..ef38bfd 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -16379,7 +16379,7 @@ wine_fn_config_makefile documentation enable_documentation
|
||||
wine_fn_config_makefile fonts enable_fonts install-lib
|
||||
wine_fn_config_makefile include enable_include install-dev
|
||||
wine_fn_config_makefile libs/port enable_libs_port
|
||||
-wine_fn_config_makefile libs/wine enable_libs_wine
|
||||
+wine_fn_config_makefile libs/wine enable_libs_wine install-dev,install-lib
|
||||
wine_fn_config_makefile libs/wpp enable_libs_wpp
|
||||
wine_fn_config_makefile loader enable_loader install-lib,manpage
|
||||
wine_fn_config_program aspnet_regiis enable_aspnet_regiis install
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 6dd2348..b44673e 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -3173,7 +3173,7 @@ WINE_CONFIG_MAKEFILE([documentation])
|
||||
WINE_CONFIG_MAKEFILE([fonts],,[install-lib])
|
||||
WINE_CONFIG_MAKEFILE([include],,[install-dev])
|
||||
WINE_CONFIG_MAKEFILE([libs/port])
|
||||
-WINE_CONFIG_MAKEFILE([libs/wine])
|
||||
+WINE_CONFIG_MAKEFILE([libs/wine],,[install-dev,install-lib])
|
||||
WINE_CONFIG_MAKEFILE([libs/wpp])
|
||||
WINE_CONFIG_MAKEFILE([loader],,[install-lib,manpage])
|
||||
WINE_CONFIG_PROGRAM(aspnet_regiis,,[install])
|
||||
diff --git a/libs/wine/Makefile.in b/libs/wine/Makefile.in
|
||||
index b8dc385..7de7799 100644
|
||||
--- a/libs/wine/Makefile.in
|
||||
+++ b/libs/wine/Makefile.in
|
||||
@@ -111,4 +111,8 @@ version.c: dummy
|
||||
$(RELPATH):
|
||||
@cd $(TOOLSDIR)/tools && $(MAKE) relpath$(TOOLSEXT)
|
||||
|
||||
+# Make sure that make_makefiles sees the install rules
|
||||
+install install-lib::
|
||||
+install install-dev::
|
||||
+
|
||||
@LIBWINE_RULES@
|
11
wine-iexplore.desktop
Normal file
11
wine-iexplore.desktop
Normal file
@ -0,0 +1,11 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=Wine Internet Explorer
|
||||
GenericName=Internet Explorer
|
||||
GenericName[it]=Internet Explorer
|
||||
Exec=wine iexplore
|
||||
Icon=iexplore
|
||||
Type=Application
|
||||
Terminal=false
|
||||
X-KDE-StartupNotify=false
|
||||
Categories=X-Wine;
|
1
wine-ldconfig-32
Normal file
1
wine-ldconfig-32
Normal file
@ -0,0 +1 @@
|
||||
/usr/lib/wine
|
1
wine-ldconfig-64
Normal file
1
wine-ldconfig-64
Normal file
@ -0,0 +1 @@
|
||||
/usr/lib64/wine
|
29
wine-notepad.desktop
Normal file
29
wine-notepad.desktop
Normal file
@ -0,0 +1,29 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=Notepad
|
||||
GenericName=Notepad
|
||||
GenericName[cs]=Notepad
|
||||
GenericName[da]=Notesblok
|
||||
GenericName[de]=Editor
|
||||
GenericName[en]=Notepad
|
||||
GenericName[eo]=Notbloko
|
||||
GenericName[es]=Bloc de notas
|
||||
GenericName[fi]=Notepad
|
||||
GenericName[fr]=Bloc-notes
|
||||
GenericName[hu]=Jegyzettömb
|
||||
GenericName[it]=Blocco note
|
||||
GenericName[nl]=Kladblok
|
||||
GenericName[no]=Notisblokk
|
||||
GenericName[pl]=Notatnik
|
||||
GenericName[pt]=Notepad
|
||||
GenericName[sk]=Notepad
|
||||
GenericName[sw]=Anteckningar
|
||||
GenericName[th]=Notepad
|
||||
GenericName[tr]=Not Defteri
|
||||
GenericName[wa]=Notepad
|
||||
Exec=notepad
|
||||
Icon=notepad
|
||||
Type=Application
|
||||
Terminal=false
|
||||
X-KDE-StartupNotify=false
|
||||
Categories=X-Wine;
|
10
wine-oleview.desktop
Normal file
10
wine-oleview.desktop
Normal file
@ -0,0 +1,10 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=Wine OLE View
|
||||
GenericName=Windows OLE View
|
||||
Exec=wine oleview
|
||||
Icon=wine
|
||||
Type=Application
|
||||
Terminal=false
|
||||
X-KDE-StartupNotify=false
|
||||
Categories=X-Wine;
|
23
wine-regedit.desktop
Normal file
23
wine-regedit.desktop
Normal file
@ -0,0 +1,23 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=Regedit
|
||||
GenericName=Registry Editor
|
||||
GenericName[cs]=Editor registru
|
||||
GenericName[de]=Registry Editor
|
||||
GenericName[en]=Registry Editor
|
||||
GenericName[es]=Editor del registro
|
||||
GenericName[fr]=Éditeur de registres
|
||||
GenericName[hu]=Regisztrációs adatbázis szerkesztõ
|
||||
GenericName[it]=Editor del Registro
|
||||
GenericName[nl]=Register-editor
|
||||
GenericName[no]=Registerredigering
|
||||
GenericName[pl]=Edytor rejestru
|
||||
GenericName[pt]=Editor do Registro
|
||||
GenericName[si]=Urejevalnik registra
|
||||
GenericName[tr]=Kayýt DÜzenleyici
|
||||
Exec=regedit
|
||||
Icon=regedit
|
||||
Type=Application
|
||||
Terminal=false
|
||||
X-KDE-StartupNotify=false
|
||||
Categories=X-Wine;
|
6
wine-rootmenu.directory
Normal file
6
wine-rootmenu.directory
Normal file
@ -0,0 +1,6 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Type=Directory
|
||||
Name=Wine
|
||||
Icon=wine
|
||||
SortOrder=
|
12
wine-rootmenu.menu
Normal file
12
wine-rootmenu.menu
Normal file
@ -0,0 +1,12 @@
|
||||
<!DOCTYPE Menu PUBLIC '-//freedesktop//DTD Menu 1.0//EN'
|
||||
'http://standards.freedesktop.org/menu-spec/menu-1.0.dtd'>
|
||||
<Menu>
|
||||
<Name>Applications</Name>
|
||||
<Menu>
|
||||
<Name>wine-wine</Name>
|
||||
<Directory>wine.directory</Directory>
|
||||
<Include>
|
||||
<Category>X-Wine</Category>
|
||||
</Include>
|
||||
</Menu>
|
||||
</Menu>
|
5
wine-systemd-32
Normal file
5
wine-systemd-32
Normal file
@ -0,0 +1,5 @@
|
||||
# Pre-PE Windows Executables
|
||||
:windows:M::MZ::/usr/bin/wine:
|
||||
|
||||
# PE Windows Executables
|
||||
:windowsPE:M::PE::/usr/bin/wine:
|
5
wine-systemd-64
Normal file
5
wine-systemd-64
Normal file
@ -0,0 +1,5 @@
|
||||
# Pre-PE Windows Executables
|
||||
:windows:M::MZ::/usr/bin/wine64:
|
||||
|
||||
# PE Windows Executables
|
||||
:windowsPE:M::PE::/usr/bin/wine64:
|
23
wine-uninstaller.desktop
Normal file
23
wine-uninstaller.desktop
Normal file
@ -0,0 +1,23 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=Uninstaller
|
||||
GenericName=Wine Software Uninstaller
|
||||
GenericName[de]=Wine Anwendungsentferner
|
||||
GenericName[en]=Wine Application Uninstaller
|
||||
GenericName[eo]=Wine Programa Malinstalilo
|
||||
GenericName[es]=Desinstalador de aplicaciones de Wine
|
||||
GenericName[fi]=Wine Sovelluksen Poistaja
|
||||
GenericName[fr]=Désinstalleur d'applications de Wine
|
||||
GenericName[hu]=Wine Alkalmazás eltávolító
|
||||
GenericName[it]=Disinstallazione Applicazioni Wine
|
||||
GenericName[nl]=Programma verwijderen
|
||||
GenericName[no]=Avinstaller programmer
|
||||
GenericName[pl]=Wine usuwanie programów
|
||||
GenericName[pt]=Desinstalador de Aplicações Wine
|
||||
GenericName[tr]=Wine Uygulama Kaldrc
|
||||
Exec=wine uninstaller
|
||||
Icon=wine
|
||||
Type=Application
|
||||
Terminal=false
|
||||
X-KDE-StartupNotify=false
|
||||
Categories=X-Wine;
|
15
wine-winecfg.desktop
Normal file
15
wine-winecfg.desktop
Normal file
@ -0,0 +1,15 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=Winecfg
|
||||
GenericName=Wine Configuration Tool
|
||||
GenericName[de]=Wine Kontrollzentrum
|
||||
GenericName[es]=Panel de control de Wine
|
||||
GenericName[fr]=Outil de configuration pour Wine
|
||||
GenericName[it]=Strumento di configurazione per Wine
|
||||
GenericName[pt_BR]=Configurador do Wine
|
||||
Exec=winecfg
|
||||
Icon=notepad
|
||||
Type=Application
|
||||
Terminal=false
|
||||
X-KDE-StartupNotify=false
|
||||
Categories=X-Wine;
|
10
wine-winefile.desktop
Normal file
10
wine-winefile.desktop
Normal file
@ -0,0 +1,10 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=Winefile
|
||||
GenericName=Wine File
|
||||
Exec=winefile
|
||||
Icon=winefile
|
||||
Type=Application
|
||||
Terminal=false
|
||||
X-KDE-StartupNotify=false
|
||||
Categories=X-Wine;
|
26
wine-winemine.desktop
Normal file
26
wine-winemine.desktop
Normal file
@ -0,0 +1,26 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=Winemine
|
||||
GenericName=Winemine Game
|
||||
GenericName[cs]=WineMine
|
||||
GenericName[de]=WineMine
|
||||
GenericName[en]=WineMine
|
||||
GenericName[es]=WineMine
|
||||
GenericName[fi]=WineMine
|
||||
GenericName[fr]=Démineur Wine
|
||||
GenericName[it]=Campo Minato
|
||||
GenericName[ko]=WineMine
|
||||
GenericName[nl]=WineMine
|
||||
GenericName[no]=Minesveiper
|
||||
GenericName[pl]=WineMine
|
||||
GenericName[pt]=WineMine
|
||||
GenericName[ro]=WineMine
|
||||
GenericName[ru]=WineMine
|
||||
GenericName[si]=WineMine
|
||||
GenericName[tr]=Wine Mayn Tarlas
|
||||
Exec=winemine
|
||||
Icon=winemine
|
||||
Type=Application
|
||||
Terminal=false
|
||||
X-KDE-StartupNotify=false
|
||||
Categories=X-Wine;
|
29
wine-winhelp.desktop
Normal file
29
wine-winhelp.desktop
Normal file
@ -0,0 +1,29 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=Winhelp
|
||||
GenericName=Wine Help
|
||||
GenericName[cs]=Nápovìda Wine
|
||||
GenericName[da]=Wine Hjælp
|
||||
GenericName[de]=Wine Hilfe
|
||||
GenericName[en]=Wine Help
|
||||
GenericName[eo]=Wine Helpanto
|
||||
GenericName[es]=Ayuda de Wine
|
||||
GenericName[fi]=Wine Ohje
|
||||
GenericName[fr]=Aide de Wine
|
||||
GenericName[hu]=Wine súgó
|
||||
GenericName[it]=Guida di Wine
|
||||
GenericName[nl]=Wine Help
|
||||
GenericName[no]=Hjelp
|
||||
GenericName[pl]=Wine Pomoc
|
||||
GenericName[pt]=Ajuda Wine
|
||||
GenericName[si]=Wine Pomoè
|
||||
GenericName[sk]=Wine Pomoc
|
||||
GenericName[sw]=Wine Hjälp
|
||||
GenericName[tr]=Wine Yardm
|
||||
GenericName[wa]=Aidance di Wine
|
||||
Exec=wine winhlp32
|
||||
Icon=winhelp
|
||||
Type=Application
|
||||
Terminal=false
|
||||
X-KDE-StartupNotify=false
|
||||
Categories=X-Wine;
|
11
wine-wordpad.desktop
Normal file
11
wine-wordpad.desktop
Normal file
@ -0,0 +1,11 @@
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Name=Wine Wordpad
|
||||
GenericName=Wordpad Editor
|
||||
GenericName[it]=Editor Wordpad
|
||||
Exec=wine wordpad
|
||||
Icon=wordpad
|
||||
Type=Application
|
||||
Terminal=false
|
||||
X-KDE-StartupNotify=false
|
||||
Categories=X-Wine;
|
9
wine_hidden_kde-desktop
Normal file
9
wine_hidden_kde-desktop
Normal file
@ -0,0 +1,9 @@
|
||||
[Desktop Entry]
|
||||
Type=Application
|
||||
Encoding=UTF-8
|
||||
Name=Wine
|
||||
Exec=wine %f
|
||||
Icon=exec_wine
|
||||
MimeType=application/x-msdos-program;application/x-ms-dos-executable;application/x-msdownload;application/exe;application/x-exe;application/dos-exe;vms/exe;application/x-winexe;application/msdos-windows;
|
||||
GenericName=Wine
|
||||
Terminal=false
|
Loading…
Reference in New Issue
Block a user