automatic version update by autodist [release 2.42.4-1mamba;Sun Jan 07 2024]
This commit is contained in:
parent
91a933d6be
commit
f19917236e
@ -1,12 +0,0 @@
|
||||
--- Source/WebCore/plugins/PluginDatabase.cpp 2011-01-08 17:50:59.000000000 +0100
|
||||
+++ Source/WebCore/plugins/PluginDatabase.cpp-gil 2011-01-26 09:54:45.000000000 +0100
|
||||
@@ -393,6 +393,9 @@
|
||||
paths.append("/usr/lib64/mozilla/plugins");
|
||||
paths.append("/usr/lib/nsbrowser/plugins");
|
||||
paths.append("/usr/lib64/nsbrowser/plugins");
|
||||
+ /* And for nspluginwrapper */
|
||||
+ paths.append("/usr/lib64/mozilla/plugins-wrapped");
|
||||
+ paths.append("/usr/lib/mozilla/plugins-wrapped");
|
||||
|
||||
String mozHome(getenv("MOZILLA_HOME"));
|
||||
mozHome.append("/plugins");
|
@ -1,20 +0,0 @@
|
||||
--- webkitgtk-2.16.6/Source/WTF/wtf/Atomics.cpp.orig 2018-02-08 13:49:54.606360518 +0100
|
||||
+++ webkitgtk-2.16.6/Source/WTF/wtf/Atomics.cpp 2018-02-08 12:52:43.959319225 +0100
|
||||
@@ -58,7 +58,7 @@
|
||||
return value;
|
||||
}
|
||||
|
||||
-extern "C" {
|
||||
+/*extern "C" {
|
||||
|
||||
int64_t __sync_add_and_fetch_8(int64_t volatile* addend, int64_t value)
|
||||
{
|
||||
@@ -70,7 +70,7 @@
|
||||
return atomicStep(addend, -value);
|
||||
}
|
||||
|
||||
-} // extern "C"
|
||||
+} // extern "C"*/
|
||||
|
||||
} // namespace WTF
|
||||
|
@ -4,11 +4,15 @@
|
||||
%define libname libwebkit2gtk
|
||||
%else
|
||||
%define apiver %with_apiver
|
||||
%if "%?with_apiver" == "4.1"
|
||||
%define libname libwebkit2gtk-%{with_apiver}
|
||||
%else
|
||||
%define libname libwebkitgtk-%{with_apiver}
|
||||
%endif
|
||||
%endif
|
||||
|
||||
Name: webkitgtk
|
||||
Version: 2.42.2
|
||||
Version: 2.42.4
|
||||
Release: 1mamba
|
||||
Summary: Port of WebKit embeddable web component to GTK+
|
||||
Group: System/Libraries
|
||||
@ -17,8 +21,6 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.webkitgtk.org/
|
||||
Source0: http://www.webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
|
||||
Patch0: libwebkit-gtk-1.3.10-nspluginwrapper.patch
|
||||
Patch1: webkitgtk-2.16.6-arm-sync_add_and_fetch_8_duplicate.patch
|
||||
Patch2: webkitgtk-2.30.2-x86-arm-jit-build-workaround.patch
|
||||
Patch3: webkitgtk-2.42.2-libxml2-2.12.1.patch
|
||||
License: BSD, LGPL
|
||||
@ -28,11 +30,13 @@ BuildRequires: gst-plugins-bad-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXcomposite-devel
|
||||
BuildRequires: libXdamage-devel
|
||||
BuildRequires: libat-spi2-core-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: libatomic-devel
|
||||
BuildRequires: libavif-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libdrm-devel
|
||||
BuildRequires: libenchant-devel
|
||||
BuildRequires: libepoxy-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
@ -40,9 +44,11 @@ BuildRequires: libgcc
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: libgraphene-devel
|
||||
BuildRequires: libgst-plugins-base-devel
|
||||
BuildRequires: libgstreamer-devel
|
||||
BuildRequires: libgtk3-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libhyphen-devel
|
||||
BuildRequires: libicu-devel
|
||||
@ -61,7 +67,9 @@ BuildRequires: libsqlite-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libsystemd-devel
|
||||
BuildRequires: libtasn1-devel
|
||||
BuildRequires: libvulkan-devel
|
||||
BuildRequires: libwayland-devel
|
||||
BuildRequires: libwayland-egl-devel
|
||||
BuildRequires: libwebp-devel
|
||||
BuildRequires: libwoff2-devel
|
||||
BuildRequires: libwpe-devel
|
||||
@ -149,7 +157,7 @@ This package contains the documentation for %{name},
|
||||
#sed -i "s|ARM64|ARMv7|" Source/JavaScriptCore/CMakeLists.txt
|
||||
sed -i "s|WTF_CPU_ARM64|WTF_CPU_ARM|" CMakeLists.txt
|
||||
%endif
|
||||
%patch 3 -p1
|
||||
#%patch 3 -p1
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
@ -196,6 +204,10 @@ EXTRA_CXXFLAGS="-g1"
|
||||
%endif
|
||||
%if "%?with_apiver" == "5.0"
|
||||
-DUSE_GTK4=ON \
|
||||
%endif
|
||||
%if "%?with_apiver" == "6.0"
|
||||
-DUSE_GTK4=ON \
|
||||
-DUSE_AVIF=ON \
|
||||
%endif
|
||||
-DENABLE_MINIBROWSER=ON
|
||||
|
||||
@ -243,16 +255,13 @@ rm -f %{buildroot}%{_bindir}/WebKitWebDriver
|
||||
|
||||
%files -n %{libname} -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libwebkit2gtk-%{apiver}.so.*
|
||||
%{_libdir}/libwebkit*-%{apiver}.so.*
|
||||
%{_libdir}/libjavascriptcoregtk-%{apiver}.so.*
|
||||
%{_libdir}/girepository-1.0/JavaScriptCore-%{apiver}.typelib
|
||||
%{_libdir}/girepository-1.0/WebKit2-%{apiver}.typelib
|
||||
%{_libdir}/girepository-1.0/WebKit2WebExtension-%{apiver}.typelib
|
||||
%{_libdir}/webkit2gtk-%{apiver}/injected-bundle/libwebkit2gtkinjectedbundle.so
|
||||
%{_libexecdir}/webkit2gtk-%{apiver}/MiniBrowser
|
||||
%{_libexecdir}/webkit2gtk-%{apiver}/jsc
|
||||
%dir %{_libexecdir}/webkit2gtk-%{apiver}
|
||||
%{_libexecdir}/webkit2gtk-%{apiver}/WebKit*
|
||||
%{_libdir}/girepository-1.0/WebKit*-%{apiver}.typelib
|
||||
%{_libdir}/webkit*-%{apiver}/injected-bundle/libwebkit*gtkinjectedbundle.so
|
||||
%dir %{_libexecdir}/webkit*-%{apiver}
|
||||
%{_libexecdir}/webkit*-%{apiver}/*
|
||||
|
||||
%files -n %{libname}-devel
|
||||
%defattr(-,root,root)
|
||||
@ -262,24 +271,23 @@ rm -f %{buildroot}%{_bindir}/WebKitWebDriver
|
||||
%dir %{_includedir}/webkitgtk-%{apiver}
|
||||
%{_includedir}/webkitgtk-%{apiver}/*
|
||||
%{_libdir}/libjavascriptcoregtk-%{apiver}.so
|
||||
%{_libdir}/libwebkit2gtk-%{apiver}.so
|
||||
%{_libdir}/libwebkit*-%{apiver}.so
|
||||
%{_datadir}/gir-1.0/JavaScriptCore-%{apiver}.gir
|
||||
%{_datadir}/gir-1.0/WebKit2-%{apiver}.gir
|
||||
%{_datadir}/gir-1.0/WebKit2WebExtension-%{apiver}.gir
|
||||
%{_libdir}/pkgconfig/webkit2gtk-%{apiver}.pc
|
||||
%{_datadir}/gir-1.0/WebKit*-%{apiver}.gir
|
||||
%{_libdir}/pkgconfig/webkit*-%{apiver}.pc
|
||||
%{_libdir}/pkgconfig/javascriptcoregtk-%{apiver}.pc
|
||||
%{_libdir}/pkgconfig/webkit2gtk-web-extension-%{apiver}.pc
|
||||
|
||||
%files -n %{libname}-doc
|
||||
%defattr(-,root,root)
|
||||
%dir %{_datadir}/gtk-doc/html/javascriptcoregtk-%{apiver}
|
||||
%{_datadir}/gtk-doc/html/javascriptcoregtk-%{apiver}/*
|
||||
%dir %{_datadir}/gtk-doc/html/webkit2gtk-%{apiver}
|
||||
%{_datadir}/gtk-doc/html/webkit2gtk-%{apiver}/*
|
||||
%dir %{_datadir}/gtk-doc/html/webkit2gtk-web-extension-%{apiver}
|
||||
%{_datadir}/gtk-doc/html/webkit2gtk-web-extension-%{apiver}/*
|
||||
%dir %{_datadir}/gtk-doc/html/webkit*-%{apiver}
|
||||
%{_datadir}/gtk-doc/html/webkit*-%{apiver}/*
|
||||
|
||||
%changelog
|
||||
* Sun Jan 07 2024 Automatic Build System <autodist@openmamba.org> 2.42.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Nov 25 2023 Automatic Build System <autodist@mambasoft.it> 2.42.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user