automatic version update by autodist [release 2.42.2-1mamba;Sat Nov 25 2023]
This commit is contained in:
parent
04bc1c6975
commit
91a933d6be
22
webkitgtk-2.42.2-libxml2-2.12.1.patch
Normal file
22
webkitgtk-2.42.2-libxml2-2.12.1.patch
Normal file
@ -0,0 +1,22 @@
|
||||
--- webkitgtk-2.42.2/Source/WebCore/xml/XSLTProcessor.h.orig 2023-11-25 15:40:55.964477218 +0100
|
||||
+++ webkitgtk-2.42.2/Source/WebCore/xml/XSLTProcessor.h 2023-11-25 15:41:00.126507392 +0100
|
||||
@@ -61,7 +61,7 @@
|
||||
|
||||
void reset();
|
||||
|
||||
- static void parseErrorFunc(void* userData, xmlError*);
|
||||
+ static void parseErrorFunc(void* userData, const xmlError*);
|
||||
static void genericErrorFunc(void* userData, const char* msg, ...);
|
||||
|
||||
// Only for libXSLT callbacks
|
||||
--- webkitgtk-2.42.2/Source/WebCore/xml/XSLTProcessorLibxslt.cpp.orig 2023-11-25 15:54:11.058051011 +0100
|
||||
+++ webkitgtk-2.42.2/Source/WebCore/xml/XSLTProcessorLibxslt.cpp 2023-11-25 15:54:18.276056735 +0100
|
||||
@@ -59,7 +59,7 @@
|
||||
// It would be nice to do something with this error message.
|
||||
}
|
||||
|
||||
-void XSLTProcessor::parseErrorFunc(void* userData, xmlError* error)
|
||||
+void XSLTProcessor::parseErrorFunc(void* userData, const xmlError* error)
|
||||
{
|
||||
PageConsoleClient* console = static_cast<PageConsoleClient*>(userData);
|
||||
if (!console)
|
@ -8,7 +8,7 @@
|
||||
%endif
|
||||
|
||||
Name: webkitgtk
|
||||
Version: 2.38.5
|
||||
Version: 2.42.2
|
||||
Release: 1mamba
|
||||
Summary: Port of WebKit embeddable web component to GTK+
|
||||
Group: System/Libraries
|
||||
@ -20,26 +20,26 @@ Source0: http://www.webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
|
||||
Patch0: libwebkit-gtk-1.3.10-nspluginwrapper.patch
|
||||
Patch1: webkitgtk-2.16.6-arm-sync_add_and_fetch_8_duplicate.patch
|
||||
Patch2: webkitgtk-2.30.2-x86-arm-jit-build-workaround.patch
|
||||
Patch3: webkitgtk-2.42.2-libxml2-2.12.1.patch
|
||||
License: BSD, LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: gst-plugins-bad-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXcomposite-devel
|
||||
BuildRequires: libXdamage-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: libat-spi2-core-devel
|
||||
BuildRequires: libatomic-devel
|
||||
BuildRequires: libavif-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libenchant-devel
|
||||
BuildRequires: libdrm-devel
|
||||
BuildRequires: libepoxy-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgcrypt-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libgpg-error-devel
|
||||
BuildRequires: libgst-plugins-base-devel
|
||||
BuildRequires: libgstreamer-devel
|
||||
BuildRequires: libgtk3-devel
|
||||
@ -47,8 +47,10 @@ BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libhyphen-devel
|
||||
BuildRequires: libicu-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: libjxl-devel
|
||||
BuildRequires: liblcms2-devel
|
||||
BuildRequires: libmanette-devel
|
||||
BuildRequires: libmesa-devel
|
||||
BuildRequires: libopenjpeg-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpng-devel
|
||||
@ -60,7 +62,6 @@ BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libsystemd-devel
|
||||
BuildRequires: libtasn1-devel
|
||||
BuildRequires: libwayland-devel
|
||||
BuildRequires: libwayland-egl-devel
|
||||
BuildRequires: libwebp-devel
|
||||
BuildRequires: libwoff2-devel
|
||||
BuildRequires: libwpe-devel
|
||||
@ -69,18 +70,18 @@ BuildRequires: libxml2-devel
|
||||
BuildRequires: libxslt-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libmanette-devel
|
||||
BuildRequires: libnpth-devel
|
||||
BuildRequires: geoclue-devel
|
||||
BuildRequires: bison
|
||||
BuildRequires: bubblewrap
|
||||
BuildRequires: flex
|
||||
BuildRequires: GConf-devel
|
||||
BuildRequires: geoclue-devel
|
||||
BuildRequires: gobject-introspection-devel
|
||||
BuildRequires: gperf
|
||||
BuildRequires: icu
|
||||
BuildRequires: libtool
|
||||
BuildRequires: libnpth-devel
|
||||
BuildRequires: perl
|
||||
BuildRequires: bubblewrap
|
||||
BuildRequires: unifdef
|
||||
BuildRequires: xdg-dbus-proxy
|
||||
|
||||
%description
|
||||
@ -142,12 +143,13 @@ This package contains the documentation for %{name},
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
%ifarch arm %{ix86}
|
||||
%patch2 -p1
|
||||
%patch 2 -p1
|
||||
%endif
|
||||
%ifarch arm
|
||||
#sed -i "s|ARM64|ARMv7|" Source/JavaScriptCore/CMakeLists.txt
|
||||
sed -i "s|WTF_CPU_ARM64|WTF_CPU_ARM|" CMakeLists.txt
|
||||
%endif
|
||||
%patch 3 -p1
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
@ -180,6 +182,7 @@ EXTRA_CXXFLAGS="-g1"
|
||||
%endif
|
||||
%ifarch arm
|
||||
-DATOMICS_REQUIRE_LIBATOMIC=ON \
|
||||
-DENABLE_WEBGL=OFF \
|
||||
-DENABLE_GTKDOC=OFF \
|
||||
-DENABLE_SPELLCHECK=0 \
|
||||
%else
|
||||
@ -277,6 +280,9 @@ rm -f %{buildroot}%{_bindir}/WebKitWebDriver
|
||||
%{_datadir}/gtk-doc/html/webkit2gtk-web-extension-%{apiver}/*
|
||||
|
||||
%changelog
|
||||
* Sat Nov 25 2023 Automatic Build System <autodist@mambasoft.it> 2.42.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Feb 17 2023 Automatic Build System <autodist@mambasoft.it> 2.38.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user