update to 3.2.5e [release 3.2.5e-1mamba;Fri Sep 13 2013]
This commit is contained in:
parent
77df0f2339
commit
e6c0d75d60
@ -1,2 +1,4 @@
|
|||||||
# transfig
|
# transfig
|
||||||
|
|
||||||
|
TransFig is a set of tools for creating TeX documents with graphics which are portable, in the sense that they can be printed in a wide variety of environments.
|
||||||
|
|
||||||
|
36
transfig-3.2.4-badc.patch
Normal file
36
transfig-3.2.4-badc.patch
Normal file
@ -0,0 +1,36 @@
|
|||||||
|
diff -ur transfig/fig2dev/fig2dev.c transfig.3.2.4/fig2dev/fig2dev.c
|
||||||
|
--- transfig/fig2dev/fig2dev.c 2004-10-18 22:19:04.396035488 +0200
|
||||||
|
+++ transfig.3.2.4/fig2dev/fig2dev.c 2004-10-18 22:30:39.739327240 +0200
|
||||||
|
@@ -707,7 +707,8 @@
|
||||||
|
depth_usage();
|
||||||
|
switch(*s) { /* what's the delim? */
|
||||||
|
case ':': /* parse a range */
|
||||||
|
- d->d2 = strtol(++s,&s,10);
|
||||||
|
+ s++;
|
||||||
|
+ d->d2 = strtol(s,&s,10);
|
||||||
|
if (d->d2 < d->d1)
|
||||||
|
depth_usage();
|
||||||
|
break;
|
||||||
|
diff -ur transfig/transfig/sys.c transfig.3.2.4/transfig/sys.c
|
||||||
|
--- transfig/transfig/sys.c 2004-10-18 22:19:04.000000000 +0200
|
||||||
|
+++ transfig.3.2.4/transfig/sys.c 2004-10-18 23:04:48.129924536 +0200
|
||||||
|
@@ -15,6 +15,8 @@
|
||||||
|
*/
|
||||||
|
|
||||||
|
#include <stdio.h>
|
||||||
|
+#include <stdlib.h>
|
||||||
|
+#include <unistd.h>
|
||||||
|
#include "transfig.h"
|
||||||
|
|
||||||
|
#define MAXSYS 10000
|
||||||
|
diff -ur transfig/transfig/transfig.c transfig.3.2.4/transfig/transfig.c
|
||||||
|
--- transfig/transfig/transfig.c 2004-10-18 22:19:04.000000000 +0200
|
||||||
|
+++ transfig.3.2.4/transfig/transfig.c 2004-10-18 23:04:43.603612640 +0200
|
||||||
|
@@ -25,6 +25,7 @@
|
||||||
|
*/
|
||||||
|
|
||||||
|
#include <stdio.h>
|
||||||
|
+#include <stdlib.h>
|
||||||
|
#include "patchlevel.h"
|
||||||
|
#include "transfig.h"
|
||||||
|
|
29
transfig-3.2.4-broken.patch
Normal file
29
transfig-3.2.4-broken.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
--- transfig.3.2.4/fig2dev/dev/genemf.c.orig 2003-06-17 10:18:43.000000000 -0400
|
||||||
|
+++ transfig.3.2.4/fig2dev/dev/genemf.c 2003-06-17 10:18:34.000000000 -0400
|
||||||
|
@@ -375,7 +375,7 @@
|
||||||
|
static void rotate();
|
||||||
|
static void shape();
|
||||||
|
static void shape_interior();
|
||||||
|
-static void text();
|
||||||
|
+static void textfunc();
|
||||||
|
static void textangle();
|
||||||
|
static void textcolr();
|
||||||
|
static void textfont();
|
||||||
|
@@ -1788,7 +1788,7 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
|
||||||
|
-static void text(x, y, h, l, text, type)
|
||||||
|
+static void textfunc(x, y, h, l, text, type)
|
||||||
|
int x, y;
|
||||||
|
double h, l; /* Pixels (1200 dpi) */
|
||||||
|
char *text;
|
||||||
|
@@ -2206,7 +2206,7 @@
|
||||||
|
texttype(t->type);
|
||||||
|
textcolr(t->color);
|
||||||
|
textangle(t->angle);
|
||||||
|
- text(t->base_x, t->base_y, t->height, t->length, t->cstring, t->type);
|
||||||
|
+ textfunc(t->base_x, t->base_y, t->height, t->length, t->cstring, t->type);
|
||||||
|
}
|
||||||
|
|
||||||
|
|
31
transfig-3.2.4-gcc33.patch
Normal file
31
transfig-3.2.4-gcc33.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
--- transfig.3.2.4/fig2dev/fig2dev.h.varargs 2003-05-22 23:56:28.000000000 -0400
|
||||||
|
+++ transfig.3.2.4/fig2dev/fig2dev.h 2003-05-22 23:56:42.000000000 -0400
|
||||||
|
@@ -22,7 +22,7 @@
|
||||||
|
#include <sys/file.h>
|
||||||
|
#include <signal.h>
|
||||||
|
#include <string.h>
|
||||||
|
-#include <varargs.h>
|
||||||
|
+#include <stdarg.h>
|
||||||
|
#include <pwd.h>
|
||||||
|
#include <errno.h>
|
||||||
|
#include <time.h>
|
||||||
|
--- transfig.3.2.4/fig2dev/dev/gensvg.c.gcc33 2003-05-22 23:58:14.000000000 -0400
|
||||||
|
+++ transfig.3.2.4/fig2dev/dev/gensvg.c 2003-05-22 23:58:37.000000000 -0400
|
||||||
|
@@ -692,7 +692,7 @@
|
||||||
|
if (t->angle != 0) {
|
||||||
|
fprintf (tfp, "<g transform=\"translate(%d,%d) rotate(%d)\" >\n",
|
||||||
|
(int) (t->base_x * mag), (int) (t->base_y * mag), degrees (t->angle));
|
||||||
|
- fprintf (tfp, "<text x=\"0\" y=\"0\" fill=\"#%6.6x\" font-family=\"%s\"
|
||||||
|
+ fprintf (tfp, "<text x=\"0\" y=\"0\" fill=\"#%6.6x\" font-family=\"%s\" \n\
|
||||||
|
font-style=\"%s\" font-weight=\"%s\" font-size=\"%d\" text-anchor=\"%s\" >\n",
|
||||||
|
rgbColorVal (t->color), family[(int) ceil ((t->font + 1) / 4)],
|
||||||
|
(t->font % 2 == 0 ? "normal" : "italic"),
|
||||||
|
@@ -700,7 +700,7 @@
|
||||||
|
anchor[t->type]);
|
||||||
|
}
|
||||||
|
else
|
||||||
|
- fprintf (tfp, "<text x=\"%d\" y=\"%d\" fill=\"#%6.6x\" font-family=\"%s\"
|
||||||
|
+ fprintf (tfp, "<text x=\"%d\" y=\"%d\" fill=\"#%6.6x\" font-family=\"%s\" \n\
|
||||||
|
font-style=\"%s\" font-weight=\"%s\" font-size=\"%d\" text-anchor=\"%s\" >\n",
|
||||||
|
(int) (t->base_x * mag), (int) (t->base_y * mag), rgbColorVal (t->color),
|
||||||
|
family[(int) ceil ((t->font + 1) / 4)],
|
76
transfig-3.2.5-settings.patch
Normal file
76
transfig-3.2.5-settings.patch
Normal file
@ -0,0 +1,76 @@
|
|||||||
|
diff -Nru transfig.3.2.5.orig/fig2dev/Imakefile transfig.3.2.5/fig2dev/Imakefile
|
||||||
|
--- transfig.3.2.5.orig/fig2dev/Imakefile 2005-10-27 18:56:02.000000000 +0200
|
||||||
|
+++ transfig.3.2.5/fig2dev/Imakefile 2008-06-16 12:12:34.000000000 +0200
|
||||||
|
@@ -34,13 +34,13 @@
|
||||||
|
XCOMM You should point XFIGLIBDIR to the same directory you did when you compiled
|
||||||
|
XCOMM and installed xfig.
|
||||||
|
|
||||||
|
-XFIGLIBDIR = /usr/local/lib/X11/xfig
|
||||||
|
+XFIGLIBDIR = /usr/lib/X11/xfig
|
||||||
|
|
||||||
|
XCOMM ******
|
||||||
|
XCOMM If your system doesn't have the strerror() function (has sys_errlist) then
|
||||||
|
XCOMM uncomment NEED_STRERROR.
|
||||||
|
|
||||||
|
-XCOMM NEED_STRERROR = -DNEED_STRERROR
|
||||||
|
+NEED_STRERROR = -DNEED_STRERROR
|
||||||
|
|
||||||
|
XCOMM The following probably only applies to Windows 9x/NT:
|
||||||
|
XCOMM If your system can open files in text and binary modes and has the
|
||||||
|
@@ -53,7 +53,7 @@
|
||||||
|
XCOMM inline functions. With the "INLINE" keyword, you should notice that
|
||||||
|
XCOMM the display will be a bit faster in complex figures
|
||||||
|
|
||||||
|
-XCOMM USEINLINE = -DUSE_INLINE
|
||||||
|
+USEINLINE = -DUSE_INLINE
|
||||||
|
|
||||||
|
XCOMM ****************
|
||||||
|
XCOMM Change RGB if necessary, to point to your rgb.txt color database
|
||||||
|
@@ -62,7 +62,7 @@
|
||||||
|
XCOMM the full name (rgb.txt) now.
|
||||||
|
XCOMM
|
||||||
|
|
||||||
|
-RGB = $(LIBDIR)/rgb.txt
|
||||||
|
+RGB = /usr/share/X11/rgb.txt
|
||||||
|
|
||||||
|
XCOMM Comment out the following #define USEPNG if you don't want PNG support
|
||||||
|
XCOMM Uncomment the #define for USEPNG if you want to be able to import
|
||||||
|
@@ -76,7 +76,7 @@
|
||||||
|
#ifdef USEPNG
|
||||||
|
PNGLIBDIR = $(USRLIBDIR)
|
||||||
|
ZLIBDIR = $(USRLIBDIR)
|
||||||
|
-PNGINC = -I/usr/include/X11
|
||||||
|
+PNGINC = -I/usr/include
|
||||||
|
#endif
|
||||||
|
|
||||||
|
XCOMM ****************
|
||||||
|
@@ -97,7 +97,7 @@
|
||||||
|
|
||||||
|
XCOMM ****************
|
||||||
|
XCOMM Uncomment the following to set default paper size to A4
|
||||||
|
-XCOMM DDA4 = -DA4
|
||||||
|
+DDA4 = -DA4
|
||||||
|
|
||||||
|
XCOMM ****************
|
||||||
|
XCOMM Uncomment the following to set IBM Graphics Enhancement Cartridge
|
||||||
|
@@ -141,7 +141,7 @@
|
||||||
|
|
||||||
|
#ifdef I18N
|
||||||
|
I18N_DEFS = -DI18N
|
||||||
|
-FIG2DEV_LIBDIR = /usr/local/lib/fig2dev
|
||||||
|
+FIG2DEV_LIBDIR = /usr/share/fig2dev
|
||||||
|
I18N_DEV_DEFS = $(I18N_DEFS) -DFIG2DEV_LIBDIR=$(FIG2DEV_LIBDIR) -DFIG2DEV_LIBDIR_STR=\\\"$(FIG2DEV_LIBDIR)\\\"
|
||||||
|
|
||||||
|
#endif /* I18N */
|
||||||
|
diff -Nru transfig.3.2.5.orig/transfig/Imakefile transfig.3.2.5/transfig/Imakefile
|
||||||
|
--- transfig.3.2.5.orig/transfig/Imakefile 2003-03-25 21:52:37.000000000 +0100
|
||||||
|
+++ transfig.3.2.5/transfig/Imakefile 2008-06-16 12:12:51.000000000 +0200
|
||||||
|
@@ -32,7 +32,7 @@
|
||||||
|
XCOMM \\usepackage{} command for LaTeX2e.
|
||||||
|
XCOMM The default is to use \\documentstyle{} for LaTeX209.
|
||||||
|
|
||||||
|
-XCOMM USELATEX2E = -DLATEX2E
|
||||||
|
+USELATEX2E = -DLATEX2E
|
||||||
|
|
||||||
|
XCOMM ******* DON'T CHANGE ANYTHING BELOW THIS POINT *******
|
||||||
|
|
39
transfig-3.2.5d-libpng-1.5.patch
Normal file
39
transfig-3.2.5d-libpng-1.5.patch
Normal file
@ -0,0 +1,39 @@
|
|||||||
|
http://bugs.gentoo.org/show_bug.cgi?id=356751
|
||||||
|
|
||||||
|
Index: transfig.3.2.5d/fig2dev/dev/readpng.c
|
||||||
|
===================================================================
|
||||||
|
--- transfig.3.2.5d.orig/fig2dev/dev/readpng.c
|
||||||
|
+++ transfig.3.2.5d/fig2dev/dev/readpng.c
|
||||||
|
@@ -62,7 +62,7 @@ read_png(file,filetype,pic,llx,lly)
|
||||||
|
}
|
||||||
|
|
||||||
|
/* set long jump here */
|
||||||
|
- if (setjmp(png_ptr->jmpbuf)) {
|
||||||
|
+ if (setjmp(png_jmpbuf(png_ptr))) {
|
||||||
|
/* if we get here there was a problem reading the file */
|
||||||
|
png_destroy_read_struct(&png_ptr, &info_ptr, &end_info);
|
||||||
|
return 0;
|
||||||
|
@@ -78,15 +78,17 @@ read_png(file,filetype,pic,llx,lly)
|
||||||
|
png_get_IHDR(png_ptr, info_ptr, &w, &h, &bit_depth, &color_type,
|
||||||
|
&interlace_type, &compression_type, &filter_type);
|
||||||
|
|
||||||
|
- if (info_ptr->valid & PNG_INFO_gAMA)
|
||||||
|
- png_set_gamma(png_ptr, 2.2, info_ptr->gamma);
|
||||||
|
- else
|
||||||
|
- png_set_gamma(png_ptr, 2.2, 0.45);
|
||||||
|
+ png_fixed_point gamma = 0.45;
|
||||||
|
+ png_get_gAMA_fixed(png_ptr,info_ptr,&gamma);
|
||||||
|
+ png_set_gamma(png_ptr, 2.2, gamma);
|
||||||
|
|
||||||
|
- if (info_ptr->valid & PNG_INFO_bKGD)
|
||||||
|
+ if (png_get_valid(png_ptr,info_ptr,PNG_INFO_bKGD)) {
|
||||||
|
/* set the background to the one supplied */
|
||||||
|
- png_set_background(png_ptr, &info_ptr->background,
|
||||||
|
+ png_color_16p background;
|
||||||
|
+ png_get_bKGD(png_ptr,info_ptr,&background);
|
||||||
|
+ png_set_background(png_ptr, background,
|
||||||
|
PNG_BACKGROUND_GAMMA_FILE, 1, 1.0);
|
||||||
|
+ }
|
||||||
|
else {
|
||||||
|
/* blend the canvas background using the alpha channel */
|
||||||
|
if (bgspec) {
|
88
transfig.spec
Normal file
88
transfig.spec
Normal file
@ -0,0 +1,88 @@
|
|||||||
|
%define fig2dev_dir /usr/share/fig2dev
|
||||||
|
%define xfig_dir /usr/lib/X11/xfig
|
||||||
|
|
||||||
|
Name: transfig
|
||||||
|
Version: 3.2.5e
|
||||||
|
Release: 1mamba
|
||||||
|
Summary: Tools for creating TeX documents with graphics
|
||||||
|
Group: Applications/Publishing
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
|
URL: http://xfig.org/
|
||||||
|
Source: http://downloads.sourceforge.net/project/mcj/mcj-source/transfig.%{version}.tar.gz
|
||||||
|
Patch0: %{name}-3.2.5-settings.patch
|
||||||
|
Patch1: %{name}-3.2.4-gcc33.patch
|
||||||
|
Patch2: %{name}-3.2.4-broken.patch
|
||||||
|
Patch3: %{name}-3.2.4-badc.patch
|
||||||
|
Patch4: transfig-3.2.5d-libpng-1.5.patch
|
||||||
|
License: Distributable
|
||||||
|
Requires: netpbm >= 9.1, ghostscript >= 7.07
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: ghostscript-devel
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXpm-devel
|
||||||
|
BuildRequires: libz-devel
|
||||||
|
BuildRequires: netpbm-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
|
||||||
|
|
||||||
|
%description
|
||||||
|
TransFig is a set of tools for creating TeX documents with graphics which are portable, in the sense that they can be printed in a wide variety of environments.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}.%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
#%patch1 -p1
|
||||||
|
#%patch2 -p1
|
||||||
|
#%patch3 -p1
|
||||||
|
#%patch4 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
xmkmf
|
||||||
|
make Makefiles LIBDIR=%{_libdir}/X11
|
||||||
|
make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
|
||||||
|
install -d %{buildroot}%{fig2dev_dir}
|
||||||
|
install -d %{buildroot}%{xfig_dir}
|
||||||
|
|
||||||
|
make \
|
||||||
|
DESTDIR=%{buildroot} \
|
||||||
|
BINDIR=%{_bindir} \
|
||||||
|
MANSOURCEPATH=%{_mandir}/man \
|
||||||
|
install install.man
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||||
|
|
||||||
|
%files
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_bindir}/fig2dev
|
||||||
|
%{_bindir}/fig2ps2tex
|
||||||
|
%{_bindir}/fig2ps2tex.sh
|
||||||
|
%{_bindir}/pic2tpic
|
||||||
|
%{_bindir}/transfig
|
||||||
|
%dir %{fig2dev_dir}
|
||||||
|
%{fig2dev_dir}/*
|
||||||
|
%dir %{xfig_dir}
|
||||||
|
%{xfig_dir}/*
|
||||||
|
%{_mandir}/man1/*
|
||||||
|
%doc CHANGES LATEX.AND.XFIG* NOTES README
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Sep 13 2013 Automatic Build System <autodist@mambasoft.it> 3.2.5e-1mamba
|
||||||
|
- update to 3.2.5e
|
||||||
|
|
||||||
|
* Sat May 18 2013 Automatic Build System <autodist@mambasoft.it> 3.2.5d-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
* Mon Jun 16 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.5-1mamba
|
||||||
|
- update to 3.2.5
|
||||||
|
|
||||||
|
* Mon Mar 07 2005 Davide Madrisan <davide.madrisan@qilinux.it> 3.2.4-1qilnx
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user