automatic version update by autodist [release 1.3.7-1mamba;Sun Nov 06 2022]
This commit is contained in:
parent
eaccf171e6
commit
72bf43ef56
25
torcs-1.3.7-gcc6-isnan.patch
Normal file
25
torcs-1.3.7-gcc6-isnan.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
From: Aurelien Jarno <aurelien@aurel32.net>
|
||||||
|
Date: Mon, 1 May 2017 15:53:17 +0200
|
||||||
|
Subject: gcc6-isnan
|
||||||
|
|
||||||
|
car->ctrl->gear is defined as int, therefore it can never be infinite or
|
||||||
|
NaN. Just drop the tests.
|
||||||
|
|
||||||
|
Forwarded: https://sourceforge.net/p/torcs/mailman/message/35831161/
|
||||||
|
---
|
||||||
|
src/drivers/olethros/geometry.cpp | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/src/drivers/olethros/geometry.cpp b/src/drivers/olethros/geometry.cpp
|
||||||
|
index 7b6bc82..846aef7 100644
|
||||||
|
--- a/src/drivers/olethros/geometry.cpp
|
||||||
|
+++ b/src/drivers/olethros/geometry.cpp
|
||||||
|
@@ -370,7 +370,7 @@ void EstimateSphere (std::vector<Vector> P, ParametricSphere* sphere)
|
||||||
|
}
|
||||||
|
delta_total += delta;
|
||||||
|
}
|
||||||
|
- if (isnan(r)) {
|
||||||
|
+ if (std::isnan(r)) {
|
||||||
|
for (i=0; i<d; i++) {
|
||||||
|
center[i] = ((*(sphere->C))[i] - mean[i]) / scale;
|
||||||
|
}
|
18
torcs-1.3.7-gcc7.patch
Normal file
18
torcs-1.3.7-gcc7.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
--- a/src/libs/musicplayer/OpenALMusicPlayer.cpp 2014-02-05 09:54:43.000000000 +0000
|
||||||
|
+++ b/src/libs/musicplayer/OpenALMusicPlayer.cpp 2017-08-10 03:28:31.025410384 +0000
|
||||||
|
@@ -161,7 +161,7 @@
|
||||||
|
{
|
||||||
|
char pcm[BUFFERSIZE];
|
||||||
|
int size = 0;
|
||||||
|
- const char* error = '\0';
|
||||||
|
+ const char* error = nullptr;
|
||||||
|
|
||||||
|
if (!stream->read(pcm, BUFFERSIZE, &size, &error)) {
|
||||||
|
GfError("OpenALMusicPlayer: Stream read error: %s\n", error);
|
||||||
|
@@ -268,4 +268,4 @@
|
||||||
|
alSourcePlay(source);
|
||||||
|
|
||||||
|
return true;
|
||||||
|
-}
|
||||||
|
\ No newline at end of file
|
||||||
|
+}
|
35
torcs.spec
35
torcs.spec
@ -1,29 +1,22 @@
|
|||||||
Name: torcs
|
Name: torcs
|
||||||
Version: 1.3.6
|
Version: 1.3.7
|
||||||
Release: 1mamba
|
Release: 1mamba
|
||||||
Summary: The Open Racing Car Simulator
|
Summary: The Open Racing Car Simulator
|
||||||
Group: Graphical Desktop/Applications/Games
|
Group: Graphical Desktop/Applications/Games
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
Distribution: openmamba
|
Distribution: openmamba
|
||||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||||
URL: http://torcs.sourceforge.net/
|
URL: https://torcs.sourceforge.net/
|
||||||
Source: http://downloads.sourceforge.net/sourceforge/torcs/torcs-%{version}.tar.bz2
|
Source: http://downloads.sourceforge.net/sourceforge/torcs/torcs-%{version}.tar.bz2
|
||||||
Patch0: %{name}-1.3.0-gcc43.patch
|
Patch0: %{name}-1.3.0-gcc43.patch
|
||||||
|
Patch1: torcs-1.3.7-gcc7.patch
|
||||||
|
Patch2: torcs-1.3.7-gcc6-isnan.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libfreealut-devel
|
|
||||||
BuildRequires: libfreeglut-devel
|
|
||||||
BuildRequires: libgcc
|
|
||||||
BuildRequires: libGL-devel
|
|
||||||
BuildRequires: libGLU-devel
|
BuildRequires: libGLU-devel
|
||||||
BuildRequires: libICE-devel
|
BuildRequires: libICE-devel
|
||||||
BuildRequires: libopenal-devel
|
|
||||||
BuildRequires: libplib-devel
|
|
||||||
BuildRequires: libpng-devel
|
|
||||||
BuildRequires: libSM-devel
|
BuildRequires: libSM-devel
|
||||||
BuildRequires: libstdc++6-devel
|
|
||||||
BuildRequires: libvorbis-devel
|
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
BuildRequires: libXext-devel
|
BuildRequires: libXext-devel
|
||||||
BuildRequires: libXi-devel
|
BuildRequires: libXi-devel
|
||||||
@ -32,19 +25,34 @@ BuildRequires: libXrandr-devel
|
|||||||
BuildRequires: libXrender-devel
|
BuildRequires: libXrender-devel
|
||||||
BuildRequires: libXt-devel
|
BuildRequires: libXt-devel
|
||||||
BuildRequires: libXxf86vm-devel
|
BuildRequires: libXxf86vm-devel
|
||||||
|
BuildRequires: libfreealut-devel
|
||||||
|
BuildRequires: libfreeglut-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libglvnd-devel
|
||||||
|
BuildRequires: libopenal-devel
|
||||||
|
BuildRequires: libplib-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libvorbis-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
Requires(post):%{__install_info}
|
Requires(post):%{__install_info}
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
This is the official site of TORCS, The Open Racing Car Simulator. TORCS is a highly portable multi platform car racing simulation. It is used as ordinary car racing game, as AI racing game and as research platform.
|
This is the official site of TORCS, The Open Racing Car Simulator. TORCS is a highly portable multi platform car racing simulation. It is used as ordinary car racing game, as AI racing game and as research platform.
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
#-D -T
|
||||||
|
#:<< _EOF
|
||||||
#%patch0 -p1
|
#%patch0 -p1
|
||||||
|
%patch1 -p1 -b .gcc7
|
||||||
|
%patch2 -p1 -b .gcc6-isnan
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
#:<< _EOF
|
||||||
%configure \
|
%configure \
|
||||||
--x-includes=%{_includedir} \
|
--x-includes=%{_includedir} \
|
||||||
--x-libraries=%{_libdir}
|
--x-libraries=%{_libdir}
|
||||||
@ -102,6 +110,9 @@ _EOF
|
|||||||
%doc COPYING README
|
%doc COPYING README
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Nov 06 2022 Automatic Build System <autodist@mambasoft.it> 1.3.7-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sat May 24 2014 Automatic Build System <autodist@mambasoft.it> 1.3.6-1mamba
|
* Sat May 24 2014 Automatic Build System <autodist@mambasoft.it> 1.3.6-1mamba
|
||||||
- automatic update by autodist
|
- automatic update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user