automatic update by autodist [release 1.3.6-1mamba;Sat May 24 2014]
This commit is contained in:
parent
0299b49599
commit
eaccf171e6
@ -1,2 +1,4 @@
|
||||
# torcs
|
||||
|
||||
This is the official site of TORCS, The Open Racing Car Simulator. TORCS is a highly portable multi platform car racing simulation. It is used as ordinary car racing game, as AI racing game and as research platform.
|
||||
|
||||
|
60
torcs-1.3.0-gcc43.patch
Normal file
60
torcs-1.3.0-gcc43.patch
Normal file
@ -0,0 +1,60 @@
|
||||
diff -Naupr torcs-1.3.0.orig/src/drivers/olethros/Trajectory.cpp torcs-1.3.0/src/drivers/olethros/Trajectory.cpp
|
||||
--- torcs-1.3.0.orig/src/drivers/olethros/Trajectory.cpp 2006-11-05 02:49:55.000000000 +0100
|
||||
+++ torcs-1.3.0/src/drivers/olethros/Trajectory.cpp 2008-02-24 14:27:56.000000000 +0100
|
||||
@@ -10,6 +10,8 @@
|
||||
***************************************************************************/
|
||||
#include <cstdio>
|
||||
#include <cstdlib>
|
||||
+#include <cstring>
|
||||
+#include <ctime>
|
||||
#include <cmath>
|
||||
#include <cassert>
|
||||
#include <list>
|
||||
diff -Naupr torcs-1.3.0.orig/src/modules/simu/simuv2/SOLID-2.0/src/BBoxTree.cpp torcs-1.3.0/src/modules/simu/simuv2/SOLID-2.0/src/BBoxTree.cpp
|
||||
--- torcs-1.3.0.orig/src/modules/simu/simuv2/SOLID-2.0/src/BBoxTree.cpp 2006-11-05 02:42:22.000000000 +0100
|
||||
+++ torcs-1.3.0/src/modules/simu/simuv2/SOLID-2.0/src/BBoxTree.cpp 2008-02-24 14:19:02.000000000 +0100
|
||||
@@ -32,7 +32,7 @@
|
||||
#include "Transform.h"
|
||||
|
||||
#include <algorithm>
|
||||
-#include <new.h>
|
||||
+#include <new>
|
||||
|
||||
class BBoxCompAxis {
|
||||
public:
|
||||
diff -Naupr torcs-1.3.0.orig/src/modules/simu/simuv2/SOLID-2.0/src/Complex.cpp torcs-1.3.0/src/modules/simu/simuv2/SOLID-2.0/src/Complex.cpp
|
||||
--- torcs-1.3.0.orig/src/modules/simu/simuv2/SOLID-2.0/src/Complex.cpp 2006-11-05 02:42:22.000000000 +0100
|
||||
+++ torcs-1.3.0/src/modules/simu/simuv2/SOLID-2.0/src/Complex.cpp 2008-02-24 14:18:51.000000000 +0100
|
||||
@@ -32,7 +32,7 @@
|
||||
#include "Transform.h"
|
||||
#include "BBoxTree.h"
|
||||
|
||||
-#include <new.h>
|
||||
+#include <new>
|
||||
|
||||
BBoxInternal *free_node;
|
||||
|
||||
diff -Naupr torcs-1.3.0.orig/src/modules/simu/simuv2/SOLID-2.0/src/Endpoint.cpp torcs-1.3.0/src/modules/simu/simuv2/SOLID-2.0/src/Endpoint.cpp
|
||||
--- torcs-1.3.0.orig/src/modules/simu/simuv2/SOLID-2.0/src/Endpoint.cpp 2006-11-05 02:42:23.000000000 +0100
|
||||
+++ torcs-1.3.0/src/modules/simu/simuv2/SOLID-2.0/src/Endpoint.cpp 2008-02-24 14:19:11.000000000 +0100
|
||||
@@ -32,7 +32,7 @@
|
||||
#include "Object.h"
|
||||
#include "Encounter.h"
|
||||
|
||||
-#include <new.h>
|
||||
+#include <new>
|
||||
|
||||
void addPair(ObjectPtr object1, ObjectPtr object2);
|
||||
void removePair(ObjectPtr object1, ObjectPtr object2);
|
||||
diff -Naupr torcs-1.3.0.orig/src/modules/simu/simuv2/SOLID-2.0/src/Object.cpp torcs-1.3.0/src/modules/simu/simuv2/SOLID-2.0/src/Object.cpp
|
||||
--- torcs-1.3.0.orig/src/modules/simu/simuv2/SOLID-2.0/src/Object.cpp 2006-11-05 02:42:23.000000000 +0100
|
||||
+++ torcs-1.3.0/src/modules/simu/simuv2/SOLID-2.0/src/Object.cpp 2008-02-24 14:22:35.000000000 +0100
|
||||
@@ -33,7 +33,7 @@
|
||||
#include "Convex.h"
|
||||
#include "Complex.h"
|
||||
|
||||
-#include <new.h>
|
||||
+#include <new>
|
||||
|
||||
Object::Object(DtObjectRef obj, ShapePtr shape) :
|
||||
ref(obj),
|
124
torcs.spec
Normal file
124
torcs.spec
Normal file
@ -0,0 +1,124 @@
|
||||
Name: torcs
|
||||
Version: 1.3.6
|
||||
Release: 1mamba
|
||||
Summary: The Open Racing Car Simulator
|
||||
Group: Graphical Desktop/Applications/Games
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://torcs.sourceforge.net/
|
||||
Source: http://downloads.sourceforge.net/sourceforge/torcs/torcs-%{version}.tar.bz2
|
||||
Patch0: %{name}-1.3.0-gcc43.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libfreealut-devel
|
||||
BuildRequires: libfreeglut-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libopenal-devel
|
||||
BuildRequires: libplib-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXi-devel
|
||||
BuildRequires: libXmu-devel
|
||||
BuildRequires: libXrandr-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libXt-devel
|
||||
BuildRequires: libXxf86vm-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
Requires(post):%{__install_info}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
This is the official site of TORCS, The Open Racing Car Simulator. TORCS is a highly portable multi platform car racing simulation. It is used as ordinary car racing game, as AI racing game and as research platform.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--x-includes=%{_includedir} \
|
||||
--x-libraries=%{_libdir}
|
||||
|
||||
%make -j1
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall datainstall
|
||||
|
||||
install -d %{buildroot}%{_datadir}/applications/
|
||||
cat > %{buildroot}%{_datadir}/applications/torcs.desktop << _EOF
|
||||
[Desktop Entry]
|
||||
Encoding=UTF-8
|
||||
Categories=Application;Game;ArcadeGame
|
||||
Name=TORCS
|
||||
GenericName=Cars Racing Simulator
|
||||
GenericName[it]=Simulatore di corse automobilistiche
|
||||
Exec=torcs
|
||||
Terminal=0
|
||||
Type=Application
|
||||
Icon=%{_datadir}/games/torcs/Ticon.ico
|
||||
_EOF
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
%install_info torcs
|
||||
|
||||
%preun
|
||||
%uninstall_info torcs
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/accc
|
||||
%{_bindir}/nfs2ac
|
||||
%{_bindir}/nfsperf
|
||||
%{_bindir}/texmapper
|
||||
%{_bindir}/torcs
|
||||
%{_bindir}/trackgen
|
||||
%{_datadir}/applications/torcs.desktop
|
||||
%{_libdir}/torcs/accc-bin
|
||||
%{_libdir}/torcs/nfs2ac-bin
|
||||
%{_libdir}/torcs/nfsperf-bin
|
||||
%{_libdir}/torcs/setup_linux.sh
|
||||
%{_libdir}/torcs/texmapper-bin
|
||||
%{_libdir}/torcs/torcs-bin
|
||||
%{_libdir}/torcs/trackgen-bin
|
||||
%{_libdir}/torcs/drivers/*
|
||||
%{_libdir}/torcs/lib/*
|
||||
%{_libdir}/torcs/modules/*
|
||||
%dir %{_datadir}/games/torcs
|
||||
%{_datadir}/games/torcs/*
|
||||
%doc COPYING README
|
||||
|
||||
%changelog
|
||||
* Sat May 24 2014 Automatic Build System <autodist@mambasoft.it> 1.3.6-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Nov 17 2013 Automatic Build System <autodist@mambasoft.it> 1.3.5-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Oct 22 2012 openmamba WebBuild System <webbuild@openmamba.org> 1.3.4-1mamba
|
||||
- update to 1.3.4
|
||||
|
||||
* Tue Sep 04 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.3-1mamba
|
||||
- update to 1.3.3
|
||||
|
||||
* Mon Jul 13 2009 Automatic Build System <autodist@mambasoft.it> 1.3.1-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Apr 20 2009 Automatic Build System <autodist@mambasoft.it> 1.3.0-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Wed Nov 07 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.0-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user