stand-alone package from tcltk [release 8.6.10-4mamba;Sat Jan 04 2020]
This commit is contained in:
parent
248bb0969c
commit
8135ecd177
@ -1,2 +1,6 @@
|
||||
# tk
|
||||
|
||||
Tk is a X Windows widget set designed to work closely with the tcl scripting language.
|
||||
It allows you to write simple programs with full featured GUI's in only a little more time then it takes to write a text based interface.
|
||||
Tcl/Tk applications can also be run on Windows and Macintosh platforms.
|
||||
|
||||
|
9
tcltk-8.6.0-tk-pkgconfig.patch
Normal file
9
tcltk-8.6.0-tk-pkgconfig.patch
Normal file
@ -0,0 +1,9 @@
|
||||
--- tk8.6.0/unix/tk.pc.in.orig 2013-07-02 19:19:58.979511616 +0200
|
||||
+++ tk8.6.0/unix/tk.pc.in 2013-07-02 19:20:08.903430998 +0200
|
||||
@@ -11,5 +11,5 @@
|
||||
Version: @TK_VERSION@
|
||||
Requires:
|
||||
Conflicts:
|
||||
-Libs: -L${libdir} @TK_LIBS@
|
||||
+Libs: -L${libdir} @XLIBSW@ @XFT_LIBS@ @LIBS@ @TCL_LIBS@
|
||||
Cflags: -I${includedir}
|
316
tk.spec
Normal file
316
tk.spec
Normal file
@ -0,0 +1,316 @@
|
||||
%define majversion %(echo %version | cut -d. -f1-2)
|
||||
|
||||
Name: tk
|
||||
Version: 8.6.10
|
||||
Release: 4mamba
|
||||
Summary: A X Windows widget set designed to work closely with the tcl scripting language
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.tcl.tk
|
||||
Source0: http://downloads.sourceforge.net/sourceforge/tcl/tk%{version}-src.tar.gz
|
||||
Patch4: tcltk-8.6.0-tk-pkgconfig.patch
|
||||
License: BSD
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXScrnSaver-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXft-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libtcl-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: chrpath
|
||||
BuildRequires: libtcl-devel = %{version}
|
||||
Provides: tcltk
|
||||
Obsoletes: tcltk
|
||||
Requires: tcl >= %{version}
|
||||
Provides: /usr/bin/wish
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Tk is a X Windows widget set designed to work closely with the tcl scripting language.
|
||||
It allows you to write simple programs with full featured GUI's in only a little more time then it takes to write a text based interface.
|
||||
Tcl/Tk applications can also be run on Windows and Macintosh platforms.
|
||||
|
||||
%package -n lib%{name}
|
||||
Summary: An embeddable scripting language
|
||||
Group: System/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires(pre): /usr/sbin/alternatives
|
||||
|
||||
%description -n lib%{name}
|
||||
Tk is a X Windows widget set designed to work closely with the tcl scripting language.
|
||||
It allows you to write simple programs with full featured GUI's in only a little more time then it takes to write a text based interface.
|
||||
Tcl/Tk applications can also be run on Windows and Macintosh platforms.
|
||||
|
||||
%package -n lib%{name}-devel
|
||||
Summary: Static libraries and headers for libtk
|
||||
Group: System/Libraries
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: libtcl-devel = %{version}-%{release}
|
||||
|
||||
%description -n lib%{name}-devel
|
||||
Tk is a X Windows widget set designed to work closely with the tcl scripting language.
|
||||
It allows you to write simple programs with full featured GUI's in only a little more time then it takes to write a text based interface.
|
||||
Tcl/Tk applications can also be run on Windows and Macintosh platforms.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n tk%{version}
|
||||
|
||||
%build
|
||||
#
|
||||
# Important: before committing new releases/updates check that the following
|
||||
# tk applications continue to work: wish, amsn
|
||||
#
|
||||
|
||||
cd unix
|
||||
%configure \
|
||||
--disable-rpath \
|
||||
--enable-threads \
|
||||
--enable-xft \
|
||||
%ifarch x86_64
|
||||
--enable-64bit
|
||||
%endif
|
||||
|
||||
# --enable-man-suffix=%{?ver_suffix}
|
||||
|
||||
%make XFT_LIBS="-lXft -lfontconfig"
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
make -C unix install install-private-headers \
|
||||
INSTALL_ROOT=%{buildroot}
|
||||
|
||||
#ln -s wish%{majversion} %{buildroot}%{_bindir}/wish
|
||||
rm -f %{buildroot}%{_libdir}/tk%{majversion}/pkgIndex.tcl
|
||||
|
||||
# remove mann or rpm crashes for no really known reason
|
||||
rm -rf %{buildroot}%{_mandir}/mann
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post
|
||||
/usr/sbin/alternatives --install \
|
||||
%{_bindir}/wish wish %{_bindir}/wish%{majversion} 30
|
||||
/usr/sbin/update-alternatives --auto wish
|
||||
:
|
||||
|
||||
%postun
|
||||
if [ "$1" = "0" ]; then
|
||||
/usr/sbin/update-alternatives --remove wish %{_bindir}/wish%{majversion}
|
||||
fi
|
||||
:
|
||||
|
||||
%posttrans
|
||||
if [ $1 -gt 0 ]; then
|
||||
/usr/sbin/alternatives --install \
|
||||
%{_bindir}/wish wish %{_bindir}/wish%{majversion} 30 2>/dev/null
|
||||
/usr/sbin/update-alternatives --auto wish
|
||||
fi
|
||||
:
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/wish%{majversion}
|
||||
%dir %{_prefix}/lib/tk%{majversion}
|
||||
%{_prefix}/lib/tk%{majversion}/*
|
||||
%{_mandir}/man1/wish.*
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libtk%{majversion}.so
|
||||
%doc license.terms
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/tk*.h
|
||||
%{_includedir}/ttkDecls.h
|
||||
%{_includedir}/ttkTheme.h
|
||||
%{_libdir}/libtkstub%{majversion}.a
|
||||
%{_libdir}/tkConfig.sh
|
||||
%{_libdir}/pkgconfig/tk.pc
|
||||
%{_mandir}/man3/*.3*
|
||||
%doc ChangeLog changes
|
||||
|
||||
%changelog
|
||||
* Sat Jan 04 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 8.6.10-4mamba
|
||||
- stand-alone package from tcltk
|
||||
|
||||
* Fri Jan 03 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 8.6.10-3mamba
|
||||
- rebuilt with current toolchain and --enable-64bit
|
||||
|
||||
* Sat Nov 23 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 8.6.10-2mamba
|
||||
- add tcktk package with common files for biarch support
|
||||
|
||||
* Fri Nov 22 2019 Automatic Build System <autodist@mambasoft.it> 8.6.10-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jun 22 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 8.6.9-2mamba
|
||||
- move tclConfig.sh from %{_libdir} to %{_prefix}/lib/tcl%{majversion}
|
||||
|
||||
* Sat Nov 17 2018 Automatic Build System <autodist@mambasoft.it> 8.6.9-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Aug 22 2018 Silvan Calarco <silvan.calarco@mambasoft.it> 8.6.8-2mamba
|
||||
- rebuilt with glibc >= 2.27 to remove deps on obsoleted libieee
|
||||
|
||||
* Wed Dec 27 2017 Automatic Build System <autodist@mambasoft.it> 8.6.8-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Aug 25 2017 Automatic Build System <autodist@mambasoft.it> 8.6.7-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jul 28 2016 Automatic Build System <autodist@mambasoft.it> 8.6.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Mar 01 2016 Automatic Build System <autodist@mambasoft.it> 8.6.5-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Mar 20 2015 Automatic Build System <autodist@mambasoft.it> 8.6.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Nov 15 2014 Automatic Build System <autodist@mambasoft.it> 8.6.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Sep 18 2014 Automatic Build System <autodist@mambasoft.it> 8.6.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue May 06 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 8.6.1-4mamba
|
||||
- fix tools calling expect (can't find package Expect)
|
||||
|
||||
* Sun Feb 09 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 8.6.1-3mamba
|
||||
- remove sqlite pkg provided by libsqlite-tcl
|
||||
|
||||
* Sat Sep 21 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 8.6.1-2mamba
|
||||
- patch example requiring expectk which is no longer provided
|
||||
|
||||
* Sat Sep 21 2013 Automatic Build System <autodist@mambasoft.it> 8.6.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jul 08 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 8.6.0-4mamba
|
||||
- libtk-devel: don't provide/obsolete libtk85-devel
|
||||
- expect: update to 5.45
|
||||
- fix conflicting files installed in wrong version dir %{_prefix}/lib/tcl8/8.5
|
||||
|
||||
* Tue Jul 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 8.6.0-3mamba
|
||||
- add patch to fix libs in tk.pc
|
||||
|
||||
* Tue Jul 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 8.6.0-2mamba
|
||||
- remove requires/obsoletes for *85 version (provided by tcltk85 legacy packages)
|
||||
|
||||
* Thu Jan 03 2013 Automatic Build System <autodist@mambasoft.it> 8.6.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Nov 10 2012 Automatic Build System <autodist@mambasoft.it> 8.5.13-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Jul 27 2012 Automatic Build System <autodist@mambasoft.it> 8.5.12-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Nov 10 2011 Automatic Build System <autodist@mambasoft.it> 8.5.11-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jun 25 2011 Automatic Build System <autodist@mambasoft.it> 8.5.10-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Dec 14 2010 Davide Madrisan <davide.madrisan@gmail.com> 8.5.9-2mamba
|
||||
- libtcl: provide tcl (required to install some closed-source packages)
|
||||
- libtk: provide tk
|
||||
|
||||
* Thu Sep 09 2010 Automatic Build System <autodist@mambasoft.it> 8.5.9-1mamba
|
||||
- automatic update to 8.5.9 by autodist
|
||||
|
||||
* Thu Sep 02 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 8.5.8-4mamba
|
||||
- fixed alternatives installation in posttrans script
|
||||
|
||||
* Thu Jun 03 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 8.5.8-3mamba
|
||||
- added prereq for /usr/sbin/alternatives
|
||||
- update to 5.44.1.15 from sourceforge.net/project/expect
|
||||
|
||||
* Tue Mar 16 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 8.5.8-2mamba
|
||||
- renamed from tcltk85 to tlctk obsoleting old package names
|
||||
|
||||
* Wed Nov 18 2009 Automatic Build System <autodist@mambasoft.it> 8.5.8-1mamba
|
||||
- automatic update to 8.5.8 by autodist
|
||||
|
||||
* Thu Apr 16 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 8.5.7-1mamba
|
||||
- automatic update to 8.5.7 by autodist
|
||||
|
||||
* Tue Dec 23 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 8.5.6-1mamba
|
||||
- automatic update to 8.5.6 by autodist
|
||||
|
||||
* Thu Oct 16 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 8.5.5-1mamba
|
||||
- automatic update to 8.5.5 by autodist
|
||||
|
||||
* Sun Aug 31 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 8.5.4-1mamba
|
||||
- update to 8.5.4
|
||||
|
||||
* Fri May 09 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 8.5.2-1mamba
|
||||
- update to 8.5.2
|
||||
|
||||
* Wed Nov 21 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 8.5b3-1mamba
|
||||
- update to 8.5b3
|
||||
|
||||
* Tue Nov 20 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 8.5b2-1mamba
|
||||
- update to 8.5b2
|
||||
- expect: update to 5.44.1
|
||||
|
||||
* Sun Apr 22 2007 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 8.4.14-2mamba
|
||||
- specfile cleaned
|
||||
- added missing header files in devel packages
|
||||
- update expect to version 5.43.0
|
||||
- fixed shared library permissions
|
||||
- update patches
|
||||
|
||||
* Wed Apr 04 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 8.4.14-1mamba
|
||||
- update to version 8.4.14 by autospec
|
||||
|
||||
* Mon Jan 23 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 8.4.12-1qilnx
|
||||
- update to version 8.4.12 by autospec
|
||||
|
||||
* Tue Sep 27 2005 Davide Madrisan <davide.madrisan@qilinux.it> 8.4.11-2qilnx
|
||||
- rebuilt
|
||||
|
||||
* Mon Jul 11 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 8.4.11-1qilnx
|
||||
- update to version 8.4.11 by autospec
|
||||
|
||||
* Wed Jan 19 2005 Davide Madrisan <davide.madrisan@qilinux.it> 8.4.9-1qilnx
|
||||
- update to version 8.4.9 by autospec
|
||||
- patched autoconf to remove autoconf2.13 requirement
|
||||
- updated the security patch for `expect' and `expectk' binaries
|
||||
- fixed libraries permissions
|
||||
- dinamically build the list of man pages for all the subpackages
|
||||
|
||||
* Mon Aug 02 2004 Davide Madrisan <davide.madrisan@qilinux.it> 8.4.7-1qilnx
|
||||
- update to 8.4.7
|
||||
|
||||
* Wed Mar 03 2004 Davide Madrisan <davide.madrisan@qilinux.it> 8.4.6-1qilnx
|
||||
- rebuilt for 8.4.6
|
||||
|
||||
* Sat Feb 28 2004 Davide Madrisan <davide.madrisan@qilinux.it> 8.4.5-1qilnx
|
||||
- Tcl and Tk updated to version 8.4.5; expect updated to version 5.40
|
||||
- extended specfile cleanups
|
||||
- security fix: removed in `expect' and `expectk' the world writable runtime
|
||||
library search path `{buildroot}%{_libdir}' (patch0)
|
||||
|
||||
* Fri Aug 01 2003 Silvan Calarco <silvan.calarco@qinet.it> 8.4.4-1qilnx
|
||||
- rebuilt for 8.4.4
|
||||
- added expect
|
||||
|
||||
* Thu May 15 2003 Alessandro Ramazzina <alessandro.ramazzina@qinet.it> 8.4.2-2qilnx
|
||||
- delete tcllib package from the tcltk.spec file
|
||||
|
||||
* Wed May 14 2003 Alessandro Ramazzina <alessandro.ramazzina@qinet.it> 8.4.2-1qilnx
|
||||
- creation of tcltk package
|
Loading…
Reference in New Issue
Block a user