update to 106.0 [release 106.0-1mamba;Mon Nov 18 2024]
This commit is contained in:
parent
710ca2419d
commit
758f131a95
@ -1,12 +0,0 @@
|
||||
diff --git a/rts/System/Sync/SHA512.cpp b/rts/System/Sync/SHA512.cpp
|
||||
index ab4e973a23..adc9b3ee47 100644
|
||||
--- a/rts/System/Sync/SHA512.cpp
|
||||
+++ b/rts/System/Sync/SHA512.cpp
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
#include <cassert>
|
||||
#include <cstring>
|
||||
+#include <cstdio>
|
||||
|
||||
#include "SHA512.hpp"
|
||||
|
@ -1,44 +0,0 @@
|
||||
From d159c9f0d21d3bc96c85063cc258b6fd8ec1be2d Mon Sep 17 00:00:00 2001
|
||||
From: abma <spring@abma.de>
|
||||
Date: Mon, 6 Jan 2020 11:16:25 +0100
|
||||
Subject: [PATCH] fix #6358: compile error because of new openal version /
|
||||
changed struct
|
||||
|
||||
---
|
||||
rts/System/Sound/OpenAL/Sound.cpp | 1 -
|
||||
rts/System/Sound/OpenAL/Sound.h | 3 +--
|
||||
2 files changed, 1 insertion(+), 3 deletions(-)
|
||||
|
||||
diff --git a/rts/System/Sound/OpenAL/Sound.cpp b/rts/System/Sound/OpenAL/Sound.cpp
|
||||
index 50bc40e8c4..9ea2ad6a73 100644
|
||||
--- a/rts/System/Sound/OpenAL/Sound.cpp
|
||||
+++ b/rts/System/Sound/OpenAL/Sound.cpp
|
||||
@@ -4,7 +4,6 @@
|
||||
|
||||
#include <cstdlib>
|
||||
#include <cmath>
|
||||
-#include <alc.h>
|
||||
|
||||
#ifndef ALC_ALL_DEVICES_SPECIFIER
|
||||
#define ALC_ALL_DEVICES_SPECIFIER 0x1013
|
||||
diff --git a/rts/System/Sound/OpenAL/Sound.h b/rts/System/Sound/OpenAL/Sound.h
|
||||
index 11d36ef86c..d362cb5b39 100644
|
||||
--- a/rts/System/Sound/OpenAL/Sound.h
|
||||
+++ b/rts/System/Sound/OpenAL/Sound.h
|
||||
@@ -5,6 +5,7 @@
|
||||
|
||||
#include <string>
|
||||
#include <vector>
|
||||
+#include <alc.h>
|
||||
|
||||
#include "System/Sound/ISound.h"
|
||||
#include "System/float3.h"
|
||||
@@ -16,8 +17,6 @@
|
||||
class CSoundSource;
|
||||
class SoundBuffer;
|
||||
class SoundItem;
|
||||
-struct ALCdevice_struct;
|
||||
-typedef struct ALCdevice_struct ALCdevice;
|
||||
|
||||
/// Default sound system implementation (OpenAL)
|
||||
class CSound : public ISound
|
@ -1,15 +0,0 @@
|
||||
diff --git a/rts/Rendering/GL/myGL.cpp b/rts/Rendering/GL/myGL.cpp
|
||||
index 5abef32ce0..95a786970c 100644
|
||||
--- a/rts/Rendering/GL/myGL.cpp
|
||||
+++ b/rts/Rendering/GL/myGL.cpp
|
||||
@@ -146,8 +147,8 @@ static bool GetVideoMemInfoMESA(GLint* memInfo)
|
||||
|
||||
typedef PFNGLXQUERYCURRENTRENDERERINTEGERMESAPROC QCRIProc;
|
||||
|
||||
- static constexpr const GLubyte* qcriProcName = (const GLubyte*) "glXQueryCurrentRendererIntegerMESA";
|
||||
- static const QCRIProc qcriProcAddr = (QCRIProc) glXGetProcAddress(qcriProcName);
|
||||
+ static const char qcriProcName[] = "glXQueryCurrentRendererIntegerMESA";
|
||||
+ static const QCRIProc qcriProcAddr = (QCRIProc) glXGetProcAddress(reinterpret_cast<const GLubyte*>(qcriProcName));
|
||||
|
||||
if (qcriProcAddr == nullptr)
|
||||
return false;
|
10
spring-106.0-fix-doc-install.patch
Normal file
10
spring-106.0-fix-doc-install.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- spring_106.0/doc/CMakeLists.txt.orig 2024-11-18 19:50:06.848633103 +0100
|
||||
+++ spring_106.0/doc/CMakeLists.txt 2024-11-18 19:50:36.365688154 +0100
|
||||
@@ -45,7 +45,6 @@
|
||||
set(man_dst
|
||||
"${MAN_BUILD_DIR}/spring-dedicated.6.gz"
|
||||
"${MAN_BUILD_DIR}/spring-headless.6.gz"
|
||||
- "${MAN_BUILD_DIR}/spring-opengl4.6.gz"
|
||||
"${MAN_BUILD_DIR}/spring.6.gz")
|
||||
set_source_files_properties(${man_dst} PROPERTIES GENERATED TRUE)
|
||||
|
28
spring-106.0-gcc-12.patch
Normal file
28
spring-106.0-gcc-12.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From addd1eb2995aed10fd9bcb5c97bbb00872728a85 Mon Sep 17 00:00:00 2001
|
||||
From: Elperson <40611324+Elpersonn@users.noreply.github.com>
|
||||
Date: Wed, 20 Jul 2022 17:02:07 +0200
|
||||
Subject: [PATCH] Fix compile error (#574)
|
||||
|
||||
---
|
||||
rts/Lua/LuaObjectRendering.h | 5 +----
|
||||
1 file changed, 1 insertion(+), 4 deletions(-)
|
||||
|
||||
diff --git a/rts/Lua/LuaObjectRendering.h b/rts/Lua/LuaObjectRendering.h
|
||||
index 13ecc7562bd..7e63ab5c4cb 100644
|
||||
--- a/rts/Lua/LuaObjectRendering.h
|
||||
+++ b/rts/Lua/LuaObjectRendering.h
|
||||
@@ -11,13 +11,10 @@ struct lua_State;
|
||||
template<LuaObjType T> class LuaObjectRendering;
|
||||
|
||||
class LuaObjectRenderingImpl {
|
||||
-#if __GNUC__ == 11
|
||||
public:
|
||||
-#else
|
||||
-private:
|
||||
friend class LuaObjectRendering<LUAOBJ_UNIT>;
|
||||
friend class LuaObjectRendering<LUAOBJ_FEATURE>;
|
||||
-#endif
|
||||
+
|
||||
static void CreateMatRefMetatable(lua_State* L);
|
||||
static void PushFunction(lua_State* L, int (*fnPntr)(lua_State*), const char* fnName);
|
||||
|
96
spring-106.0-gcc-13.patch
Normal file
96
spring-106.0-gcc-13.patch
Normal file
@ -0,0 +1,96 @@
|
||||
diff --git a/AI/Skirmish/CircuitAI/src/circuit/util/MaskHandler.h b/AI/Skirmish/CircuitAI/src/circuit/util/MaskHandler.h
|
||||
index 7bde5c3..970080e 100644
|
||||
--- a/AI/Skirmish/CircuitAI/src/circuit/util/MaskHandler.h
|
||||
+++ b/AI/Skirmish/CircuitAI/src/circuit/util/MaskHandler.h
|
||||
@@ -8,6 +8,7 @@
|
||||
#ifndef SRC_CIRCUIT_UTIL_MASKHANDLER_H_
|
||||
#define SRC_CIRCUIT_UTIL_MASKHANDLER_H_
|
||||
|
||||
+#include <cstdint>
|
||||
#include <string>
|
||||
#include <vector>
|
||||
#include <unordered_map>
|
||||
diff --git a/rts/Lua/LuaHashString.h b/rts/Lua/LuaHashString.h
|
||||
index 09e612a..c8cf5b5 100644
|
||||
--- a/rts/Lua/LuaHashString.h
|
||||
+++ b/rts/Lua/LuaHashString.h
|
||||
@@ -3,6 +3,7 @@
|
||||
#ifndef LUA_HASH_STRING_H
|
||||
#define LUA_HASH_STRING_H
|
||||
|
||||
+#include <cstdint>
|
||||
#include <string>
|
||||
|
||||
#include "LuaInclude.h"
|
||||
diff --git a/rts/Sim/Misc/BuildingMaskMap.h b/rts/Sim/Misc/BuildingMaskMap.h
|
||||
index 89351a3..b06b30f 100644
|
||||
--- a/rts/Sim/Misc/BuildingMaskMap.h
|
||||
+++ b/rts/Sim/Misc/BuildingMaskMap.h
|
||||
@@ -3,6 +3,7 @@
|
||||
#ifndef BUILDINGMASKMAP_H
|
||||
#define BUILDINGMASKMAP_H
|
||||
|
||||
+#include <cstdint>
|
||||
#include <vector>
|
||||
|
||||
#include "System/creg/creg_cond.h"
|
||||
diff --git a/rts/System/CRC.h b/rts/System/CRC.h
|
||||
index 1abde22..ee25b24 100644
|
||||
--- a/rts/System/CRC.h
|
||||
+++ b/rts/System/CRC.h
|
||||
@@ -3,6 +3,7 @@
|
||||
#ifndef CRC_H
|
||||
#define CRC_H
|
||||
|
||||
+#include <cstdint>
|
||||
#include <string>
|
||||
|
||||
/** @brief An updateable CRC-32 checksum. */
|
||||
diff --git a/rts/System/Platform/Misc.h b/rts/System/Platform/Misc.h
|
||||
index 37bb44f..e71e3d2 100644
|
||||
--- a/rts/System/Platform/Misc.h
|
||||
+++ b/rts/System/Platform/Misc.h
|
||||
@@ -3,6 +3,7 @@
|
||||
#ifndef PLATFORM_MISC_H
|
||||
#define PLATFORM_MISC_H
|
||||
|
||||
+#include <cstdint>
|
||||
#include <string>
|
||||
#include <array>
|
||||
|
||||
diff --git a/rts/System/SpringHashSet.hpp b/rts/System/SpringHashSet.hpp
|
||||
index 071a6c3..bb79364 100644
|
||||
--- a/rts/System/SpringHashSet.hpp
|
||||
+++ b/rts/System/SpringHashSet.hpp
|
||||
@@ -7,6 +7,7 @@
|
||||
#pragma once
|
||||
|
||||
#include <cstdlib> // malloc
|
||||
+#include <cstdint>
|
||||
#include <iterator>
|
||||
#include <utility>
|
||||
#include <algorithm>
|
||||
diff --git a/rts/System/StringUtil.h b/rts/System/StringUtil.h
|
||||
index e9ba35b..6a6b9d3 100644
|
||||
--- a/rts/System/StringUtil.h
|
||||
+++ b/rts/System/StringUtil.h
|
||||
@@ -5,6 +5,7 @@
|
||||
|
||||
#include <algorithm>
|
||||
#include <cstring>
|
||||
+#include <cstdint>
|
||||
#include <string>
|
||||
#include <sstream>
|
||||
#include <vector>
|
||||
diff --git a/rts/lib/luasocket/src/restrictions.cpp b/rts/lib/luasocket/src/restrictions.cpp
|
||||
index c9cbbfb..4ed3a81 100644
|
||||
--- a/rts/lib/luasocket/src/restrictions.cpp
|
||||
+++ b/rts/lib/luasocket/src/restrictions.cpp
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
#include "restrictions.h"
|
||||
|
||||
+#include <cstdint>
|
||||
#include <string>
|
||||
|
||||
#include "System/SafeUtil.h"
|
@ -1,10 +0,0 @@
|
||||
--- spring_95.0/tools/pr-downloader/src/CMakeLists.txt.orig 2013-12-07 15:47:18.534925170 +0100
|
||||
+++ spring_95.0/tools/pr-downloader/src/CMakeLists.txt 2013-12-07 15:47:01.695091154 +0100
|
||||
@@ -40,6 +40,7 @@
|
||||
Plasma
|
||||
Widget
|
||||
FileSystem
|
||||
+ boost_filesystem
|
||||
)
|
||||
|
||||
|
70
spring.spec
70
spring.spec
@ -1,34 +1,33 @@
|
||||
Name: spring
|
||||
Version: 104.0
|
||||
Release: 2mamba
|
||||
Version: 106.0
|
||||
Release: 1mamba
|
||||
Summary: A project aiming to create a new and versatile RTS Engine
|
||||
Group: Graphical Desktop/Applications/Games
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
|
||||
URL: http://springrts.com/
|
||||
Source: http://downloads.sourceforge.net/project/springrts/springrts/%{name}-%{version}/%{name}_%{version}_src.tar.gz
|
||||
Patch0: spring-95.0-boost_filesystem.patch
|
||||
Patch1: spring-104.0-libopenal-1.20.1.patch
|
||||
Patch2: spring-104.0-reinterpret_cast-in-constexpr.patch
|
||||
Patch3: spring-104.0-SHA512-fix-include.patch
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://springrts.com/
|
||||
Source: https://springrts.com/dl/buildbot/default/master/%{version}/source/spring_%{version}_src.tar.gz
|
||||
#Source: https://github.com/spring/spring.git/%{version}/spring-%{version}_src.tar.bz2
|
||||
Patch0: spring-106.0-gcc-12.patch
|
||||
Patch1: spring-106.0-gcc-13.patch
|
||||
Patch2: spring-106.0-fix-doc-install.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libSDL2-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXcursor-devel
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libdevil-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libglew-devel
|
||||
BuildRequires: libglu-devel
|
||||
BuildRequires: libglvnd-devel
|
||||
BuildRequires: libgperftools-devel
|
||||
BuildRequires: libjsoncpp-devel
|
||||
BuildRequires: libminizip1-devel
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: libopenal-devel
|
||||
@ -39,8 +38,7 @@ BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libboost-devel >= 1.55
|
||||
Provides: springrts
|
||||
Obsoletes: springrts
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
Obsoletes: springrts < 104
|
||||
|
||||
%description
|
||||
Spring is a project aiming to create a new and versatile RTS Engine.
|
||||
@ -48,52 +46,38 @@ Spring is a project aiming to create a new and versatile RTS Engine.
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}_%{version}
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%ifarch %{ix86}
|
||||
sed -i "s|use-ld=gold|use-ld=ld|" rts/build/cmake/TestCXXFlags.cmake
|
||||
%endif
|
||||
%setup -q -n spring_%{version}
|
||||
%patch 0 -p1 -b .gcc-12
|
||||
%patch 1 -p1 -b .gcc-13
|
||||
%patch 2 -p1
|
||||
|
||||
#remove bundled libraries
|
||||
rm -r tools/pr-downloader/src/lib/jsoncpp
|
||||
rm -r tools/pr-downloader/src/lib/minizip
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
%cmake -d build \
|
||||
-DLIBDIR=%{_lib}
|
||||
-DLIBDIR=%{_lib} \
|
||||
-DPRD_JSONCPP_INTERNAL=OFF
|
||||
|
||||
# NOTE: % make does not work
|
||||
make %{_smp_mflags}
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
#install -m0755 build/tools/pr-downloader/src/libCurlWrapper.so \
|
||||
# %{buildroot}%{_libdir}/libCurlWrapper.so
|
||||
#install -m0755 build/tools/pr-downloader/src/FileSystem/libFileSystem.so \
|
||||
# %{buildroot}%{_libdir}/libFileSystem.so
|
||||
#install -m0755 build/tools/pr-downloader/src/lib/7z/libpr-7z.so \
|
||||
# %{buildroot}%{_libdir}/libpr-7z.so
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/mapcompile
|
||||
%{_bindir}/mapdecompile
|
||||
%{_bindir}/spring
|
||||
#%{_bindir}/spring-multithreaded
|
||||
%{_bindir}/spring-dedicated
|
||||
%{_bindir}/spring-headless
|
||||
%{_bindir}/pr-downloader
|
||||
#%{_libdir}/libpr-downloader_static.a
|
||||
#%{_libdir}/libpr-downloader_shared.so
|
||||
%{_libdir}/libunitsync.so
|
||||
#%{_libdir}/libCurlWrapper.so
|
||||
#%{_libdir}/libFileSystem.so
|
||||
#%{_libdir}/libpr-7z.so
|
||||
%dir %{_datadir}/games/spring
|
||||
%{_datadir}/games/spring/*
|
||||
%{_datadir}/applications/spring.desktop
|
||||
@ -101,10 +85,12 @@ make %{_smp_mflags}
|
||||
%{_datadir}/pixmaps/*.png
|
||||
%{_mandir}/man6/spring-dedicated.6*
|
||||
%{_mandir}/man6/spring-headless.6*
|
||||
%{_mandir}/man6/spring-legacy.6*
|
||||
%{_mandir}/man6/spring.6*
|
||||
|
||||
%changelog
|
||||
* Mon Nov 18 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 106.0-1mamba
|
||||
- update to 106.0
|
||||
|
||||
* Mon Oct 19 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 104.0-2mamba
|
||||
- rebuilt without apache-maven3 build requirement
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user