rebuilt without apache-maven3 build requirement [release 104.0-2mamba;Mon Oct 19 2020]
This commit is contained in:
parent
e22c4ea113
commit
710ca2419d
12
spring-104.0-SHA512-fix-include.patch
Normal file
12
spring-104.0-SHA512-fix-include.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff --git a/rts/System/Sync/SHA512.cpp b/rts/System/Sync/SHA512.cpp
|
||||
index ab4e973a23..adc9b3ee47 100644
|
||||
--- a/rts/System/Sync/SHA512.cpp
|
||||
+++ b/rts/System/Sync/SHA512.cpp
|
||||
@@ -2,6 +2,7 @@
|
||||
|
||||
#include <cassert>
|
||||
#include <cstring>
|
||||
+#include <cstdio>
|
||||
|
||||
#include "SHA512.hpp"
|
||||
|
44
spring-104.0-libopenal-1.20.1.patch
Normal file
44
spring-104.0-libopenal-1.20.1.patch
Normal file
@ -0,0 +1,44 @@
|
||||
From d159c9f0d21d3bc96c85063cc258b6fd8ec1be2d Mon Sep 17 00:00:00 2001
|
||||
From: abma <spring@abma.de>
|
||||
Date: Mon, 6 Jan 2020 11:16:25 +0100
|
||||
Subject: [PATCH] fix #6358: compile error because of new openal version /
|
||||
changed struct
|
||||
|
||||
---
|
||||
rts/System/Sound/OpenAL/Sound.cpp | 1 -
|
||||
rts/System/Sound/OpenAL/Sound.h | 3 +--
|
||||
2 files changed, 1 insertion(+), 3 deletions(-)
|
||||
|
||||
diff --git a/rts/System/Sound/OpenAL/Sound.cpp b/rts/System/Sound/OpenAL/Sound.cpp
|
||||
index 50bc40e8c4..9ea2ad6a73 100644
|
||||
--- a/rts/System/Sound/OpenAL/Sound.cpp
|
||||
+++ b/rts/System/Sound/OpenAL/Sound.cpp
|
||||
@@ -4,7 +4,6 @@
|
||||
|
||||
#include <cstdlib>
|
||||
#include <cmath>
|
||||
-#include <alc.h>
|
||||
|
||||
#ifndef ALC_ALL_DEVICES_SPECIFIER
|
||||
#define ALC_ALL_DEVICES_SPECIFIER 0x1013
|
||||
diff --git a/rts/System/Sound/OpenAL/Sound.h b/rts/System/Sound/OpenAL/Sound.h
|
||||
index 11d36ef86c..d362cb5b39 100644
|
||||
--- a/rts/System/Sound/OpenAL/Sound.h
|
||||
+++ b/rts/System/Sound/OpenAL/Sound.h
|
||||
@@ -5,6 +5,7 @@
|
||||
|
||||
#include <string>
|
||||
#include <vector>
|
||||
+#include <alc.h>
|
||||
|
||||
#include "System/Sound/ISound.h"
|
||||
#include "System/float3.h"
|
||||
@@ -16,8 +17,6 @@
|
||||
class CSoundSource;
|
||||
class SoundBuffer;
|
||||
class SoundItem;
|
||||
-struct ALCdevice_struct;
|
||||
-typedef struct ALCdevice_struct ALCdevice;
|
||||
|
||||
/// Default sound system implementation (OpenAL)
|
||||
class CSound : public ISound
|
15
spring-104.0-reinterpret_cast-in-constexpr.patch
Normal file
15
spring-104.0-reinterpret_cast-in-constexpr.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff --git a/rts/Rendering/GL/myGL.cpp b/rts/Rendering/GL/myGL.cpp
|
||||
index 5abef32ce0..95a786970c 100644
|
||||
--- a/rts/Rendering/GL/myGL.cpp
|
||||
+++ b/rts/Rendering/GL/myGL.cpp
|
||||
@@ -146,8 +147,8 @@ static bool GetVideoMemInfoMESA(GLint* memInfo)
|
||||
|
||||
typedef PFNGLXQUERYCURRENTRENDERERINTEGERMESAPROC QCRIProc;
|
||||
|
||||
- static constexpr const GLubyte* qcriProcName = (const GLubyte*) "glXQueryCurrentRendererIntegerMESA";
|
||||
- static const QCRIProc qcriProcAddr = (QCRIProc) glXGetProcAddress(qcriProcName);
|
||||
+ static const char qcriProcName[] = "glXQueryCurrentRendererIntegerMESA";
|
||||
+ static const QCRIProc qcriProcAddr = (QCRIProc) glXGetProcAddress(reinterpret_cast<const GLubyte*>(qcriProcName));
|
||||
|
||||
if (qcriProcAddr == nullptr)
|
||||
return false;
|
34
spring.spec
34
spring.spec
@ -1,6 +1,6 @@
|
||||
Name: spring
|
||||
Version: 104.0
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: A project aiming to create a new and versatile RTS Engine
|
||||
Group: Graphical Desktop/Applications/Games
|
||||
Vendor: openmamba
|
||||
@ -9,28 +9,34 @@ Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
|
||||
URL: http://springrts.com/
|
||||
Source: http://downloads.sourceforge.net/project/springrts/springrts/%{name}-%{version}/%{name}_%{version}_src.tar.gz
|
||||
Patch0: spring-95.0-boost_filesystem.patch
|
||||
Patch1: spring-104.0-libopenal-1.20.1.patch
|
||||
Patch2: spring-104.0-reinterpret_cast-in-constexpr.patch
|
||||
Patch3: spring-104.0-SHA512-fix-include.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libSDL2-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXcursor-devel
|
||||
BuildRequires: libboost-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libdevil-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libglew-devel
|
||||
BuildRequires: libGLU-devel
|
||||
#BuildRequires: libgoogle-perftools-devel
|
||||
BuildRequires: libgperftools-devel
|
||||
BuildRequires: libminizip1-devel
|
||||
BuildRequires: libogg-devel
|
||||
BuildRequires: libopenal-devel
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libunwind-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXcursor-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: apache-maven3
|
||||
BuildRequires: libboost-devel >= 1.55
|
||||
Provides: springrts
|
||||
Obsoletes: springrts
|
||||
@ -39,16 +45,23 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
%description
|
||||
Spring is a project aiming to create a new and versatile RTS Engine.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}_%{version}
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
#%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%ifarch %{ix86}
|
||||
sed -i "s|use-ld=gold|use-ld=ld|" rts/build/cmake/TestCXXFlags.cmake
|
||||
%endif
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
%cmake -d build \
|
||||
-DMVN_BIN=%{bindir}/mvn3 \
|
||||
-DLIBDIR=%{_lib}
|
||||
|
||||
# NOTE: % make does not work
|
||||
@ -92,6 +105,9 @@ make %{_smp_mflags}
|
||||
%{_mandir}/man6/spring.6*
|
||||
|
||||
%changelog
|
||||
* Mon Oct 19 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 104.0-2mamba
|
||||
- rebuilt without apache-maven3 build requirement
|
||||
|
||||
* Sat Jan 06 2018 Automatic Build System <autodist@mambasoft.it> 104.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user