python 2.7 mass rebuild [release 0.8.4-4mamba;Fri May 17 2013]

This commit is contained in:
Silvan Calarco 2024-01-05 16:54:42 +01:00
parent 6894f5328f
commit f3759e1236
3 changed files with 82 additions and 0 deletions

View File

@ -1,2 +1,5 @@
# python-xml
The PyXML package is a collection of libraries to process XML with Python.
The distribution contains a validating XML parser, an implementation of the SAX and DOM programming interfaces and an interface to the Expat parser.

View File

@ -0,0 +1,10 @@
--- PyXML-0.8.4/xml/parsers/xmlproc/xmlutils.py.orig 2009-12-30 11:43:21.000000000 +0100
+++ PyXML-0.8.4/xml/parsers/xmlproc/xmlutils.py 2009-12-30 11:44:12.000000000 +0100
@@ -720,6 +720,7 @@
# to the recoding.
try:
self.data = self.charset_converter(self.data)
+ self.datasize = len(self.data)
except UnicodeError, e:
self._handle_decoding_error(self.data, e)
self.input_encoding = enc1

69
python-xml.spec Normal file
View File

@ -0,0 +1,69 @@
Name: python-xml
Version: 0.8.4
Release: 4mamba
Summary: XML package for Python
Group: Development/Bindings
Vendor: openmamba
Distribution: openmamba
Packager: Aleph0 <aleph0@openmamba.org>
URL: http://www.python.org/sigs/xml-sig/
Source: http://downloads.sourceforge.net/pyxml/PyXML-%{version}.tar.gz
Patch: python-xml-0.8.4-datasize.patch
License: Python
Provides: python-pyxml
Obsoletes: python-pyxml
Provides: pyxml
BuildRoot: %{_tmppath}/%{name}-%{version}-root
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libpython-devel
## AUTOBUILDREQ-END
%description
The PyXML package is a collection of libraries to process XML with Python.
The distribution contains a validating XML parser, an implementation of the SAX and DOM programming interfaces and an interface to the Expat parser.
%prep
%setup -q -n PyXML-%{version}
%patch -p1
%build
CFLAGS="%{optflags}" %{__python} setup.py build \
--with-xslt
%install
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%{__python} setup.py install \
--root=%{buildroot} \
--install-headers=%{_includedir}/python \
--install-lib=%{python_sitearch} \
--with-xslt
#%{__python} -O %{_libdir}/python%{pyver}/compileall.py \
# %{buildroot}%{python_sitearch}
%clean
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
%files
%defattr(-,root,root)
%{_bindir}/xmlproc_parse
%{_bindir}/xmlproc_val
%dir %{python_sitearch}/_xmlplus
%{python_sitearch}/_xmlplus/*
%{python_sitearch}/PyXML-%{version}-py%{python_version}.egg-info
%changelog
* Fri May 17 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.8.4-4mamba
- python 2.7 mass rebuild
* Wed Dec 30 2009 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.8.4-3mamba
- fixed a problem calculating the datasize of the data read from an XML file
- fixed license
- added missing build requirements
* Tue Sep 30 2008 Tiziana Ferro <tiziana.ferro@email.it> 0.8.4-2mamba
- update buildrequirements list and rebuild
* Fri Sep 23 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.8.4-1qilnx
- package created by autospec