python-dbus/python-dbus-1.3.2-Move-python-modules-to-architecture-specific-directo.patch

48 lines
1.3 KiB
Diff

From 86741aa93aaaf388899d1fa0c25d0d67729b7a5c Mon Sep 17 00:00:00 2001
From: leigh123linux <leigh123linux@googlemail.com>
Date: Tue, 23 Feb 2016 07:32:08 +0000
Subject: [PATCH] Move python modules to architecture-specific directory
This is because dbus-python gets dragged in as a dependency of other
things people want to be multilib-compatible. As is the Python
modules conflict.
---
Makefile.am | 7 ++++---
1 file changed, 4 insertions(+), 3 deletions(-)
diff --git a/Makefile.am b/Makefile.am
index 8738d57..b6d30c0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -176,7 +176,8 @@ test_dbus_py_test_la_SOURCES = \
# === dbus package ===
-nobase_python_PYTHON = \
+dbuspydir = $(pyexecdir)
+nobase_dbuspy_DATA = \
dbus/bus.py \
dbus/connection.py \
dbus/_compat.py \
@@ -195,7 +196,7 @@ nobase_python_PYTHON = \
dbus/service.py \
dbus/types.py
-check_py_sources = $(nobase_python_PYTHON)
+check_py_sources = $(nobase_dbuspy_DATA)
include $(top_srcdir)/tools/check-coding-style.mk
# === Devel stuff ===
@@ -434,7 +435,7 @@ uninstall-local-pycache:
if ENABLE_DOCUMENTATION
all: doc/html/.stamp
-doc/html/.stamp: $(nobase_python_PYTHON) \
+doc/html/.stamp: $(nobase_dbuspy_DATA) \
_dbus_bindings.la \
_dbus_glib_bindings.la \
$(sphinx_sources) \
--
2.37.3