provide python*dist(dbus-python) [release 1.3.2-2mamba;Thu Nov 10 2022]
This commit is contained in:
parent
c164c37959
commit
3177886153
@ -0,0 +1,47 @@
|
||||
From 86741aa93aaaf388899d1fa0c25d0d67729b7a5c Mon Sep 17 00:00:00 2001
|
||||
From: leigh123linux <leigh123linux@googlemail.com>
|
||||
Date: Tue, 23 Feb 2016 07:32:08 +0000
|
||||
Subject: [PATCH] Move python modules to architecture-specific directory
|
||||
|
||||
This is because dbus-python gets dragged in as a dependency of other
|
||||
things people want to be multilib-compatible. As is the Python
|
||||
modules conflict.
|
||||
---
|
||||
Makefile.am | 7 ++++---
|
||||
1 file changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/Makefile.am b/Makefile.am
|
||||
index 8738d57..b6d30c0 100644
|
||||
--- a/Makefile.am
|
||||
+++ b/Makefile.am
|
||||
@@ -176,7 +176,8 @@ test_dbus_py_test_la_SOURCES = \
|
||||
|
||||
# === dbus package ===
|
||||
|
||||
-nobase_python_PYTHON = \
|
||||
+dbuspydir = $(pyexecdir)
|
||||
+nobase_dbuspy_DATA = \
|
||||
dbus/bus.py \
|
||||
dbus/connection.py \
|
||||
dbus/_compat.py \
|
||||
@@ -195,7 +196,7 @@ nobase_python_PYTHON = \
|
||||
dbus/service.py \
|
||||
dbus/types.py
|
||||
|
||||
-check_py_sources = $(nobase_python_PYTHON)
|
||||
+check_py_sources = $(nobase_dbuspy_DATA)
|
||||
include $(top_srcdir)/tools/check-coding-style.mk
|
||||
|
||||
# === Devel stuff ===
|
||||
@@ -434,7 +435,7 @@ uninstall-local-pycache:
|
||||
if ENABLE_DOCUMENTATION
|
||||
all: doc/html/.stamp
|
||||
|
||||
-doc/html/.stamp: $(nobase_python_PYTHON) \
|
||||
+doc/html/.stamp: $(nobase_dbuspy_DATA) \
|
||||
_dbus_bindings.la \
|
||||
_dbus_glib_bindings.la \
|
||||
$(sphinx_sources) \
|
||||
--
|
||||
2.37.3
|
||||
|
@ -1,5 +1,5 @@
|
||||
Name: python-dbus
|
||||
Version: 1.2.18
|
||||
Version: 1.3.2
|
||||
Release: 2mamba
|
||||
Summary: D-Bus python bindings for use with python programs
|
||||
Group: System/Libraries/Python
|
||||
@ -8,13 +8,13 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.freedesktop.org/wiki/Software/dbus/
|
||||
Source: https://dbus.freedesktop.org/releases/dbus-python/dbus-python-%{version}.tar.gz
|
||||
Patch0: python-dbus-1.3.2-Move-python-modules-to-architecture-specific-directo.patch
|
||||
License: GPL, Academic Free License
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libpython3-devel
|
||||
BuildRequires: libsystemd-devel
|
||||
## AUTOBUILDREQ-END
|
||||
|
||||
%description
|
||||
@ -38,16 +38,23 @@ Obsoletes: python-dbus < 1.2.18-2mamba
|
||||
%endif
|
||||
|
||||
%if 0%{?with_pyver}
|
||||
%define py_requires_append \
|
||||
Provides: python%{python_version}dist(dbus-python)
|
||||
%pyver_package
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%setup -q -n dbus-python-%{version}
|
||||
%patch0 -p1 -b .Move-python-modules-to-architecture-specific-directo
|
||||
|
||||
autoreconf -fi
|
||||
|
||||
#%ifarch x86_64 aarch64
|
||||
#sed -i "s|/lib/python|/lib64/python|" configure
|
||||
#%endif
|
||||
|
||||
%build
|
||||
export DBUS_PYTHON_USE_AUTOTOOLS=1
|
||||
%configure \
|
||||
PYTHON=%{__python} \
|
||||
--disable-documentation
|
||||
@ -56,6 +63,7 @@ Obsoletes: python-dbus < 1.2.18-2mamba
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
export DBUS_PYTHON_USE_AUTOTOOLS=1
|
||||
%make_install \
|
||||
pythondir=%{python_sitearch}
|
||||
|
||||
@ -69,9 +77,7 @@ rm -rf %{buildroot}%{_datadir}/doc/dbus-python
|
||||
%defattr(-,root,root)
|
||||
%dir %{python_sitearch}/dbus
|
||||
%{python_sitearch}/dbus/*
|
||||
%{python_sitearch}/_dbus_bindings.la
|
||||
%{python_sitearch}/_dbus_bindings.so
|
||||
%{python_sitearch}/_dbus_glib_bindings.la
|
||||
%{python_sitearch}/_dbus_glib_bindings.so
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
@ -83,6 +89,12 @@ rm -rf %{buildroot}%{_datadir}/doc/dbus-python
|
||||
%doc ChangeLog NEWS README doc/*.txt
|
||||
|
||||
%changelog
|
||||
* Thu Nov 10 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.2-2mamba
|
||||
- provide python*dist(dbus-python)
|
||||
|
||||
* Thu Nov 10 2022 Automatic Build System <autodist@mambasoft.it> 1.3.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Apr 08 2022 Silvan Calarco <silvan.calarco@mambasoft.it> 1.2.18-2mamba
|
||||
- rebuilt with python 3.10
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user