added upstream patch to bring authentication dialog to the front when it is shown [release 0.99.0-2mamba;Sun Feb 19 2012]

This commit is contained in:
Silvan Calarco 2024-01-06 10:24:33 +01:00
parent 8d6d53ac20
commit 648352b68c
3 changed files with 98 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# polkit-kde-agent-1
KDE authentication agent for polkit.

View File

@ -0,0 +1,28 @@
From: Jonathan Thomas <echidnaman@kubuntu.org>
Date: Wed, 19 Jan 2011 15:21:53 +0000
Subject: Bring the auth dialog to the front when it is shown. Otherwise it pops up behind the app requesting it and the user never sees it.
X-Git-Url: http://quickgit.kde.org/?p=polkit-kde-agent-1.git&amp;a=commitdiff&amp;h=0701f84a57156f8f584bb4fe928811a26ceefcf0
---
Bring the auth dialog to the front when it is shown. Otherwise it pops up behind the app requesting it and the user never sees it.
---
--- a/policykitlistener.cpp
+++ b/policykitlistener.cpp
@@ -22,6 +22,7 @@
#include "AuthDialog.h"
#include <KDebug>
+#include <KWindowSystem>
#include <PolkitQt1/Agent/Listener>
#include <PolkitQt1/Agent/Session>
@@ -100,6 +101,7 @@ void PolicyKitListener::initiateAuthenti
kDebug() << "WinId of the dialog is " << m_dialog.data()->winId() << m_dialog.data()->effectiveWinId();
m_dialog.data()->setOptions();
m_dialog.data()->show();
+ KWindowSystem::forceActiveWindow(m_dialog.data()->winId());
kDebug() << "WinId of the shown dialog is " << m_dialog.data()->winId() << m_dialog.data()->effectiveWinId();
m_numTries = 0;

68
polkit-kde-agent-1.spec Normal file
View File

@ -0,0 +1,68 @@
Name: polkit-kde-agent-1
Version: 0.99.0
Release: 2mamba
Summary: KDE authentication agent for polkit
Group: Graphical Desktop/Applications/Security
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.kde.org
Source: ftp://ftp.kde.org/pub/kde/stable/apps/KDE4.x/admin/polkit-kde-agent-1-%{version}.tar.bz2
Patch0: %{name}-0.99.0-bring_the_auth_dialog_to_the_front.patch
License: GPL
BuildRequires: cmake
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: kdelibs4-devel
BuildRequires: libgcc
BuildRequires: libqt4-devel
BuildRequires: libstdc++6-devel
BuildRequires: polkit-qt-1-devel >= 0.99.0
## AUTOBUILDREQ-END
Obsoletes: polkit-kde-1
Provides: polkit-kde-1 = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
KDE authentication agent for polkit.
%prep
%setup -q
%patch0 -p1
%build
%cmake_kde4 -d build
%make
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall -C build
%find_lang polkit-kde-authentication-agent-1
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%files -f polkit-kde-authentication-agent-1.lang
%defattr(-,root,root)
%{_kde4_autostartdir}/polkit-kde-authentication-agent-1.desktop
%{_kde4_datadir}/policykit1-kde/policykit1-kde.notifyrc
%{_kde4_libexecdir}/polkit-kde-authentication-agent-1
%doc COPYING
%changelog
* Sun Feb 19 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.99.0-2mamba
- added upstream patch to bring authentication dialog to the front when it is shown
* Sat Jan 29 2011 Davide Madrisan <davide.madrisan@gmail.com> 0.99.0-1mamba
- update to 0.99.0
- renamed to polkit-kde-agent-1
* Sat Jan 29 2011 Davide Madrisan <davide.madrisan@gmail.com> 0.95.1-3mamba
- rebuilt against latest polkit-qt-1
* Mon May 31 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.95.1-2mamba
- added gcc45 ftbfs patch
* Mon Apr 05 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.95.1-1mamba
- package created by autospec