perl 5.16 mass rebuild [release 1.03-3mamba;Tue Nov 13 2012]

This commit is contained in:
Silvan Calarco 2024-01-06 08:56:43 +01:00
parent 1b4a5c822b
commit 06986d446a
3 changed files with 82 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# perl-Event-Lib
This module is a Perl wrapper around libevent as available from http://monkey.org/~provos/libevent/. It allows to execute a function whenever a given event on a filehandle happens, a timeout occurs or a signal is received

View File

@ -0,0 +1,14 @@
diff -Nru Event-Lib-1.03.orig/Lib.xs Event-Lib-1.03/Lib.xs
--- Event-Lib-1.03.orig/Lib.xs 2012-02-20 17:19:43.612532195 +0100
+++ Event-Lib-1.03/Lib.xs 2012-02-20 17:16:44.852534514 +0100
@@ -5,6 +5,10 @@
#include <sys/time.h>
#endif
+# ifndef __USE_FILE_OFFSET64
+#define off64_t off_t
+# endif
+
#include "EXTERN.h"
#include "perl.h"
#include "XSUB.h"

66
perl-Event-Lib.spec Normal file
View File

@ -0,0 +1,66 @@
%define perl_major_ver %(eval `perl -V:version`; echo ${version%*.[0-9]*}.0)
Name: perl-Event-Lib
Version: 1.03
Release: 3mamba
Summary: Event::Lib - Perl wrapper around libevent
Group: System/Libraries/Perl
Vendor: openmamba
Distribution: openmamba
Packager: Automatic Build System <autodist@mambasoft.it>
URL: http://www.cpan.org
Source: http://search.cpan.org/CPAN/authors/id/V/VP/VPARSEVAL/Event-Lib-%{version}.tar.gz
Patch0: %{name}-1.03-arm-fix-missing-off64_t.patch
License: Artistic, GPL
Requires: perl >= %perl_major_ver
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libevent-devel
BuildRequires: perl-devel >= %perl_major_ver
## AUTOBUILDREQ-END
BuildRequires: perl-Test-Pod
BuildRequires: perl-Test-Pod-Coverage
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
This module is a Perl wrapper around libevent as available from http://monkey.org/~provos/libevent/. It allows to execute a function whenever a given event on a filehandle happens, a timeout occurs or a signal is received
%prep
%setup -q -n Event-Lib-%{version}
%patch0 -p1
%build
perl Makefile.PL PREFIX=%{_prefix} INSTALLDIRS=vendor
%make %{?_smp_mflags}
#% make test
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall_perl
packlist=`find %{buildroot} -name .packlist`
[ -z "$packlist" ] && exit 1 || cat $packlist | \
sed "s,%buildroot,,g;s,.*/man/.*,&.gz,g" | \
sort -u > .packlist && rm $packlist
strid=`echo $packlist | sed 's,.*auto\(.*\)/.packlist,\1,'`
for dir in `find %{buildroot} -type d | grep $strid`; do
echo "%dir ${dir#%buildroot}" >> .packlist
done
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
rm -f .packlist
%files -f .packlist
%defattr(-,root,root)
%changelog
* Tue Nov 13 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.03-3mamba
- perl 5.16 mass rebuild
* Tue Nov 04 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.03-2mamba
- automatic rebuild by autodist
* Wed Jul 02 2008 gil <puntogil@libero.it> 1.03-1mamba
- package created by autospec