newt/newt-0.52.17-configure-pythonvers.patch

25 lines
1.2 KiB
Diff

diff -Nru newt-0.52.17.orig/configure newt-0.52.17/configure
--- newt-0.52.17.orig/configure 2014-02-19 17:57:06.000000000 +0100
+++ newt-0.52.17/configure 2014-07-13 17:37:18.610079390 +0200
@@ -3674,7 +3674,7 @@
$as_echo "skipped" >&6; }
PYTHONVERS=
else
- PYTHONVERS=$(ls /usr/include/python*/Python.h 2> /dev/null | sed 's|.*\(python[0-9]*\.[0-9]*\).*|\1|g' | tr '\n' ' ')
+ PYTHONVERS=$(ls /usr/include/python*.*/Python.h 2> /dev/null | sed 's|.*\(python[0-9]*\.[0-9]*\).*|\1|g' | tr '\n' ' ')
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $PYTHONVERS" >&5
$as_echo "$PYTHONVERS" >&6; }
fi
diff -Nru newt-0.52.17.orig/configure.ac newt-0.52.17/configure.ac
--- newt-0.52.17.orig/configure.ac 2014-02-19 17:56:53.000000000 +0100
+++ newt-0.52.17/configure.ac 2014-07-13 17:37:29.102076684 +0200
@@ -60,7 +60,7 @@
AC_MSG_RESULT([skipped])
PYTHONVERS=
else
- PYTHONVERS=$(ls /usr/include/python*/Python.h 2> /dev/null | sed 's|.*\(python[[0-9]]*\.[[0-9]]*\).*|\1|g' | tr '\n' ' ')
+ PYTHONVERS=$(ls /usr/include/python*.*/Python.h 2> /dev/null | sed 's|.*\(python[[0-9]]*\.[[0-9]]*\).*|\1|g' | tr '\n' ' ')
AC_MSG_RESULT([$PYTHONVERS])
fi
AC_SUBST([PYTHONVERS])