rebuilt to fix link with correct soname [release 0.52.17-2mamba;Thu Jul 17 2014]

This commit is contained in:
Silvan Calarco 2024-01-06 07:37:20 +01:00
parent 9043f5559f
commit 0daf39a7fc
3 changed files with 65 additions and 41 deletions

View File

@ -1,11 +0,0 @@
--- newt-0.51.6/Makefile.in.orig 2005-06-30 09:59:52.000000000 +0200
+++ newt-0.51.6/Makefile.in 2005-06-30 10:02:47.000000000 +0200
@@ -12,7 +12,7 @@
CVSTAG = r$(subst .,-,$(VERSION))
SONAME = @SONAME@
-PYTHONVERS = $(shell ls /usr/include/python*/Python.h | sed "s|/usr/include/||g"| sed "s|/Python.h||g")
+PYTHONVERS = python
WHIPTCLSO=
#WHIPTCLSO=whiptcl.so

View File

@ -0,0 +1,24 @@
diff -Nru newt-0.52.17.orig/configure newt-0.52.17/configure
--- newt-0.52.17.orig/configure 2014-02-19 17:57:06.000000000 +0100
+++ newt-0.52.17/configure 2014-07-13 17:37:18.610079390 +0200
@@ -3674,7 +3674,7 @@
$as_echo "skipped" >&6; }
PYTHONVERS=
else
- PYTHONVERS=$(ls /usr/include/python*/Python.h 2> /dev/null | sed 's|.*\(python[0-9]*\.[0-9]*\).*|\1|g' | tr '\n' ' ')
+ PYTHONVERS=$(ls /usr/include/python*.*/Python.h 2> /dev/null | sed 's|.*\(python[0-9]*\.[0-9]*\).*|\1|g' | tr '\n' ' ')
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $PYTHONVERS" >&5
$as_echo "$PYTHONVERS" >&6; }
fi
diff -Nru newt-0.52.17.orig/configure.ac newt-0.52.17/configure.ac
--- newt-0.52.17.orig/configure.ac 2014-02-19 17:56:53.000000000 +0100
+++ newt-0.52.17/configure.ac 2014-07-13 17:37:29.102076684 +0200
@@ -60,7 +60,7 @@
AC_MSG_RESULT([skipped])
PYTHONVERS=
else
- PYTHONVERS=$(ls /usr/include/python*/Python.h 2> /dev/null | sed 's|.*\(python[[0-9]]*\.[[0-9]]*\).*|\1|g' | tr '\n' ' ')
+ PYTHONVERS=$(ls /usr/include/python*.*/Python.h 2> /dev/null | sed 's|.*\(python[[0-9]]*\.[[0-9]]*\).*|\1|g' | tr '\n' ' ')
AC_MSG_RESULT([$PYTHONVERS])
fi
AC_SUBST([PYTHONVERS])

View File

@ -1,8 +1,6 @@
%define libname libnewt
Name: newt
Version: 0.52.15
Release: 1mamba
Version: 0.52.17
Release: 2mamba
Summary: A development library for text mode user interfaces
Group: System/Libraries
Vendor: openmamba
@ -10,16 +8,21 @@ Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: ftp://fedorahosted.org/newt
Source: https://fedorahosted.org/releases/n/e/newt/newt-%{version}.tar.gz
Patch0: %{name}-0.51.6-pydir.patch
Patch0: newt-0.52.17-configure-pythonvers.patch
Patch1: %{name}-0.51.6-if1close.patch
License: LGPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libpopt-devel
BuildRequires: libslang-devel
## AUTOBUILDREQ-END
BuildRequires: libpython-devel
BuildRequires: libpython27-devel
BuildRequires: libpython3-devel
BuildRequires: libslang-devel
BuildRequires: libtcl-devel
## AUTOBUILDREQ-END
BuildRequires: libpython3-devel
BuildRequires: libpython27-devel
BuildRequires: libtcl-devel >= 8.6.1
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
@ -27,28 +30,28 @@ Newt is a programming library for color text mode, widget based user interfaces.
Newt can be used to add stacked windows, entry widgets, checkboxes, radio buttons, labels, plain text fields, scrollbars, etc., to text mode user interfaces.
This package contains a /usr/bin/dialog replacement called whiptail. Newt is based on the slang library.
%package -n %{libname}
%package -n lib%{name}
Summary: Newt windowing toolkit development files library
Group: System/Libraries
%description -n %{libname}
%description -n lib%{name}
Newt is a programming library for color text mode, widget based user interfaces.
Newt can be used to add stacked windows, entry widgets, checkboxes, radio buttons, labels, plain text fields, scrollbars, etc., to text mode user interfaces.
This package contains the shared library needed by programs built with newt. Newt is based on the slang library.
%package -n %{libname}-devel
%package -n lib%{name}-devel
Summary: Newt windowing toolkit development files
Group: Development/Libraries
Requires: %{name} = %{version}-%{release}
%description -n %{libname}-devel
%description -n lib%{name}-devel
Newt is a development library for text mode user interfaces. Newt is based on the slang library.
This package contains the header files and libraries necessary for developing applications which use newt.
%package -n python-%{name}
Summary: Python bindings for GNU parted for newt windowing toolkit
Group: Development/Libraries/Python
Requires: %{libname} = %{version}
Requires: lib%{name} = %{version}-%{release}
Requires: python >= 2.3.4
%description -n python-%{name}
@ -59,7 +62,7 @@ This module contains Python bindings for the newt library.
%package -n python-%{name}-py27
Summary: Python 2.7 bindings for GNU parted for newt windowing toolkit
Group: Development/Libraries/Python
Requires: %{libname} = %{version}
Requires: lib%{name} = %{version}-%{release}
Requires: python27
%description -n python-%{name}-py27
@ -69,16 +72,17 @@ This module contains Python 2.7 bindings for the newt library.
%prep
%setup -q
#%patch0 -p1 -b .pydir
%patch0 -p1
%patch1 -p1 -b .if1close
%build
%configure
%make LIBTCL="-ltcl8.5" \
%make \
%if "%{_host}" != "%{_build}"
LIBS="-lslang -ldl -lm"
%endif
#LIBTCL="-ltcl8.5" \
chmod 0644 peanuts.py popcorn.py
@ -101,41 +105,48 @@ mv %{buildroot}%{_libdir}/python* %{buildroot}%{_prefix}/lib/
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -n %{libname} -p /sbin/ldconfig
%postun -n %{libname} -p /sbin/ldconfig
%post -n lib%{name} -p /sbin/ldconfig
%postun -n lib%{name} -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_bindir}/whiptail
%{_mandir}/man1/whiptail.1*
%doc CHANGES COPYING
%doc COPYING
%files -n %{libname} -f %{name}.lang
%files -n lib%{name} -f %{name}.lang
%defattr(-,root,root)
%{_libdir}/*.so.*
%{_libdir}/libnewt.so.*
%files -n %{libname}-devel
%files -n lib%{name}-devel
%defattr(-,root,root)
%{_includedir}/%{name}.h
%{_libdir}/%{libname}.a
%{_libdir}/%{libname}.so
%{_libdir}/libnewt.a
%{_libdir}/libnewt.so
%{_libdir}/pkgconfig/libnewt.pc
%if "%{_host}" == "%{_build}"
%{_libdir}/whiptcl.so
%endif
%doc CHANGES
%doc tutorial.sgml peanuts.py popcorn.py
%files -n python-newt
%defattr(-,root,root)
%{python_sitearch}/*.so
%{python_sitearch}/*.py
%files -n python-newt-py27
%defattr(-,root,root)
%{python27_sitearch}/*.so
%{python27_sitearch}/*.py
%{python3_sitelib}/*.so
%{python3_sitelib}/*.py
%{python27_sitelib}/*.so
%{python27_sitelib}/*.py
%changelog
* Thu Jul 17 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.52.17-2mamba
- rebuilt to fix link with correct soname
* Sun Jul 13 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.52.17-1mamba
- update to 0.52.17
* Sun Aug 11 2013 Automatic Build System <autodist@mambasoft.it> 0.52.16-1mamba
- automatic update by autodist
* Thu Mar 28 2013 Automatic Build System <autodist@mambasoft.it> 0.52.15-1mamba
- automatic version update by autodist