automatic version update by autodist [release 0.52.15-1mamba;Thu Mar 28 2013]
This commit is contained in:
parent
dfe80fc11b
commit
9043f5559f
@ -1,2 +1,6 @@
|
||||
# newt
|
||||
|
||||
Newt is a programming library for color text mode, widget based user interfaces.
|
||||
Newt can be used to add stacked windows, entry widgets, checkboxes, radio buttons, labels, plain text fields, scrollbars, etc., to text mode user interfaces.
|
||||
This package contains a /usr/bin/dialog replacement called whiptail. Newt is based on the slang library.
|
||||
|
||||
|
29
newt-0.51.6-if1close.patch
Normal file
29
newt-0.51.6-if1close.patch
Normal file
@ -0,0 +1,29 @@
|
||||
--- newt-0.51.6/form.c.orig 2004-10-15 11:17:35.042333181 -0400
|
||||
+++ newt-0.51.6/form.c 2004-10-15 11:18:53.428533351 -0400
|
||||
@@ -889,6 +889,7 @@
|
||||
struct eventResult er;
|
||||
int key, i, max;
|
||||
int done = 0;
|
||||
+ int success;
|
||||
fd_set readSet, writeSet, exceptSet;
|
||||
struct timeval nextTimeout, now, timeout;
|
||||
#ifdef USE_GPM
|
||||
@@ -902,7 +903,7 @@
|
||||
conn.minMod = 0;
|
||||
conn.maxMod = 0;
|
||||
|
||||
- Gpm_Open(&conn, 0);
|
||||
+ success = Gpm_Open(&conn, 0);
|
||||
#endif
|
||||
|
||||
newtFormSetSize(co);
|
||||
@@ -1062,7 +1063,8 @@
|
||||
}
|
||||
newtRefresh();
|
||||
#ifdef USE_GPM
|
||||
- Gpm_Close();
|
||||
+ if (success > 0)
|
||||
+ Gpm_Close();
|
||||
#endif
|
||||
}
|
||||
|
11
newt-0.51.6-pydir.patch
Normal file
11
newt-0.51.6-pydir.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- newt-0.51.6/Makefile.in.orig 2005-06-30 09:59:52.000000000 +0200
|
||||
+++ newt-0.51.6/Makefile.in 2005-06-30 10:02:47.000000000 +0200
|
||||
@@ -12,7 +12,7 @@
|
||||
CVSTAG = r$(subst .,-,$(VERSION))
|
||||
SONAME = @SONAME@
|
||||
|
||||
-PYTHONVERS = $(shell ls /usr/include/python*/Python.h | sed "s|/usr/include/||g"| sed "s|/Python.h||g")
|
||||
+PYTHONVERS = python
|
||||
|
||||
WHIPTCLSO=
|
||||
#WHIPTCLSO=whiptcl.so
|
175
newt.spec
Normal file
175
newt.spec
Normal file
@ -0,0 +1,175 @@
|
||||
%define libname libnewt
|
||||
|
||||
Name: newt
|
||||
Version: 0.52.15
|
||||
Release: 1mamba
|
||||
Summary: A development library for text mode user interfaces
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: ftp://fedorahosted.org/newt
|
||||
Source: https://fedorahosted.org/releases/n/e/newt/newt-%{version}.tar.gz
|
||||
Patch0: %{name}-0.51.6-pydir.patch
|
||||
Patch1: %{name}-0.51.6-if1close.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libpopt-devel
|
||||
BuildRequires: libslang-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: libpython27-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Newt is a programming library for color text mode, widget based user interfaces.
|
||||
Newt can be used to add stacked windows, entry widgets, checkboxes, radio buttons, labels, plain text fields, scrollbars, etc., to text mode user interfaces.
|
||||
This package contains a /usr/bin/dialog replacement called whiptail. Newt is based on the slang library.
|
||||
|
||||
%package -n %{libname}
|
||||
Summary: Newt windowing toolkit development files library
|
||||
Group: System/Libraries
|
||||
|
||||
%description -n %{libname}
|
||||
Newt is a programming library for color text mode, widget based user interfaces.
|
||||
Newt can be used to add stacked windows, entry widgets, checkboxes, radio buttons, labels, plain text fields, scrollbars, etc., to text mode user interfaces.
|
||||
This package contains the shared library needed by programs built with newt. Newt is based on the slang library.
|
||||
|
||||
%package -n %{libname}-devel
|
||||
Summary: Newt windowing toolkit development files
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description -n %{libname}-devel
|
||||
Newt is a development library for text mode user interfaces. Newt is based on the slang library.
|
||||
This package contains the header files and libraries necessary for developing applications which use newt.
|
||||
|
||||
%package -n python-%{name}
|
||||
Summary: Python bindings for GNU parted for newt windowing toolkit
|
||||
Group: Development/Libraries/Python
|
||||
Requires: %{libname} = %{version}
|
||||
Requires: python >= 2.3.4
|
||||
|
||||
%description -n python-%{name}
|
||||
Newt is a programming library for color text mode, widget based user interfaces.
|
||||
Newt can be used to add stacked windows, entry widgets, checkboxes, radio buttons, labels, plain text fields, scrollbars, etc., to text mode user interfaces.
|
||||
This module contains Python bindings for the newt library.
|
||||
|
||||
%package -n python-%{name}-py27
|
||||
Summary: Python 2.7 bindings for GNU parted for newt windowing toolkit
|
||||
Group: Development/Libraries/Python
|
||||
Requires: %{libname} = %{version}
|
||||
Requires: python27
|
||||
|
||||
%description -n python-%{name}-py27
|
||||
Newt is a programming library for color text mode, widget based user interfaces.
|
||||
Newt can be used to add stacked windows, entry widgets, checkboxes, radio buttons, labels, plain text fields, scrollbars, etc., to text mode user interfaces.
|
||||
This module contains Python 2.7 bindings for the newt library.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1 -b .pydir
|
||||
%patch1 -p1 -b .if1close
|
||||
|
||||
%build
|
||||
%configure
|
||||
|
||||
%make LIBTCL="-ltcl8.5" \
|
||||
%if "%{_host}" != "%{_build}"
|
||||
LIBS="-lslang -ldl -lm"
|
||||
%endif
|
||||
|
||||
chmod 0644 peanuts.py popcorn.py
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
make install instroot=%{buildroot}
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
rm -f %{buildroot}%{_libdir}/python/site-packages/*.so
|
||||
rm -f %{buildroot}%{_libdir}/python/site-packages/*.py
|
||||
rm -f %{buildroot}%{_libdir}/python2.4/site-packages/*.so
|
||||
rm -f %{buildroot}%{_libdir}/python2.4/site-packages/*.py
|
||||
|
||||
%ifarch x86_64
|
||||
install -d -m0755 %{buildroot}%{_prefix}/lib
|
||||
mv %{buildroot}%{_libdir}/python* %{buildroot}%{_prefix}/lib/
|
||||
%endif
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n %{libname} -p /sbin/ldconfig
|
||||
%postun -n %{libname} -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/whiptail
|
||||
%{_mandir}/man1/whiptail.1*
|
||||
%doc CHANGES COPYING
|
||||
|
||||
%files -n %{libname} -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/*.so.*
|
||||
|
||||
%files -n %{libname}-devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/%{name}.h
|
||||
%{_libdir}/%{libname}.a
|
||||
%{_libdir}/%{libname}.so
|
||||
%{_libdir}/pkgconfig/libnewt.pc
|
||||
%if "%{_host}" == "%{_build}"
|
||||
%{_libdir}/whiptcl.so
|
||||
%endif
|
||||
%doc tutorial.sgml peanuts.py popcorn.py
|
||||
|
||||
%files -n python-newt
|
||||
%defattr(-,root,root)
|
||||
%{python_sitearch}/*.so
|
||||
%{python_sitearch}/*.py
|
||||
|
||||
%files -n python-newt-py27
|
||||
%defattr(-,root,root)
|
||||
%{python27_sitearch}/*.so
|
||||
%{python27_sitearch}/*.py
|
||||
|
||||
%changelog
|
||||
* Thu Mar 28 2013 Automatic Build System <autodist@mambasoft.it> 0.52.15-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Nov 11 2011 Automatic Build System <autodist@mambasoft.it> 0.52.14-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Dec 01 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.52.12-2mamba
|
||||
- move whiptcl.so to devel package
|
||||
|
||||
* Mon Aug 09 2010 Automatic Build System <autodist@mambasoft.it> 0.52.12-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu May 27 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.52.11-2mamba
|
||||
- rebuilt against libtcl 8.5
|
||||
|
||||
* Fri Jan 15 2010 Automatic Build System <autodist@mambasoft.it> 0.52.11-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Jul 12 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.52.10-1mamba
|
||||
- update to 0.52.10
|
||||
|
||||
* Fri Jul 25 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.51.6-3mamba
|
||||
- specfile updated
|
||||
|
||||
* Mon Feb 27 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 0.51.6-2qilnx
|
||||
- added missing build requirement
|
||||
- fixed subpackage python-newt group
|
||||
|
||||
* Thu Jun 30 2005 Davide Madrisan <davide.madrisan@qilinux.it> 0.51.6-1qilnx
|
||||
- update to version 0.51.6 by autospec
|
||||
- new package python-newt
|
||||
|
||||
* Thu Apr 27 2003 Silvan Calarco <silvan.calarco@qinet.it> 1.20.1-2qilnx
|
||||
- fixed inclusion mask of /usr/lib/libnewt.so.*
|
||||
|
||||
* Thu Apr 24 2003 Alessandro Ramazzina <alessandro.ramazzina@qinet.it> 1.20.1-1qilnx
|
||||
- Creation of newt package
|
Loading…
Reference in New Issue
Block a user