update to 3.14.3 [release 3.14.3-1mamba;Sun Dec 28 2014]
This commit is contained in:
parent
f065db0fc7
commit
25f2489583
10
mutter-3.14.1-gcc-4.9.patch
Normal file
10
mutter-3.14.1-gcc-4.9.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- mutter-3.14.1/src/core/screen.c.orig 2014-10-16 13:17:31.325165609 +0200
|
||||
+++ mutter-3.14.1/src/core/screen.c 2014-10-16 13:17:53.250166692 +0200
|
||||
@@ -3022,7 +3022,6 @@
|
||||
{
|
||||
MetaScreen *screen = data;
|
||||
MetaWindow *window;
|
||||
- GSList *tmp;
|
||||
GSList *fullscreen_monitors = NULL;
|
||||
GSList *obscured_monitors = NULL;
|
||||
gboolean in_fullscreen_changed = FALSE;
|
20
mutter-3.14.2-build-fix-x86.patch
Normal file
20
mutter-3.14.2-build-fix-x86.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- mutter-3.14.2/src/core/window.c.orig 2014-12-28 12:45:03.578000000 +0100
|
||||
+++ mutter-3.14.2/src/core/window.c 2014-12-28 12:45:32.097000000 +0100
|
||||
@@ -3481,7 +3481,7 @@
|
||||
|
||||
static MetaMonitorInfo *
|
||||
find_monitor_by_winsys_id (MetaWindow *window,
|
||||
- guint winsys_id)
|
||||
+ gint winsys_id)
|
||||
{
|
||||
int i;
|
||||
|
||||
@@ -3602,7 +3602,7 @@
|
||||
*/
|
||||
|
||||
gboolean did_placement;
|
||||
- guint old_output_winsys_id;
|
||||
+ gint old_output_winsys_id;
|
||||
MetaRectangle unconstrained_rect;
|
||||
MetaRectangle constrained_rect;
|
||||
MetaMoveResizeResultFlags result = 0;
|
@ -1,20 +0,0 @@
|
||||
--- mutter-3.6.0/src/core/prefs.c.orig 2012-10-03 04:07:48.000000000 +0200
|
||||
+++ mutter-3.6.0/src/core/prefs.c 2012-10-03 04:08:33.000000000 +0200
|
||||
@@ -1664,7 +1664,7 @@
|
||||
void
|
||||
meta_prefs_set_num_workspaces (int n_workspaces)
|
||||
{
|
||||
- MetaBasePreference *pref;
|
||||
+ MetaBasePreference *pref = NULL;
|
||||
|
||||
find_pref (preferences_int, sizeof(MetaIntPreference),
|
||||
KEY_NUM_WORKSPACES, &pref);
|
||||
@@ -2144,7 +2144,7 @@
|
||||
void
|
||||
meta_prefs_set_no_tab_popup (gboolean whether)
|
||||
{
|
||||
- MetaBasePreference *pref;
|
||||
+ MetaBasePreference *pref = NULL;
|
||||
|
||||
find_pref (preferences_bool, sizeof(MetaBoolPreference),
|
||||
KEY_NO_TAB_POPUP, &pref);
|
52
mutter.spec
52
mutter.spec
@ -1,6 +1,6 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: mutter
|
||||
Version: 3.12.2
|
||||
Version: 3.14.3
|
||||
Release: 1mamba
|
||||
Summary: A compositing window manager based on Metacity
|
||||
Group: Graphical Desktop/Libraries/GNOME
|
||||
@ -9,12 +9,15 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://live.gnome.org
|
||||
Source: ftp://ftp.gnome.org/pub/gnome/sources/mutter/%{majver}/mutter-%{version}.tar.xz
|
||||
Patch0: mutter-3.8.0-gcc-4.7.patch
|
||||
Patch0: mutter-3.14.1-gcc-4.9.patch
|
||||
Patch1: mutter-3.14.2-build-fix-x86.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: gnome-desktop-devel
|
||||
BuildRequires: gobject-introspection-devel
|
||||
BuildRequires: gsettings-desktop-schemas-devel
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libX11-devel
|
||||
@ -35,10 +38,12 @@ BuildRequires: libcairo-devel
|
||||
BuildRequires: libcanberra-devel
|
||||
BuildRequires: libclutter-devel
|
||||
BuildRequires: libcogl-devel
|
||||
BuildRequires: libdrm-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgbm-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
@ -55,6 +60,9 @@ BuildRequires: libtdb-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libvorbis-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libxkbcommon-devel
|
||||
BuildRequires: libxkbfile-devel
|
||||
BuildRequires: libxkbcommon-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: upower-devel
|
||||
## AUTOBUILDREQ-END
|
||||
@ -98,6 +106,7 @@ This package includes the %{name} API documentation.
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -112,8 +121,19 @@ This package includes the %{name} API documentation.
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
%post
|
||||
/sbin/ldconfig
|
||||
if [ $1 -ge 1 ]; then
|
||||
glib-compile-schemas %{_datadir}/glib-2.0/schemas
|
||||
fi
|
||||
:
|
||||
|
||||
%postun
|
||||
/sbin/ldconfig
|
||||
if [ $1 -eq 0 ]; then
|
||||
glib-compile-schemas %{_datadir}/glib-2.0/schemas
|
||||
fi
|
||||
:
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
@ -122,15 +142,17 @@ This package includes the %{name} API documentation.
|
||||
#%{_bindir}/mutter-theme-viewer
|
||||
#%{_bindir}/mutter-window-demo
|
||||
%{_datadir}/applications/mutter.desktop
|
||||
%{_datadir}/applications/mutter-wayland.desktop
|
||||
#%{_datadir}/mutter/icons/mutter-window-demo.png
|
||||
%{_datadir}/GConf/gsettings/mutter-schemas.convert
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.mutter.wayland.gschema.xml
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.mutter.gschema.xml
|
||||
%{_datadir}/gnome-control-center/keybindings/50-mutter-*.xml
|
||||
%{_datadir}/gnome/wm-properties/mutter-wm.desktop
|
||||
#%{_datadir}/gnome/wm-properties/mutter-wm.desktop
|
||||
#%{_mandir}/man1/mutter-message.1.gz
|
||||
#%{_mandir}/man1/mutter-theme-viewer.1.gz
|
||||
#%{_mandir}/man1/mutter-window-demo.1.gz
|
||||
%{_mandir}/man1/mutter.1.gz
|
||||
%{_mandir}/man1/mutter.1*
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
@ -139,26 +161,36 @@ This package includes the %{name} API documentation.
|
||||
%dir %{_libdir}/mutter/plugins
|
||||
%{_libdir}/mutter/plugins/default.so
|
||||
%{_libdir}/mutter/Meta-3.0.typelib
|
||||
%doc AUTHORS COPYING
|
||||
%{_libexecdir}/mutter-restart-helper
|
||||
%doc COPYING
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/mutter
|
||||
%dir %{_includedir}/mutter/meta
|
||||
%{_includedir}/mutter/meta/*.h
|
||||
%{_libdir}/libmutter.a
|
||||
#%{_libdir}/libmutter.a
|
||||
%{_libdir}/libmutter.la
|
||||
%{_libdir}/libmutter.so
|
||||
%{_libdir}/mutter/Meta-3.0.gir
|
||||
%{_libdir}/pkgconfig/libmutter.pc
|
||||
%{_libdir}/pkgconfig/mutter-plugins.pc
|
||||
%doc ChangeLog NEWS README
|
||||
#%{_libdir}/pkgconfig/mutter-plugins.pc
|
||||
%doc NEWS
|
||||
|
||||
%files apidocs
|
||||
%defattr(-,root,root)
|
||||
%{_datadir}/gtk-doc/html/meta/*
|
||||
|
||||
%changelog
|
||||
* Sun Dec 28 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 3.14.3-1mamba
|
||||
- update to 3.14.3
|
||||
|
||||
* Sat Nov 22 2014 Automatic Build System <autodist@mambasoft.it> 3.14.2-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Oct 16 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 3.14.1-1mamba
|
||||
- update to 3.14.1
|
||||
|
||||
* Wed Jun 18 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 3.12.2-1mamba
|
||||
- update to 3.12.2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user