update to 3.12.2 [release 3.12.2-1mamba;Wed Jun 18 2014]

This commit is contained in:
Silvan Calarco 2024-01-06 07:27:49 +01:00
parent 2f907d78f4
commit f065db0fc7
1 changed files with 36 additions and 31 deletions

View File

@ -1,6 +1,6 @@
%define majver %(echo %version | cut -d. -f1-2)
Name: mutter
Version: 3.10.4
Version: 3.12.2
Release: 1mamba
Summary: A compositing window manager based on Metacity
Group: Graphical Desktop/Libraries/GNOME
@ -11,40 +11,14 @@ URL: http://live.gnome.org
Source: ftp://ftp.gnome.org/pub/gnome/sources/mutter/%{majver}/mutter-%{version}.tar.xz
Patch0: mutter-3.8.0-gcc-4.7.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: gnome-desktop-devel
BuildRequires: gobject-introspection-devel
BuildRequires: gsettings-desktop-schemas-devel
BuildRequires: libatk-devel
BuildRequires: libbzip2-devel
BuildRequires: libcairo-devel
BuildRequires: libcanberra-devel
BuildRequires: libclutter-devel
BuildRequires: libcogl-devel
BuildRequires: libdrm-devel
BuildRequires: libelf-devel
BuildRequires: libexpat-devel
BuildRequires: libffi-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libGL-devel
BuildRequires: libglib-devel
BuildRequires: libgtk-devel
BuildRequires: libICE-devel
BuildRequires: libjson-glib-devel
BuildRequires: libpango-devel
BuildRequires: libpixman-devel
BuildRequires: libpng-devel
BuildRequires: libpthread-stubs-devel
BuildRequires: libselinux-devel
BuildRequires: libSM-devel
BuildRequires: libstartup-notification-devel
BuildRequires: libstdc++6-devel
BuildRequires: libuuid-devel
BuildRequires: libX11-devel
BuildRequires: libXau-devel
BuildRequires: libxcb-devel
BuildRequires: libXcomposite-devel
BuildRequires: libXcursor-devel
BuildRequires: libXdamage-devel
@ -55,10 +29,38 @@ BuildRequires: libXi-devel
BuildRequires: libXinerama-devel
BuildRequires: libXrandr-devel
BuildRequires: libXrender-devel
BuildRequires: libatk-devel
BuildRequires: libbzip2-devel
BuildRequires: libcairo-devel
BuildRequires: libcanberra-devel
BuildRequires: libclutter-devel
BuildRequires: libcogl-devel
BuildRequires: libexpat-devel
BuildRequires: libffi-devel
BuildRequires: libfontconfig-devel
BuildRequires: libfreetype-devel
BuildRequires: libgdk-pixbuf-devel
BuildRequires: libglib-devel
BuildRequires: libgraphite2-devel
BuildRequires: libgtk-devel
BuildRequires: libharfbuzz-devel
BuildRequires: libjson-glib-devel
BuildRequires: libltdl-devel
BuildRequires: libogg-devel
BuildRequires: libpango-devel
BuildRequires: libpng-devel
BuildRequires: libselinux-devel
BuildRequires: libstartup-notification-devel
BuildRequires: libtdb-devel
BuildRequires: libuuid-devel
BuildRequires: libvorbis-devel
BuildRequires: libxcb-devel
BuildRequires: libz-devel
BuildRequires: pkg-config
BuildRequires: udev-devel
BuildRequires: upower-devel
## AUTOBUILDREQ-END
BuildRequires: libcogl-devel >= 1.18
BuildRequires: libgnome-desktop-devel >= %{majver}
BuildRequires: upower-devel >= 0.99
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
@ -95,7 +97,7 @@ This package includes the %{name} API documentation.
%prep
%setup -q
%patch0 -p1
#%patch0 -p1
%build
%configure
@ -157,6 +159,9 @@ This package includes the %{name} API documentation.
%{_datadir}/gtk-doc/html/meta/*
%changelog
* Wed Jun 18 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 3.12.2-1mamba
- update to 3.12.2
* Thu Feb 20 2014 Automatic Build System <autodist@mambasoft.it> 3.10.4-1mamba
- automatic version update by autodist