update to 9.0.1 [release 9.0.1-1mamba;Mon Dec 30 2019]

This commit is contained in:
Silvan Calarco 2024-01-06 06:26:10 +01:00
parent 414565341a
commit 1a3da34681
2 changed files with 38 additions and 44 deletions

View File

@ -0,0 +1,11 @@
--- llvm-9.0.1.src/tools/lld/docs/conf.py.orig 2019-12-30 19:06:39.896000000 +0100
+++ llvm-9.0.1.src/tools/lld/docs/conf.py 2019-12-30 19:05:48.263000000 +0100
@@ -134,7 +134,7 @@
#html_use_smartypants = True
# Custom sidebar templates, maps document names to template names.
-html_sidebars = {'index': 'indexsidebar.html'}
+html_sidebars = {'index': ['indexsidebar.html']}
# Additional templates that should be rendered to pages, maps page names to
# template names.

View File

@ -1,7 +1,7 @@
%define gccver %(gcc -dumpversion)
%define majver %(echo %version | cut -d. -f1-2)
Name: llvm
Version: 8.0.0
Version: 9.0.1
Release: 1mamba
Summary: The Low Level Virtual Machine
Group: Development/Languages
@ -9,12 +9,12 @@ Vendor: openmamba
Distribution: openmamba
Packager: Davide Madrisan <davide.madrisan@gmail.com>
URL: https://llvm.org/
Source0: https://releases.llvm.org/%{version}/llvm-%{version}.src.tar.xz
Source1: https://releases.llvm.org/%{version}/cfe-%{version}.src.tar.xz
Source2: https://releases.llvm.org/%{version}/compiler-rt-%{version}.src.tar.xz
Source3: https://releases.llvm.org/%{version}/clang-tools-extra-%{version}.src.tar.xz
Source4: https://releases.llvm.org/%{version}/lld-%{version}.src.tar.xz
Source5: https://releases.llvm.org/%{version}/lldb-%{version}.src.tar.xz
Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/llvm-%{version}.src.tar.xz
Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-%{version}.src.tar.xz
Source2: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/compiler-rt-%{version}.src.tar.xz
Source3: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-tools-extra-%{version}.src.tar.xz
Source4: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lld-%{version}.src.tar.xz
Source5: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lldb-%{version}.src.tar.xz
Source6: llvm-6.0.0-llvm-config.patch
Patch0: %{name}-3.1-llvm-config.patch
Patch1: llvm-3.4-default-to-i586.patch
@ -30,6 +30,7 @@ Patch10: llvm-6.0.0-cmake-fix-a-typo-in-llvm_config-macro.patch
Patch11: llvm-6.0.0-export-LLVMInitializeInstCombine-as-extern-C.patch
Patch12: llvm-6.0.0-DebugInfo-discard-invalid-DBG_VALUE-instructions.patch
Patch13: llvm-6.0.0-fixup-for-rL326769-RegState-Debug-is-being-truncated.patch
Patch14: llvm-9.0.1-Sphinx-2.3.1.patch
License: NCSA
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -45,8 +46,8 @@ BuildRequires: perl-devel
## AUTOBUILDREQ-END
BuildRequires: gcc-c++ >= 8.1.0
BuildRequires: glibc-devel
BuildRequires: ocaml
BuildRequires: ocaml-ctypes
BuildRequires: ocaml >= 4.09.0-4mamba
BuildRequires: ocaml-ctypes >= 0.16
BuildRequires: ocaml-ounit
BuildRequires: z3
BuildRequires: libz3-devel
@ -160,13 +161,13 @@ Requires: gtk-doc
This package includes the LLVM ocaml API documentation.
%prep
%setup -q -a1 -a2 -a3 -a4 -a5 -n %{name}-%{version}.src
#% setup -q -n %{name}-%{version}.src -D -T
#:<< _EOF
#% setup -q -a1 -a2 -a3 -a4 -a5 -n %{name}-%{version}.src
%setup -q -n %{name}-%{version}.src -D -T
:<< _EOF
#%patch0 -p1
#%patch1 -p1
mv cfe-%{version}.src tools/clang
mv clang-%{version}.src tools/clang
mv compiler-rt-%{version}.src projects/compiler-rt
mv clang-tools-extra-%{version}.src tools/clang/tools/extra
mv lld-%{version}.src tools/lld
@ -180,13 +181,8 @@ mv lldb-%{version}.src tools/lldb
#%patch5 -p1
#%endif
%patch6 -p1
#%patch7 -p1
#%patch8 -p1
%patch9 -p1
#%patch10 -p0
#%patch11 -p1
#%patch12 -p1
#%patch13 -p1
#%patch9 -p1
%patch14 -p1
# https://bugs.llvm.org/show_bug.cgi?id=34123
#sed -i '/LLVMSupport/d' tools/clang/tools/extra/clangd/tool/CMakeLists.txt
@ -279,6 +275,7 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
%files
%defattr(-,root,root)
%{_bindir}/bugpoint
%{_bindir}/lit-cpuid
%{_bindir}/llc
%{_bindir}/lli
%{_bindir}/llvm*
@ -303,28 +300,7 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
%{_mandir}/man1/lit.1*
%{_mandir}/man1/llc.1*
%{_mandir}/man1/lli.1*
%{_mandir}/man1/llvm-ar.1*
%{_mandir}/man1/llvm-as.1*
%{_mandir}/man1/llvm-bcanalyzer.1*
%{_mandir}/man1/llvm-build.1*
%{_mandir}/man1/llvm-config.1*
%{_mandir}/man1/llvm-cov.1*
%{_mandir}/man1/llvm-cxxmap.1*
%{_mandir}/man1/llvm-diff.1*
%{_mandir}/man1/llvm-dis.1*
%{_mandir}/man1/llvm-dwarfdump.1*
%{_mandir}/man1/llvm-exegesis.1*
%{_mandir}/man1/llvm-extract.1*
%{_mandir}/man1/llvm-lib.1*
%{_mandir}/man1/llvm-link.1*
%{_mandir}/man1/llvm-mca.1*
%{_mandir}/man1/llvm-nm.1*
%{_mandir}/man1/llvm-objdump.1*
%{_mandir}/man1/llvm-pdbutil.1*
%{_mandir}/man1/llvm-profdata.1*
%{_mandir}/man1/llvm-readobj.1*
%{_mandir}/man1/llvm-stress.1*
%{_mandir}/man1/llvm-symbolizer.1*
%{_mandir}/man1/llvm-*.1*
%{_mandir}/man1/opt.1*
%{_mandir}/man1/scan-build.1*
%{_mandir}/man1/tblgen.1*
@ -354,6 +330,8 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
%{_docdir}/clang-tools/*
%dir %{_docdir}/lld
%{_docdir}/lld/*
%dir %{_docdir}/lldb
%{_docdir}/lldb/*
%{_mandir}/man1/extraclangtools.1*
%{_mandir}/man1/diagtool.1*
@ -363,8 +341,9 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
%{_libdir}/libLTO.so.*
%{_libdir}/liblldb.so.*
%{_libdir}/liblldbIntelFeatures.so.*
%{_libdir}/libOptRemarks.so.*
%{_libdir}/libRemarks.so.*
%{_libdir}/libclang.so.*
%{_libdir}/libclang-cpp.so.*
%files -n libllvm-devel
%defattr(-,root,root)
@ -377,7 +356,8 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
%{_libdir}/*.a
%{_libdir}/libLLVM.so
%{_libdir}/libLTO.so
%{_libdir}/libOptRemarks.so
%{_libdir}/libRemarks.so
%{_libdir}/libclang-cpp.so
%{_libdir}/liblldb.so
%{_libdir}/liblldbIntelFeatures.so
%{_libdir}/LLVM*.so
@ -442,6 +422,9 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
%{_docdir}/llvm/ocaml-html/*
%changelog
* Mon Dec 30 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 9.0.1-1mamba
- update to 9.0.1
* Thu Mar 28 2019 Automatic Build System <autodist@mambasoft.it> 8.0.0-1mamba
- automatic version update by autodist