automatic version update by autodist [release 8.0.0-1mamba;Thu Mar 28 2019]
This commit is contained in:
parent
fef16ad5e9
commit
414565341a
@ -1,15 +1,15 @@
|
||||
--- llvm-7.0.0.src/tools/clang/lib/Driver/ToolChains/Gnu.cpp.orig 2018-07-31 16:21:46.000000000 +0200
|
||||
+++ llvm-7.0.0.src/tools/clang/lib/Driver/ToolChains/Gnu.cpp 2018-10-07 21:50:01.056333257 +0200
|
||||
@@ -1818,7 +1818,7 @@
|
||||
--- llvm-8.0.0.src/tools/clang/lib/Driver/ToolChains/Gnu.cpp.orig 2019-01-15 22:04:36.000000000 +0100
|
||||
+++ llvm-8.0.0.src/tools/clang/lib/Driver/ToolChains/Gnu.cpp 2019-03-26 15:46:18.841353843 +0100
|
||||
@@ -1877,7 +1877,7 @@
|
||||
"aarch64_be-linux-gnu"};
|
||||
|
||||
static const char *const ARMLibDirs[] = {"/lib"};
|
||||
- static const char *const ARMTriples[] = {"arm-linux-gnueabi"};
|
||||
+ static const char *const ARMTriples[] = {"arm-openmamba-linux-gnueabi", "arm-linux-gnueabi"};
|
||||
- static const char *const ARMTriples[] = {"arm-linux-gnueabi",
|
||||
+ static const char *const ARMTriples[] = {"arm-openmamba-linux-gnueabi", "arm-linux-gnueabi",
|
||||
"arm-linux-androideabi"};
|
||||
static const char *const ARMHFTriples[] = {"arm-linux-gnueabihf",
|
||||
"armv7hl-redhat-linux-gnueabi",
|
||||
"armv6hl-suse-linux-gnueabi",
|
||||
@@ -1830,6 +1830,7 @@
|
||||
@@ -1891,6 +1891,7 @@
|
||||
|
||||
static const char *const X86_64LibDirs[] = {"/lib64", "/lib"};
|
||||
static const char *const X86_64Triples[] = {
|
||||
@ -17,7 +17,7 @@
|
||||
"x86_64-linux-gnu", "x86_64-unknown-linux-gnu",
|
||||
"x86_64-pc-linux-gnu", "x86_64-redhat-linux6E",
|
||||
"x86_64-redhat-linux", "x86_64-suse-linux",
|
||||
@@ -1839,6 +1840,7 @@
|
||||
@@ -1900,6 +1901,7 @@
|
||||
static const char *const X32LibDirs[] = {"/libx32"};
|
||||
static const char *const X86LibDirs[] = {"/lib32", "/lib"};
|
||||
static const char *const X86Triples[] = {
|
43
llvm.spec
43
llvm.spec
@ -1,8 +1,8 @@
|
||||
%define gccver %(gcc -dumpversion)
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: llvm
|
||||
Version: 7.0.1
|
||||
Release: 4mamba
|
||||
Version: 8.0.0
|
||||
Release: 1mamba
|
||||
Summary: The Low Level Virtual Machine
|
||||
Group: Development/Languages
|
||||
Vendor: openmamba
|
||||
@ -18,7 +18,7 @@ Source5: https://releases.llvm.org/%{version}/lldb-%{version}.src.tar.xz
|
||||
Source6: llvm-6.0.0-llvm-config.patch
|
||||
Patch0: %{name}-3.1-llvm-config.patch
|
||||
Patch1: llvm-3.4-default-to-i586.patch
|
||||
Patch2: llvm-7.0.0-openmamba-triplet.patch
|
||||
Patch2: llvm-8.0.0-openmamba-triplet.patch
|
||||
Patch3: llvm-3.5.0-buildfix-CommandLine_h-getOption.patch
|
||||
Patch4: llvm-3.5.0-x86_64-llvm-config.patch
|
||||
Patch5: llvm-3.5.0-llvm-config.patch
|
||||
@ -162,6 +162,7 @@ This package includes the LLVM ocaml API documentation.
|
||||
%prep
|
||||
%setup -q -a1 -a2 -a3 -a4 -a5 -n %{name}-%{version}.src
|
||||
#% setup -q -n %{name}-%{version}.src -D -T
|
||||
#:<< _EOF
|
||||
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
@ -193,6 +194,7 @@ mv lldb-%{version}.src tools/lldb
|
||||
sed -i "/REMOVE_DUPLICATES/d" tools/llvm-shlib/CMakeLists.txt
|
||||
|
||||
%build
|
||||
#:<< __EOF
|
||||
mkdir -p build
|
||||
cd build
|
||||
cmake \
|
||||
@ -279,18 +281,13 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
||||
%{_bindir}/bugpoint
|
||||
%{_bindir}/llc
|
||||
%{_bindir}/lli
|
||||
#%{_bindir}/lli-child-target
|
||||
%{_bindir}/llvm*
|
||||
#%{_bindir}/macho-dump
|
||||
#%{_bindir}/c-index-test
|
||||
%{_bindir}/obj2yaml
|
||||
%{_bindir}/sancov
|
||||
%{_bindir}/sanstats
|
||||
%{_bindir}/verify-uselistorder
|
||||
%{_bindir}/yaml2obj
|
||||
%{_bindir}/wasm-ld
|
||||
#%{_libdir}/ocaml/META.llvm
|
||||
#%{_bindir}/llvm-config
|
||||
%{_bindir}/opt
|
||||
%{_bindir}/scan-build
|
||||
%{_bindir}/scan-view
|
||||
@ -312,6 +309,7 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
||||
%{_mandir}/man1/llvm-build.1*
|
||||
%{_mandir}/man1/llvm-config.1*
|
||||
%{_mandir}/man1/llvm-cov.1*
|
||||
%{_mandir}/man1/llvm-cxxmap.1*
|
||||
%{_mandir}/man1/llvm-diff.1*
|
||||
%{_mandir}/man1/llvm-dis.1*
|
||||
%{_mandir}/man1/llvm-dwarfdump.1*
|
||||
@ -321,6 +319,7 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
||||
%{_mandir}/man1/llvm-link.1*
|
||||
%{_mandir}/man1/llvm-mca.1*
|
||||
%{_mandir}/man1/llvm-nm.1*
|
||||
%{_mandir}/man1/llvm-objdump.1*
|
||||
%{_mandir}/man1/llvm-pdbutil.1*
|
||||
%{_mandir}/man1/llvm-profdata.1*
|
||||
%{_mandir}/man1/llvm-readobj.1*
|
||||
@ -346,10 +345,7 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
||||
%{_bindir}/lld
|
||||
%{_bindir}/lld-link
|
||||
%{_bindir}/lldb
|
||||
%{_bindir}/lldb-argdumper
|
||||
%{_bindir}/lldb-mi
|
||||
%{_bindir}/lldb-server
|
||||
%{_bindir}/lldb-test
|
||||
%{_bindir}/lldb-*
|
||||
%{_bindir}/lli-child-target
|
||||
%{_bindir}/modularize
|
||||
%{_bindir}/not
|
||||
@ -363,11 +359,12 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
||||
|
||||
%files -n libllvm
|
||||
%defattr(-,root,root)
|
||||
#%{_libdir}/libLLVM-%{majver}.so
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/libLLVM-*.so
|
||||
%{_libdir}/libLTO.so.*
|
||||
%{_libdir}/liblldb.so.*
|
||||
%{_libdir}/liblldbIntelFeatures.so.*
|
||||
%{_libdir}/libOptRemarks.so.*
|
||||
%{_libdir}/libclang.so.*
|
||||
|
||||
%files -n libllvm-devel
|
||||
%defattr(-,root,root)
|
||||
@ -378,7 +375,12 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
||||
%dir %{_includedir}/lldb
|
||||
%{_includedir}/lldb/*
|
||||
%{_libdir}/*.a
|
||||
#%exclude %{_libdir}/libLLVM-%{majver}.so
|
||||
%{_libdir}/libLLVM.so
|
||||
%{_libdir}/libLTO.so
|
||||
%{_libdir}/libOptRemarks.so
|
||||
%{_libdir}/liblldb.so
|
||||
%{_libdir}/liblldbIntelFeatures.so
|
||||
%{_libdir}/LLVM*.so
|
||||
%dir %{_libdir}/cmake/llvm
|
||||
%{_libdir}/cmake/llvm/*.cmake
|
||||
%doc README.txt
|
||||
@ -395,15 +397,11 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
||||
%{_bindir}/clang++
|
||||
%{_bindir}/clang-*
|
||||
%{_bindir}/git-clang-format
|
||||
#%{_bindir}/clang-tblgen
|
||||
#%{_bindir}/count
|
||||
#%{_bindir}/not
|
||||
%{_prefix}/libexec/c++-analyzer
|
||||
%{_prefix}/libexec/ccc-analyzer
|
||||
%dir %{_libdir}/clang
|
||||
%dir %{_libdir}/clang/%{version}
|
||||
%{_libdir}/clang/%{version}/*
|
||||
%{_libdir}/libclang.so.*
|
||||
%dir %{_datadir}/clang/
|
||||
%{_datadir}/clang/*
|
||||
%{_mandir}/man1/clang.1*
|
||||
@ -413,13 +411,11 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/clang-c
|
||||
%{_includedir}/clang-c/*.h
|
||||
#%{_includedir}/clang-c/module.modulemap
|
||||
%dir %{_includedir}/clang/ARCMigrate
|
||||
%{_includedir}/clang/ARCMigrate/*.h
|
||||
%dir %{_includedir}/clang
|
||||
%{_includedir}/clang/*
|
||||
%dir %{_datadir}/doc/clang/html/
|
||||
%{_datadir}/doc/clang/html/*
|
||||
%{_libdir}/libclang.so
|
||||
%dir %{_libdir}/cmake/clang
|
||||
%{_libdir}/cmake/clang/*.cmake
|
||||
%doc tools/clang/{NOTES.txt,README.txt}
|
||||
@ -446,6 +442,9 @@ rm -f %{buildroot}%{_datadir}/doc/llvm/html/.buildinfo
|
||||
%{_docdir}/llvm/ocaml-html/*
|
||||
|
||||
%changelog
|
||||
* Thu Mar 28 2019 Automatic Build System <autodist@mambasoft.it> 8.0.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Jan 26 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 7.0.1-4mamba
|
||||
- bump release
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user