update to 1.23 [release 1.23-1mamba;Sat Mar 16 2024]
This commit is contained in:
parent
fe83283372
commit
4d1b5bd4a1
@ -1,10 +0,0 @@
|
||||
diff -Nru tslib-1.0.orig//etc/ts.conf tslib-1.0/etc/ts.conf
|
||||
--- tslib-1.0.orig//etc/ts.conf 2006-08-24 23:02:55.000000000 +0200
|
||||
+++ tslib-1.0/etc/ts.conf 2011-01-20 19:26:12.176541145 +0100
|
||||
@@ -1,5 +1,5 @@
|
||||
# Uncomment if you wish to use the linux input layer event interface
|
||||
-# module_raw input
|
||||
+module_raw input
|
||||
|
||||
# Uncomment if you're using a Sharp Zaurus SL-5500/SL-5000d
|
||||
# module_raw collie
|
23
libts.spec
23
libts.spec
@ -1,22 +1,19 @@
|
||||
Name: libts
|
||||
Version: 1.22
|
||||
Version: 1.23
|
||||
Release: 1mamba
|
||||
Summary: An abstraction library for touchscreen panel events
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://tslib.berlios.de/
|
||||
URL: http://www.tslib.org/
|
||||
Source: https://github.com/libts/tslib.git/%{version}/tslib-%{version}.tar.bz2
|
||||
Source1: ts-calibrate-init
|
||||
Source2: ts-calibrate.conf.sample
|
||||
Source3: ts-calibrate.service
|
||||
Patch0: %{name}-1.0-enable_input_interface.patch
|
||||
Source1: ts-calibrate.conf.sample
|
||||
Source2: ts-calibrate.service
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Tslib is an abstraction layer for touchscreen panel events, as well as a filter stack for the manipulation of those events. It was created by Russell King, of arm.linux.org.uk. Examples of implemented filters include jitter smoothing and the calibration transform.
|
||||
@ -46,7 +43,6 @@ This package contains static tools for %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q -n tslib-%{version}
|
||||
#%patch0 -p1
|
||||
./autogen.sh
|
||||
|
||||
%build
|
||||
@ -57,11 +53,8 @@ This package contains static tools for %{name}.
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
#ln -s libts-1.0.so.0 %{buildroot}%{_libdir}/libts-1.0.so
|
||||
|
||||
#install -D -m0755 %{SOURCE1} %{buildroot}%{_initrddir}/ts-calibrate
|
||||
install -m0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/ts-calibrate.conf.sample
|
||||
install -D -m0644 %{SOURCE3} %{buildroot}/lib/systemd/system/ts-calibrate.service
|
||||
install -m0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/ts-calibrate.conf.sample
|
||||
install -D -m0644 %{SOURCE2} %{buildroot}%{_unitdir}/ts-calibrate.service
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -100,7 +93,6 @@ install -D -m0644 %{SOURCE3} %{buildroot}/lib/systemd/system/ts-calibrate.servic
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/tslib.h
|
||||
%{_libdir}/libts.la
|
||||
%{_libdir}/libts.so
|
||||
%{_libdir}/pkgconfig/tslib.pc
|
||||
%{_mandir}/man3/ts_*.3*
|
||||
@ -108,6 +100,9 @@ install -D -m0644 %{SOURCE3} %{buildroot}/lib/systemd/system/ts-calibrate.servic
|
||||
%doc ChangeLog README
|
||||
|
||||
%changelog
|
||||
* Sat Mar 16 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.23-1mamba
|
||||
- update to 1.23
|
||||
|
||||
* Mon Feb 15 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 1.22-1mamba
|
||||
- update to 1.22
|
||||
|
||||
|
@ -1,21 +0,0 @@
|
||||
#!/bin/bash
|
||||
# ts-calibrate - tslib calibration script
|
||||
#
|
||||
# chkconfig: 5 97 99
|
||||
# description: tslib calibration script
|
||||
#
|
||||
# processname: ts_calibrate
|
||||
|
||||
[ -e /etc/ts-calibrate.conf ] || exit 1
|
||||
|
||||
. /etc/ts-calibrate.conf
|
||||
|
||||
case "$1" in
|
||||
start)
|
||||
[ -e /etc/pointercal ] || /usr/bin/ts_calibrate
|
||||
;;
|
||||
*)
|
||||
echo "Usage: $0 {start}"
|
||||
exit 1
|
||||
;;
|
||||
esac
|
Loading…
Reference in New Issue
Block a user