automatic version update by autodist [release 0.16.16-1mamba;Fri Apr 04 2014]

This commit is contained in:
Automatic Build System 2024-01-06 05:56:58 +01:00
parent bb0d7dcbd6
commit 786270f799
3 changed files with 202 additions and 0 deletions

View File

@ -1,2 +1,4 @@
# libtorrent-rasterbar
libtorrent is a C++ library that aims to be a good alternative to all the other bittorrent implementations around. It is a library and not a full featured client, although it comes with a working example client.

View File

@ -0,0 +1,42 @@
diff -Nru libtorrent-rasterbar-0.13.1.orig/include/libtorrent/disk_io_thread.hpp libtorrent-rasterbar-0.13.1/include/libtorrent/disk_io_thread.hpp
--- libtorrent-rasterbar-0.13.1.orig/include/libtorrent/disk_io_thread.hpp 2008-04-09 10:48:02.000000000 +0200
+++ libtorrent-rasterbar-0.13.1/include/libtorrent/disk_io_thread.hpp 2008-10-31 17:43:07.000000000 +0100
@@ -132,7 +132,7 @@
typedef boost::recursive_mutex mutex_t;
mutable mutex_t m_mutex;
- boost::condition m_signal;
+ boost::condition_variable_any m_signal;
bool m_abort;
std::list<disk_io_job> m_jobs;
size_type m_queue_buffer_size;
diff -Nru libtorrent-rasterbar-0.13.1.orig/src/torrent_info.cpp libtorrent-rasterbar-0.13.1/src/torrent_info.cpp
--- libtorrent-rasterbar-0.13.1.orig/src/torrent_info.cpp 2008-07-01 18:03:01.000000000 +0200
+++ libtorrent-rasterbar-0.13.1/src/torrent_info.cpp 2008-10-31 17:42:39.000000000 +0100
@@ -354,7 +354,7 @@
{
m_name = tmp.leaf();
}
- else if (tmp.has_branch_path())
+ else if (tmp.has_parent_path())
{
fs::path p;
for (fs::path::iterator i = tmp.begin()
@@ -572,7 +572,7 @@
{
// TORRENT_ASSERT(file.begin() != file.end());
- if (!file.has_branch_path())
+ if (!file.has_parent_path())
{
// you have already added at least one file with a
// path to the file (branch_path), which means that
@@ -662,7 +662,7 @@
fs::path const* file_path;
if (i->orig_path) file_path = &(*i->orig_path);
else file_path = &i->path;
- TORRENT_ASSERT(file_path->has_branch_path());
+ TORRENT_ASSERT(file_path->has_parent_path());
TORRENT_ASSERT(*file_path->begin() == m_name);
for (fs::path::iterator j = boost::next(file_path->begin());

158
libtorrent-rasterbar.spec Normal file
View File

@ -0,0 +1,158 @@
Name: libtorrent-rasterbar
Version: 0.16.16
Release: 1mamba
Summary: A C++ implementation of the BitTorrent protocol with the goals of being efficient and easy to use
Group: System/Libraries
Vendor: openmamba
Distribution: openmamba
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
URL: http://www.libtorrent.org/
Source: http://downloads.sourceforge.net/project/libtorrent/libtorrent/libtorrent-rasterbar-%{version}.tar.gz
Patch0: %{name}-0.13.1-boost-1.36.patch
License: BSD
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
BuildRequires: libboost-devel
BuildRequires: libgcc
BuildRequires: libGeoIP-devel
BuildRequires: libopenssl-devel
BuildRequires: libpython-devel
BuildRequires: libstdc++6-devel
BuildRequires: libz-devel
## AUTOBUILDREQ-END
BuildRoot: %{_tmppath}/%{name}-%{version}-root
%description
libtorrent is a C++ library that aims to be a good alternative to all the other bittorrent implementations around. It is a library and not a full featured client, although it comes with a working example client.
%package devel
Summary: Devel package for %{name}
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%description devel
libtorrent is a C++ library that aims to be a good alternative to all the other bittorrent implementations around. It is a library and not a full featured client, although it comes with a working example client.
This package contains static libraries and header files need for development.
%package -n python-%{name}
Summary: Python bindings for libtorrent-rasterbar
Group: Development/Libraries
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
%{py_requires}
%description -n python-%{name}
This package contains Python bindings for the libtorrent-rasterbar library.
%prep
%setup -q
%build
%configure \
--enable-python-binding \
--with-libgeoip \
--with-boost-system=mt
%make V=1 \
%ifarch x86_64
LDFLAGS="-L%{_libdir}"
%endif
%install
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%makeinstall
%clean
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig
%files
%defattr(-,root,root)
%{_libdir}/libtorrent-rasterbar.so.*
%doc AUTHORS COPYING
%files devel
%defattr(-,root,root)
%{_includedir}/libtorrent
%{_libdir}/libtorrent-rasterbar.a
%{_libdir}/libtorrent-rasterbar.la
%{_libdir}/libtorrent-rasterbar.so
%{_libdir}/pkgconfig/*.pc
%doc ChangeLog NEWS README
%files -n python-%{name}
%defattr(-,root,root)
%{python_sitearch}/libtorrent.so
%{python_sitearch}/python_libtorrent-*
%changelog
* Fri Apr 04 2014 Automatic Build System <autodist@mambasoft.it> 0.16.16-1mamba
- automatic version update by autodist
* Sat Mar 01 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.16.15-1mamba
- update to 0.16.15
* Sun Jan 26 2014 Automatic Build System <autodist@mambasoft.it> 0.16.12-1mamba
- automatic version update by autodist
* Tue May 21 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.16.9-2mamba
- python 2.7 mass rebuild
* Thu Mar 28 2013 Automatic Build System <autodist@mambasoft.it> 0.16.9-1mamba
- automatic version update by autodist
* Wed Feb 27 2013 Automatic Build System <autodist@mambasoft.it> 0.16.8-1mamba
- automatic version update by autodist
* Sun Jan 27 2013 Automatic Build System <autodist@mambasoft.it> 0.16.7-1mamba
- automatic version update by autodist
* Tue Jan 08 2013 Automatic Build System <autodist@mambasoft.it> 0.16.6-1mamba
- automatic version update by autodist
* Sat Dec 15 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.16.5-2mamba
- libboost 1.52 mass rebuild
* Sat Dec 01 2012 Automatic Build System <autodist@mambasoft.it> 0.16.5-1mamba
- automatic version update by autodist
* Sun Jan 23 2011 Stefano Cotta Ramusino <stefano.cotta@openmamba.org> 0.15.5-1mamba
- update to 0.15.5
* Wed Dec 15 2010 Automatic Build System <autodist@mambasoft.it> 0.15.4-1mamba
- update to 0.15.4
* Wed Dec 15 2010 Automatic Build System <autodist@mambasoft.it> 0.15.0-3mamba
- automatic rebuild by autodist
* Sun Jun 13 2010 Automatic Build System <autodist@mambasoft.it> 0.15.0-2mamba
- automatic rebuild by autodist
* Sun Jun 06 2010 Automatic Build System <autodist@mambasoft.it> 0.15.0-1mamba
- automatic update by autodist
* Tue Jan 12 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.14.5-3mamba
- remove temporary specfile build modifications (i.e. setup -D -T) to allow automatic rebuilds
* Mon Jan 11 2010 Davide Madrisan <davide.madrisan@gmail.com> 0.14.5-2mamba
- build python bindings
* Tue Aug 11 2009 Automatic Build System <autodist@mambasoft.it> 0.14.5-1mamba
- automatic update by autodist
* Sat Jul 11 2009 Automatic Build System <autodist@mambasoft.it> 0.14.4-1mamba
- automatic update by autodist
* Sun Jun 07 2009 Automatic Build System <autodist@mambasoft.it> 0.14.2-3mamba
- automatic rebuild by autodist
* Thu Jun 04 2009 Automatic Build System <autodist@mambasoft.it> 0.14.2-2mamba
- automatic rebuild by autodist
* Mon Mar 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 0.14.2-1mamba
- automatic update by autodist
* Fri Oct 31 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 0.13.1-1mamba
- package created by autospec