rebuilt with build fixes [release 12.10.0-3mamba;Mon Nov 22 2021]
This commit is contained in:
parent
73bc077f1f
commit
c3e4c5c7e1
59
libappindicator-12.10.0-nopython.patch
Normal file
59
libappindicator-12.10.0-nopython.patch
Normal file
@ -0,0 +1,59 @@
|
|||||||
|
diff --git a/bindings/Makefile.am b/bindings/Makefile.am
|
||||||
|
index d1f6d73..dccca6c 100644
|
||||||
|
--- a/bindings/Makefile.am
|
||||||
|
+++ b/bindings/Makefile.am
|
||||||
|
@@ -3,7 +3,6 @@ SUBDIRS = \
|
||||||
|
vala
|
||||||
|
else
|
||||||
|
SUBDIRS = \
|
||||||
|
- python \
|
||||||
|
vala
|
||||||
|
endif
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index ee03390..4713b22 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -181,33 +181,6 @@ AM_CONDITIONAL(BUILD_MONO_TEST, test x${have_nunit} = xyes)
|
||||||
|
with_localinstall="no"
|
||||||
|
AC_ARG_ENABLE(localinstall, AS_HELP_STRING([--enable-localinstall], [install all of the files localy instead of system directories (for distcheck)]), with_localinstall=$enableval, with_localinstall=no)
|
||||||
|
|
||||||
|
-###########################
|
||||||
|
-# Python
|
||||||
|
-###########################
|
||||||
|
-
|
||||||
|
-PYGTK_REQUIRED=2.14.0
|
||||||
|
-PYGOBJECT_REQUIRED=0.22
|
||||||
|
-
|
||||||
|
-AM_PATH_PYTHON(2.3.5)
|
||||||
|
-AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
|
||||||
|
-
|
||||||
|
-PKG_CHECK_MODULES(APPINDICATOR_PYTHON,
|
||||||
|
- [
|
||||||
|
- pygtk-2.0 >= $PYGTK_REQUIRED
|
||||||
|
- gtk+-2.0 >= $GTK_REQUIRED_VERSION
|
||||||
|
- pygobject-2.0 >= $PYGOBJECT_REQUIRED
|
||||||
|
- ])
|
||||||
|
-
|
||||||
|
-AC_MSG_CHECKING(for pygtk defs)
|
||||||
|
-PYGTK_DEFSDIR=`$PKG_CONFIG --variable=defsdir pygtk-2.0`
|
||||||
|
-AC_SUBST(PYGTK_DEFSDIR)
|
||||||
|
-AC_MSG_RESULT($PYGTK_DEFSDIR)
|
||||||
|
-
|
||||||
|
-AC_MSG_CHECKING(for pygtk codegen)
|
||||||
|
-PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
|
||||||
|
-AC_SUBST(PYGTK_CODEGEN)
|
||||||
|
-AC_MSG_RESULT($PYGTK_CODEGEN)
|
||||||
|
-
|
||||||
|
#########################
|
||||||
|
# Check if build tests
|
||||||
|
#########################
|
||||||
|
@@ -239,8 +212,6 @@ src/Makefile
|
||||||
|
src/appindicator-0.1.pc
|
||||||
|
src/appindicator3-0.1.pc
|
||||||
|
bindings/Makefile
|
||||||
|
-bindings/python/Makefile
|
||||||
|
-bindings/python/appindicator.override
|
||||||
|
bindings/vala/Makefile
|
||||||
|
bindings/vala/examples/Makefile
|
||||||
|
tests/Makefile
|
@ -1,6 +1,6 @@
|
|||||||
Name: libappindicator
|
Name: libappindicator
|
||||||
Version: 12.10.0
|
Version: 12.10.0
|
||||||
Release: 2mamba
|
Release: 3mamba
|
||||||
Summary: Allow applications to export a menu into the Unity Menu bar
|
Summary: Allow applications to export a menu into the Unity Menu bar
|
||||||
Group: System/Libraries
|
Group: System/Libraries
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -10,43 +10,36 @@ URL: https://launchpad.net/libappindicator
|
|||||||
Source: https://launchpad.net/libappindicator/12.10/%{version}/+download/libappindicator-%{version}.tar.gz
|
Source: https://launchpad.net/libappindicator/12.10/%{version}/+download/libappindicator-%{version}.tar.gz
|
||||||
Patch0: libappindicator-12.10.0-libglib-2.60.5.patch
|
Patch0: libappindicator-12.10.0-libglib-2.60.5.patch
|
||||||
Patch1: libappindicator-12.10.0-mono-4.2.2.30.patch
|
Patch1: libappindicator-12.10.0-mono-4.2.2.30.patch
|
||||||
|
Patch2: libappindicator-12.10.0-nopython.patch
|
||||||
License: LGPL
|
License: LGPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: gtk-sharp2-devel
|
BuildRequires: gtk-sharp2-devel
|
||||||
BuildRequires: libatk-devel
|
BuildRequires: libatk-devel
|
||||||
BuildRequires: libblkid-devel
|
BuildRequires: libbrotli-devel
|
||||||
BuildRequires: libbzip2-devel
|
BuildRequires: libbzip2-devel
|
||||||
BuildRequires: libcairo-devel
|
BuildRequires: libcairo-devel
|
||||||
BuildRequires: libdbusmenu-devel
|
BuildRequires: libdbusmenu-devel
|
||||||
BuildRequires: libdbusmenu-gtk-devel
|
BuildRequires: libdbusmenu-gtk-devel
|
||||||
BuildRequires: libdbusmenu-gtk3-devel
|
BuildRequires: libdbusmenu-gtk3-devel
|
||||||
BuildRequires: libexpat-devel
|
BuildRequires: libexpat-devel
|
||||||
BuildRequires: libffi-devel
|
|
||||||
BuildRequires: libfontconfig-devel
|
BuildRequires: libfontconfig-devel
|
||||||
BuildRequires: libfreetype-devel
|
BuildRequires: libfreetype-devel
|
||||||
BuildRequires: libfribidi-devel
|
|
||||||
BuildRequires: libgdk-pixbuf-devel
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
BuildRequires: libglib-devel
|
BuildRequires: libglib-devel
|
||||||
BuildRequires: libgraphite2-devel
|
BuildRequires: libgraphite2-devel
|
||||||
BuildRequires: libgtk-devel
|
|
||||||
BuildRequires: libgtk2-devel
|
BuildRequires: libgtk2-devel
|
||||||
|
BuildRequires: libgtk3-devel
|
||||||
BuildRequires: libharfbuzz-devel
|
BuildRequires: libharfbuzz-devel
|
||||||
BuildRequires: libindicator-devel
|
BuildRequires: libindicator-devel
|
||||||
BuildRequires: libindicator3-devel
|
BuildRequires: libindicator3-devel
|
||||||
BuildRequires: libmount-devel
|
|
||||||
BuildRequires: libpango-devel
|
BuildRequires: libpango-devel
|
||||||
BuildRequires: libpcre-devel
|
BuildRequires: libpcre-devel
|
||||||
BuildRequires: libpng-devel
|
BuildRequires: libpng-devel
|
||||||
BuildRequires: libpython-devel
|
|
||||||
BuildRequires: libselinux-devel
|
|
||||||
BuildRequires: libsepol-devel
|
|
||||||
BuildRequires: libthai-devel
|
|
||||||
BuildRequires: libuuid-devel
|
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
BuildRequires: mono-core
|
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
Obsoletes: libappindicator-python <= 12.10.0-2mamba
|
||||||
|
Obsoletes: python-appindicator <= 12.10.0-2mamba
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Allow applications to export a menu into the Unity Menu bar.
|
Allow applications to export a menu into the Unity Menu bar.
|
||||||
@ -56,7 +49,6 @@ Group: Development/Libraries
|
|||||||
Summary: Development files for %{name}
|
Summary: Development files for %{name}
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
Requires: %{name}-mono = %{?epoch:%epoch:}%{version}-%{release}
|
Requires: %{name}-mono = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
Requires: %{name}-python = %{?epoch:%epoch:}%{version}-%{release}
|
|
||||||
Requires: pkg-config
|
Requires: pkg-config
|
||||||
|
|
||||||
%description devel
|
%description devel
|
||||||
@ -88,15 +80,15 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
|||||||
%description mono
|
%description mono
|
||||||
This package contains the Mono bindings for %{name}.
|
This package contains the Mono bindings for %{name}.
|
||||||
|
|
||||||
%package -n python-appindicator
|
#%package -n python-appindicator
|
||||||
Group: System/Libraries
|
#Group: System/Libraries
|
||||||
Summary: Python binings for %{name}
|
#Summary: Python binings for %{name}
|
||||||
Provides: libappindicator-python
|
#Provides: libappindicator-python
|
||||||
Obsoletes: libappindicator-python
|
#Obsoletes: libappindicator-python <= 12.10.0-2mamba
|
||||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
#Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||||
|
#
|
||||||
%description -n python-appindicator
|
#%description -n python-appindicator
|
||||||
This package contains the Python bindings for %{name}.
|
#This package contains the Python bindings for %{name}.
|
||||||
|
|
||||||
%package apidocs
|
%package apidocs
|
||||||
Group: Documentation
|
Group: Documentation
|
||||||
@ -118,6 +110,7 @@ mv %{name}-%{version} build-gtk2
|
|||||||
cd build-gtk2
|
cd build-gtk2
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
sed -i "s#gmcs#mcs#g" configure.ac
|
sed -i "s#gmcs#mcs#g" configure.ac
|
||||||
# fix for gtk-doc 1.26
|
# fix for gtk-doc 1.26
|
||||||
sed -i 's/--nogtkinit//' docs/reference/Makefile.am
|
sed -i 's/--nogtkinit//' docs/reference/Makefile.am
|
||||||
@ -138,9 +131,9 @@ cd build-gtk2
|
|||||||
--disable-gtk-doc-html \
|
--disable-gtk-doc-html \
|
||||||
--disable-static \
|
--disable-static \
|
||||||
--disable-tests \
|
--disable-tests \
|
||||||
CFLAGS="-Wno-deprecated-declarations"
|
CFLAGS="-Wno-deprecated-declarations -Wno-error"
|
||||||
|
|
||||||
%make || make
|
%make -j1 V=1
|
||||||
|
|
||||||
cd ..
|
cd ..
|
||||||
#_ EOF
|
#_ EOF
|
||||||
@ -153,9 +146,9 @@ cd build-gtk3
|
|||||||
--disable-gtk-doc-html \
|
--disable-gtk-doc-html \
|
||||||
--disable-static \
|
--disable-static \
|
||||||
--disable-tests \
|
--disable-tests \
|
||||||
CFLAGS="-Wno-deprecated-declarations"
|
CFLAGS="-Wno-deprecated-declarations -Wno-error"
|
||||||
|
|
||||||
%make || make
|
%make -j1 V=1
|
||||||
cd ..
|
cd ..
|
||||||
|
|
||||||
%install
|
%install
|
||||||
@ -191,12 +184,12 @@ cd ..
|
|||||||
%dir %{_libdir}/appindicator-sharp-0.1
|
%dir %{_libdir}/appindicator-sharp-0.1
|
||||||
%{_libdir}/appindicator-sharp-0.1/*
|
%{_libdir}/appindicator-sharp-0.1/*
|
||||||
|
|
||||||
%files -n python-appindicator
|
#%files -n python-appindicator
|
||||||
%defattr(-,root,root)
|
#%defattr(-,root,root)
|
||||||
%dir %{python27_sitearch}/appindicator
|
#%dir %{python27_sitearch}/appindicator
|
||||||
%{python27_sitearch}/appindicator/__init__.py*
|
#%{python27_sitearch}/appindicator/__init__.py*
|
||||||
%{python27_sitearch}/appindicator/_appindicator.*
|
#%{python27_sitearch}/appindicator/_appindicator.*
|
||||||
%{_datadir}/pygtk/2.0/defs/appindicator.defs
|
#%{_datadir}/pygtk/2.0/defs/appindicator.defs
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
@ -230,6 +223,9 @@ cd ..
|
|||||||
%{_datadir}/gtk-doc/html/libappindicator/*
|
%{_datadir}/gtk-doc/html/libappindicator/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Nov 22 2021 Silvan Calarco <silvan.calarco@mambasoft.it> 12.10.0-3mamba
|
||||||
|
- rebuilt with build fixes
|
||||||
|
|
||||||
* Sat Jul 20 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 12.10.0-2mamba
|
* Sat Jul 20 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 12.10.0-2mamba
|
||||||
- added python 3.6 binding
|
- added python 3.6 binding
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user