added python 3.6 binding [release 12.10.0-2mamba;Sat Jul 20 2019]
This commit is contained in:
parent
b9640c53f0
commit
73bc077f1f
12
libappindicator-12.10.0-libglib-2.60.5.patch
Normal file
12
libappindicator-12.10.0-libglib-2.60.5.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up libappindicator-12.10.0/src/app-indicator.c.build_fix libappindicator-12.10.0/src/app-indicator.c
|
||||
--- libappindicator-12.10.0/src/app-indicator.c.build_fix 2018-04-10 14:43:57.134400594 +0200
|
||||
+++ libappindicator-12.10.0/src/app-indicator.c 2018-04-10 14:45:34.655448722 +0200
|
||||
@@ -2196,7 +2196,7 @@ app_indicator_set_secondary_activate_tar
|
||||
|
||||
g_return_if_fail (GTK_IS_WIDGET (menuitem));
|
||||
|
||||
- priv->sec_activate_target = g_object_ref(G_OBJECT(menuitem));
|
||||
+ priv->sec_activate_target = g_object_ref(menuitem);
|
||||
priv->sec_activate_enabled = widget_is_menu_child(self, menuitem);
|
||||
g_signal_connect(menuitem, "parent-set", G_CALLBACK(sec_activate_target_parent_changed), self);
|
||||
}
|
24
libappindicator-12.10.0-mono-4.2.2.30.patch
Normal file
24
libappindicator-12.10.0-mono-4.2.2.30.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -Nru libappindicator-0.4.92.orig/bindings/mono/appindicator-sharp-0.1.pc.in libappindicator-0.4.92/bindings/mono/appindicator-sharp-0.1.pc.in
|
||||
--- libappindicator-0.4.92.orig/bindings/mono/appindicator-sharp-0.1.pc.in 2012-06-27 21:04:30.199741626 -0400
|
||||
+++ libappindicator-0.4.92/bindings/mono/appindicator-sharp-0.1.pc.in 2012-06-27 21:05:23.326822552 -0400
|
||||
@@ -1,7 +1,7 @@
|
||||
prefix=@prefix@
|
||||
exec_prefix=@exec_prefix@
|
||||
libdir=@libdir@
|
||||
-assemblies_dir=${libdir}/cli/appindicator-sharp-0.1
|
||||
+assemblies_dir=${libdir}/appindicator-sharp-0.1
|
||||
|
||||
Name: appindicator-sharp
|
||||
Description: application indicators for .NET
|
||||
diff -Nru libappindicator-0.4.92.orig/bindings/mono/Makefile.am libappindicator-0.4.92/bindings/mono/Makefile.am
|
||||
--- libappindicator-0.4.92.orig/bindings/mono/Makefile.am 2012-06-27 21:04:30.199741626 -0400
|
||||
+++ libappindicator-0.4.92/bindings/mono/Makefile.am 2012-06-27 21:04:59.562786431 -0400
|
||||
@@ -31,7 +31,7 @@
|
||||
$(DLLPOLICY1) \
|
||||
$(POLICY1).config
|
||||
|
||||
-assemblydir = $(libdir)/cli/appindicator-sharp-0.1
|
||||
+assemblydir = $(libdir)/appindicator-sharp-0.1
|
||||
assembly_DATA = $(TARGET)
|
||||
|
||||
CLEANFILES = \
|
@ -1,6 +1,6 @@
|
||||
Name: libappindicator
|
||||
Version: 12.10.0
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: Allow applications to export a menu into the Unity Menu bar
|
||||
Group: System/Libraries
|
||||
Vendor: openmamba
|
||||
@ -8,22 +8,42 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://launchpad.net/libappindicator
|
||||
Source: https://launchpad.net/libappindicator/12.10/%{version}/+download/libappindicator-%{version}.tar.gz
|
||||
Patch0: libappindicator-12.10.0-libglib-2.60.5.patch
|
||||
Patch1: libappindicator-12.10.0-mono-4.2.2.30.patch
|
||||
License: LGPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: gtk-sharp2-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libblkid-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libdbusmenu-devel
|
||||
BuildRequires: libdbusmenu-gtk-devel
|
||||
BuildRequires: libdbusmenu-gtk3-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libfribidi-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgtk-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libindicator-devel
|
||||
BuildRequires: libindicator3-devel
|
||||
BuildRequires: libmount-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpcre-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libsepol-devel
|
||||
BuildRequires: libthai-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: mono-core
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
@ -42,6 +62,24 @@ Requires: pkg-config
|
||||
%description devel
|
||||
This package contains libraries and header files for developing applications that use %{name}.
|
||||
|
||||
%package -n %{name}3
|
||||
Group: System/Libraries
|
||||
Summary: Allow Gtk3 applications to export a menu into the Unity Menu bar
|
||||
Requires: %{name}3 = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: pkg-config
|
||||
|
||||
%description -n %{name}3
|
||||
Allow Gtk3 applications to export a menu into the Unity Menu bar.
|
||||
|
||||
%package -n %{name}3-devel
|
||||
Group: Development/Libraries
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name}3 = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: pkg-config
|
||||
|
||||
%description -n %{name}3-devel
|
||||
This package contains libraries and header files for developing applications that use %{name}.
|
||||
|
||||
%package mono
|
||||
Group: System/Libraries
|
||||
Summary: Mono binings for %{name}
|
||||
@ -50,12 +88,14 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
%description mono
|
||||
This package contains the Mono bindings for %{name}.
|
||||
|
||||
%package python
|
||||
%package -n python-appindicator
|
||||
Group: System/Libraries
|
||||
Summary: Python binings for %{name}
|
||||
Provides: libappindicator-python
|
||||
Obsoletes: libappindicator-python
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description python
|
||||
%description -n python-appindicator
|
||||
This package contains the Python bindings for %{name}.
|
||||
|
||||
%package apidocs
|
||||
@ -70,24 +110,59 @@ This package includes the %{name} API documentation.
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%setup -q -c
|
||||
#-D -T
|
||||
#:<< _EOF
|
||||
tar xf %{SOURCE0}
|
||||
mv %{name}-%{version} build-gtk2
|
||||
cd build-gtk2
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
sed -i "s#gmcs#mcs#g" configure.ac
|
||||
# fix for gtk-doc 1.26
|
||||
sed -i 's/--nogtkinit//' docs/reference/Makefile.am
|
||||
gtkdocize --copy
|
||||
cp -f gtk-doc.make gtk-doc.local.make
|
||||
autoreconf -vif
|
||||
cd ..
|
||||
|
||||
cp -a build-gtk2 build-gtk3
|
||||
|
||||
%build
|
||||
#:<< _EOF
|
||||
cd build-gtk2
|
||||
%configure \
|
||||
--enable-gtk-doc \
|
||||
--disable-introspection \
|
||||
--with-gtk=2 \
|
||||
--disable-mono-test \
|
||||
--disable-gtk-doc-html \
|
||||
--disable-static \
|
||||
--disable-tests \
|
||||
CFLAGS="-Wno-deprecated-declarations"
|
||||
|
||||
%make || make
|
||||
|
||||
%make CSC=mcs
|
||||
cd ..
|
||||
#_ EOF
|
||||
|
||||
cd build-gtk3
|
||||
%configure \
|
||||
--enable-gtk-doc \
|
||||
--with-gtk=3 \
|
||||
--disable-mono-test \
|
||||
--disable-gtk-doc-html \
|
||||
--disable-static \
|
||||
--disable-tests \
|
||||
CFLAGS="-Wno-deprecated-declarations"
|
||||
|
||||
%make || make
|
||||
cd ..
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
%makeinstall -C build-gtk2
|
||||
|
||||
%makeinstall -C build-gtk3
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -95,18 +170,28 @@ This package includes the %{name} API documentation.
|
||||
%post -p /sbin/ldconfig
|
||||
%postun -p /sbin/ldconfig
|
||||
|
||||
%post -n %{name}3 -p /sbin/ldconfig
|
||||
%postun -n %{name}3 -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libappindicator.so.*
|
||||
%doc AUTHORS COPYING
|
||||
%{_libdir}/girepository-1.0/AppIndicator-0.1.typelib
|
||||
%doc build-gtk2/AUTHORS build-gtk2/COPYING
|
||||
|
||||
%files -n libappindicator3
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libappindicator3.so.*
|
||||
%{_libdir}/girepository-1.0/AppIndicator3-0.1.typelib
|
||||
%doc build-gtk3/AUTHORS build-gtk3/COPYING
|
||||
|
||||
%files mono
|
||||
%defattr(-,root,root)
|
||||
%{_prefix}/lib/mono/*
|
||||
%dir %{_libdir}/cli/appindicator-sharp-0.1
|
||||
%{_libdir}/cli/appindicator-sharp-0.1/*
|
||||
%dir %{_libdir}/appindicator-sharp-0.1
|
||||
%{_libdir}/appindicator-sharp-0.1/*
|
||||
|
||||
%files python
|
||||
%files -n python-appindicator
|
||||
%defattr(-,root,root)
|
||||
%dir %{python27_sitearch}/appindicator
|
||||
%{python27_sitearch}/appindicator/__init__.py*
|
||||
@ -120,9 +205,24 @@ This package includes the %{name} API documentation.
|
||||
%{_includedir}/libappindicator-0.1/libappindicator/*
|
||||
%{_libdir}/libappindicator.la
|
||||
%{_libdir}/libappindicator.so
|
||||
%{_datadir}/gir-1.0/AppIndicator-0.1.gir
|
||||
%{_datadir}/vala/vapi/appindicator-0.1.deps
|
||||
%{_datadir}/vala/vapi/appindicator-0.1.vapi
|
||||
%{_libdir}/pkgconfig/appindicator-sharp-0.1.pc
|
||||
%{_libdir}/pkgconfig/appindicator-0.1.pc
|
||||
%doc ChangeLog README
|
||||
%doc build-gtk2/ChangeLog build-gtk2/README
|
||||
|
||||
%files -n %{name}3-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/libappindicator3-0.1
|
||||
%dir %{_includedir}/libappindicator3-0.1/libappindicator
|
||||
%{_includedir}/libappindicator3-0.1/libappindicator/*
|
||||
%{_libdir}/libappindicator3.la
|
||||
%{_libdir}/libappindicator3.so
|
||||
%{_datadir}/gir-1.0/AppIndicator3-0.1.gir
|
||||
%{_datadir}/vala/vapi/appindicator3-0.1.deps
|
||||
%{_datadir}/vala/vapi/appindicator3-0.1.vapi
|
||||
%{_libdir}/pkgconfig/appindicator3-0.1.pc
|
||||
|
||||
%files apidocs
|
||||
%defattr(-,root,root)
|
||||
@ -130,5 +230,8 @@ This package includes the %{name} API documentation.
|
||||
%{_datadir}/gtk-doc/html/libappindicator/*
|
||||
|
||||
%changelog
|
||||
* Sat Jul 20 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 12.10.0-2mamba
|
||||
- added python 3.6 binding
|
||||
|
||||
* Tue Mar 15 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 12.10.0-1mamba
|
||||
- package created using the webbuild interface
|
||||
|
Loading…
Reference in New Issue
Block a user