alsa-modprobe: add alias to autoload snd-bcm2835 on raspberry-pi [release 1.0.27.2-4mamba;Wed Sep 18 2013]
This commit is contained in:
parent
c54ea23ce5
commit
789fe50343
@ -1,2 +1,11 @@
|
||||
# libalsa
|
||||
|
||||
The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI functionality to the Linux operating system.
|
||||
|
||||
ALSA has the following significant features:
|
||||
- efficient support for all types of audio interfaces, from consumer soundcards to professional multichannel audio interfaces
|
||||
- fully modularized sound drivers
|
||||
- SMP and thread-safe design
|
||||
- user space library (alsa-lib) to simplify application programming and provide higher level functionality
|
||||
- support for the older OSS API, providing binary compatibility for most OSS programs
|
||||
|
||||
|
62
alsa-initscript
Normal file
62
alsa-initscript
Normal file
@ -0,0 +1,62 @@
|
||||
#! /bin/bash
|
||||
#
|
||||
# alsa
|
||||
#
|
||||
# This script takes care of starting alsa oss compatibility modules for
|
||||
# pcm and saving/restoring mixer volume settings.
|
||||
# If an alsa driver is not loaded this script does nothing.
|
||||
#
|
||||
# Copyright (c) 2004-2011 by Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
#
|
||||
# chkconfig: 2345 87 14
|
||||
# description: ALSA volumes set and oss compatibiliy layer
|
||||
#
|
||||
### END INIT INFO
|
||||
|
||||
[ -r /etc/init.d/functions ] && . /etc/init.d/functions
|
||||
[ -r /etc/sysconfig/sound ] && . /etc/sysconfig/sound
|
||||
|
||||
# see how we were called.
|
||||
case "$1" in
|
||||
start)
|
||||
if [ -d /proc/asound ]; then
|
||||
[ "$ENABLE_LEGACY_OSS" = "true" -o "$ENABLE_LEGACY_OSS" = "1" ] && {
|
||||
echo -n "Loading ALSA-OSS legacy sound modules: "
|
||||
modprobe snd-seq-oss
|
||||
modprobe snd-mixer-oss
|
||||
modprobe snd-pcm-oss
|
||||
evaluate_retval
|
||||
echo
|
||||
}
|
||||
# Restore is now called by udev
|
||||
#echo -n "Restoring sound card volumes"
|
||||
#/usr/sbin/alsactl restore >/dev/null 2>&1
|
||||
#evaluate_retval
|
||||
#echo
|
||||
else
|
||||
echo "ALSA driver is not running."
|
||||
fi
|
||||
;;
|
||||
stop)
|
||||
# stop oss emulation modules
|
||||
if [ -d /proc/asound ]; then
|
||||
echo -n "Saving sound card volumes"
|
||||
/usr/sbin/alsactl store >/dev/null 2>&1
|
||||
evaluate_retval
|
||||
fi
|
||||
;;
|
||||
restart|reload)
|
||||
$0 stop
|
||||
$0 start
|
||||
;;
|
||||
status)
|
||||
[ -n "`lsmod | grep snd[-_]mixer[-_]oss`" ] \
|
||||
&& echo "ALSA-OSS legacy modules loaded." \
|
||||
|| echo "ALSA-OSS legacy modules not loaded."
|
||||
;;
|
||||
*)
|
||||
echo "Usage: alsa {start|stop|restart|status}"
|
||||
exit 1
|
||||
esac
|
||||
|
||||
exit 0
|
12
alsa-modprobe
Normal file
12
alsa-modprobe
Normal file
@ -0,0 +1,12 @@
|
||||
# Prevent abnormal drivers and external cards from grabbing index 0
|
||||
options bt87x index=-2
|
||||
options cx88_alsa index=-2
|
||||
options snd-atiixp-modem index=-2
|
||||
options snd-intel8x0m index=-2
|
||||
options snd-via82xx-modem index=-2
|
||||
options snd-pcsp index=-2
|
||||
options snd-usb-audio index=-2
|
||||
options snd-aloop index=-2
|
||||
|
||||
#raspberry-pi
|
||||
alias platform:bcm2835_AUD0 snd-bcm2835
|
34
libalsa-1.0.23-thread_safe_locale.patch
Normal file
34
libalsa-1.0.23-thread_safe_locale.patch
Normal file
@ -0,0 +1,34 @@
|
||||
diff --git a/src/conf.c b/src/conf.c
|
||||
index 570c90f..ce252ab 100644
|
||||
--- a/src/conf.c
|
||||
+++ b/src/conf.c
|
||||
@@ -499,22 +499,20 @@ static int safe_strtod(const char *str, double *val)
|
||||
{
|
||||
char *end;
|
||||
double v;
|
||||
- char *saved_locale;
|
||||
- char locstr[64]; /* enough? */
|
||||
+ locale_t saved_locale, c_locale;
|
||||
int err;
|
||||
|
||||
if (!*str)
|
||||
return -EINVAL;
|
||||
- saved_locale = setlocale(LC_NUMERIC, NULL);
|
||||
- if (saved_locale) {
|
||||
- snprintf(locstr, sizeof(locstr), "%s", saved_locale);
|
||||
- setlocale(LC_NUMERIC, "C");
|
||||
- }
|
||||
+ c_locale = newlocale(LC_NUMERIC_MASK, "C", 0);
|
||||
+ saved_locale = uselocale(c_locale);
|
||||
errno = 0;
|
||||
v = strtod(str, &end);
|
||||
err = -errno;
|
||||
- if (saved_locale)
|
||||
- setlocale(LC_NUMERIC, locstr);
|
||||
+ if (c_locale != (locale_t)0) {
|
||||
+ uselocale(saved_locale);
|
||||
+ freelocale(c_locale);
|
||||
+ }
|
||||
if (err)
|
||||
return err;
|
||||
if (*end)
|
28
libalsa-1.0.25-hctl_remove_a_useless_assert.patch
Normal file
28
libalsa-1.0.25-hctl_remove_a_useless_assert.patch
Normal file
@ -0,0 +1,28 @@
|
||||
From: Martin Sandsmark <martin.sandsmark@kde.org>
|
||||
Date: Thu, 5 Jul 2012 07:40:07 +0000 (+0200)
|
||||
Subject: hctl: Remove a useless assert
|
||||
X-Git-Url: http://git.alsa-project.org/?p=alsa-lib.git;a=commitdiff_plain;h=86e27cdbf119440101a850e1b44baebfefe863ca;hp=52160de21ee6a710a746b0881d9581994d039123
|
||||
|
||||
hctl: Remove a useless assert
|
||||
|
||||
The case where the element is unavailable (for example gone away since
|
||||
the event was created) is handled beneath.
|
||||
|
||||
See also bug 5471.
|
||||
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=5471
|
||||
|
||||
Signed-off-by: Takashi Iwai <tiwai@suse.de>
|
||||
---
|
||||
|
||||
diff --git a/src/control/hcontrol.c b/src/control/hcontrol.c
|
||||
index 8ffc434..ee1d907 100644
|
||||
--- a/src/control/hcontrol.c
|
||||
+++ b/src/control/hcontrol.c
|
||||
@@ -761,7 +761,6 @@ static int snd_hctl_handle_event(snd_hctl_t *hctl, snd_ctl_event_t *event)
|
||||
if (event->data.elem.mask & (SNDRV_CTL_EVENT_MASK_VALUE |
|
||||
SNDRV_CTL_EVENT_MASK_INFO)) {
|
||||
elem = snd_hctl_find_elem(hctl, &event->data.elem.id);
|
||||
- assert(elem);
|
||||
if (!elem)
|
||||
return -ENOENT;
|
||||
res = snd_hctl_elem_throw_event(elem, event->data.elem.mask &
|
154
libalsa-1.0.27-use-__inline__-for-exported-headers.patch
Normal file
154
libalsa-1.0.27-use-__inline__-for-exported-headers.patch
Normal file
@ -0,0 +1,154 @@
|
||||
From 30122df4faf7ccc79b9525db95f55c5a8ed6fe4d Mon Sep 17 00:00:00 2001
|
||||
From: Takashi Iwai <tiwai@suse.de>
|
||||
Date: Thu, 25 Apr 2013 09:52:33 +0200
|
||||
Subject: [PATCH 4/5] Use __inline__ for exported headers
|
||||
|
||||
Some programs are still using C90.
|
||||
|
||||
Bugzilla: https://bugzilla.novell.com/show_bug.cgi?id=817077
|
||||
Signed-off-by: Takashi Iwai <tiwai@suse.de>
|
||||
---
|
||||
include/control.h | 4 ++--
|
||||
include/iatomic.h | 14 +++++++-------
|
||||
include/pcm.h | 2 +-
|
||||
include/pcm_extplug.h | 4 ++--
|
||||
include/use-case.h | 4 ++--
|
||||
5 files changed, 14 insertions(+), 14 deletions(-)
|
||||
|
||||
diff --git a/include/control.h b/include/control.h
|
||||
index 27fe2ac..5fdf379 100644
|
||||
--- a/include/control.h
|
||||
+++ b/include/control.h
|
||||
@@ -234,7 +234,7 @@ int snd_ctl_open_lconf(snd_ctl_t **ctl, const char *name, int mode, snd_config_t
|
||||
int snd_ctl_open_fallback(snd_ctl_t **ctl, snd_config_t *root, const char *name, const char *orig_name, int mode);
|
||||
int snd_ctl_close(snd_ctl_t *ctl);
|
||||
int snd_ctl_nonblock(snd_ctl_t *ctl, int nonblock);
|
||||
-static inline int snd_ctl_abort(snd_ctl_t *ctl) { return snd_ctl_nonblock(ctl, 2); }
|
||||
+static __inline__ int snd_ctl_abort(snd_ctl_t *ctl) { return snd_ctl_nonblock(ctl, 2); }
|
||||
int snd_async_add_ctl_handler(snd_async_handler_t **handler, snd_ctl_t *ctl,
|
||||
snd_async_callback_t callback, void *private_data);
|
||||
snd_ctl_t *snd_async_handler_get_ctl(snd_async_handler_t *handler);
|
||||
@@ -532,7 +532,7 @@ int snd_hctl_open(snd_hctl_t **hctl, const char *name, int mode);
|
||||
int snd_hctl_open_ctl(snd_hctl_t **hctlp, snd_ctl_t *ctl);
|
||||
int snd_hctl_close(snd_hctl_t *hctl);
|
||||
int snd_hctl_nonblock(snd_hctl_t *hctl, int nonblock);
|
||||
-static inline int snd_hctl_abort(snd_hctl_t *hctl) { return snd_hctl_nonblock(hctl, 2); }
|
||||
+static __inline__ int snd_hctl_abort(snd_hctl_t *hctl) { return snd_hctl_nonblock(hctl, 2); }
|
||||
int snd_hctl_poll_descriptors_count(snd_hctl_t *hctl);
|
||||
int snd_hctl_poll_descriptors(snd_hctl_t *hctl, struct pollfd *pfds, unsigned int space);
|
||||
int snd_hctl_poll_descriptors_revents(snd_hctl_t *ctl, struct pollfd *pfds, unsigned int nfds, unsigned short *revents);
|
||||
diff --git a/include/iatomic.h b/include/iatomic.h
|
||||
index e92dbfd..5711fe8 100644
|
||||
--- a/include/iatomic.h
|
||||
+++ b/include/iatomic.h
|
||||
@@ -980,7 +980,7 @@ static __inline__ int atomic_dec_and_test(volatile atomic_t *v)
|
||||
return result;
|
||||
}
|
||||
|
||||
-static inline int atomic_add_negative(int i, volatile atomic_t *v)
|
||||
+static __inline__ int atomic_add_negative(int i, volatile atomic_t *v)
|
||||
{
|
||||
unsigned long flags;
|
||||
int result;
|
||||
@@ -1160,36 +1160,36 @@ typedef struct {
|
||||
|
||||
void snd_atomic_read_wait(snd_atomic_read_t *t);
|
||||
|
||||
-static inline void snd_atomic_write_init(snd_atomic_write_t *w)
|
||||
+static __inline__ void snd_atomic_write_init(snd_atomic_write_t *w)
|
||||
{
|
||||
w->begin = 0;
|
||||
w->end = 0;
|
||||
}
|
||||
|
||||
-static inline void snd_atomic_write_begin(snd_atomic_write_t *w)
|
||||
+static __inline__ void snd_atomic_write_begin(snd_atomic_write_t *w)
|
||||
{
|
||||
w->begin++;
|
||||
wmb();
|
||||
}
|
||||
|
||||
-static inline void snd_atomic_write_end(snd_atomic_write_t *w)
|
||||
+static __inline__ void snd_atomic_write_end(snd_atomic_write_t *w)
|
||||
{
|
||||
wmb();
|
||||
w->end++;
|
||||
}
|
||||
|
||||
-static inline void snd_atomic_read_init(snd_atomic_read_t *r, snd_atomic_write_t *w)
|
||||
+static __inline__ void snd_atomic_read_init(snd_atomic_read_t *r, snd_atomic_write_t *w)
|
||||
{
|
||||
r->write = w;
|
||||
}
|
||||
|
||||
-static inline void snd_atomic_read_begin(snd_atomic_read_t *r)
|
||||
+static __inline__ void snd_atomic_read_begin(snd_atomic_read_t *r)
|
||||
{
|
||||
r->end = r->write->end;
|
||||
rmb();
|
||||
}
|
||||
|
||||
-static inline int snd_atomic_read_ok(snd_atomic_read_t *r)
|
||||
+static __inline__ int snd_atomic_read_ok(snd_atomic_read_t *r)
|
||||
{
|
||||
rmb();
|
||||
return r->end == r->write->begin;
|
||||
diff --git a/include/pcm.h b/include/pcm.h
|
||||
index e440030..95b8aed 100644
|
||||
--- a/include/pcm.h
|
||||
+++ b/include/pcm.h
|
||||
@@ -451,7 +451,7 @@ int snd_pcm_poll_descriptors_count(snd_pcm_t *pcm);
|
||||
int snd_pcm_poll_descriptors(snd_pcm_t *pcm, struct pollfd *pfds, unsigned int space);
|
||||
int snd_pcm_poll_descriptors_revents(snd_pcm_t *pcm, struct pollfd *pfds, unsigned int nfds, unsigned short *revents);
|
||||
int snd_pcm_nonblock(snd_pcm_t *pcm, int nonblock);
|
||||
-static inline int snd_pcm_abort(snd_pcm_t *pcm) { return snd_pcm_nonblock(pcm, 2); }
|
||||
+static __inline__ int snd_pcm_abort(snd_pcm_t *pcm) { return snd_pcm_nonblock(pcm, 2); }
|
||||
int snd_async_add_pcm_handler(snd_async_handler_t **handler, snd_pcm_t *pcm,
|
||||
snd_async_callback_t callback, void *private_data);
|
||||
snd_pcm_t *snd_async_handler_get_pcm(snd_async_handler_t *handler);
|
||||
diff --git a/include/pcm_extplug.h b/include/pcm_extplug.h
|
||||
index 884f322..e3b71bc 100644
|
||||
--- a/include/pcm_extplug.h
|
||||
+++ b/include/pcm_extplug.h
|
||||
@@ -188,7 +188,7 @@ int snd_pcm_extplug_set_slave_param_minmax(snd_pcm_extplug_t *extplug, int type,
|
||||
/**
|
||||
* set the parameter constraint with a single value
|
||||
*/
|
||||
-static inline int snd_pcm_extplug_set_param(snd_pcm_extplug_t *extplug, int type, unsigned int val)
|
||||
+static __inline__ int snd_pcm_extplug_set_param(snd_pcm_extplug_t *extplug, int type, unsigned int val)
|
||||
{
|
||||
return snd_pcm_extplug_set_param_list(extplug, type, 1, &val);
|
||||
}
|
||||
@@ -196,7 +196,7 @@ static inline int snd_pcm_extplug_set_param(snd_pcm_extplug_t *extplug, int type
|
||||
/**
|
||||
* set the parameter constraint for slave PCM with a single value
|
||||
*/
|
||||
-static inline int snd_pcm_extplug_set_slave_param(snd_pcm_extplug_t *extplug, int type, unsigned int val)
|
||||
+static __inline__ int snd_pcm_extplug_set_slave_param(snd_pcm_extplug_t *extplug, int type, unsigned int val)
|
||||
{
|
||||
return snd_pcm_extplug_set_slave_param_list(extplug, type, 1, &val);
|
||||
}
|
||||
diff --git a/include/use-case.h b/include/use-case.h
|
||||
index defd4ea..93b3456 100644
|
||||
--- a/include/use-case.h
|
||||
+++ b/include/use-case.h
|
||||
@@ -354,7 +354,7 @@ int snd_use_case_mgr_reset(snd_use_case_mgr_t *uc_mgr);
|
||||
* \param list Returned allocated list
|
||||
* \return Number of list entries if success, otherwise a negative error code
|
||||
*/
|
||||
-static inline int snd_use_case_card_list(const char **list[])
|
||||
+static __inline__ int snd_use_case_card_list(const char **list[])
|
||||
{
|
||||
return snd_use_case_get_list(NULL, NULL, list);
|
||||
}
|
||||
@@ -365,7 +365,7 @@ static inline int snd_use_case_card_list(const char **list[])
|
||||
* \param list Returned list of verbs
|
||||
* \return Number of list entries if success, otherwise a negative error code
|
||||
*/
|
||||
-static inline int snd_use_case_verb_list(snd_use_case_mgr_t *uc_mgr,
|
||||
+static __inline__ int snd_use_case_verb_list(snd_use_case_mgr_t *uc_mgr,
|
||||
const char **list[])
|
||||
{
|
||||
return snd_use_case_get_list(uc_mgr, "_verbs", list);
|
||||
--
|
||||
1.8.2.1
|
378
libalsa.spec
Normal file
378
libalsa.spec
Normal file
@ -0,0 +1,378 @@
|
||||
Name: libalsa
|
||||
Version: 1.0.27.2
|
||||
Release: 4mamba
|
||||
Summary: Library for the Advanced Linux Sound Architecture (ALSA)
|
||||
Group: System/Kernel and Hardware
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.alsa-project.org/
|
||||
Source0: ftp://ftp.alsa-project.org/pub/lib/alsa-lib-%{version}.tar.bz2
|
||||
Source1: alsa-initscript
|
||||
Source2: alsa-modprobe
|
||||
Source3: libalsa-ucm-Midas_WM1811.tar.xz
|
||||
Patch0: %{name}-1.0.23-thread_safe_locale.patch
|
||||
Patch1: %{name}-1.0.25-hctl_remove_a_useless_assert.patch
|
||||
Patch2: libalsa-1.0.27-use-__inline__-for-exported-headers.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libpython-devel
|
||||
## AUTOBUILDREQ-END
|
||||
%ifarch x86_64
|
||||
BuildRequires: gcc-multilib
|
||||
BuildRequires: glibc-multilib-devel
|
||||
%endif
|
||||
Requires(post):/sbin/ldconfig
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI functionality to the Linux operating system.
|
||||
|
||||
ALSA has the following significant features:
|
||||
- efficient support for all types of audio interfaces, from consumer soundcards to professional multichannel audio interfaces
|
||||
- fully modularized sound drivers
|
||||
- SMP and thread-safe design
|
||||
- user space library (alsa-lib) to simplify application programming and provide higher level functionality
|
||||
- support for the older OSS API, providing binary compatibility for most OSS programs
|
||||
|
||||
%package devel
|
||||
Summary: Devel package for ALSA libraries
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI functionality to the Linux operating system.
|
||||
|
||||
ALSA has the following significant features:
|
||||
- efficient support for all types of audio interfaces, from consumer soundcards to professional multichannel audio interfaces
|
||||
- fully modularized sound drivers
|
||||
- SMP and thread-safe design
|
||||
- user space library (alsa-lib) to simplify application programming and provide higher level functionality
|
||||
- support for the older OSS API, providing binary compatibility for most OSS programs
|
||||
|
||||
This is the development package for the libraries.
|
||||
|
||||
%package -n python-smixer
|
||||
Summary: Python smixer binding for ALSA libraries
|
||||
Group: System/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description -n python-smixer
|
||||
The Advanced Linux Sound Architecture (ALSA) provides audio and MIDI functionality to the Linux operating system.
|
||||
|
||||
ALSA has the following significant features:
|
||||
- efficient support for all types of audio interfaces, from consumer soundcards to professional multichannel audio interfaces
|
||||
- fully modularized sound drivers
|
||||
- SMP and thread-safe design
|
||||
- user space library (alsa-lib) to simplify application programming and provide higher level functionality
|
||||
- support for the older OSS API, providing binary compatibility for most OSS programs
|
||||
|
||||
This package contains the python smixer binding.
|
||||
|
||||
%package -n lib32-%{name}
|
||||
Summary: Library for the Advanced Linux Sound Architecture (ALSA)
|
||||
Group: System/Libraries
|
||||
|
||||
%description -n lib32-%{name}
|
||||
Library for the Advanced Linux Sound Architecture (ALSA).
|
||||
|
||||
%package -n lib32-%{name}-devel
|
||||
Summary: Devel package for lib32-%{name}
|
||||
Group: Development/Libraries
|
||||
Requires: lib32-%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: %{name}-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n lib32-%{name}-devel
|
||||
Library for the Advanced Linux Sound Architecture (ALSA).
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n alsa-lib-%{version}
|
||||
#% patch0 -p1
|
||||
#%patch1 -p1
|
||||
#%patch2 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-shared
|
||||
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall
|
||||
install -D %{SOURCE2} %{buildroot}/lib/modprobe.d/alsa.conf
|
||||
|
||||
(cd %{buildroot}%{_datadir}/alsa/ucm
|
||||
tar xf %{SOURCE3})
|
||||
|
||||
%ifarch x86_64
|
||||
# x86_64 lib64 support
|
||||
make clean
|
||||
CC=%{_target_platform}-gcc \
|
||||
CFLAGS="%{optflags} -m32" \
|
||||
CXXLAGS="%{optflags} -m32" \
|
||||
./configure --prefix=%{_prefix} --libdir=%{_prefix}/lib \
|
||||
--disable-python
|
||||
|
||||
make
|
||||
make install DESTDIR=`pwd`/lib32
|
||||
cp -a lib32/%{_prefix}/lib %{buildroot}%{_prefix}/
|
||||
%endif
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%post -p /sbin/ldconfig
|
||||
%preun -p /sbin/ldconfig
|
||||
%post -n lib32-%{name} -p /sbin/ldconfig
|
||||
%postun -n lib32-%{name} -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/aserver
|
||||
%dir %{_datadir}/alsa
|
||||
%{_datadir}/alsa/*
|
||||
/lib/modprobe.d/alsa.conf
|
||||
%{_libdir}/*.so.*
|
||||
%{_libdir}/alsa-lib/smixer/smixer-ac97.la
|
||||
%{_libdir}/alsa-lib/smixer/smixer-ac97.so
|
||||
%{_libdir}/alsa-lib/smixer/smixer-hda.la
|
||||
%{_libdir}/alsa-lib/smixer/smixer-hda.so
|
||||
%{_libdir}/alsa-lib/smixer/smixer-sbase.la
|
||||
%{_libdir}/alsa-lib/smixer/smixer-sbase.so
|
||||
%doc COPYING
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
#%{_bindir}/alsalisp
|
||||
%{_datadir}/aclocal/alsa.m4
|
||||
%dir %{_includedir}/alsa
|
||||
%{_includedir}/alsa/*.h
|
||||
%{_includedir}/alsa/sound/*.h
|
||||
%{_includedir}/sys/*.h
|
||||
#%{_libdir}/alsa-lib/smixer/smixer-*.a
|
||||
#%{_libdir}/libasound.a
|
||||
%{_libdir}/*.la
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/*
|
||||
%doc ChangeLog MEMORY-LEAK NOTES TODO
|
||||
|
||||
%files -n python-smixer
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/alsa-lib/smixer/smixer-python.la
|
||||
%{_libdir}/alsa-lib/smixer/smixer-python.so
|
||||
|
||||
%ifarch x86_64
|
||||
%files -n lib32-%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_prefix}/lib/alsa-lib/smixer/smixer-ac97.la
|
||||
%{_prefix}/lib/alsa-lib/smixer/smixer-ac97.so
|
||||
%{_prefix}/lib/alsa-lib/smixer/smixer-hda.la
|
||||
%{_prefix}/lib/alsa-lib/smixer/smixer-hda.so
|
||||
%{_prefix}/lib/alsa-lib/smixer/smixer-sbase.la
|
||||
%{_prefix}/lib/alsa-lib/smixer/smixer-sbase.so
|
||||
%{_prefix}/lib/libasound.so.*
|
||||
|
||||
%files -n lib32-%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%{_prefix}/lib/libasound.la
|
||||
%{_prefix}/lib/libasound.so
|
||||
%{_prefix}/lib/pkgconfig/alsa.pc
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Sep 18 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.27.2-4mamba
|
||||
- alsa-modprobe: add alias to autoload snd-bcm2835 on raspberry-pi
|
||||
|
||||
* Fri Aug 02 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.27.2-3mamba
|
||||
- alsa-modprobe: add index=-2 to snd-aloop to prevent it from being loaded as primary soundcard
|
||||
|
||||
* Tue Jul 30 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.27.2-2mamba
|
||||
- install ucm files for Midas_WM1811 (Galaxy Note 10.1)
|
||||
|
||||
* Tue Jul 09 2013 Automatic Build System <autodist@mambasoft.it> 1.0.27.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed May 22 2013 Automatic Build System <autodist@mambasoft.it> 1.0.27.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed May 08 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.27-3mamba
|
||||
- added a patch to fix headers with gcc 4.8
|
||||
|
||||
* Sun Apr 14 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.27-2mamba
|
||||
- move /etc/modprobe.d/alsa.conf to /lib/modprobe.d for dracut to use it as not host-only configuration
|
||||
|
||||
* Fri Apr 12 2013 Automatic Build System <autodist@mambasoft.it> 1.0.27-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Sep 22 2012 Automatic Build System <autodist@mambasoft.it> 1.0.26-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jul 05 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.25-2mamba
|
||||
- added upstream patch to fix a asser which caused a kmix crash after boot (https://bugs.kde.org/show_bug.cgi?id=209975)
|
||||
|
||||
* Thu Jan 26 2012 Automatic Build System <autodist@mambasoft.it> 1.0.25-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Aug 07 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.24.1-2mamba
|
||||
- modify /etc/modprobe.d/alsa.conf to prevent abnormal and snd-usb-audio drivers to load as first soundcard
|
||||
|
||||
* Wed Feb 09 2011 Automatic Build System <autodist@mambasoft.it> 1.0.24.1-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Dec 19 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.23-4mamba
|
||||
- created package python-smixer to move out python dependency
|
||||
|
||||
* Sun Nov 07 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.23-3mamba
|
||||
- rebuilt with static libraries for qemu static
|
||||
|
||||
* Mon Sep 27 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.23-2mamba
|
||||
- added patch to use thread safe locale functions setlocale and uselocale. Fixes VLC bug with softvol and max_dB set
|
||||
|
||||
* Sat Apr 17 2010 Automatic Build System <autodist@mambasoft.it> 1.0.23-1mamba
|
||||
- automatic update to 1.0.23 by autodist
|
||||
|
||||
* Wed Dec 16 2009 Automatic Build System <autodist@mambasoft.it> 1.0.22-1mamba
|
||||
- automatic update to 1.0.22 by autodist
|
||||
|
||||
* Thu Sep 10 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.21a-1mamba
|
||||
- update to 1.0.21a
|
||||
|
||||
* Tue Sep 01 2009 Automatic Build System <autodist@mambasoft.it> 1.0.21-1mamba
|
||||
- automatic update to 1.0.21 by autodist
|
||||
|
||||
* Sat Jul 25 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.20-2mamba
|
||||
- install modprobe file as /etc/modprobe.d/alsa.conf
|
||||
|
||||
* Thu May 07 2009 Automatic Build System <autodist@mambasoft.it> 1.0.20-1mamba
|
||||
- automatic update to 1.0.20 by autodist
|
||||
|
||||
* Tue Mar 03 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.19-2mamba
|
||||
- blacklist snd_pcsp and pcspkr modules
|
||||
|
||||
* Mon Jan 19 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.19-1mamba
|
||||
- automatic update to 1.0.19 by autodist
|
||||
|
||||
* Fri Jan 02 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.18rc3-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Oct 30 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.18-1mamba
|
||||
- automatic update to 1.0.18 by autodist
|
||||
|
||||
* Thu Aug 21 2008 gil <puntogil@libero.it> 1.0.17a-1mamba
|
||||
- update to 1.0.17a
|
||||
|
||||
* Sun Feb 17 2008 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.16-1mamba
|
||||
- update to 1.0.16
|
||||
|
||||
* Thu Oct 18 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.15-1mamba
|
||||
- update to 1.0.15
|
||||
|
||||
* Sat Aug 11 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.14a-2mamba
|
||||
- initscript moved to alsa-utils
|
||||
- removed requirement for postplug-sound
|
||||
- removed build requirement for kernelsource
|
||||
|
||||
* Mon Jun 11 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.14a-1mamba
|
||||
- update to 1.0.14a
|
||||
|
||||
* Mon Jun 04 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.14-1mamba
|
||||
- update to 1.0.14
|
||||
- removed requirement for alsa-utils
|
||||
|
||||
* Fri Oct 20 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.13-4qilnx
|
||||
- add requirement for alsa-utils needed by alsa initscript
|
||||
|
||||
* Thu Oct 12 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.13-3qilnx
|
||||
- alsa initscript: unload mixer and pcm oss modules in correct order
|
||||
|
||||
* Wed Oct 11 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.13-2qilnx
|
||||
- alsa initscript: fix check on oss2jack before unloading mixer and pcm modules
|
||||
|
||||
* Sun Oct 01 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.13-1qilnx
|
||||
- update to version 1.0.13 by autospec
|
||||
- alsa intiscript: don't load oss mixer module if oss2jack is enabled
|
||||
|
||||
* Wed Sep 27 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.12-1qilnx
|
||||
- update to version 1.0.12 by autospec
|
||||
|
||||
* Wed Apr 26 2006 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.11-1qilnx
|
||||
- update to version 1.0.11 by autospec
|
||||
- alsalisp no more installed, see changelog
|
||||
|
||||
* Mon Dec 05 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.10-2qilnx
|
||||
- don't start snd-pcm-oss if jack is configured in /etc/sysconfig/sound
|
||||
|
||||
* Mon Nov 21 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.10-1qilnx
|
||||
- update to version 1.0.10 by autospec
|
||||
|
||||
* Wed Nov 09 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.9-2qilnx
|
||||
- requires postplug-sound
|
||||
|
||||
* Mon Sep 26 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.9-1qilnx
|
||||
- update to version 1.0.9 by autospec
|
||||
- obsolete build requirement for kernel-alsa-devel and devfs configuration
|
||||
file removed
|
||||
|
||||
* Mon Aug 22 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.8-5qilnx
|
||||
- initscript fix
|
||||
|
||||
* Fri May 13 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.8-4qilnx
|
||||
- same fix as before, now really
|
||||
|
||||
* Mon Mar 07 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.8-3qilnx
|
||||
- fix: chkconfig script on install, not just on upgrade
|
||||
|
||||
* Tue Feb 01 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.8-2qilnx
|
||||
- %pre script fixes
|
||||
|
||||
* Tue Feb 01 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.8-1qilnx
|
||||
- update to version 1.0.8 by autospec
|
||||
- initscript renamed to alsa also saves and restores mixer volumes
|
||||
|
||||
* Fri Nov 26 2004 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0.7-1qilnx
|
||||
- update to version 1.0.7 by autospec
|
||||
|
||||
* Tue Nov 02 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.5-2qilnx
|
||||
- added requirement: chkconfig
|
||||
|
||||
* Mon May 31 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.5-1qilnx
|
||||
- new version rebuild
|
||||
|
||||
* Wed Apr 07 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.4-2qilnx
|
||||
- modified alsaoss initscript to work with new modutils and 2.6.x kernels
|
||||
|
||||
* Mon Apr 05 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.4-1qilnx
|
||||
- new version rebuild
|
||||
|
||||
* Mon Mar 08 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.3-2qilnx
|
||||
- fixed the dmix/dshare/dsnoop poll() problems
|
||||
|
||||
* Tue Mar 02 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.3-1qilnx
|
||||
- rebuilt with alsa-lib-1.0.3
|
||||
|
||||
* Tue Jan 27 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.2-1qilnx
|
||||
- rebuilt with version 1.0.2
|
||||
- added alsaoss-initscript, alsa-sound-devfs previously located in kernel packages
|
||||
|
||||
* Fri Jan 09 2004 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.1-1qilnx
|
||||
- rebuilt with version 1.0.1
|
||||
- added kernel-alsa-devel, kernelsource dependencies
|
||||
|
||||
* Fri Dec 05 2003 Davide Madrisan <davide.madrisan@qilinux.it> 1.0.0rc2-1qilnx
|
||||
- rebuilt with latest rc version
|
||||
|
||||
* Mon Oct 22 2003 Davide Madrisan <davide.madrisan@qilinux.it> 0.9.8-1qilnx
|
||||
- rebuilt with version 0.9.8
|
||||
|
||||
* Fri Sep 26 2003 Davide Madrisan <davide.madrisan@qilinux.it> 0.9.7-1qilnx
|
||||
- rebuilt with version 0.9.7
|
||||
|
||||
* Tue Sep 02 2003 Davide Madrisan <davide.madrisan@qinet.it> 0.9.6-1qilnx
|
||||
- rebuilt with version 0.9.6
|
||||
|
||||
* Tue Jul 03 2003 Silvan Calarco <silvan.calarco@qinet.it> 0.9.4-1qilnx
|
||||
- first build
|
Loading…
Reference in New Issue
Block a user