rebuilt with debug package and aarch64 build fix [release 0.6.0_rc2-2mamba;Sat Dec 12 2020]
This commit is contained in:
parent
92568097ff
commit
88a2db43d3
14
lash-0.6.0_rc2-fix-manual-generation.patch
Normal file
14
lash-0.6.0_rc2-fix-manual-generation.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- docs/Makefile.in.orig 2008-11-09 22:45:28.000000000 +0100
|
||||
+++ docs/Makefile.in 2011-07-23 17:12:26.000000000 +0200
|
||||
@@ -527,9 +527,9 @@
|
||||
@HAVE_TEXI2HTML_TRUE@ mkdir -lash-manual-html-split; \
|
||||
@HAVE_TEXI2HTML_TRUE@ fi
|
||||
@HAVE_TEXI2HTML_TRUE@ cd lash-manual-html-one-page && \
|
||||
-@HAVE_TEXI2HTML_TRUE@ texi2html --number ../$(top_srcdir)/docs/lash-manual.texi
|
||||
+@HAVE_TEXI2HTML_TRUE@ texi2html --number-footnotes --number-sections ../$(top_srcdir)/docs/lash-manual.texi
|
||||
@HAVE_TEXI2HTML_TRUE@ cd lash-manual-html-split && \
|
||||
-@HAVE_TEXI2HTML_TRUE@ texi2html --number --split=chapter ../$(top_srcdir)/docs/lash-manual.texi
|
||||
+@HAVE_TEXI2HTML_TRUE@ texi2html --number-footnotes --number-sections --split=chapter ../$(top_srcdir)/docs/lash-manual.texi
|
||||
@HAVE_TEXI2HTML_TRUE@ touch html-manual-stamp
|
||||
# Tell versions [3.59,3.63) of GNU make to not export all variables.
|
||||
# Otherwise a system limit (for SysV at least) may be exceeded.
|
39
lash.spec
39
lash.spec
@ -2,7 +2,7 @@
|
||||
%define srcver %(echo %version | sed "s|_.*|.594|")
|
||||
Name: lash
|
||||
Version: 0.6.0_rc2
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: A session management system for JACK and ALSA audio applications on GNU/Linux
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
@ -12,16 +12,18 @@ URL: http://lash.nongnu.org/
|
||||
Source: http://download.savannah.gnu.org/releases/lash/lash-%{pkgver}.tar.bz2
|
||||
Patch0: %{name}-0.5.4-gcc44.patch
|
||||
Patch1: lash-0.6.0_rc2-arm-sigsegv.patch
|
||||
Patch2: lash-0.6.0_rc2-fix-manual-generation.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: ldconfig
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libe2fs-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
@ -30,22 +32,23 @@ BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libjack-devel
|
||||
BuildRequires: libkrb5-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: libreadline-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libsystemd-devel
|
||||
BuildRequires: libtirpc-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
BuildRequires: python
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: tetex
|
||||
BuildRequires: swig
|
||||
Requires: swig
|
||||
PreReq: %{__install_info}
|
||||
Requires(post):%{__install_info}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
@ -67,8 +70,7 @@ Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n lib%{name}-devel
|
||||
LASH is a session management system for JACK and ALSA audio applications on GNU/Linux. It is an implementation of a proposal that originated from this discussion. Its aim is to allow you to have many different audio programs running at once, to save their setup, close them down and then easily reload the setup at some other time. LASH doesn't deal with any kind of audio data itself; it just runs programs, deals with saving/loading (arbitrary) data and connects different kinds of virtual audio ports together (currently JACK and ALSA sequencer ports). It can also be used to move entire sessions between computers, or post sessions on the Internet for download.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
This package contains static libraries and header files needed for development.
|
||||
|
||||
%package -n python-%{name}
|
||||
Summary: Python wrapper for LASH
|
||||
@ -78,16 +80,24 @@ Requires: %{name} = %{version}-%{release}
|
||||
%description -n python-%{name}
|
||||
Contains Python language bindings for developing Python applications that use LASH.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{srcver}
|
||||
%ifarch arm
|
||||
sed -i "s,| arm-\* |,| aarch64-\* | arm-\* |," config.sub
|
||||
%ifarch arm aarch64
|
||||
%patch1 -p1
|
||||
%endif
|
||||
cd docs
|
||||
%patch2 -p1
|
||||
cd ..
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-alsa-midi \
|
||||
LIBS="-luuid -lm -ltirpc"
|
||||
LIBS="-luuid -lm -ltirpc" \
|
||||
CFLAGS="%{optflags} -I%{_includedir}/tirpc"
|
||||
|
||||
# FIXME http://bugs.gentoo.org/show_bug.cgi?id=214234 removed pylash pakage
|
||||
make -j1 ALSA_LIBS="-lpthread -lasound"
|
||||
|
||||
@ -146,12 +156,15 @@ EOF
|
||||
|
||||
%files -n python-%{name}
|
||||
%defattr(-,root,root)
|
||||
%{python_sitearch}/_lash.a
|
||||
%{python_sitearch}/_lash.la
|
||||
%{python_sitearch}/_lash.so
|
||||
%{python_sitearch}/lash.py
|
||||
%{python_sitelib}/_lash.a
|
||||
%{python_sitelib}/_lash.la
|
||||
%{python_sitelib}/_lash.so
|
||||
%{python_sitelib}/lash.py
|
||||
|
||||
%changelog
|
||||
* Sat Dec 12 2020 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.0_rc2-2mamba
|
||||
- rebuilt with debug package and aarch64 build fix
|
||||
|
||||
* Tue Feb 12 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.0_rc2-1mamba
|
||||
- update to 0.6.0_rc2
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user