update to 0.6.0_rc2 [release 0.6.0_rc2-1mamba;Tue Feb 12 2013]
This commit is contained in:
parent
f59301e93c
commit
92568097ff
@ -1,2 +1,4 @@
|
||||
# lash
|
||||
|
||||
LASH is a session management system for JACK and ALSA audio applications on GNU/Linux. It is an implementation of a proposal that originated from this discussion. Its aim is to allow you to have many different audio programs running at once, to save their setup, close them down and then easily reload the setup at some other time. LASH doesn't deal with any kind of audio data itself; it just runs programs, deals with saving/loading (arbitrary) data and connects different kinds of virtual audio ports together (currently JACK and ALSA sequencer ports). It can also be used to move entire sessions between computers, or post sessions on the Internet for download.
|
||||
|
||||
|
14
lash-0.5.4-gcc44.patch
Normal file
14
lash-0.5.4-gcc44.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- liblash/socket.c.old 2008-06-26 15:20:44.227064193 +0200
|
||||
+++ liblash/socket.c 2008-06-26 15:21:18.245063129 +0200
|
||||
@@ -20,6 +20,11 @@
|
||||
|
||||
#define _POSIX_SOURCE /* addrinfo */
|
||||
|
||||
+#ifdef LASH_BUILD
|
||||
+#define _GNU_SOURCE
|
||||
+#include "config.h"
|
||||
+#endif /* LASH_BUILD */
|
||||
+
|
||||
#include <stdint.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/socket.h>
|
16
lash-0.6.0_rc2-arm-sigsegv.patch
Normal file
16
lash-0.6.0_rc2-arm-sigsegv.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -Nru lash-0.6.0.594.orig/lashd/sigsegv.c lash-0.6.0.594/lashd/sigsegv.c
|
||||
--- lash-0.6.0.594.orig/lashd/sigsegv.c 2008-09-07 00:19:51.000000000 +0200
|
||||
+++ lash-0.6.0.594/lashd/sigsegv.c 2013-03-05 12:05:42.376925531 +0100
|
||||
@@ -90,10 +90,10 @@
|
||||
lash_error("info.si_errno = %d", info->si_errno);
|
||||
lash_error("info.si_code = %d (%s)", info->si_code, si_codes[info->si_code]);
|
||||
lash_error("info.si_addr = %p", info->si_addr);
|
||||
- for(i = 0; i < NGREG; i++)
|
||||
- lash_error("reg[%02d] = 0x" REGFORMAT, i, ucontext->uc_mcontext.gregs[i]);
|
||||
|
||||
#if defined(SIGSEGV_STACK_X86) || defined(SIGSEGV_STACK_IA64)
|
||||
+ for(i = 0; i < NGREG; i++)
|
||||
+ lash_error("reg[%02d] = 0x" REGFORMAT, i, ucontext->uc_mcontext.gregs[i]);
|
||||
# if defined(SIGSEGV_STACK_IA64)
|
||||
ip = (void*)ucontext->uc_mcontext.gregs[REG_RIP];
|
||||
bp = (void**)ucontext->uc_mcontext.gregs[REG_RBP];
|
171
lash.spec
Normal file
171
lash.spec
Normal file
@ -0,0 +1,171 @@
|
||||
%define pkgver %(echo %version | tr _ '~')
|
||||
%define srcver %(echo %version | sed "s|_.*|.594|")
|
||||
Name: lash
|
||||
Version: 0.6.0_rc2
|
||||
Release: 1mamba
|
||||
Summary: A session management system for JACK and ALSA audio applications on GNU/Linux
|
||||
Group: Graphical Desktop/Applications/Multimedia
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://lash.nongnu.org/
|
||||
Source: http://download.savannah.gnu.org/releases/lash/lash-%{pkgver}.tar.bz2
|
||||
Patch0: %{name}-0.5.4-gcc44.patch
|
||||
Patch1: lash-0.6.0_rc2-arm-sigsegv.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libbzip2-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libffi-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libgraphite2-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libharfbuzz-devel
|
||||
BuildRequires: libjack-devel
|
||||
BuildRequires: liblzma-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: libreadline-devel
|
||||
BuildRequires: libselinux-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtirpc-devel
|
||||
BuildRequires: libuuid-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: tetex
|
||||
BuildRequires: swig
|
||||
Requires: swig
|
||||
PreReq: %{__install_info}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
LASH is a session management system for JACK and ALSA audio applications on GNU/Linux. It is an implementation of a proposal that originated from this discussion. Its aim is to allow you to have many different audio programs running at once, to save their setup, close them down and then easily reload the setup at some other time. LASH doesn't deal with any kind of audio data itself; it just runs programs, deals with saving/loading (arbitrary) data and connects different kinds of virtual audio ports together (currently JACK and ALSA sequencer ports). It can also be used to move entire sessions between computers, or post sessions on the Internet for download.
|
||||
|
||||
%package -n lib%{name}
|
||||
Summary: A session management system for JACK and ALSA audio applications on GNU/Linux
|
||||
Group: System/Libraries
|
||||
|
||||
%description -n lib%{name}
|
||||
LASH is a session management system for JACK and ALSA audio applications on GNU/Linux. It is an implementation of a proposal that originated from this discussion. Its aim is to allow you to have many different audio programs running at once, to save their setup, close them down and then easily reload the setup at some other time. LASH doesn't deal with any kind of audio data itself; it just runs programs, deals with saving/loading (arbitrary) data and connects different kinds of virtual audio ports together (currently JACK and ALSA sequencer ports). It can also be used to move entire sessions between computers, or post sessions on the Internet for download.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%package -n lib%{name}-devel
|
||||
Summary: Devel package for %{name}
|
||||
Group: Development/Libraries
|
||||
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n lib%{name}-devel
|
||||
LASH is a session management system for JACK and ALSA audio applications on GNU/Linux. It is an implementation of a proposal that originated from this discussion. Its aim is to allow you to have many different audio programs running at once, to save their setup, close them down and then easily reload the setup at some other time. LASH doesn't deal with any kind of audio data itself; it just runs programs, deals with saving/loading (arbitrary) data and connects different kinds of virtual audio ports together (currently JACK and ALSA sequencer ports). It can also be used to move entire sessions between computers, or post sessions on the Internet for download.
|
||||
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%package -n python-%{name}
|
||||
Summary: Python wrapper for LASH
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description -n python-%{name}
|
||||
Contains Python language bindings for developing Python applications that use LASH.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{srcver}
|
||||
%ifarch arm
|
||||
%patch1 -p1
|
||||
%endif
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-alsa-midi \
|
||||
LIBS="-luuid -lm -ltirpc"
|
||||
# FIXME http://bugs.gentoo.org/show_bug.cgi?id=214234 removed pylash pakage
|
||||
make -j1 ALSA_LIBS="-lpthread -lasound"
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall
|
||||
|
||||
mkdir -p %{buildroot}%{_datadir}/applications
|
||||
cat > %{buildroot}%{_datadir}/applications/%{name}-panel.desktop << EOF
|
||||
[Desktop Entry]
|
||||
Name=LASH Panel
|
||||
Comment=LASH Panel
|
||||
Icon=/usr/share/lash/icons/lash_48px.png
|
||||
Exec=/usr/bin/lash_panel
|
||||
Terminal=false
|
||||
Type=Application
|
||||
StartupNotify=false
|
||||
Categories=Qt;KDE;AudioVideo;
|
||||
EOF
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%post -n lib%{name} -p /sbin/ldconfig
|
||||
%postun -n lib%{name} -p /sbin/ldconfig
|
||||
|
||||
%post -n python-%{name} -p /sbin/ldconfig
|
||||
%postun -n python-%{name} -p /sbin/ldconfig
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/lash_*
|
||||
%{_bindir}/lashd
|
||||
%dir %{_datadir}/lash/icons
|
||||
%{_datadir}/lash/icons/lash.svg
|
||||
%{_datadir}/lash/icons/lash.xcf
|
||||
%{_datadir}/lash/icons/lash_*px.png
|
||||
%{_datadir}/applications/%{name}-panel.desktop
|
||||
%{_datadir}/dbus-1/services/org.nongnu.lash.service
|
||||
|
||||
%files -n lib%{name}
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/liblash.so.*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files -n lib%{name}-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/lash-1.0/lash
|
||||
%{_includedir}/lash-1.0/lash/*.h
|
||||
%{_libdir}/liblash.a
|
||||
%{_libdir}/liblash.la
|
||||
%{_libdir}/liblash.so
|
||||
%{_datadir}/lash/dtds/lash-project-1.0.dtd
|
||||
%{_libdir}/pkgconfig/*.pc
|
||||
%doc ChangeLog ChangeLog.old NEWS README README.SECURITY TODO
|
||||
|
||||
%files -n python-%{name}
|
||||
%defattr(-,root,root)
|
||||
%{python_sitearch}/_lash.a
|
||||
%{python_sitearch}/_lash.la
|
||||
%{python_sitearch}/_lash.so
|
||||
%{python_sitearch}/lash.py
|
||||
|
||||
%changelog
|
||||
* Tue Feb 12 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.6.0_rc2-1mamba
|
||||
- update to 0.6.0_rc2
|
||||
|
||||
* Thu Apr 05 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.4-3mamba
|
||||
- pass link libraries to fix build; remove python-lash subpackage
|
||||
|
||||
* Sat Apr 24 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.4-2mamba
|
||||
- added patch to build against current gcc
|
||||
- added requirements for swig
|
||||
|
||||
* Fri Aug 22 2008 gil <puntogil@libero.it> 0.5.4-1mamba
|
||||
- update to 0.5.4
|
||||
- added lash-panel.desktop
|
||||
- FIXME http://bugs.gentoo.org/show_bug.cgi?id=214234 or removed python-lash pakage
|
||||
|
||||
* Thu Oct 26 2006 Silvan Calarco <silvan.calarco@mambasoft.it> 0.5.2-1qilnx
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user