rebuilt with ImageMagick 6.8.8.6 [release 0.9.2-2mamba;Fri Feb 28 2014]
This commit is contained in:
parent
f280e31560
commit
b2744cb439
@ -1,2 +1,4 @@
|
|||||||
# kxstitch
|
# kxstitch
|
||||||
|
|
||||||
|
KXStitch is a program that lets you create cross stitch patterns and charts. Patterns can be created from scratch on a user defined size of grid, which can be enlarged or reduced in size as your pattern progresses. Alternatively you can import images from many graphics formats which will allow you to reduce the number of colours and to restrict the conversion to full stitches or optionally use fractional stitches. You may also use an image as a background. These imported images can then be modified using the supplied tools to produce your final design.
|
||||||
|
|
||||||
|
267
kxstitch-0.9.0-cmakelist.patch
Normal file
267
kxstitch-0.9.0-cmakelist.patch
Normal file
@ -0,0 +1,267 @@
|
|||||||
|
diff -Nru kxstitch-0.9.0-KDE4-orig/CMakeLists.txt kxstitch-0.9.0-KDE4/CMakeLists.txt
|
||||||
|
--- kxstitch-0.9.0-KDE4-orig/CMakeLists.txt 2012-04-18 22:13:18.000000000 +0200
|
||||||
|
+++ kxstitch-0.9.0-KDE4/CMakeLists.txt 2012-04-25 08:11:39.298245326 +0200
|
||||||
|
@@ -1,130 +1,133 @@
|
||||||
|
-cmake_minimum_required(VERSION 2.6)
|
||||||
|
-
|
||||||
|
-project (kxstitch)
|
||||||
|
-
|
||||||
|
-find_package (KDE4 REQUIRED)
|
||||||
|
-find_package (ImageMagick COMPONENTS MagickCore Magick++ REQUIRED)
|
||||||
|
-find_package (Doxygen)
|
||||||
|
-find_package (SharedMimeInfo)
|
||||||
|
-
|
||||||
|
-if (DOXYGEN_FOUND)
|
||||||
|
- configure_file(${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile @ONLY)
|
||||||
|
- add_custom_target (doc ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile
|
||||||
|
- WORKING_DIRECTORY ${CMAKE_CURENT_BINARY_DIR}
|
||||||
|
- COMMENT "Generating API documentation with Doxygen" VERBATIM)
|
||||||
|
-endif (DOXYGEN_FOUND)
|
||||||
|
-
|
||||||
|
-include_directories (${KDE4_INCLUDES} ${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR})
|
||||||
|
-include_directories (${ImageMagick_Magick++_INCLUDE_DIR} ${ImageMagick_MagickCore_INCLUDE_DIR})
|
||||||
|
-
|
||||||
|
-set (kxstitch_SRCS
|
||||||
|
- src/BackgroundImage.cpp
|
||||||
|
- src/BackgroundImages.cpp
|
||||||
|
- src/Boundary.cpp
|
||||||
|
- src/Commands.cpp
|
||||||
|
- src/ConfigurationDialogs.cpp
|
||||||
|
- src/Document.cpp
|
||||||
|
- src/DocumentFloss.cpp
|
||||||
|
- src/DocumentPalette.cpp
|
||||||
|
- src/Editor.cpp
|
||||||
|
- src/Element.cpp
|
||||||
|
- src/Floss.cpp
|
||||||
|
- src/FlossScheme.cpp
|
||||||
|
- src/KeycodeLineEdit.cpp
|
||||||
|
- src/Layer.cpp
|
||||||
|
- src/Layers.cpp
|
||||||
|
- src/LibraryFile.cpp
|
||||||
|
- src/LibraryPattern.cpp
|
||||||
|
- src/Main.cpp
|
||||||
|
- src/MainWindow.cpp
|
||||||
|
- src/Page.cpp
|
||||||
|
- src/Palette.cpp
|
||||||
|
- src/PaperSizes.cpp
|
||||||
|
- src/Pattern.cpp
|
||||||
|
- src/Preview.cpp
|
||||||
|
- src/PrinterConfiguration.cpp
|
||||||
|
- src/Renderer.cpp
|
||||||
|
- src/Scale.cpp
|
||||||
|
- src/SchemeManager.cpp
|
||||||
|
- src/SchemeParser.cpp
|
||||||
|
- src/Stitch.cpp
|
||||||
|
- src/StitchData.cpp
|
||||||
|
- src/XKeyLock.cpp
|
||||||
|
-
|
||||||
|
- src/AlphaSelect.cpp
|
||||||
|
- src/CalibrateFlossDlg.cpp
|
||||||
|
- src/CharSelectorDlg.cpp
|
||||||
|
- src/ExtendPatternDlg.cpp
|
||||||
|
- src/FilePropertiesDlg.cpp
|
||||||
|
- src/ImportImageDlg.cpp
|
||||||
|
- src/KeyElementDlg.cpp
|
||||||
|
- src/LibraryFilePathsDlg.cpp
|
||||||
|
- src/LibraryListWidget.cpp
|
||||||
|
- src/LibraryListWidgetItem.cpp
|
||||||
|
- src/LibraryManagerDlg.cpp
|
||||||
|
- src/LibraryPatternPropertiesDlg.cpp
|
||||||
|
- src/LibraryTreeWidget.cpp
|
||||||
|
- src/LibraryTreeWidgetItem.cpp
|
||||||
|
- src/NewFlossDlg.cpp
|
||||||
|
- src/PaletteManagerDlg.cpp
|
||||||
|
- src/PageLayoutEditor.cpp
|
||||||
|
- src/PagePreviewListWidgetItem.cpp
|
||||||
|
- src/PagePropertiesDlg.cpp
|
||||||
|
- src/PatternElementDlg.cpp
|
||||||
|
- src/PrintSetupDlg.cpp
|
||||||
|
- src/SelectArea.cpp
|
||||||
|
- src/TextElementDlg.cpp
|
||||||
|
- src/TextToolDlg.cpp
|
||||||
|
-)
|
||||||
|
-
|
||||||
|
-add_subdirectory(icons)
|
||||||
|
-add_subdirectory(po)
|
||||||
|
-add_subdirectory(schemes)
|
||||||
|
-add_subdirectory(doc)
|
||||||
|
-
|
||||||
|
-kde4_add_kcfg_files(kxstitch_SRCS configuration.kcfgc)
|
||||||
|
-
|
||||||
|
-kde4_add_ui_files(kxstitch_SRCS
|
||||||
|
- ui/CalibrateFloss.ui
|
||||||
|
- ui/CharSelector.ui
|
||||||
|
- ui/ExtendPattern.ui
|
||||||
|
- ui/FileProperties.ui
|
||||||
|
- ui/KeyElement.ui
|
||||||
|
- ui/ImportImage.ui
|
||||||
|
- ui/LibraryFilePaths.ui
|
||||||
|
- ui/LibraryManager.ui
|
||||||
|
- ui/LibraryPatternProperties.ui
|
||||||
|
- ui/NewFloss.ui
|
||||||
|
- ui/PageProperties.ui
|
||||||
|
- ui/PaletteManager.ui
|
||||||
|
- ui/PatternElement.ui
|
||||||
|
- ui/PrintSetup.ui
|
||||||
|
- ui/TextElement.ui
|
||||||
|
- ui/TextTool.ui
|
||||||
|
- ui/EditorConfigPage.ui
|
||||||
|
- ui/PatternConfigPage.ui
|
||||||
|
- ui/ImportConfigPage.ui
|
||||||
|
- ui/LibraryConfigPage.ui
|
||||||
|
- ui/PrinterConfigPage.ui
|
||||||
|
-)
|
||||||
|
-
|
||||||
|
-kde4_install_icons(${ICON_INSTALL_DIR})
|
||||||
|
-
|
||||||
|
-kde4_add_executable (kxstitch ${kxstitch_SRCS})
|
||||||
|
-
|
||||||
|
-target_link_libraries (kxstitch ${KDE4_KDEUI_LIBS}
|
||||||
|
- ${KDE4_KIO_LIBS}
|
||||||
|
- ${ImageMagick_Magick++_LIBRARY} ${ImageMagick_MagickCore_LIBRARY})
|
||||||
|
-
|
||||||
|
-set (CMAKE_CXX_FLAGS "-DQT_NO_COMPAT -DKDE_NO_COMPAT")
|
||||||
|
-
|
||||||
|
-install (TARGETS kxstitch DESTINATION ${BIN_INSTALL_DIR})
|
||||||
|
-install (FILES kxstitchui.rc DESTINATION ${DATA_INSTALL_DIR}/kxstitch)
|
||||||
|
-install (FILES kxstitch.kcfg DESTINATION ${KCFG_INSTALL_DIR})
|
||||||
|
-install (FILES kxstitch.desktop DESTINATION ${XDG_APPS_INSTALL_DIR})
|
||||||
|
-install (FILES kxstitch.1.gz DESTINATION ${MAN_INSTALL_DIR}/man1)
|
||||||
|
-
|
||||||
|
-IF (SHARED_MIME_INFO_FOUND AND IS_DIRECTORY ${XDG_MIME_INSTALL_DIR})
|
||||||
|
- install (FILES kxstitch.xml DESTINATION ${XDG_MIME_INSTALL_DIR})
|
||||||
|
- update_xdg_mimetypes (${XDG_MIME_INSTALL_DIR})
|
||||||
|
-ENDIF(SHARED_MIME_INFO_FOUND AND IS_DIRECTORY ${XDG_MIME_INSTALL_DIR})
|
||||||
|
+cmake_minimum_required(VERSION 2.6)
|
||||||
|
+
|
||||||
|
+project (kxstitch)
|
||||||
|
+
|
||||||
|
+find_package (KDE4 REQUIRED)
|
||||||
|
+find_package (ImageMagick COMPONENTS MagickCore Magick++ REQUIRED)
|
||||||
|
+find_package (X11)
|
||||||
|
+find_package (Doxygen)
|
||||||
|
+find_package (SharedMimeInfo)
|
||||||
|
+
|
||||||
|
+if (DOXYGEN_FOUND)
|
||||||
|
+ configure_file(${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile @ONLY)
|
||||||
|
+ add_custom_target (doc ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile
|
||||||
|
+ WORKING_DIRECTORY ${CMAKE_CURENT_BINARY_DIR}
|
||||||
|
+ COMMENT "Generating API documentation with Doxygen" VERBATIM)
|
||||||
|
+endif (DOXYGEN_FOUND)
|
||||||
|
+
|
||||||
|
+include_directories (${KDE4_INCLUDES} ${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_CURRENT_SOURCE_DIR})
|
||||||
|
+include_directories (${ImageMagick_Magick++_INCLUDE_DIR} ${ImageMagick_MagickCore_INCLUDE_DIR})
|
||||||
|
+include_directories (${X11_INCLUDE_DIR})
|
||||||
|
+
|
||||||
|
+set (kxstitch_SRCS
|
||||||
|
+ src/BackgroundImage.cpp
|
||||||
|
+ src/BackgroundImages.cpp
|
||||||
|
+ src/Boundary.cpp
|
||||||
|
+ src/Commands.cpp
|
||||||
|
+ src/ConfigurationDialogs.cpp
|
||||||
|
+ src/Document.cpp
|
||||||
|
+ src/DocumentFloss.cpp
|
||||||
|
+ src/DocumentPalette.cpp
|
||||||
|
+ src/Editor.cpp
|
||||||
|
+ src/Element.cpp
|
||||||
|
+ src/Floss.cpp
|
||||||
|
+ src/FlossScheme.cpp
|
||||||
|
+ src/KeycodeLineEdit.cpp
|
||||||
|
+ src/Layer.cpp
|
||||||
|
+ src/Layers.cpp
|
||||||
|
+ src/LibraryFile.cpp
|
||||||
|
+ src/LibraryPattern.cpp
|
||||||
|
+ src/Main.cpp
|
||||||
|
+ src/MainWindow.cpp
|
||||||
|
+ src/Page.cpp
|
||||||
|
+ src/Palette.cpp
|
||||||
|
+ src/PaperSizes.cpp
|
||||||
|
+ src/Pattern.cpp
|
||||||
|
+ src/Preview.cpp
|
||||||
|
+ src/PrinterConfiguration.cpp
|
||||||
|
+ src/Renderer.cpp
|
||||||
|
+ src/Scale.cpp
|
||||||
|
+ src/SchemeManager.cpp
|
||||||
|
+ src/SchemeParser.cpp
|
||||||
|
+ src/Stitch.cpp
|
||||||
|
+ src/StitchData.cpp
|
||||||
|
+ src/XKeyLock.cpp
|
||||||
|
+
|
||||||
|
+ src/AlphaSelect.cpp
|
||||||
|
+ src/CalibrateFlossDlg.cpp
|
||||||
|
+ src/CharSelectorDlg.cpp
|
||||||
|
+ src/ExtendPatternDlg.cpp
|
||||||
|
+ src/FilePropertiesDlg.cpp
|
||||||
|
+ src/ImportImageDlg.cpp
|
||||||
|
+ src/KeyElementDlg.cpp
|
||||||
|
+ src/LibraryFilePathsDlg.cpp
|
||||||
|
+ src/LibraryListWidget.cpp
|
||||||
|
+ src/LibraryListWidgetItem.cpp
|
||||||
|
+ src/LibraryManagerDlg.cpp
|
||||||
|
+ src/LibraryPatternPropertiesDlg.cpp
|
||||||
|
+ src/LibraryTreeWidget.cpp
|
||||||
|
+ src/LibraryTreeWidgetItem.cpp
|
||||||
|
+ src/NewFlossDlg.cpp
|
||||||
|
+ src/PaletteManagerDlg.cpp
|
||||||
|
+ src/PageLayoutEditor.cpp
|
||||||
|
+ src/PagePreviewListWidgetItem.cpp
|
||||||
|
+ src/PagePropertiesDlg.cpp
|
||||||
|
+ src/PatternElementDlg.cpp
|
||||||
|
+ src/PrintSetupDlg.cpp
|
||||||
|
+ src/SelectArea.cpp
|
||||||
|
+ src/TextElementDlg.cpp
|
||||||
|
+ src/TextToolDlg.cpp
|
||||||
|
+)
|
||||||
|
+
|
||||||
|
+add_subdirectory(icons)
|
||||||
|
+add_subdirectory(po)
|
||||||
|
+add_subdirectory(schemes)
|
||||||
|
+add_subdirectory(doc)
|
||||||
|
+
|
||||||
|
+kde4_add_kcfg_files(kxstitch_SRCS configuration.kcfgc)
|
||||||
|
+
|
||||||
|
+kde4_add_ui_files(kxstitch_SRCS
|
||||||
|
+ ui/CalibrateFloss.ui
|
||||||
|
+ ui/CharSelector.ui
|
||||||
|
+ ui/ExtendPattern.ui
|
||||||
|
+ ui/FileProperties.ui
|
||||||
|
+ ui/KeyElement.ui
|
||||||
|
+ ui/ImportImage.ui
|
||||||
|
+ ui/LibraryFilePaths.ui
|
||||||
|
+ ui/LibraryManager.ui
|
||||||
|
+ ui/LibraryPatternProperties.ui
|
||||||
|
+ ui/NewFloss.ui
|
||||||
|
+ ui/PageProperties.ui
|
||||||
|
+ ui/PaletteManager.ui
|
||||||
|
+ ui/PatternElement.ui
|
||||||
|
+ ui/PrintSetup.ui
|
||||||
|
+ ui/TextElement.ui
|
||||||
|
+ ui/TextTool.ui
|
||||||
|
+ ui/EditorConfigPage.ui
|
||||||
|
+ ui/PatternConfigPage.ui
|
||||||
|
+ ui/ImportConfigPage.ui
|
||||||
|
+ ui/LibraryConfigPage.ui
|
||||||
|
+ ui/PrinterConfigPage.ui
|
||||||
|
+)
|
||||||
|
+
|
||||||
|
+kde4_install_icons(${ICON_INSTALL_DIR})
|
||||||
|
+
|
||||||
|
+kde4_add_executable (kxstitch ${kxstitch_SRCS})
|
||||||
|
+
|
||||||
|
+target_link_libraries (kxstitch ${KDE4_KDEUI_LIBS}
|
||||||
|
+ ${KDE4_KIO_LIBS}
|
||||||
|
+ ${ImageMagick_Magick++_LIBRARY} ${ImageMagick_MagickCore_LIBRARY}
|
||||||
|
+ ${X11_LIBRARIES})
|
||||||
|
+
|
||||||
|
+set (CMAKE_CXX_FLAGS "-DQT_NO_COMPAT -DKDE_NO_COMPAT")
|
||||||
|
+
|
||||||
|
+install (TARGETS kxstitch DESTINATION ${BIN_INSTALL_DIR})
|
||||||
|
+install (FILES kxstitchui.rc DESTINATION ${DATA_INSTALL_DIR}/kxstitch)
|
||||||
|
+install (FILES kxstitch.kcfg DESTINATION ${KCFG_INSTALL_DIR})
|
||||||
|
+install (FILES kxstitch.desktop DESTINATION ${XDG_APPS_INSTALL_DIR})
|
||||||
|
+install (FILES kxstitch.1.gz DESTINATION ${MAN_INSTALL_DIR}/man1)
|
||||||
|
+
|
||||||
|
+IF (SHARED_MIME_INFO_FOUND AND IS_DIRECTORY ${XDG_MIME_INSTALL_DIR})
|
||||||
|
+ install (FILES kxstitch.xml DESTINATION ${XDG_MIME_INSTALL_DIR})
|
||||||
|
+ update_xdg_mimetypes (${XDG_MIME_INSTALL_DIR})
|
||||||
|
+ENDIF(SHARED_MIME_INFO_FOUND AND IS_DIRECTORY ${XDG_MIME_INSTALL_DIR})
|
97
kxstitch.spec
Normal file
97
kxstitch.spec
Normal file
@ -0,0 +1,97 @@
|
|||||||
|
Name: kxstitch
|
||||||
|
Version: 0.9.2
|
||||||
|
Release: 2mamba
|
||||||
|
Summary: A program that lets you create cross stitch patterns and charts
|
||||||
|
Group: Graphical Desktop/Applications/Graphics
|
||||||
|
Vendor: openmamba
|
||||||
|
Distribution: openmamba
|
||||||
|
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
|
||||||
|
URL: http://sourceforge.net/apps/mediawiki/kxstitch/index.php?title=Main_Page
|
||||||
|
Source: http://downloads.sourceforge.net/project/kxstitch/kxstitch/%{version}/kxstitch-%{version}-KDE4.tar.gz
|
||||||
|
Source1: it.po
|
||||||
|
# the patch fix a bug in Cmakelist that prevent to find X11 libraries (Thanks to Stephen Allewell)
|
||||||
|
Patch: kxstitch-0.9.0-cmakelist.patch
|
||||||
|
License: GPL
|
||||||
|
## AUTOBUILDREQ-BEGIN
|
||||||
|
BuildRequires: glibc-devel
|
||||||
|
BuildRequires: kdelibs-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libICE-devel
|
||||||
|
BuildRequires: libMagick-devel
|
||||||
|
BuildRequires: libqt4-devel
|
||||||
|
BuildRequires: libSM-devel
|
||||||
|
BuildRequires: libstdc++6-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXau-devel
|
||||||
|
BuildRequires: libXdmcp-devel
|
||||||
|
BuildRequires: libXext-devel
|
||||||
|
BuildRequires: libXft-devel
|
||||||
|
BuildRequires: libXpm-devel
|
||||||
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: cmake
|
||||||
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
|
%debug_package
|
||||||
|
|
||||||
|
%description
|
||||||
|
KXStitch is a program that lets you create cross stitch patterns and charts. Patterns can be created from scratch on a user defined size of grid, which can be enlarged or reduced in size as your pattern progresses. Alternatively you can import images from many graphics formats which will allow you to reduce the number of colours and to restrict the conversion to full stitches or optionally use fractional stitches. You may also use an image as a background. These imported images can then be modified using the supplied tools to produce your final design.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}-%{version}-KDE4
|
||||||
|
#%patch -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
%cmake_kde4 -d build
|
||||||
|
|
||||||
|
#\
|
||||||
|
# -DImageMagick_Magick++_INCLUDE_DIR=%{_includedir}/ImageMagick-6 \
|
||||||
|
# -DImageMagick_MagickCore_INCLUDE_DIR=%{_includedir}/ImageMagick-6
|
||||||
|
|
||||||
|
%make
|
||||||
|
|
||||||
|
%install
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
#cp %{SOURCE1} po/
|
||||||
|
%makeinstall -C build
|
||||||
|
|
||||||
|
%find_lang %{name}
|
||||||
|
|
||||||
|
%clean
|
||||||
|
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||||
|
|
||||||
|
%files -f %{name}.lang
|
||||||
|
%defattr(-,root,root)
|
||||||
|
%{_kde4_bindir}/kxstitch
|
||||||
|
%{_kde4_xdgappsdir}/kxstitch.desktop
|
||||||
|
%dir %{_kde4_datadir}/kxstitch
|
||||||
|
%{_kde4_datadir}/kxstitch/kxstitchui.rc
|
||||||
|
%dir %{_kde4_datadir}/kxstitch/schemes
|
||||||
|
%{_kde4_datadir}/kxstitch/schemes/*.xml
|
||||||
|
%dir %{_kde4_datadir}/kxstitch/symbols
|
||||||
|
%{_kde4_datadir}/kxstitch/symbols/kxstitch.sym
|
||||||
|
%{_kde4_datadir}/kxstitch/toolbar/3quarter.png
|
||||||
|
%dir %{_kde4_datadir}/kxstitch/toolbar
|
||||||
|
%{_kde4_datadir}/kxstitch/toolbar/*.png
|
||||||
|
%{_kde4_kcfgdir}/kxstitch.kcfg
|
||||||
|
%doc %lang(en) %{_kde4_htmldir}/en/kxstitch/*
|
||||||
|
%{_kde4_icondir}/hicolor/*/apps/kxstitch.png
|
||||||
|
%{_kde4_icondir}/locolor/*/apps/kxstitch.png
|
||||||
|
%{_kde4_xdgmimedir}/kxstitch.xml
|
||||||
|
%{_mandir}/man1/kxstitch.1.gz
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Feb 28 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.2-2mamba
|
||||||
|
- rebuilt with ImageMagick 6.8.8.6
|
||||||
|
|
||||||
|
* Mon Aug 26 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 0.9.2-1mamba
|
||||||
|
- update to 0.9.2
|
||||||
|
|
||||||
|
* Mon Apr 30 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.9.1-1mamba
|
||||||
|
- update to 0.9.1
|
||||||
|
|
||||||
|
* Wed Apr 25 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 0.9.0-2mamba
|
||||||
|
- added italian translation
|
||||||
|
- fixed version number error in changelog
|
||||||
|
|
||||||
|
* Mon Apr 23 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> KDE4-1mamba
|
||||||
|
- package created by autospec
|
Loading…
Reference in New Issue
Block a user