33 lines
1.3 KiB
Diff
33 lines
1.3 KiB
Diff
From 8d5ac30955cf052a12ef8c87c0cae6d124d4d7b6 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?=D9=85=D9=87=D8=AF=D9=8A=20=D8=B4=D9=8A=D9=86=D9=88=D9=86?=
|
|
=?UTF-8?q?=20=28Mehdi=20Chinoune=29?= <mehdi.chinoune@hotmail.com>
|
|
Date: Fri, 30 Dec 2022 17:10:12 +0000
|
|
Subject: [PATCH] meson: Accept latest version of opencv 4.x
|
|
|
|
We've been bumping along the maximum opencv 4.x version for years,
|
|
just accept all opencv versions till someone reports breakage.
|
|
|
|
Fixes https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1680
|
|
|
|
Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/3664>
|
|
---
|
|
subprojects/gst-plugins-bad/ext/opencv/meson.build | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/subprojects/gst-plugins-bad/ext/opencv/meson.build b/subprojects/gst-plugins-bad/ext/opencv/meson.build
|
|
index 77c9f443894..37e20156eb6 100644
|
|
--- a/subprojects/gst-plugins-bad/ext/opencv/meson.build
|
|
+++ b/subprojects/gst-plugins-bad/ext/opencv/meson.build
|
|
@@ -71,7 +71,7 @@ if opencv_found
|
|
endif
|
|
|
|
if not opencv_found
|
|
- opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.7.0'], required : false)
|
|
+ opencv_dep = dependency('opencv4', version : '>= 4.0.0', required : false)
|
|
opencv_found = opencv_dep.found()
|
|
if opencv_found
|
|
foreach h : libopencv4_headers
|
|
--
|
|
GitLab
|
|
|