rebuilt by autoport with build requirements: libopencv-devel>=0:4.7.0-1mamba [release 1.20.5-2mamba;Sat Jan 21 2023]
This commit is contained in:
parent
799d71f033
commit
5501e16dee
32
gst-plugins-bad-1.20.5-opencv-4.7.patch
Normal file
32
gst-plugins-bad-1.20.5-opencv-4.7.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
From 8d5ac30955cf052a12ef8c87c0cae6d124d4d7b6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?=D9=85=D9=87=D8=AF=D9=8A=20=D8=B4=D9=8A=D9=86=D9=88=D9=86?=
|
||||||
|
=?UTF-8?q?=20=28Mehdi=20Chinoune=29?= <mehdi.chinoune@hotmail.com>
|
||||||
|
Date: Fri, 30 Dec 2022 17:10:12 +0000
|
||||||
|
Subject: [PATCH] meson: Accept latest version of opencv 4.x
|
||||||
|
|
||||||
|
We've been bumping along the maximum opencv 4.x version for years,
|
||||||
|
just accept all opencv versions till someone reports breakage.
|
||||||
|
|
||||||
|
Fixes https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1680
|
||||||
|
|
||||||
|
Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/3664>
|
||||||
|
---
|
||||||
|
subprojects/gst-plugins-bad/ext/opencv/meson.build | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/subprojects/gst-plugins-bad/ext/opencv/meson.build b/subprojects/gst-plugins-bad/ext/opencv/meson.build
|
||||||
|
index 77c9f443894..37e20156eb6 100644
|
||||||
|
--- a/subprojects/gst-plugins-bad/ext/opencv/meson.build
|
||||||
|
+++ b/subprojects/gst-plugins-bad/ext/opencv/meson.build
|
||||||
|
@@ -71,7 +71,7 @@ if opencv_found
|
||||||
|
endif
|
||||||
|
|
||||||
|
if not opencv_found
|
||||||
|
- opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.7.0'], required : false)
|
||||||
|
+ opencv_dep = dependency('opencv4', version : '>= 4.0.0', required : false)
|
||||||
|
opencv_found = opencv_dep.found()
|
||||||
|
if opencv_found
|
||||||
|
foreach h : libopencv4_headers
|
||||||
|
--
|
||||||
|
GitLab
|
||||||
|
|
60
gst-plugins-bad-1.20.5-zxing-cpp-1.4.patch
Normal file
60
gst-plugins-bad-1.20.5-zxing-cpp-1.4.patch
Normal file
@ -0,0 +1,60 @@
|
|||||||
|
From 7cfc3130a7906c199861d2ef331a07d749a4b769 Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?St=C3=A9phane=20Cerveau?= <scerveau@igalia.com>
|
||||||
|
Date: Tue, 22 Nov 2022 12:32:52 +0100
|
||||||
|
Subject: [PATCH] zxing: update to 1.4.0 tag
|
||||||
|
|
||||||
|
Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/3450>
|
||||||
|
---
|
||||||
|
subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp | 4 ++--
|
||||||
|
subprojects/gst-plugins-bad/ext/zxing/meson.build | 5 +++--
|
||||||
|
2 files changed, 5 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp b/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp
|
||||||
|
index 5f296ecab79..7836dbbcf18 100644
|
||||||
|
--- a/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp
|
||||||
|
+++ b/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp
|
||||||
|
@@ -368,7 +368,7 @@ gst_zxing_transform_frame_ip (GstVideoFilter * vfilter, GstVideoFrame * frame)
|
||||||
|
auto result = ReadBarcode ({(unsigned char *)data, width, height, zxing->image_format}, hints);
|
||||||
|
if (result.isValid ()) {
|
||||||
|
GST_DEBUG_OBJECT (zxing, "Symbol found. Text: %s Format: %s",
|
||||||
|
- TextUtfEncoding::ToUtf8 (result.text ()).c_str (),
|
||||||
|
+ result.text ().c_str (),
|
||||||
|
ToString (result.format ()));
|
||||||
|
} else {
|
||||||
|
goto out;
|
||||||
|
@@ -396,7 +396,7 @@ gst_zxing_transform_frame_ip (GstVideoFilter * vfilter, GstVideoFrame * frame)
|
||||||
|
"running-time", G_TYPE_UINT64, running_time,
|
||||||
|
"type", G_TYPE_STRING, ToString (result.format ()),
|
||||||
|
"symbol", G_TYPE_STRING,
|
||||||
|
- TextUtfEncoding::ToUtf8 (result.text ()).c_str (), NULL);
|
||||||
|
+ result.text ().c_str (), NULL);
|
||||||
|
|
||||||
|
if (zxing->attach_frame) {
|
||||||
|
/* create a sample from image */
|
||||||
|
diff --git a/subprojects/gst-plugins-bad/ext/zxing/meson.build b/subprojects/gst-plugins-bad/ext/zxing/meson.build
|
||||||
|
index 5992f0d9e02..2dbad9ab1ee 100644
|
||||||
|
--- a/subprojects/gst-plugins-bad/ext/zxing/meson.build
|
||||||
|
+++ b/subprojects/gst-plugins-bad/ext/zxing/meson.build
|
||||||
|
@@ -2,16 +2,17 @@ zxing_sources = [
|
||||||
|
'gstzxing.cpp',
|
||||||
|
'gstzxingplugin.c',
|
||||||
|
]
|
||||||
|
-zxing_dep = dependency('zxing', version : '>= 1.1.1', required : get_option('zxing'))
|
||||||
|
+zxing_dep = dependency('zxing', version : '>= 1.4.0', required : get_option('zxing'))
|
||||||
|
if zxing_dep.found()
|
||||||
|
gstzxing = library('gstzxing',
|
||||||
|
zxing_sources,
|
||||||
|
c_args : gst_plugins_bad_args,
|
||||||
|
+ cpp_args: '-DZX_USE_UTF8',
|
||||||
|
include_directories : [configinc],
|
||||||
|
dependencies : [gstvideo_dep, zxing_dep],
|
||||||
|
install : true,
|
||||||
|
install_dir : plugins_install_dir,
|
||||||
|
- override_options : ['cpp_std=c++11'],
|
||||||
|
+ override_options : ['cpp_std=c++17'],
|
||||||
|
)
|
||||||
|
plugins += [gstzxing]
|
||||||
|
endif
|
||||||
|
--
|
||||||
|
GitLab
|
||||||
|
|
63
gst-plugins-bad-1.20.5-zxing-cpp-2.0.0.patch
Normal file
63
gst-plugins-bad-1.20.5-zxing-cpp-2.0.0.patch
Normal file
@ -0,0 +1,63 @@
|
|||||||
|
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Antonio Rojas <arojas@archlinux.org>
|
||||||
|
Date: Sat, 7 Jan 2023 16:18:03 +0100
|
||||||
|
Subject: [PATCH] Support zxing-c++ 2.0
|
||||||
|
|
||||||
|
format is a C++ string in 2.0
|
||||||
|
---
|
||||||
|
subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp | 9 +++++++++
|
||||||
|
1 file changed, 9 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp b/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp
|
||||||
|
index 7836dbbcf18e..a8a0f7b49aa4 100644
|
||||||
|
--- a/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp
|
||||||
|
+++ b/subprojects/gst-plugins-bad/ext/zxing/gstzxing.cpp
|
||||||
|
@@ -62,6 +62,7 @@
|
||||||
|
|
||||||
|
#include "ReadBarcode.h"
|
||||||
|
#include "TextUtfEncoding.h"
|
||||||
|
+#include "ZXVersion.h"
|
||||||
|
|
||||||
|
using namespace ZXing;
|
||||||
|
|
||||||
|
@@ -369,32 +370,40 @@ gst_zxing_transform_frame_ip (GstVideoFilter * vfilter, GstVideoFrame * frame)
|
||||||
|
if (result.isValid ()) {
|
||||||
|
GST_DEBUG_OBJECT (zxing, "Symbol found. Text: %s Format: %s",
|
||||||
|
result.text ().c_str (),
|
||||||
|
+#if ZXING_VERSION_MAJOR >= 2
|
||||||
|
+ ToString (result.format ()).c_str ());
|
||||||
|
+#else
|
||||||
|
ToString (result.format ()));
|
||||||
|
+#endif
|
||||||
|
} else {
|
||||||
|
goto out;
|
||||||
|
}
|
||||||
|
|
||||||
|
/* extract results */
|
||||||
|
if (zxing->message) {
|
||||||
|
GstMessage *m;
|
||||||
|
GstStructure *s;
|
||||||
|
GstSample *sample;
|
||||||
|
GstCaps *sample_caps;
|
||||||
|
GstClockTime timestamp, running_time, stream_time;
|
||||||
|
|
||||||
|
timestamp = GST_BUFFER_TIMESTAMP (frame->buffer);
|
||||||
|
running_time =
|
||||||
|
gst_segment_to_running_time (&GST_BASE_TRANSFORM (zxing)->segment,
|
||||||
|
GST_FORMAT_TIME, timestamp);
|
||||||
|
stream_time =
|
||||||
|
gst_segment_to_stream_time (&GST_BASE_TRANSFORM (zxing)->segment,
|
||||||
|
GST_FORMAT_TIME, timestamp);
|
||||||
|
|
||||||
|
s = gst_structure_new ("barcode",
|
||||||
|
"timestamp", G_TYPE_UINT64, timestamp,
|
||||||
|
"stream-time", G_TYPE_UINT64, stream_time,
|
||||||
|
"running-time", G_TYPE_UINT64, running_time,
|
||||||
|
+#if ZXING_VERSION_MAJOR >= 2
|
||||||
|
+ "type", G_TYPE_STRING, ToString (result.format ()).c_str (),
|
||||||
|
+#else
|
||||||
|
"type", G_TYPE_STRING, ToString (result.format ()),
|
||||||
|
+#endif
|
||||||
|
"symbol", G_TYPE_STRING,
|
||||||
|
result.text ().c_str (), NULL);
|
||||||
|
|
@ -3,7 +3,7 @@
|
|||||||
|
|
||||||
Name: gst-plugins-bad
|
Name: gst-plugins-bad
|
||||||
Version: 1.20.5
|
Version: 1.20.5
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: A set of plug-ins for gstreamer that aren't up to par compared to the rest
|
Summary: A set of plug-ins for gstreamer that aren't up to par compared to the rest
|
||||||
Group: System/Multimedia
|
Group: System/Multimedia
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -12,6 +12,9 @@ Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
|||||||
URL: https://gstreamer.freedesktop.org/modules/gst-plugins-bad.html
|
URL: https://gstreamer.freedesktop.org/modules/gst-plugins-bad.html
|
||||||
Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.xz
|
Source: http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-%{version}.tar.xz
|
||||||
Patch0: %{name}-0.10.9-libx264.patch
|
Patch0: %{name}-0.10.9-libx264.patch
|
||||||
|
Patch1: gst-plugins-bad-1.20.5-opencv-4.7.patch
|
||||||
|
Patch2: gst-plugins-bad-1.20.5-zxing-cpp-1.4.patch
|
||||||
|
Patch3: gst-plugins-bad-1.20.5-zxing-cpp-2.0.0.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -76,7 +79,7 @@ BuildRequires: libxml2-devel
|
|||||||
BuildRequires: libzvbi-devel
|
BuildRequires: libzvbi-devel
|
||||||
BuildRequires: libzxing-cpp-devel
|
BuildRequires: libzxing-cpp-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
BuildRequires: libopencv-devel >= 4.5.5-1mamba
|
BuildRequires: libopencv-devel >= 0:4.7.0-1mamba
|
||||||
BuildRequires: libmjpegtools-devel >= 2.2.1
|
BuildRequires: libmjpegtools-devel >= 2.2.1
|
||||||
BuildRequires: libsrtp-devel >= 2.4.2
|
BuildRequires: libsrtp-devel >= 2.4.2
|
||||||
#BuildRequires: libmusepack-devel
|
#BuildRequires: libmusepack-devel
|
||||||
@ -129,7 +132,11 @@ This package includes the %{name} API documentation.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n gst-plugins-bad-%{version}
|
%setup -q -n gst-plugins-bad-%{version}
|
||||||
|
%define _default_patch_fuzz 2
|
||||||
#%patch0 -p1
|
#%patch0 -p1
|
||||||
|
%patch1 -p3 -b .opencv-4.7
|
||||||
|
%patch2 -p3 -b .zxing-cpp-1.4
|
||||||
|
%patch3 -p3 -b .zxing-cpp-2.0.0
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%meson
|
%meson
|
||||||
@ -176,6 +183,9 @@ This package includes the %{name} API documentation.
|
|||||||
#%{_datadir}/gtk-doc/html/gst-plugins-bad-libs-%{apiver}/*
|
#%{_datadir}/gtk-doc/html/gst-plugins-bad-libs-%{apiver}/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Jan 21 2023 Sdk Build System <sdk@mambasoft.it> 1.20.5-2mamba
|
||||||
|
- rebuilt by autoport with build requirements: libopencv-devel>=0:4.7.0-1mamba
|
||||||
|
|
||||||
* Tue Dec 20 2022 Automatic Build System <autodist@mambasoft.it> 1.20.5-1mamba
|
* Tue Dec 20 2022 Automatic Build System <autodist@mambasoft.it> 1.20.5-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user