update to 2.02_beta3
patched 10_linux to set openmamba theme colors to submenu [release 2.02_beta3-1mamba;Thu Aug 25 2016]
This commit is contained in:
parent
6319bc3460
commit
a3fa445080
@ -1,9 +1,9 @@
|
|||||||
--- grub-2.00/util/grub.d/10_linux.in.orig 2015-05-28 16:57:21.522901866 +0200
|
--- grub-2.02_beta3/util/grub.d/10_linux.in.orig 2016-08-25 21:54:04.745747726 +0200
|
||||||
+++ grub-2.00/util/grub.d/10_linux.in 2015-05-28 16:59:05.512884781 +0200
|
+++ grub-2.02_beta3/util/grub.d/10_linux.in 2016-08-25 21:58:24.552485179 +0200
|
||||||
@@ -227,8 +227,13 @@
|
@@ -225,8 +225,13 @@
|
||||||
fi
|
fi
|
||||||
|
|
||||||
if [ "x$is_first_entry" = xtrue ]; then
|
if [ "x$is_top_level" = xtrue ] && [ "x${GRUB_DISABLE_SUBMENU}" != xy ]; then
|
||||||
- linux_entry "${OS}" "${version}" simple \
|
- linux_entry "${OS}" "${version}" simple \
|
||||||
- "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
|
- "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
|
||||||
+ if [ "x${GRUB_DEFAULT_NOMODESET}" = xtrue ]; then
|
+ if [ "x${GRUB_DEFAULT_NOMODESET}" = xtrue ]; then
|
||||||
@ -32,15 +32,13 @@
|
|||||||
|
|
||||||
linux_entry "${OS} (with debug messages)" "${version}" debug \
|
linux_entry "${OS} (with debug messages)" "${version}" debug \
|
||||||
"${GRUB_CMDLINE_LINUX} debug"
|
"${GRUB_CMDLINE_LINUX} debug"
|
||||||
--- grub-2.00/util/grub-mkconfig.in.orig 2015-05-28 17:00:39.500869649 +0200
|
--- grub-2.02_beta3/util/grub-mkconfig.in.orig 2016-08-25 22:00:24.140179518 +0200
|
||||||
+++ grub-2.00/util/grub-mkconfig.in 2015-05-28 17:00:56.443866922 +0200
|
+++ grub-2.02_beta3/util/grub-mkconfig.in 2016-08-25 22:25:21.236957757 +0200
|
||||||
@@ -219,7 +219,8 @@
|
@@ -230,6 +230,7 @@
|
||||||
GRUB_INIT_TUNE \
|
|
||||||
GRUB_SAVEDEFAULT \
|
GRUB_SAVEDEFAULT \
|
||||||
GRUB_ENABLE_CRYPTODISK \
|
GRUB_ENABLE_CRYPTODISK \
|
||||||
- GRUB_BADRAM
|
GRUB_BADRAM \
|
||||||
+ GRUB_BADRAM \
|
+ GRUB_DEFAULT_NOMODESET \
|
||||||
+ GRUB_DEFAULT_NOMODESET
|
GRUB_OS_PROBER_SKIP_LIST \
|
||||||
|
GRUB_DISABLE_SUBMENU
|
||||||
|
|
||||||
if test "x${grub_cfg}" != "x"; then
|
|
||||||
rm -f "${grub_cfg}.new"
|
|
@ -1,10 +1,11 @@
|
|||||||
diff -Nru grub-2.00.orig/util/grub.d/10_linux.in grub-2.00/util/grub.d/10_linux.in
|
--- grub-2.02_beta3/util/grub.d/10_linux.in.orig 2016-08-25 21:42:17.171800345 +0200
|
||||||
--- grub-2.00.orig/util/grub.d/10_linux.in 2013-06-09 23:58:16.000000000 +0200
|
+++ grub-2.02_beta3/util/grub.d/10_linux.in 2016-08-25 21:53:04.725194113 +0200
|
||||||
+++ grub-2.00/util/grub.d/10_linux.in 2014-11-06 10:50:32.485907611 +0100
|
@@ -235,16 +235,42 @@
|
||||||
@@ -237,15 +237,40 @@
|
|
||||||
fi
|
fi
|
||||||
# TRANSLATORS: %s is replaced with an OS name
|
# TRANSLATORS: %s is replaced with an OS name
|
||||||
echo "submenu '$(gettext_printf "Advanced options for %s" "${OS}" | grub_quote)' \$menuentry_id_option 'gnulinux-advanced-$boot_device_id' {"
|
echo "submenu '$(gettext_printf "Advanced options for %s" "${OS}" | grub_quote)' \$menuentry_id_option 'gnulinux-advanced-$boot_device_id' {"
|
||||||
|
+ [ -e /etc/grub.d/05_theme_openmamba ] && . /etc/grub.d/05_theme_openmamba | grep color
|
||||||
|
is_top_level=false
|
||||||
+ else
|
+ else
|
||||||
+ linux_entry "${OS}" "${version}" default \
|
+ linux_entry "${OS}" "${version}" default \
|
||||||
+ "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
|
+ "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
|
||||||
@ -41,6 +42,6 @@ diff -Nru grub-2.00.orig/util/grub.d/10_linux.in grub-2.00/util/grub.d/10_linux.
|
|||||||
+ echo -e "\t\ttrue"
|
+ echo -e "\t\ttrue"
|
||||||
+ echo -e "\t}"
|
+ echo -e "\t}"
|
||||||
+
|
+
|
||||||
list=`echo $list | tr ' ' '\n' | grep -vx $linux | tr '\n' ' '`
|
list=`echo $list | tr ' ' '\n' | fgrep -vx "$linux" | tr '\n' ' '`
|
||||||
is_first_entry=false
|
|
||||||
done
|
done
|
||||||
|
|
25
grub.spec
25
grub.spec
@ -1,9 +1,10 @@
|
|||||||
%define majver %(echo %version| cut -d. -f1-2)
|
%define majver %(echo %version| cut -d. -f1-2)
|
||||||
|
%define pkgver %(echo %version | tr _ -)
|
||||||
#%define betaver %(echo %version| cut -d. -f3)
|
#%define betaver %(echo %version| cut -d. -f3)
|
||||||
Name: grub
|
Name: grub
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 2.00.bzr20130610
|
Version: 2.02_beta3
|
||||||
Release: 9mamba
|
Release: 1mamba
|
||||||
Summary: A Multiboot boot loader derived from GRUB, the GRand Unified Bootloader
|
Summary: A Multiboot boot loader derived from GRUB, the GRand Unified Bootloader
|
||||||
Group: System/Kernel and Hardware
|
Group: System/Kernel and Hardware
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -14,20 +15,21 @@ URL: http://www.gnu.org/software/grub/
|
|||||||
# bzr branch http://bzr.savannah.gnu.org/r/grub/trunk/grub
|
# bzr branch http://bzr.savannah.gnu.org/r/grub/trunk/grub
|
||||||
# cd grub; ./autogen.sh; ./configure; make dist
|
# cd grub; ./autogen.sh; ./configure; make dist
|
||||||
#Source: ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
|
#Source: ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.xz
|
||||||
Source: ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.gz
|
Source: git://git.savannah.gnu.org/grub.git/grub-%{pkgver}/grub-%{version}.tar.bz2
|
||||||
|
#Source: ftp://ftp.gnu.org/gnu/grub/grub-%{version}.tar.gz
|
||||||
Source1: http://unifoundry.com/unifont-5.1.20080820.bdf.gz
|
Source1: http://unifoundry.com/unifont-5.1.20080820.bdf.gz
|
||||||
Source2: %{name}2-default
|
Source2: %{name}2-default
|
||||||
Source3: grub-2.00-openmamba-conf-other
|
Source3: grub-2.00-openmamba-conf-other
|
||||||
Source4: %{name}2-sysconfig
|
Source4: %{name}2-sysconfig
|
||||||
Source5: grub-2.00-openmamba-conf-other-linux
|
Source5: grub-2.00-openmamba-conf-other-linux
|
||||||
Source6: %{name}2-conf-failsafe
|
Source6: %{name}2-conf-failsafe
|
||||||
Patch1: grub-2.00-openmamba_boot_choices-2.patch
|
Patch1: grub-2.02_beta3-openmamba_boot_choices.patch
|
||||||
Patch2: grub-2.00-stdio.patch
|
Patch2: grub-2.00-stdio.patch
|
||||||
Patch3: %{name}2-1.97-sysconfig.patch
|
Patch3: %{name}2-1.97-sysconfig.patch
|
||||||
Patch9: %{name}2-1.99-fix_saved_entry_default.patch
|
Patch9: %{name}2-1.99-fix_saved_entry_default.patch
|
||||||
Patch10: grub-2.00-flex-2.5.37.patch
|
Patch10: grub-2.00-flex-2.5.37.patch
|
||||||
Patch11: grub-2.00-gcc-4.5.patch
|
Patch11: grub-2.00-gcc-4.5.patch
|
||||||
Patch12: grub-2.00-openmamba-default-nomodeset.patch
|
Patch12: grub-2.02_beta3-openmamba-default-nomodeset.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -90,6 +92,8 @@ This package contains the efi boot files needed to boot according to EFI standar
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n grub-%{majver}
|
%setup -q -n grub-%{majver}
|
||||||
|
#-D -T
|
||||||
|
#:<< _EOF
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
#%patch2 -p1
|
#%patch2 -p1
|
||||||
%patch3 -p1
|
%patch3 -p1
|
||||||
@ -106,6 +110,8 @@ ld -v | grep "gold" && {
|
|||||||
}
|
}
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
#:<< _EOF
|
||||||
|
./autogen.sh
|
||||||
# WARNING: build requires ld.bfd; ld.gold produces not working binary
|
# WARNING: build requires ld.bfd; ld.gold produces not working binary
|
||||||
%configure \
|
%configure \
|
||||||
--with-platform="pc" \
|
--with-platform="pc" \
|
||||||
@ -207,7 +213,7 @@ chmod +x %{buildroot}%{_sbindir}/update-grub
|
|||||||
|
|
||||||
install -d -m0755 %{buildroot}/boot/efi
|
install -d -m0755 %{buildroot}/boot/efi
|
||||||
|
|
||||||
%find_lang grub
|
%find_lang grub || touch %{name}.lang
|
||||||
|
|
||||||
#rm -f %{buildroot}%{_sysconfdir}/grub.d/30_os-prober
|
#rm -f %{buildroot}%{_sysconfdir}/grub.d/30_os-prober
|
||||||
|
|
||||||
@ -287,6 +293,7 @@ fi
|
|||||||
%{_bindir}/grub-mklayout
|
%{_bindir}/grub-mklayout
|
||||||
%{_bindir}/grub-mount
|
%{_bindir}/grub-mount
|
||||||
%{_bindir}/grub-editenv
|
%{_bindir}/grub-editenv
|
||||||
|
%{_bindir}/grub-file
|
||||||
%{_bindir}/grub-fstest
|
%{_bindir}/grub-fstest
|
||||||
%{_bindir}/grub-mkfont
|
%{_bindir}/grub-mkfont
|
||||||
%{_bindir}/grub-mkimage
|
%{_bindir}/grub-mkimage
|
||||||
@ -300,8 +307,10 @@ fi
|
|||||||
%{_bindir}/grub-mount
|
%{_bindir}/grub-mount
|
||||||
%endif
|
%endif
|
||||||
%{_bindir}/grub-script-check
|
%{_bindir}/grub-script-check
|
||||||
|
%{_bindir}/grub-syslinux2cfg
|
||||||
%{_sbindir}/grub-bios-setup
|
%{_sbindir}/grub-bios-setup
|
||||||
%{_sbindir}/grub-install
|
%{_sbindir}/grub-install
|
||||||
|
%{_sbindir}/grub-macbless
|
||||||
%{_sbindir}/grub-mkconfig
|
%{_sbindir}/grub-mkconfig
|
||||||
%{_sbindir}/grub-ofpathname
|
%{_sbindir}/grub-ofpathname
|
||||||
%{_sbindir}/grub-reboot
|
%{_sbindir}/grub-reboot
|
||||||
@ -359,6 +368,10 @@ fi
|
|||||||
%{_prefix}/lib/grub/x86_64-efi/*
|
%{_prefix}/lib/grub/x86_64-efi/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 25 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.02_beta3-1mamba
|
||||||
|
- update to 2.02_beta3
|
||||||
|
- patched 10_linux to set openmamba theme colors to submenu
|
||||||
|
|
||||||
* Thu May 28 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.00.bzr20130610-9mamba
|
* Thu May 28 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.00.bzr20130610-9mamba
|
||||||
- patched to support GRUB_DEFAULT_NOMODESET allowing nomodeset choice as first choice
|
- patched to support GRUB_DEFAULT_NOMODESET allowing nomodeset choice as first choice
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user