patched to support GRUB_DEFAULT_NOMODESET allowing nomodeset choice as first choice [release 2.00.bzr20130610-9mamba;Thu May 28 2015]
This commit is contained in:
parent
30bfd8cc3c
commit
6319bc3460
46
grub-2.00-openmamba-default-nomodeset.patch
Normal file
46
grub-2.00-openmamba-default-nomodeset.patch
Normal file
@ -0,0 +1,46 @@
|
||||
--- grub-2.00/util/grub.d/10_linux.in.orig 2015-05-28 16:57:21.522901866 +0200
|
||||
+++ grub-2.00/util/grub.d/10_linux.in 2015-05-28 16:59:05.512884781 +0200
|
||||
@@ -227,8 +227,13 @@
|
||||
fi
|
||||
|
||||
if [ "x$is_first_entry" = xtrue ]; then
|
||||
- linux_entry "${OS}" "${version}" simple \
|
||||
- "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
|
||||
+ if [ "x${GRUB_DEFAULT_NOMODESET}" = xtrue ]; then
|
||||
+ linux_entry "${OS} (proprietary video driver)" "${version}" nomodeset \
|
||||
+ "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT} nomodeset"
|
||||
+ else
|
||||
+ linux_entry "${OS}" "${version}" simple \
|
||||
+ "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
|
||||
+ fi
|
||||
|
||||
submenu_indentation="$grub_tab"
|
||||
|
||||
@@ -242,8 +247,13 @@
|
||||
"${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
|
||||
fi
|
||||
|
||||
- linux_entry "${OS} (proprietary video driver)" "${version}" nomodeset \
|
||||
- "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT} nomodeset"
|
||||
+ if [ "x${GRUB_DEFAULT_NOMODESET}" = xtrue ]; then
|
||||
+ linux_entry "${OS}" "${version}" simple \
|
||||
+ "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT}"
|
||||
+ else
|
||||
+ linux_entry "${OS} (proprietary video driver)" "${version}" nomodeset \
|
||||
+ "${GRUB_CMDLINE_LINUX} ${GRUB_CMDLINE_LINUX_DEFAULT} nomodeset"
|
||||
+ fi
|
||||
|
||||
linux_entry "${OS} (with debug messages)" "${version}" debug \
|
||||
"${GRUB_CMDLINE_LINUX} debug"
|
||||
--- grub-2.00/util/grub-mkconfig.in.orig 2015-05-28 17:00:39.500869649 +0200
|
||||
+++ grub-2.00/util/grub-mkconfig.in 2015-05-28 17:00:56.443866922 +0200
|
||||
@@ -219,7 +219,8 @@
|
||||
GRUB_INIT_TUNE \
|
||||
GRUB_SAVEDEFAULT \
|
||||
GRUB_ENABLE_CRYPTODISK \
|
||||
- GRUB_BADRAM
|
||||
+ GRUB_BADRAM \
|
||||
+ GRUB_DEFAULT_NOMODESET
|
||||
|
||||
if test "x${grub_cfg}" != "x"; then
|
||||
rm -f "${grub_cfg}.new"
|
13
grub.spec
13
grub.spec
@ -3,7 +3,7 @@
|
||||
Name: grub
|
||||
Epoch: 1
|
||||
Version: 2.00.bzr20130610
|
||||
Release: 8mamba
|
||||
Release: 9mamba
|
||||
Summary: A Multiboot boot loader derived from GRUB, the GRand Unified Bootloader
|
||||
Group: System/Kernel and Hardware
|
||||
Vendor: openmamba
|
||||
@ -27,6 +27,7 @@ Patch3: %{name}2-1.97-sysconfig.patch
|
||||
Patch9: %{name}2-1.99-fix_saved_entry_default.patch
|
||||
Patch10: grub-2.00-flex-2.5.37.patch
|
||||
Patch11: grub-2.00-gcc-4.5.patch
|
||||
Patch12: grub-2.00-openmamba-default-nomodeset.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -95,6 +96,7 @@ This package contains the efi boot files needed to boot according to EFI standar
|
||||
%patch9 -p1
|
||||
#%patch10 -p0
|
||||
#%patch11 -p1
|
||||
%patch12 -p1
|
||||
gunzip -c %{SOURCE1} > unifont.bdf
|
||||
|
||||
# ld.gold has problems with -Wl-Ttext=xxx and produces not working binaries
|
||||
@ -147,7 +149,7 @@ export EFI_ARCH=i586-openmamba-linux-gnu
|
||||
./configure --prefix=%{_prefix} --sysconfdir=%{_sysconfdir} --libdir=%{_prefix}/lib \
|
||||
--with-platform=efi --target=${EFI_ARCH}
|
||||
#--host=%{_host_arch} TARGET_CC="%{_host}-gcc"
|
||||
make -j1 CFLAGS="%{optflags} -Os -m32" LDFLAGS_PLATFORM="-m32"
|
||||
make -j1 CFLAGS="-Wno-error %{optflags} -Os -m32" LDFLAGS_PLATFORM="-m32"
|
||||
ARCHOUT=i386-efi
|
||||
install -d %{buildroot}%{_prefix}/lib/grub/${ARCHOUT}
|
||||
cp grub-core/{*.mod,*.lst,*.img,*.sh,*.lst} %{buildroot}%{_libdir}/grub/${ARCHOUT}/
|
||||
@ -162,7 +164,7 @@ rm -f *.d
|
||||
export EFI_ARCH=x86_64-openmamba-linux-gnu
|
||||
./configure --prefix=%{_prefix} --sysconfdir=%{_sysconfdir} --libdir=%{_prefix}/lib \
|
||||
--with-platform=efi --target=${EFI_ARCH}
|
||||
make -j1 CFLAGS=
|
||||
make -j1 CFLAGS="-Wno-error"
|
||||
ARCHOUT=x86_64-efi
|
||||
install -d %{buildroot}%{_prefix}/lib/grub/${ARCHOUT}
|
||||
cp grub-core/{*.mod,*.lst,*.img,*.sh,*.lst} %{buildroot}%{_prefix}/lib/grub/${ARCHOUT}/
|
||||
@ -178,7 +180,7 @@ rm -f *.d
|
||||
export EFI_ARCH=x86_64-openmamba-linux-gnu
|
||||
./configure --prefix=%{_prefix} --sysconfdir=%{_sysconfdir} --libdir=%{_prefix}/lib \
|
||||
--with-platform=efi
|
||||
make -j1 CFLAGS=
|
||||
make -j1 CFLAGS="-Wno-error"
|
||||
ARCHOUT=x86_64-efi
|
||||
install -d %{buildroot}%{_prefix}/lib/grub/${ARCHOUT}
|
||||
cp grub-core/{*.mod,*.lst,*.img,*.sh,*.lst} %{buildroot}%{_prefix}/lib/grub/${ARCHOUT}/
|
||||
@ -357,6 +359,9 @@ fi
|
||||
%{_prefix}/lib/grub/x86_64-efi/*
|
||||
|
||||
%changelog
|
||||
* Thu May 28 2015 Silvan Calarco <silvan.calarco@mambasoft.it> 2.00.bzr20130610-9mamba
|
||||
- patched to support GRUB_DEFAULT_NOMODESET allowing nomodeset choice as first choice
|
||||
|
||||
* Thu Nov 06 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 2.00.bzr20130610-8mamba
|
||||
- add default selection in advanced boot menu for when multiple kernels are installed
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user