automatic version update by autodist [release 3.9-1mamba;Wed May 08 2013]
This commit is contained in:
parent
6ae1718715
commit
8db574e68f
@ -1,2 +1,6 @@
|
||||
# gpsd
|
||||
|
||||
gpsd is a service daemon that monitors one or more GPSes attached to a host computer through serial or USB ports, making all data on the location/course/velocity of the sensors available to be queried on TCP port 2947 of the host computer. With gpsd, multiple GPS client applications (such as navigational and wardriving software) can share access to GPSes without contention or loss of data. Also, gpsd responds to queries with a format that is substantially easier to parse than the NMEA 0183 emitted by most GPSes. The gpsd distribution includes a linkable C service library, a C++ wrapper class, and a Python module that developers of gpsd-aware applications can use to encapsulate all communication with gpsd.
|
||||
Besides gpsd itself, the project provides auxiliary tools for diagnostic monitoring and profiling of GPSes and feeding GPS-aware applications specified track data for diagnostic purposes.
|
||||
The goal of the gpsd project is to create a solid layer of open-source infrastructure for programs running under Linux and other open-source Unixes that want to be location-sensitive. We aim for simple, robust interfaces, unfussy operation, and an easy learning curve for application developers. Applications that presently use gpsd include pyGPS, Kismet, GPSdrive, gpeGPS, position, roadmap, roadnav, navit, viking, and gaia.
|
||||
|
||||
|
17
gpsd-3.7-rpath.patch
Normal file
17
gpsd-3.7-rpath.patch
Normal file
@ -0,0 +1,17 @@
|
||||
don't set the -rpath/-L flags to the install dir as this breaks DESTDIR
|
||||
|
||||
--- a/SConstruct
|
||||
+++ b/SConstruct
|
||||
@@ -268,11 +268,7 @@
|
||||
return wrapped
|
||||
|
||||
# Honor the specified installation prefix in link paths.
|
||||
-if not env["sysroot"]:
|
||||
- env.Prepend(LIBPATH=[installdir('libdir')])
|
||||
-else:
|
||||
- env.Prepend(LIBPATH=[env["sysroot"] + installdir('libdir')])
|
||||
-if env["shared"]:
|
||||
+if env["shared"] and env["chrpath"]:
|
||||
env.Prepend(RPATH=[installdir('libdir')])
|
||||
|
||||
# Give deheader a way to set compiler flags
|
181
gpsd.spec
Normal file
181
gpsd.spec
Normal file
@ -0,0 +1,181 @@
|
||||
Name: gpsd
|
||||
Version: 3.9
|
||||
Release: 1mamba
|
||||
Summary: A service daemon that monitors one or more GPSes attached to a host computer
|
||||
Group: Graphical Desktop/Applications/Utilities
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://gpsd.berlios.de
|
||||
Source: http://download-mirror.savannah.gnu.org/releases/gpsd/gpsd-%{version}.tar.gz
|
||||
Patch0: gpsd-3.7-rpath.patch
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libexpat-devel
|
||||
BuildRequires: libfontconfig-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libncurses-devel
|
||||
BuildRequires: libpython-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
%if "%{stage1}" != "1"
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: liblesstif-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXau-devel
|
||||
BuildRequires: libXaw-devel
|
||||
BuildRequires: libxcb-devel
|
||||
BuildRequires: libXdmcp-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libXft-devel
|
||||
BuildRequires: libXp-devel
|
||||
BuildRequires: libXrender-devel
|
||||
BuildRequires: libXt-devel
|
||||
%endif
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
License: GPL
|
||||
Requires: libgps = %{?epoch:%epoch:}%{version}-%{release}
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
gpsd is a service daemon that monitors one or more GPSes attached to a host computer through serial or USB ports, making all data on the location/course/velocity of the sensors available to be queried on TCP port 2947 of the host computer. With gpsd, multiple GPS client applications (such as navigational and wardriving software) can share access to GPSes without contention or loss of data. Also, gpsd responds to queries with a format that is substantially easier to parse than the NMEA 0183 emitted by most GPSes. The gpsd distribution includes a linkable C service library, a C++ wrapper class, and a Python module that developers of gpsd-aware applications can use to encapsulate all communication with gpsd.
|
||||
Besides gpsd itself, the project provides auxiliary tools for diagnostic monitoring and profiling of GPSes and feeding GPS-aware applications specified track data for diagnostic purposes.
|
||||
The goal of the gpsd project is to create a solid layer of open-source infrastructure for programs running under Linux and other open-source Unixes that want to be location-sensitive. We aim for simple, robust interfaces, unfussy operation, and an easy learning curve for application developers. Applications that presently use gpsd include pyGPS, Kismet, GPSdrive, gpeGPS, position, roadmap, roadnav, navit, viking, and gaia.
|
||||
|
||||
%package -n libgps
|
||||
Summary: GPS libraries provided by %{name}
|
||||
Group: System/Libraries
|
||||
|
||||
%description -n libgps
|
||||
gpsd is a service daemon that monitors one or more GPSes attached to a host computer through serial or USB ports, making all data on the location/course/velocity of the sensors available to be queried on TCP port 2947 of the host computer. With gpsd, multiple GPS client applications (such as navigational and wardriving software) can share access to GPSes without contention or loss of data. Also, gpsd responds to queries with a format that is substantially easier to parse than the NMEA 0183 emitted by most GPSes. The gpsd distribution includes a linkable C service library, a C++ wrapper class, and a Python module that developers of gpsd-aware applications can use to encapsulate all communication with gpsd.
|
||||
This package contains the QT binding library for libgps.
|
||||
|
||||
%package -n libgps-devel
|
||||
Summary: Devel package for libgps
|
||||
Group: Development/Libraries
|
||||
Requires: libgps = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Provides: %{name}-devel
|
||||
Obsoletes: %{name}-devel
|
||||
|
||||
%description -n libgps-devel
|
||||
gpsd is a service daemon that monitors one or more GPSes attached to a host computer through serial or USB ports, making all data on the location/course/velocity of the sensors available to be queried on TCP port 2947 of the host computer. With gpsd, multiple GPS client applications (such as navigational and wardriving software) can share access to GPSes without contention or loss of data. Also, gpsd responds to queries with a format that is substantially easier to parse than the NMEA 0183 emitted by most GPSes. The gpsd distribution includes a linkable C service library, a C++ wrapper class, and a Python module that developers of gpsd-aware applications can use to encapsulate all communication with gpsd.
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%package -n libgps-qt
|
||||
Summary: QT binding for libgps
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libgps-qt
|
||||
gpsd is a service daemon that monitors one or more GPSes attached to a host computer through serial or USB ports, making all data on the location/course/velocity of the sensors available to be queried on TCP port 2947 of the host computer. With gpsd, multiple GPS client applications (such as navigational and wardriving software) can share access to GPSes without contention or loss of data. Also, gpsd responds to queries with a format that is substantially easier to parse than the NMEA 0183 emitted by most GPSes. The gpsd distribution includes a linkable C service library, a C++ wrapper class, and a Python module that developers of gpsd-aware applications can use to encapsulate all communication with gpsd.
|
||||
This package contains the QT binding library for libgps.
|
||||
|
||||
%package -n libgps-qt-devel
|
||||
Summary: Development package for libgps-qt
|
||||
Group: Development/Libraries
|
||||
Requires: libgps-devel = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Requires: libgps-qt = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n libgps-qt-devel
|
||||
gpsd is a service daemon that monitors one or more GPSes attached to a host computer through serial or USB ports, making all data on the location/course/velocity of the sensors available to be queried on TCP port 2947 of the host computer. With gpsd, multiple GPS client applications (such as navigational and wardriving software) can share access to GPSes without contention or loss of data. Also, gpsd responds to queries with a format that is substantially easier to parse than the NMEA 0183 emitted by most GPSes. The gpsd distribution includes a linkable C service library, a C++ wrapper class, and a Python module that developers of gpsd-aware applications can use to encapsulate all communication with gpsd.
|
||||
This package contains the QT binding library for libgps.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
scons prefix=%{_prefix} libdir=%{_lib}
|
||||
|
||||
#% configure
|
||||
#%if "%{_build}" != "%{_host}"
|
||||
#sed -i "s|-I%{_includedir}|-I%{_prefix}/%{_host}/include|" Makefile
|
||||
#%endif
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
export DESTDIR=%{buildroot}
|
||||
scons install prefix=%{_prefix} libdir=%{_lib}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/*
|
||||
%{_sbindir}/gpsd
|
||||
%{_sbindir}/gpsdctl
|
||||
%if "%{_build}" == "%{_host}"
|
||||
%{python_sitearch}/gps*
|
||||
%else
|
||||
%exclude %{python_sitearch}/gps*
|
||||
%endif
|
||||
%{_mandir}/man1/*
|
||||
%{_mandir}/man8/*
|
||||
|
||||
%files -n libgps
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libgps.so.*
|
||||
%{_libdir}/libgpsd.so.*
|
||||
|
||||
%files -n libgps-devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/*.h
|
||||
#%{_libdir}/libgps.a
|
||||
#%{_libdir}/libgps.la
|
||||
%{_libdir}/libgps.so
|
||||
#%{_libdir}/libgpsd.a
|
||||
#%{_libdir}/libgpsd.la
|
||||
%{_libdir}/libgpsd.so
|
||||
%{_libdir}/pkgconfig/libgps.pc
|
||||
%{_libdir}/pkgconfig/libgpsd.pc
|
||||
%{_mandir}/man3/*
|
||||
%{_mandir}/man5/*
|
||||
|
||||
%files -n libgps-qt
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libQgpsmm.so.*
|
||||
|
||||
%files -n libgps-qt-devel
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libQgpsmm.so
|
||||
%{_libdir}/libQgpsmm.prl
|
||||
%{_libdir}/pkgconfig/Qgpsmm.pc
|
||||
|
||||
%changelog
|
||||
* Wed May 08 2013 Automatic Build System <autodist@mambasoft.it> 3.9-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Apr 30 2013 Automatic Build System <autodist@mambasoft.it> 3.8-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Aug 10 2012 Automatic Build System <autodist@mambasoft.it> 3.7-1mamba
|
||||
- update to 3.7
|
||||
|
||||
* Fri Aug 10 2012 Automatic Build System <autodist@mambasoft.it> 3.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Mar 27 2011 Automatic Build System <autodist@mambasoft.it> 2.96-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Oct 11 2010 Automatic Build System <autodist@mambasoft.it> 2.95-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Apr 30 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.94-1mamba
|
||||
- update to 2.94
|
||||
|
||||
* Wed Jan 13 2010 Automatic Build System <autodist@mambasoft.it> 2.90-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon May 18 2009 Automatic Build System <autodist@mambasoft.it> 2.39-2mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Thu Apr 16 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.39-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Mar 05 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.38-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Jan 07 2009 Silvan Calarco <silvan.calarco@mambasoft.it> 2.37-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user