automatic version update by autodist [release 13.7-1mamba;Fri Jul 05 2024]
This commit is contained in:
parent
a41c0843a3
commit
81c30d04e5
@ -1,14 +0,0 @@
|
|||||||
--- FreeFileSync-13.6/libcurl/curl_wrap.cpp.orig 2024-06-01 12:44:04.908233411 +0200
|
|
||||||
+++ FreeFileSync-13.6/libcurl/curl_wrap.cpp 2024-06-01 12:46:58.101643783 +0200
|
|
||||||
@@ -402,9 +402,10 @@
|
|
||||||
ZEN_CHECK_CASE_FOR_CONSTANT(CURLE_SSL_CLIENTCERT);
|
|
||||||
ZEN_CHECK_CASE_FOR_CONSTANT(CURLE_UNRECOVERABLE_POLL);
|
|
||||||
ZEN_CHECK_CASE_FOR_CONSTANT(CURLE_TOO_LARGE);
|
|
||||||
+ ZEN_CHECK_CASE_FOR_CONSTANT(CURLE_ECH_REQUIRED);
|
|
||||||
ZEN_CHECK_CASE_FOR_CONSTANT(CURL_LAST);
|
|
||||||
}
|
|
||||||
- static_assert(CURL_LAST == CURLE_TOO_LARGE + 1);
|
|
||||||
+ //static_assert(CURL_LAST == CURLE_TOO_LARGE + 1);
|
|
||||||
|
|
||||||
return replaceCpy<std::wstring>(L"Curl status %x", L"%x", numberTo<std::wstring>(static_cast<int>(sc)));
|
|
||||||
}
|
|
@ -1,6 +1,6 @@
|
|||||||
Name: freefilesync
|
Name: freefilesync
|
||||||
Version: 13.6
|
Version: 13.7
|
||||||
Release: 2mamba
|
Release: 1mamba
|
||||||
Summary: A software that helps you synchronize files and synchronize folders
|
Summary: A software that helps you synchronize files and synchronize folders
|
||||||
Group: Graphical Desktop/Applications/Utilities
|
Group: Graphical Desktop/Applications/Utilities
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -12,7 +12,6 @@ Source1: freefilesync.desktop
|
|||||||
Source2: ffsicon.png
|
Source2: ffsicon.png
|
||||||
Source3: realtimesync.desktop
|
Source3: realtimesync.desktop
|
||||||
Source4: rtsicon.png
|
Source4: rtsicon.png
|
||||||
Patch0: freefilesync-13.6-curl-8.8.0.patch
|
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
@ -48,7 +47,6 @@ sed -i 's| -s | |' FreeFileSync/Source/{Makefile,RealTimeSync/Makefile}
|
|||||||
sed -i 's|#error|//#error|' FreeFileSync/Source/{application.cpp,RealTimeSync/application.cpp} zen/{string_tools.h,globals.h}
|
sed -i 's|#error|//#error|' FreeFileSync/Source/{application.cpp,RealTimeSync/application.cpp} zen/{string_tools.h,globals.h}
|
||||||
sed -i 's|::g_object_ref|g_object_ref|' FreeFileSync/Source/base/icon_loader.cpp
|
sed -i 's|::g_object_ref|g_object_ref|' FreeFileSync/Source/base/icon_loader.cpp
|
||||||
sed -i '/animalImg/s/^/\/\//' FreeFileSync/Source/ui/small_dlgs.cpp
|
sed -i '/animalImg/s/^/\/\//' FreeFileSync/Source/ui/small_dlgs.cpp
|
||||||
%patch 0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
export CXXFLAGS="%{optflags} -DMAX_SFTP_READ_SIZE=30000 -DMAX_SFTP_OUTGOING_SIZE=30000"
|
export CXXFLAGS="%{optflags} -DMAX_SFTP_READ_SIZE=30000 -DMAX_SFTP_OUTGOING_SIZE=30000"
|
||||||
@ -89,6 +87,9 @@ install -Dm644 %{SOURCE3} %{buildroot}%{_datadir}/applications/RealTimeSync.desk
|
|||||||
%doc License.txt
|
%doc License.txt
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Jul 05 2024 Automatic Build System <autodist@openmamba.org> 13.7-1mamba
|
||||||
|
- automatic version update by autodist
|
||||||
|
|
||||||
* Sat Jun 01 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 13.6-2mamba
|
* Sat Jun 01 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 13.6-2mamba
|
||||||
- remove arch to exe names to fix symlinks in bindir
|
- remove arch to exe names to fix symlinks in bindir
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user