remove arch to exe names to fix symlinks in bindir [release 13.6-2mamba;Sat Jun 01 2024]
This commit is contained in:
parent
d85e30a99f
commit
a41c0843a3
14
freefilesync-13.6-curl-8.8.0.patch
Normal file
14
freefilesync-13.6-curl-8.8.0.patch
Normal file
@ -0,0 +1,14 @@
|
||||
--- FreeFileSync-13.6/libcurl/curl_wrap.cpp.orig 2024-06-01 12:44:04.908233411 +0200
|
||||
+++ FreeFileSync-13.6/libcurl/curl_wrap.cpp 2024-06-01 12:46:58.101643783 +0200
|
||||
@@ -402,9 +402,10 @@
|
||||
ZEN_CHECK_CASE_FOR_CONSTANT(CURLE_SSL_CLIENTCERT);
|
||||
ZEN_CHECK_CASE_FOR_CONSTANT(CURLE_UNRECOVERABLE_POLL);
|
||||
ZEN_CHECK_CASE_FOR_CONSTANT(CURLE_TOO_LARGE);
|
||||
+ ZEN_CHECK_CASE_FOR_CONSTANT(CURLE_ECH_REQUIRED);
|
||||
ZEN_CHECK_CASE_FOR_CONSTANT(CURL_LAST);
|
||||
}
|
||||
- static_assert(CURL_LAST == CURLE_TOO_LARGE + 1);
|
||||
+ //static_assert(CURL_LAST == CURLE_TOO_LARGE + 1);
|
||||
|
||||
return replaceCpy<std::wstring>(L"Curl status %x", L"%x", numberTo<std::wstring>(static_cast<int>(sc)));
|
||||
}
|
@ -2,7 +2,7 @@
|
||||
Comment=
|
||||
Exec=FreeFileSync
|
||||
GenericName=Folder Comparison and Synchronization
|
||||
Icon=/usr/share/pixmaps/ffsicon.png
|
||||
Icon=/usr/share/pixmaps/FreeFileSync.png
|
||||
Name=FreeFileSync
|
||||
NoDisplay=false
|
||||
StartupNotify=true
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: freefilesync
|
||||
Version: 13.6
|
||||
Release: 1mamba
|
||||
Release: 2mamba
|
||||
Summary: A software that helps you synchronize files and synchronize folders
|
||||
Group: Graphical Desktop/Applications/Utilities
|
||||
Vendor: openmamba
|
||||
@ -12,6 +12,7 @@ Source1: freefilesync.desktop
|
||||
Source2: ffsicon.png
|
||||
Source3: realtimesync.desktop
|
||||
Source4: rtsicon.png
|
||||
Patch0: freefilesync-13.6-curl-8.8.0.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -46,13 +47,15 @@ sed -i 's|-2|-3|' FreeFileSync/Source/{Makefile,RealTimeSync/Makefile}
|
||||
sed -i 's| -s | |' FreeFileSync/Source/{Makefile,RealTimeSync/Makefile}
|
||||
sed -i 's|#error|//#error|' FreeFileSync/Source/{application.cpp,RealTimeSync/application.cpp} zen/{string_tools.h,globals.h}
|
||||
sed -i 's|::g_object_ref|g_object_ref|' FreeFileSync/Source/base/icon_loader.cpp
|
||||
sed -i '/animalImg/s/^/\/\//' FreeFileSync/Source/ui/small_dlgs.cpp
|
||||
%patch 0 -p1
|
||||
|
||||
%build
|
||||
export CXXFLAGS="%{optflags} -DMAX_SFTP_READ_SIZE=30000 -DMAX_SFTP_OUTGOING_SIZE=30000"
|
||||
export LDFLAGS="%{optflags} `pkg-config --libs gtk+-3.0` -lz"
|
||||
|
||||
%make -C FreeFileSync/Source
|
||||
%make -C FreeFileSync/Source/RealTimeSync
|
||||
%make -C FreeFileSync/Source exeName=FreeFileSync
|
||||
%make -C FreeFileSync/Source/RealTimeSync exeName=RealTimeSync
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -86,6 +89,9 @@ install -Dm644 %{SOURCE3} %{buildroot}%{_datadir}/applications/RealTimeSync.desk
|
||||
%doc License.txt
|
||||
|
||||
%changelog
|
||||
* Sat Jun 01 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 13.6-2mamba
|
||||
- remove arch to exe names to fix symlinks in bindir
|
||||
|
||||
* Mon May 13 2024 Automatic Build System <autodist@openmamba.org> 13.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
|
@ -1,9 +1,9 @@
|
||||
[Desktop Entry]
|
||||
Comment=
|
||||
Exec=RealtimeSync
|
||||
Exec=RealTimeSync
|
||||
GenericName=Automated Synchronization
|
||||
Icon=/usr/share/pixmaps/rtsicon.png
|
||||
Name=RealtimeSync
|
||||
Icon=/usr/share/pixmaps/RealTimeSync.png
|
||||
Name=RealTimeSync
|
||||
NoDisplay=false
|
||||
StartupNotify=true
|
||||
Categories=GTK;Application;Utility;
|
||||
|
Loading…
Reference in New Issue
Block a user