automatic version update by autodist [release 1.13.0-1mamba;Sun Dec 29 2024]
This commit is contained in:
parent
d7628101e3
commit
b34b520c01
@ -1,115 +0,0 @@
|
||||
From 567aca983f70b01103271e431bc71a13ac79213c Mon Sep 17 00:00:00 2001
|
||||
From: Alfred Wingate <parona@protonmail.com>
|
||||
Date: Fri, 9 Aug 2024 03:00:05 +0300
|
||||
Subject: [PATCH] Adjust to libfmt-11 changes
|
||||
|
||||
Bug: https://bugs.gentoo.org/937599
|
||||
See-Also: https://github.com/fmtlib/fmt/commit/d70729215fba1d54862e407b626abf86ddf409bf
|
||||
Signed-off-by: Alfred Wingate <parona@protonmail.com>
|
||||
---
|
||||
src/trace.h | 22 +++++++++++-----------
|
||||
1 file changed, 11 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/src/trace.h b/src/trace.h
|
||||
index 13a816650d7..8062e0b19ef 100644
|
||||
--- a/src/trace.h
|
||||
+++ b/src/trace.h
|
||||
@@ -156,7 +156,7 @@ namespace fmt { template<typename T> struct formatter {}; }
|
||||
//! adds support for formatting QCString
|
||||
template<> struct fmt::formatter<QCString> : formatter<std::string>
|
||||
{
|
||||
- auto format(const QCString &c, format_context& ctx) {
|
||||
+ auto format(const QCString &c, format_context& ctx) const {
|
||||
return formatter<std::string>::format(c.str(), ctx);
|
||||
}
|
||||
};
|
||||
@@ -164,7 +164,7 @@ template<> struct fmt::formatter<QCString> : formatter<std::string>
|
||||
//! adds support for formatting Protected
|
||||
template<> struct fmt::formatter<Protection> : formatter<std::string>
|
||||
{
|
||||
- auto format(Protection prot, format_context& ctx) {
|
||||
+ auto format(Protection prot, format_context& ctx) const {
|
||||
std::string result="Unknown";
|
||||
switch (prot)
|
||||
{
|
||||
@@ -180,7 +180,7 @@ template<> struct fmt::formatter<Protection> : formatter<std::string>
|
||||
//! adds support for formatting Specifier
|
||||
template<> struct fmt::formatter<Specifier> : formatter<std::string>
|
||||
{
|
||||
- auto format(Specifier spec, format_context& ctx) {
|
||||
+ auto format(Specifier spec, format_context& ctx) const {
|
||||
std::string result="Unknown";
|
||||
switch (spec)
|
||||
{
|
||||
@@ -195,7 +195,7 @@ template<> struct fmt::formatter<Specifier> : formatter<std::string>
|
||||
//! adds support for formatting MethodTypes
|
||||
template<> struct fmt::formatter<MethodTypes> : formatter<std::string>
|
||||
{
|
||||
- auto format(MethodTypes mtype, format_context& ctx) {
|
||||
+ auto format(MethodTypes mtype, format_context& ctx) const {
|
||||
std::string result="Unknown";
|
||||
switch (mtype)
|
||||
{
|
||||
@@ -213,7 +213,7 @@ template<> struct fmt::formatter<MethodTypes> : formatter<std::string>
|
||||
//! adds support for formatting RelatesType
|
||||
template<> struct fmt::formatter<RelatesType> : formatter<std::string>
|
||||
{
|
||||
- auto format(RelatesType type, format_context& ctx) {
|
||||
+ auto format(RelatesType type, format_context& ctx) const {
|
||||
std::string result="Unknown";
|
||||
switch (type)
|
||||
{
|
||||
@@ -228,7 +228,7 @@ template<> struct fmt::formatter<RelatesType> : formatter<std::string>
|
||||
//! adds support for formatting RelationShip
|
||||
template<> struct fmt::formatter<Relationship> : formatter<std::string>
|
||||
{
|
||||
- auto format(Relationship relation, format_context& ctx) {
|
||||
+ auto format(Relationship relation, format_context& ctx) const {
|
||||
std::string result="Unknown";
|
||||
switch (relation)
|
||||
{
|
||||
@@ -243,7 +243,7 @@ template<> struct fmt::formatter<Relationship> : formatter<std::string>
|
||||
//! adds support for formatting SrcLangExt
|
||||
template<> struct fmt::formatter<SrcLangExt> : formatter<std::string>
|
||||
{
|
||||
- auto format(SrcLangExt lang, format_context& ctx) {
|
||||
+ auto format(SrcLangExt lang, format_context& ctx) const {
|
||||
std::string result="Unknown";
|
||||
switch (lang)
|
||||
{
|
||||
@@ -273,7 +273,7 @@ template<> struct fmt::formatter<SrcLangExt> : formatter<std::string>
|
||||
//! adds support for formatting MemberType
|
||||
template<> struct fmt::formatter<MemberType> : formatter<std::string>
|
||||
{
|
||||
- auto format(MemberType mtype, format_context& ctx) {
|
||||
+ auto format(MemberType mtype, format_context& ctx) const {
|
||||
std::string result="Unknown";
|
||||
switch (mtype)
|
||||
{
|
||||
@@ -301,7 +301,7 @@ template<> struct fmt::formatter<MemberType> : formatter<std::string>
|
||||
//! adds support for formatting TypeSpecifier
|
||||
template<> struct fmt::formatter<TypeSpecifier> : formatter<std::string>
|
||||
{
|
||||
- auto format(TypeSpecifier type, format_context& ctx) {
|
||||
+ auto format(TypeSpecifier type, format_context& ctx) const {
|
||||
return formatter<std::string>::format(type.to_string(),ctx);
|
||||
}
|
||||
};
|
||||
@@ -309,7 +309,7 @@ template<> struct fmt::formatter<TypeSpecifier> : formatter<std::string>
|
||||
//! adds support for formatting EntryType
|
||||
template<> struct fmt::formatter<EntryType> : formatter<std::string>
|
||||
{
|
||||
- auto format(EntryType type, format_context& ctx) {
|
||||
+ auto format(EntryType type, format_context& ctx) const {
|
||||
return formatter<std::string>::format(type.to_string(),ctx);
|
||||
}
|
||||
};
|
||||
@@ -317,7 +317,7 @@ template<> struct fmt::formatter<EntryType> : formatter<std::string>
|
||||
//! adds support for formatting MemberListType
|
||||
template<> struct fmt::formatter<MemberListType> : formatter<std::string>
|
||||
{
|
||||
- auto format(MemberListType type, format_context& ctx) {
|
||||
+ auto format(MemberListType type, format_context& ctx) const {
|
||||
return formatter<std::string>::format(type.to_string(),ctx);
|
||||
}
|
||||
};
|
11
doxygen.spec
11
doxygen.spec
@ -7,8 +7,8 @@
|
||||
%define pck_docdir %{_datadir}/doc/doxygen-%{version}
|
||||
|
||||
Name: doxygen
|
||||
Version: 1.12.0
|
||||
Release: 3mamba
|
||||
Version: 1.13.0
|
||||
Release: 1mamba
|
||||
Summary: A documentation system for C, C++, Java, IDL, Objective-C, PHP, C# and D
|
||||
Group: Applications/Development
|
||||
Vendor: openmamba
|
||||
@ -16,7 +16,6 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.doxygen.nl/index.html
|
||||
Source: https://doxygen.nl/files/doxygen-%{version}.src.tar.gz
|
||||
Patch0: doxygen-1.12.0-libfmt-11.0.2.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -76,11 +75,8 @@ Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
Doxygen is a documentation system for C++, C, Java, IDL (Corba and Microsoft flavors) and to some extent PHP and C#.
|
||||
This package contains the documentation in HTML format and PDF format.
|
||||
|
||||
%debug_package
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch 0 -p1 -b .libfmt-11.0.2
|
||||
|
||||
%build
|
||||
%cmake -d build \
|
||||
@ -144,6 +140,9 @@ find examples -type f | xargs chmod -x
|
||||
%doc LANGUAGE.HOWTO examples
|
||||
|
||||
%changelog
|
||||
* Sun Dec 29 2024 Automatic Build System <autodist@openmamba.org> 1.13.0-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Dec 24 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12.0-3mamba
|
||||
- ensure build against system spdlog 1.15.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user