ensure build against system spdlog 1.15.0 [release 1.12.0-3mamba;Tue Dec 24 2024]
This commit is contained in:
parent
bb4b35c572
commit
d7628101e3
115
doxygen-1.12.0-libfmt-11.0.2.patch
Normal file
115
doxygen-1.12.0-libfmt-11.0.2.patch
Normal file
@ -0,0 +1,115 @@
|
||||
From 567aca983f70b01103271e431bc71a13ac79213c Mon Sep 17 00:00:00 2001
|
||||
From: Alfred Wingate <parona@protonmail.com>
|
||||
Date: Fri, 9 Aug 2024 03:00:05 +0300
|
||||
Subject: [PATCH] Adjust to libfmt-11 changes
|
||||
|
||||
Bug: https://bugs.gentoo.org/937599
|
||||
See-Also: https://github.com/fmtlib/fmt/commit/d70729215fba1d54862e407b626abf86ddf409bf
|
||||
Signed-off-by: Alfred Wingate <parona@protonmail.com>
|
||||
---
|
||||
src/trace.h | 22 +++++++++++-----------
|
||||
1 file changed, 11 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/src/trace.h b/src/trace.h
|
||||
index 13a816650d7..8062e0b19ef 100644
|
||||
--- a/src/trace.h
|
||||
+++ b/src/trace.h
|
||||
@@ -156,7 +156,7 @@ namespace fmt { template<typename T> struct formatter {}; }
|
||||
//! adds support for formatting QCString
|
||||
template<> struct fmt::formatter<QCString> : formatter<std::string>
|
||||
{
|
||||
- auto format(const QCString &c, format_context& ctx) {
|
||||
+ auto format(const QCString &c, format_context& ctx) const {
|
||||
return formatter<std::string>::format(c.str(), ctx);
|
||||
}
|
||||
};
|
||||
@@ -164,7 +164,7 @@ template<> struct fmt::formatter<QCString> : formatter<std::string>
|
||||
//! adds support for formatting Protected
|
||||
template<> struct fmt::formatter<Protection> : formatter<std::string>
|
||||
{
|
||||
- auto format(Protection prot, format_context& ctx) {
|
||||
+ auto format(Protection prot, format_context& ctx) const {
|
||||
std::string result="Unknown";
|
||||
switch (prot)
|
||||
{
|
||||
@@ -180,7 +180,7 @@ template<> struct fmt::formatter<Protection> : formatter<std::string>
|
||||
//! adds support for formatting Specifier
|
||||
template<> struct fmt::formatter<Specifier> : formatter<std::string>
|
||||
{
|
||||
- auto format(Specifier spec, format_context& ctx) {
|
||||
+ auto format(Specifier spec, format_context& ctx) const {
|
||||
std::string result="Unknown";
|
||||
switch (spec)
|
||||
{
|
||||
@@ -195,7 +195,7 @@ template<> struct fmt::formatter<Specifier> : formatter<std::string>
|
||||
//! adds support for formatting MethodTypes
|
||||
template<> struct fmt::formatter<MethodTypes> : formatter<std::string>
|
||||
{
|
||||
- auto format(MethodTypes mtype, format_context& ctx) {
|
||||
+ auto format(MethodTypes mtype, format_context& ctx) const {
|
||||
std::string result="Unknown";
|
||||
switch (mtype)
|
||||
{
|
||||
@@ -213,7 +213,7 @@ template<> struct fmt::formatter<MethodTypes> : formatter<std::string>
|
||||
//! adds support for formatting RelatesType
|
||||
template<> struct fmt::formatter<RelatesType> : formatter<std::string>
|
||||
{
|
||||
- auto format(RelatesType type, format_context& ctx) {
|
||||
+ auto format(RelatesType type, format_context& ctx) const {
|
||||
std::string result="Unknown";
|
||||
switch (type)
|
||||
{
|
||||
@@ -228,7 +228,7 @@ template<> struct fmt::formatter<RelatesType> : formatter<std::string>
|
||||
//! adds support for formatting RelationShip
|
||||
template<> struct fmt::formatter<Relationship> : formatter<std::string>
|
||||
{
|
||||
- auto format(Relationship relation, format_context& ctx) {
|
||||
+ auto format(Relationship relation, format_context& ctx) const {
|
||||
std::string result="Unknown";
|
||||
switch (relation)
|
||||
{
|
||||
@@ -243,7 +243,7 @@ template<> struct fmt::formatter<Relationship> : formatter<std::string>
|
||||
//! adds support for formatting SrcLangExt
|
||||
template<> struct fmt::formatter<SrcLangExt> : formatter<std::string>
|
||||
{
|
||||
- auto format(SrcLangExt lang, format_context& ctx) {
|
||||
+ auto format(SrcLangExt lang, format_context& ctx) const {
|
||||
std::string result="Unknown";
|
||||
switch (lang)
|
||||
{
|
||||
@@ -273,7 +273,7 @@ template<> struct fmt::formatter<SrcLangExt> : formatter<std::string>
|
||||
//! adds support for formatting MemberType
|
||||
template<> struct fmt::formatter<MemberType> : formatter<std::string>
|
||||
{
|
||||
- auto format(MemberType mtype, format_context& ctx) {
|
||||
+ auto format(MemberType mtype, format_context& ctx) const {
|
||||
std::string result="Unknown";
|
||||
switch (mtype)
|
||||
{
|
||||
@@ -301,7 +301,7 @@ template<> struct fmt::formatter<MemberType> : formatter<std::string>
|
||||
//! adds support for formatting TypeSpecifier
|
||||
template<> struct fmt::formatter<TypeSpecifier> : formatter<std::string>
|
||||
{
|
||||
- auto format(TypeSpecifier type, format_context& ctx) {
|
||||
+ auto format(TypeSpecifier type, format_context& ctx) const {
|
||||
return formatter<std::string>::format(type.to_string(),ctx);
|
||||
}
|
||||
};
|
||||
@@ -309,7 +309,7 @@ template<> struct fmt::formatter<TypeSpecifier> : formatter<std::string>
|
||||
//! adds support for formatting EntryType
|
||||
template<> struct fmt::formatter<EntryType> : formatter<std::string>
|
||||
{
|
||||
- auto format(EntryType type, format_context& ctx) {
|
||||
+ auto format(EntryType type, format_context& ctx) const {
|
||||
return formatter<std::string>::format(type.to_string(),ctx);
|
||||
}
|
||||
};
|
||||
@@ -317,7 +317,7 @@ template<> struct fmt::formatter<EntryType> : formatter<std::string>
|
||||
//! adds support for formatting MemberListType
|
||||
template<> struct fmt::formatter<MemberListType> : formatter<std::string>
|
||||
{
|
||||
- auto format(MemberListType type, format_context& ctx) {
|
||||
+ auto format(MemberListType type, format_context& ctx) const {
|
||||
return formatter<std::string>::format(type.to_string(),ctx);
|
||||
}
|
||||
};
|
@ -1,61 +0,0 @@
|
||||
diff -up doxygen-1.6.2/src/configoptions.cpp.timestamp doxygen-1.6.2/src/configoptions.cpp
|
||||
--- doxygen-1.6.2/src/configoptions.cpp.timestamp 2009-12-28 11:39:11.000000000 +0100
|
||||
+++ doxygen-1.6.2/src/configoptions.cpp 2010-01-04 11:58:33.000000000 +0100
|
||||
@@ -1088,6 +1088,14 @@ void addConfigOptions(Config *cfg)
|
||||
cs->setWidgetType(ConfigString::File);
|
||||
cs->addDependency("GENERATE_HTML");
|
||||
//----
|
||||
+ cb = cfg->addBool(
|
||||
+ "HTML_TIMESTAMP",
|
||||
+ "If the HTML_TIMESTAMP tag is set to YES then the generated HTML\n"
|
||||
+ "documentation will contain the timesstamp.",
|
||||
+ FALSE
|
||||
+ );
|
||||
+ cb->addDependency("GENERATE_HTML");
|
||||
+ //----
|
||||
cs = cfg->addString(
|
||||
"HTML_STYLESHEET",
|
||||
"The HTML_STYLESHEET tag can be used to specify a user-defined cascading\n"
|
||||
diff -up doxygen-1.6.2/src/config.xml.timestamp doxygen-1.6.2/src/config.xml
|
||||
--- doxygen-1.6.2/src/config.xml.timestamp 2009-12-28 11:38:55.000000000 +0100
|
||||
+++ doxygen-1.6.2/src/config.xml 2010-01-04 11:58:33.000000000 +0100
|
||||
@@ -761,6 +761,10 @@ The HTML_FOOTER tag can be used to speci
|
||||
each generated HTML page. If it is left blank doxygen will generate a
|
||||
standard footer.
|
||||
' defval='' depends='GENERATE_HTML'/>
|
||||
+ <option type='bool' id='HTML_TIMESTAMP' docs='
|
||||
+If the HTML_TIMESTAMP tag is set to YES then the generated HTML
|
||||
+documentation will contain the timesstamp.
|
||||
+' defval='' depends='GENERATE_HTML'/>
|
||||
<option type='string' id='HTML_STYLESHEET' format='file' docs='
|
||||
The HTML_STYLESHEET tag can be used to specify a user-defined cascading
|
||||
style sheet that is used by each HTML page. It can be used to
|
||||
diff -up doxygen-1.6.2/src/htmlgen.cpp.timestamp doxygen-1.6.2/src/htmlgen.cpp
|
||||
--- doxygen-1.6.2/src/htmlgen.cpp.timestamp 2009-12-21 11:24:22.000000000 +0100
|
||||
+++ doxygen-1.6.2/src/htmlgen.cpp 2010-01-04 12:04:31.000000000 +0100
|
||||
@@ -54,6 +54,7 @@ static const char search_script[]=
|
||||
|
||||
static QCString g_header;
|
||||
static QCString g_footer;
|
||||
+static bool timestamp=false;
|
||||
|
||||
//------------------------- Pictures for the Tabs ------------------------
|
||||
|
||||
@@ -693,6 +694,8 @@ void HtmlGenerator::init()
|
||||
if (!Config_getString("HTML_FOOTER").isEmpty())
|
||||
{
|
||||
g_footer=fileToString(Config_getString("HTML_FOOTER"));
|
||||
+ if (Config_getBool("HTML_TIMESTAMP"))
|
||||
+ timestamp=true;
|
||||
//printf("g_footer='%s'\n",g_footer.data());
|
||||
}
|
||||
createSubDirs(d);
|
||||
@@ -932,7 +935,7 @@ static void writePageFooter(QTextStream
|
||||
if (timeStamp)
|
||||
{
|
||||
t << theTranslator->trGeneratedAt(
|
||||
- dateToString(TRUE),
|
||||
+ dateToString(timestamp),
|
||||
Config_getString("PROJECT_NAME")
|
||||
);
|
||||
}
|
@ -1,95 +0,0 @@
|
||||
diff -up doxygen-1.7.1/addon/doxywizard/Makefile.in.config doxygen-1.7.1/addon/doxywizard/Makefile.in
|
||||
--- doxygen-1.7.1/addon/doxywizard/Makefile.in.config 2010-05-23 16:51:31.000000000 +0200
|
||||
+++ doxygen-1.7.1/addon/doxywizard/Makefile.in 2010-07-19 13:38:33.000000000 +0200
|
||||
@@ -10,8 +10,6 @@
|
||||
# See the GNU General Public License for more details.
|
||||
#
|
||||
|
||||
-QMAKE=qmake $(MKSPECS)
|
||||
-
|
||||
all: Makefile.doxywizard
|
||||
$(MAKE) -f Makefile.doxywizard
|
||||
|
||||
@@ -29,11 +27,11 @@ distclean: Makefile.doxywizard
|
||||
$(RM) Makefile.doxywizard
|
||||
|
||||
install:
|
||||
- $(INSTTOOL) -d $(INSTALL)/bin
|
||||
- $(INSTTOOL) -m 755 ../../bin/doxywizard $(INSTALL)/bin
|
||||
- $(INSTTOOL) -d $(INSTALL)/$(MAN1DIR)
|
||||
+ $(INSTTOOL) -d $(DESTDIR)$(INSTALL)/bin
|
||||
+ $(INSTTOOL) -m 755 ../../bin/doxywizard $(DESTDIR)$(INSTALL)/bin
|
||||
+ $(INSTTOOL) -d $(DESTDIR)$(INSTALL)/$(MAN1DIR)
|
||||
cat ../../doc/doxywizard.1 | sed -e "s/DATE/$(DATE)/g" -e "s/VERSION/$(VERSION)/g" > doxywizard.1
|
||||
- $(INSTTOOL) -m 644 doxywizard.1 $(INSTALL)/$(MAN1DIR)/doxywizard.1
|
||||
+ $(INSTTOOL) -m 644 doxywizard.1 $(DESTDIR)$(INSTALL)/$(MAN1DIR)/doxywizard.1
|
||||
rm doxywizard.1
|
||||
|
||||
FORCE:
|
||||
diff -up doxygen-1.7.1/configure.config doxygen-1.7.1/configure
|
||||
--- doxygen-1.7.1/configure.config 2010-06-25 11:46:38.000000000 +0200
|
||||
+++ doxygen-1.7.1/configure 2010-07-19 12:03:53.000000000 +0200
|
||||
@@ -268,9 +268,10 @@ if test "$f_wizard" = YES; then
|
||||
if test -z "$QTDIR"; then
|
||||
echo " QTDIR environment variable not set!"
|
||||
echo -n " Checking for Qt..."
|
||||
- for d in /usr/{lib,share,qt}/{qt-4,qt4,qt,qt*,4} /usr; do
|
||||
+ for d in /usr/{lib64,lib,share,qt}/{qt-4,qt4,qt,qt*,4} /usr; do
|
||||
if test -x "$d/bin/qmake"; then
|
||||
QTDIR=$d
|
||||
+ QMAKE=$d/bin/qmake
|
||||
fi
|
||||
done
|
||||
else
|
||||
@@ -485,6 +486,8 @@ INSTTOOL = $f_insttool
|
||||
DOXYDOCS = ..
|
||||
DOCDIR = $f_docdir
|
||||
QTDIR = $QTDIR
|
||||
+QMAKE = $QMAKE
|
||||
+MAN1DIR = share/man/man1
|
||||
EOF
|
||||
|
||||
if test "$f_dot" != NO; then
|
||||
diff -up doxygen-1.7.1/Makefile.in.config doxygen-1.7.1/Makefile.in
|
||||
--- doxygen-1.7.1/Makefile.in.config 2009-08-20 21:41:13.000000000 +0200
|
||||
+++ doxygen-1.7.1/Makefile.in 2010-07-19 12:03:53.000000000 +0200
|
||||
@@ -44,8 +44,6 @@ distclean: clean
|
||||
|
||||
DATE=$(shell date "+%B %Y")
|
||||
|
||||
-MAN1DIR = man/man1
|
||||
-
|
||||
install: doxywizard_install
|
||||
$(INSTTOOL) -d $(DESTDIR)/$(INSTALL)/bin
|
||||
$(INSTTOOL) -m 755 bin/doxygen $(DESTDIR)/$(INSTALL)/bin
|
||||
diff -up doxygen-1.7.1/tmake/lib/linux-g++/tmake.conf.config doxygen-1.7.1/tmake/lib/linux-g++/tmake.conf
|
||||
--- doxygen-1.7.1/tmake/lib/linux-g++/tmake.conf.config 2008-12-06 14:16:20.000000000 +0100
|
||||
+++ doxygen-1.7.1/tmake/lib/linux-g++/tmake.conf 2010-07-19 12:03:53.000000000 +0200
|
||||
@@ -11,7 +11,7 @@ TMAKE_CC = gcc
|
||||
TMAKE_CFLAGS = -pipe
|
||||
TMAKE_CFLAGS_WARN_ON = -Wall -W -fno-exceptions
|
||||
TMAKE_CFLAGS_WARN_OFF =
|
||||
-TMAKE_CFLAGS_RELEASE = -O2
|
||||
+TMAKE_CFLAGS_RELEASE = $(RPM_OPT_FLAGS)
|
||||
TMAKE_CFLAGS_DEBUG = -g
|
||||
TMAKE_CFLAGS_SHLIB = -fPIC
|
||||
TMAKE_CFLAGS_YACC = -Wno-unused -Wno-parentheses
|
||||
@@ -27,12 +27,12 @@ TMAKE_CXXFLAGS_YACC = $$TMAKE_CFLAGS_YAC
|
||||
|
||||
TMAKE_INCDIR =
|
||||
TMAKE_LIBDIR =
|
||||
-TMAKE_INCDIR_X11 = /usr/X11R6/include
|
||||
-TMAKE_LIBDIR_X11 = /usr/X11R6/lib
|
||||
-TMAKE_INCDIR_QT = $(QTDIR)/include
|
||||
-TMAKE_LIBDIR_QT = $(QTDIR)/lib
|
||||
-TMAKE_INCDIR_OPENGL = /usr/X11R6/include
|
||||
-TMAKE_LIBDIR_OPENGL = /usr/X11R6/lib
|
||||
+TMAKE_INCDIR_X11 =
|
||||
+TMAKE_LIBDIR_X11 =
|
||||
+TMAKE_INCDIR_QT =
|
||||
+TMAKE_LIBDIR_QT =
|
||||
+TMAKE_INCDIR_OPENGL =
|
||||
+TMAKE_LIBDIR_OPENGL =
|
||||
|
||||
TMAKE_LINK = g++
|
||||
TMAKE_LINK_SHLIB = g++
|
@ -1,16 +0,0 @@
|
||||
diff -Nru doxygen-1.7.2.orig//src/latexgen.cpp doxygen-1.7.2/src/latexgen.cpp
|
||||
--- doxygen-1.7.2.orig//src/latexgen.cpp 2010-09-19 10:31:14.000000000 +0200
|
||||
+++ doxygen-1.7.2/src/latexgen.cpp 2010-12-11 18:41:58.506293348 +0100
|
||||
@@ -328,10 +328,10 @@
|
||||
"\\RequirePackage{sectsty}\n"
|
||||
"\\RequirePackage{tocloft}\n"
|
||||
"\\allsectionsfont{\\usefont{OT1}{phv}{bc}{n}\\selectfont}\n"
|
||||
- "\\renewcommand{\\cftchapfont}{%\n"
|
||||
+ "\\newcommand{\\cftchapfont}{%\n"
|
||||
" \\fontsize{11}{13}\\usefont{OT1}{phv}{bc}{n}\\selectfont\n"
|
||||
"}\n"
|
||||
- "\\renewcommand{\\cftchappagefont}{%\n"
|
||||
+ "\\newcommand{\\cftchappagefont}{%\n"
|
||||
" \\fontsize{11}{13}\\usefont{OT1}{phv}{c}{n}\\selectfont\n"
|
||||
"}\n"
|
||||
"\\renewcommand{\\cftsecfont}{%\n"
|
@ -1,104 +0,0 @@
|
||||
From cf936efb8ae99dd297b6afb9c6a06beb81f5b0fb Mon Sep 17 00:00:00 2001
|
||||
From: Heiko Becker <heirecka@exherbo.org>
|
||||
Date: Thu, 19 Nov 2015 12:00:54 +0100
|
||||
Subject: [PATCH] Support flex-2.6.0
|
||||
|
||||
The version checks only considered YY_FLEX_SUBMINOR_VERSION and did not
|
||||
take YY_FLEX_MINOR_VERSION into account, which made them fail with
|
||||
flex-2.6.0.
|
||||
---
|
||||
src/code.l | 2 +-
|
||||
src/commentscan.l | 4 ++--
|
||||
src/fortrancode.l | 2 +-
|
||||
src/pycode.l | 2 +-
|
||||
src/vhdlcode.l | 2 +-
|
||||
src/xmlcode.l | 2 +-
|
||||
6 files changed, 7 insertions(+), 7 deletions(-)
|
||||
|
||||
diff --git a/src/code.l b/src/code.l
|
||||
index 3323580..25719af 100644
|
||||
--- a/src/code.l
|
||||
+++ b/src/code.l
|
||||
@@ -3700,7 +3700,7 @@ void codeFreeScanner()
|
||||
extern "C" { // some bogus code to keep the compiler happy
|
||||
void codeYYdummy() { yy_flex_realloc(0,0); }
|
||||
}
|
||||
-#elif YY_FLEX_SUBMINOR_VERSION<33
|
||||
+#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
|
||||
#error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
|
||||
#endif
|
||||
|
||||
diff --git a/src/commentscan.l b/src/commentscan.l
|
||||
index cf892a0..2629857 100644
|
||||
--- a/src/commentscan.l
|
||||
+++ b/src/commentscan.l
|
||||
@@ -1128,7 +1128,7 @@ RCSTAG "$"{ID}":"[^\n$]+"$"
|
||||
// but we need to know the position in the input buffer where this
|
||||
// rule matched.
|
||||
// for flex 2.5.33+ we should use YY_CURRENT_BUFFER_LVALUE
|
||||
-#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
|
||||
+#if YY_FLEX_MINOR_VERSION>5 || YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
|
||||
inputPosition=prevPosition + (int)(yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf);
|
||||
#else
|
||||
inputPosition=prevPosition + (int)(yy_bp - yy_current_buffer->yy_ch_buf);
|
||||
@@ -1190,7 +1190,7 @@ RCSTAG "$"{ID}":"[^\n$]+"$"
|
||||
g_memberGroupHeader.resize(0);
|
||||
parseMore=TRUE;
|
||||
needNewEntry = TRUE;
|
||||
-#if YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
|
||||
+#if YY_FLEX_MINOR_VERSION>5 || YY_FLEX_MINOR_VERSION>=5 && YY_FLEX_SUBMINOR_VERSION>=33
|
||||
inputPosition=prevPosition + (int)(yy_bp - YY_CURRENT_BUFFER_LVALUE->yy_ch_buf) + strlen(yytext);
|
||||
#else
|
||||
inputPosition=prevPosition + (int)(yy_bp - yy_current_buffer->yy_ch_buf) + strlen(yytext);
|
||||
diff --git a/src/fortrancode.l b/src/fortrancode.l
|
||||
index fb91a83..352912b 100644
|
||||
--- a/src/fortrancode.l
|
||||
+++ b/src/fortrancode.l
|
||||
@@ -1306,7 +1306,7 @@ void parseFortranCode(CodeOutputInterface &od,const char *className,const QCStri
|
||||
extern "C" { // some bogus code to keep the compiler happy
|
||||
void fortrancodeYYdummy() { yy_flex_realloc(0,0); }
|
||||
}
|
||||
-#elif YY_FLEX_SUBMINOR_VERSION<33
|
||||
+#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
|
||||
#error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
|
||||
#else
|
||||
extern "C" { // some bogus code to keep the compiler happy
|
||||
diff --git a/src/pycode.l b/src/pycode.l
|
||||
index 3c41a69..f58f7c1 100644
|
||||
--- a/src/pycode.l
|
||||
+++ b/src/pycode.l
|
||||
@@ -1503,7 +1503,7 @@ void parsePythonCode(CodeOutputInterface &od,const char * /*className*/,
|
||||
extern "C" { // some bogus code to keep the compiler happy
|
||||
void pycodeYYdummy() { yy_flex_realloc(0,0); }
|
||||
}
|
||||
-#elif YY_FLEX_SUBMINOR_VERSION<33
|
||||
+#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
|
||||
#error "You seem to be using a version of flex newer than 2.5.4. These are currently incompatible with 2.5.4, and do NOT work with doxygen! Please use version 2.5.4 or expect things to be parsed wrongly! A bug report has been submitted (#732132)."
|
||||
#endif
|
||||
|
||||
diff --git a/src/vhdlcode.l b/src/vhdlcode.l
|
||||
index 369ae48..6957048 100644
|
||||
--- a/src/vhdlcode.l
|
||||
+++ b/src/vhdlcode.l
|
||||
@@ -1613,7 +1613,7 @@ void codeFreeVhdlScanner()
|
||||
extern "C" { // some bogus code to keep the compiler happy
|
||||
void vhdlcodeYYdummy() { yy_flex_realloc(0,0); }
|
||||
}
|
||||
-#elif YY_FLEX_SUBMINOR_VERSION<33
|
||||
+#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
|
||||
#error "You seem to be using a version of flex newer than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen! Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"
|
||||
#endif
|
||||
|
||||
diff --git a/src/xmlcode.l b/src/xmlcode.l
|
||||
index 15b5d7e..2bef4a0 100644
|
||||
--- a/src/xmlcode.l
|
||||
+++ b/src/xmlcode.l
|
||||
@@ -407,7 +407,7 @@ void resetXmlCodeParserState()
|
||||
extern "C" { // some bogus code to keep the compiler happy
|
||||
void xmlcodeYYdummy() { yy_flex_realloc(0,0); }
|
||||
}
|
||||
-#elif YY_FLEX_SUBMINOR_VERSION<33
|
||||
+#elif YY_FLEX_MINOR_VERSION<6 && YY_FLEX_SUBMINOR_VERSION<33
|
||||
#error "You seem to be using a version of flex newer than 2.5.4. These are currently incompatible with 2.5.4, and do NOT work with doxygen! Please use version 2.5.4 or expect things to be parsed wrongly! A bug report has been submitted (#732132)."
|
||||
#endif
|
||||
|
@ -1,51 +0,0 @@
|
||||
From 9468ede259153cf79eb8d61635389744e9a2ee7d Mon Sep 17 00:00:00 2001
|
||||
From: Dimitri van Heesch <dimitri@stack.nl>
|
||||
Date: Sun, 29 Oct 2017 11:47:48 +0100
|
||||
Subject: [PATCH] Bug 789168 - Increasing access of inherited C++ members with
|
||||
'using...' is not recognized by Doxygen
|
||||
|
||||
---
|
||||
src/doxygen.cpp | 9 ++++-----
|
||||
1 file changed, 4 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/src/doxygen.cpp b/src/doxygen.cpp
|
||||
index d3554cffd..ec97d4354 100644
|
||||
--- a/src/doxygen.cpp
|
||||
+++ b/src/doxygen.cpp
|
||||
@@ -2112,9 +2112,8 @@ static void findUsingDeclImports(EntryNav *rootNav)
|
||||
(rootNav->parent()->section()&Entry::COMPOUND_MASK) // in a class/struct member
|
||||
)
|
||||
{
|
||||
- //printf("Found using declaration %s at line %d of %s inside section %x\n",
|
||||
- // root->name.data(),root->startLine,root->fileName.data(),
|
||||
- // root->parent->section);
|
||||
+ //printf("Found using declaration %s inside section %x\n",
|
||||
+ // rootNav->name().data(), rootNav->parent()->section());
|
||||
QCString fullName=removeRedundantWhiteSpace(rootNav->parent()->name());
|
||||
fullName=stripAnonymousNamespaceScope(fullName);
|
||||
fullName=stripTemplateSpecifiersFromScope(fullName);
|
||||
@@ -2130,7 +2129,7 @@ static void findUsingDeclImports(EntryNav *rootNav)
|
||||
ClassDef *bcd = getResolvedClass(cd,0,scope); // todo: file in fileScope parameter
|
||||
if (bcd)
|
||||
{
|
||||
- //printf("found class %s\n",bcd->name().data());
|
||||
+ //printf("found class %s memName=%s\n",bcd->name().data(),memName.data());
|
||||
MemberNameInfoSDict *mndict=bcd->memberNameInfoSDict();
|
||||
if (mndict)
|
||||
{
|
||||
@@ -11181,7 +11180,6 @@ void parseInput()
|
||||
g_s.end();
|
||||
|
||||
g_s.begin("Searching for members imported via using declarations...\n");
|
||||
- findUsingDeclImports(rootNav);
|
||||
// this should be after buildTypedefList in order to properly import
|
||||
// used typedefs
|
||||
findUsingDeclarations(rootNav);
|
||||
@@ -11249,6 +11247,7 @@ void parseInput()
|
||||
g_s.begin("Searching for member function documentation...\n");
|
||||
findObjCMethodDefinitions(rootNav);
|
||||
findMemberDocumentation(rootNav); // may introduce new members !
|
||||
+ findUsingDeclImports(rootNav); // may introduce new members !
|
||||
|
||||
transferRelatedFunctionDocumentation();
|
||||
transferFunctionDocumentation();
|
@ -1,48 +0,0 @@
|
||||
From 4a72a9b07e805b4ba27560e8e921bcee0002ef4c Mon Sep 17 00:00:00 2001
|
||||
From: albert-github <albert.tests@gmail.com>
|
||||
Date: Mon, 9 Sep 2019 13:28:28 +0200
|
||||
Subject: [PATCH] issue #7248: Including external tag files with TOC produces a
|
||||
broken index.qhp
|
||||
|
||||
Ignore automatically generated anchor names when importing a tag file.
|
||||
---
|
||||
src/tagreader.cpp | 19 ++++++++++++++++++-
|
||||
1 file changed, 18 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/tagreader.cpp b/src/tagreader.cpp
|
||||
index 56dbe7df9..d79d9b5c5 100644
|
||||
--- a/src/tagreader.cpp
|
||||
+++ b/src/tagreader.cpp
|
||||
@@ -494,6 +494,23 @@ class TagFileParser : public QXmlDefaultHandler
|
||||
|
||||
void endDocAnchor()
|
||||
{
|
||||
+ // Check whether or not the tag is automatically generate, in that case ignore the tag.
|
||||
+ switch(m_state)
|
||||
+ {
|
||||
+ case InClass:
|
||||
+ case InFile:
|
||||
+ case InNamespace:
|
||||
+ case InGroup:
|
||||
+ case InPage:
|
||||
+ case InMember:
|
||||
+ case InPackage:
|
||||
+ case InDir:
|
||||
+ if (QString(m_curString).startsWith("autotoc_md")) return;
|
||||
+ break;
|
||||
+ default:
|
||||
+ warn("Unexpected tag 'docanchor' found");
|
||||
+ return;
|
||||
+ }
|
||||
switch(m_state)
|
||||
{
|
||||
case InClass: m_curClass->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
|
||||
@@ -504,7 +521,7 @@ class TagFileParser : public QXmlDefaultHandler
|
||||
case InMember: m_curMember->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
|
||||
case InPackage: m_curPackage->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
|
||||
case InDir: m_curDir->docAnchors.append(new TagAnchorInfo(m_fileName,m_curString,m_title)); break;
|
||||
- default: warn("Unexpected tag 'docanchor' found"); break;
|
||||
+ default: warn("Unexpected tag 'docanchor' found"); break; // Not really necessary anymore
|
||||
}
|
||||
}
|
||||
|
33
doxygen.spec
33
doxygen.spec
@ -8,7 +8,7 @@
|
||||
|
||||
Name: doxygen
|
||||
Version: 1.12.0
|
||||
Release: 2mamba
|
||||
Release: 3mamba
|
||||
Summary: A documentation system for C, C++, Java, IDL, Objective-C, PHP, C# and D
|
||||
Group: Applications/Development
|
||||
Vendor: openmamba
|
||||
@ -16,12 +16,7 @@ Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.doxygen.nl/index.html
|
||||
Source: https://doxygen.nl/files/doxygen-%{version}.src.tar.gz
|
||||
Patch1: doxygen-1.7.1-config.patch
|
||||
Patch2: doxygen-1.6.2-timestamp.patch
|
||||
Patch3: doxygen-1.7.2-fix_cftchapfont.patch
|
||||
Patch4: doxygen-1.8.10-flex-2.6.patch
|
||||
Patch5: doxygen-1.8.14-upstream-bug-789168-segfault.patch
|
||||
Patch6: doxygen-1.8.16-compat.patch
|
||||
Patch0: doxygen-1.12.0-libfmt-11.0.2.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -29,7 +24,10 @@ BuildRequires: libQt5Core
|
||||
BuildRequires: libQt5Gui
|
||||
BuildRequires: libQt5Widgets
|
||||
BuildRequires: libQt5Xml
|
||||
BuildRequires: libclang-devel
|
||||
BuildRequires: libfmt-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libllvm-devel
|
||||
BuildRequires: libspdlog-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libxapian-devel
|
||||
@ -82,25 +80,22 @@ This package contains the documentation in HTML format and PDF format.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch4 -p1
|
||||
#%patch5 -R -p1
|
||||
#%patch6 -p1
|
||||
%patch 0 -p1 -b .libfmt-11.0.2
|
||||
|
||||
%build
|
||||
# FIXME: % cmake macro fails
|
||||
%cmake -d build \
|
||||
-DPYTHON_EXECUTABLE=%{__python27} \
|
||||
-DDOC_INSTALL_DIR:PATH=share/doc/doxygen \
|
||||
%if %{with_qt_wiz}
|
||||
-Dbuild_wizard=ON \
|
||||
%endif
|
||||
-Dbuild_doc=ON \
|
||||
-Dbuild_wizard:BOOL=ON \
|
||||
-Duse_sqlite3=ON \
|
||||
-Duse_sys_spdlog=ON \
|
||||
-Dbuild_search=ON \
|
||||
-Duse_libclang:BOOL=ON \
|
||||
..
|
||||
|
||||
# -Duse_libclang=ON \
|
||||
|
||||
%make
|
||||
make docs
|
||||
|
||||
@ -110,11 +105,6 @@ make docs
|
||||
%{expand:%%define MAN1DIR %(echo %_mandir/man1 | sed "s,%{_prefix}/,,")}
|
||||
%makeinstall -C build
|
||||
|
||||
# install_docs \
|
||||
# INSTALL=%{buildroot}%{_prefix} \
|
||||
# MAN1DIR=%{MAN1DIR} \
|
||||
# DOCDIR=%{buildroot}%{pck_docdir}
|
||||
|
||||
iconv --from=ISO-8859-1 --to=UTF-8 LANGUAGE.HOWTO > LANGUAGE.HOWTO.new
|
||||
touch -r LANGUAGE.HOWTO LANGUAGE.HOWTO.new
|
||||
mv LANGUAGE.HOWTO.new LANGUAGE.HOWTO
|
||||
@ -124,8 +114,6 @@ find %{buildroot}%{pck_docdir}/ -name Makefile\* | xargs rm -f
|
||||
|
||||
find examples -type f | xargs chmod -x
|
||||
|
||||
#sed -i -e "s|#!perl|#! /usr/bin/perl|" examples/tag/html/installdox
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
@ -156,6 +144,9 @@ find examples -type f | xargs chmod -x
|
||||
%doc LANGUAGE.HOWTO examples
|
||||
|
||||
%changelog
|
||||
* Tue Dec 24 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 1.12.0-3mamba
|
||||
- ensure build against system spdlog 1.15.0
|
||||
|
||||
* Sun Dec 22 2024 Automatic Build System <autodist@openmamba.org> 1.12.0-2mamba
|
||||
- rebuilt by autoport with build requirements: libspdlog-devel>=0:1.15.0-1mamba
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user