reapply patch to skip modules with sources removed and cleanup old broken modules in posttrans [release 2.4.0-2mamba;Sun Jun 18 2017]
This commit is contained in:
parent
6af0a857bf
commit
492d3f204a
@ -1,20 +1,15 @@
|
||||
diff -ru dkms-2.3/dkms dkms-2.3.patched/dkms
|
||||
--- dkms-2.3/dkms 2016-12-17 17:42:56.000000000 +0100
|
||||
+++ dkms-2.3.patched/dkms 2016-12-17 17:47:06.448995920 +0100
|
||||
@@ -512,8 +512,11 @@
|
||||
[[ $conf ]] && read_conf_file="$conf"
|
||||
--- dkms-2.4.0/dkms.orig 2017-06-18 16:14:10.760200880 +0200
|
||||
+++ dkms-2.4.0/dkms 2017-06-18 16:17:02.255901350 +0200
|
||||
@@ -515,7 +515,7 @@
|
||||
[[ $3 ]] && read_conf_file="$3"
|
||||
|
||||
+ [[ ! -r $read_conf_file && -r $dkms_tree/$module/$module_version/build/dkms.conf ]] && \
|
||||
+ read_conf_file="$dkms_tree/$module/$module_version/build/dkms.conf"
|
||||
+
|
||||
[[ -r $read_conf_file ]] || die 4 $"Could not locate dkms.conf file." \
|
||||
- $"File: $conf does not exist."
|
||||
+ $"File: $read_conf_file does not exist."
|
||||
|
||||
[[ $last_mvka = $module/$module_version/$1/$2 && \
|
||||
$last_mvka_conf = $(readlink -f $read_conf_file) ]] && return
|
||||
@@ -1550,6 +1553,7 @@
|
||||
@@ -1558,6 +1558,7 @@
|
||||
is_module_added() {
|
||||
[[ $1 && $2 ]] || return 1
|
||||
[[ -d $dkms_tree/$1/$2 ]] || return 2
|
20
dkms.spec
20
dkms.spec
@ -1,16 +1,16 @@
|
||||
Name: dkms
|
||||
Version: 2.3
|
||||
Release: 1mamba
|
||||
Version: 2.4.0
|
||||
Release: 2mamba
|
||||
Summary: Dynamic Kernel Module Support
|
||||
Group: System/Tools
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Ercole 'ercolinux' Carpanetto <ercole69@gmail.com>
|
||||
URL: http://linux.dell.com/projects.shtml#dkms
|
||||
Source: https://github.com/dell/dkms.git/%{version}/dkms-%{version}.tar.bz2
|
||||
Source: https://github.com/dell/dkms.git/v%{version}/dkms-%{version}.tar.bz2
|
||||
Source1: dkms.service
|
||||
Source2: dkms.systemd
|
||||
Patch0: dkms-2.3-dont_fail_if_module_source_removed.patch
|
||||
Patch0: dkms-2.4.0-dont_fail_if_module_source_removed.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
## AUTOBUILDREQ-END
|
||||
@ -23,7 +23,7 @@ DKMS stands for Dynamic Kernel Module Support. It is designed to create a framew
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
|
||||
@ -63,7 +63,9 @@ fi
|
||||
|
||||
%posttrans
|
||||
# clean old sysv broken links
|
||||
find /etc/rc[0-6].d/ -type l -xtype l -exec rm -f {} \;
|
||||
find /etc/rc[0-6].d/ -type l -xtype l -exec rm -f {} \;
|
||||
# clean old badly uninstalled modules
|
||||
find /var/lib/dkms/*/*/source -xtype l | while read line; do ls -ld ${line/source}; done
|
||||
:
|
||||
|
||||
%files
|
||||
@ -91,6 +93,12 @@ find /etc/rc[0-6].d/ -type l -xtype l -exec rm -f {} \;
|
||||
#README.dkms TODO
|
||||
|
||||
%changelog
|
||||
* Sun Jun 18 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.0-2mamba
|
||||
- reapply patch to skip modules with sources removed and cleanup old broken modules in posttrans
|
||||
|
||||
* Sat Jun 17 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 2.4.0-1mamba
|
||||
- update to 2.4.0
|
||||
|
||||
* Sat Dec 17 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 2.3-1mamba
|
||||
- update to 2.3
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user