automatic version update by autodist [release 1.4.2-1mamba;Sat May 03 2014]
This commit is contained in:
parent
e3e485eab3
commit
687b4f4639
@ -1,2 +1,6 @@
|
||||
# darktable
|
||||
|
||||
Darktable is an open source photography workflow application and RAW developer.
|
||||
A virtual lighttable and darkroom for photographers.
|
||||
It manages your digital negatives in a database, lets you view them through a zoomable lighttable and enables you to develop raw images and enhance them.
|
||||
|
||||
|
30
darktable-1.0-librsvg-2.36.4.patch
Normal file
30
darktable-1.0-librsvg-2.36.4.patch
Normal file
@ -0,0 +1,30 @@
|
||||
commit 343df29553a126f29b5379fefeb7c2cfd1adc073
|
||||
Author: Tobias Ellinghaus <me@houz.org>
|
||||
Date: Sat Sep 15 11:53:25 2012 +0200
|
||||
|
||||
Hopefully fix #8931 with an ugly hack
|
||||
|
||||
diff --git a/src/iop/watermark.c b/src/iop/watermark.c
|
||||
index bcd65d6..e3da730 100644
|
||||
--- a/src/iop/watermark.c
|
||||
+++ b/src/iop/watermark.c
|
||||
@@ -36,7 +36,10 @@
|
||||
#include <inttypes.h>
|
||||
|
||||
#include <librsvg/rsvg.h>
|
||||
+// ugh, ugly hack. why do people break stuff all the time?
|
||||
+#ifndef RSVG_CAIRO_H
|
||||
#include <librsvg/rsvg-cairo.h>
|
||||
+#endif
|
||||
|
||||
#include "common/metadata.h"
|
||||
#include "common/utility.h"
|
||||
@@ -712,7 +715,7 @@ static void refresh_watermarks( dt_iop_module_t *self )
|
||||
snprintf(filename, DT_MAX_PATH_LEN, "%s/%s", configdir, d_name);
|
||||
gtk_combo_box_append_text( g->combobox1, d_name );
|
||||
count++;
|
||||
- }
|
||||
+ }
|
||||
g_dir_close(dir) ;
|
||||
}
|
||||
|
151
darktable.spec
Normal file
151
darktable.spec
Normal file
@ -0,0 +1,151 @@
|
||||
%define majver %(echo %version | cut -d. -f1-2)
|
||||
Name: darktable
|
||||
Version: 1.4.2
|
||||
Release: 1mamba
|
||||
Summary: An open source photography workflow application and RAW developer
|
||||
Group: Graphical Desktop/Applications/Graphics
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
||||
URL: http://www.darktable.org/
|
||||
Source: http://downloads.sourceforge.net/project/darktable/darktable/%{majver}/darktable-%{version}.tar.xz
|
||||
Patch0: darktable-1.0-librsvg-2.36.4.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libatk-devel
|
||||
BuildRequires: libcairo-devel
|
||||
BuildRequires: libcurl-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libdbus-glib-devel
|
||||
BuildRequires: libexiv2-devel
|
||||
BuildRequires: libflickcurl-devel
|
||||
BuildRequires: libfreetype-devel
|
||||
BuildRequires: libgcc
|
||||
BuildRequires: libgdk-pixbuf-devel
|
||||
BuildRequires: libGL-devel
|
||||
BuildRequires: libglib-devel
|
||||
BuildRequires: libGLU-devel
|
||||
BuildRequires: libgnome-keyring-devel
|
||||
BuildRequires: libgomp-devel
|
||||
BuildRequires: libgphoto-devel
|
||||
BuildRequires: libgtk2-devel
|
||||
BuildRequires: libICE-devel
|
||||
BuildRequires: libilmbase-devel
|
||||
BuildRequires: libjpeg-devel
|
||||
BuildRequires: liblcms2-devel
|
||||
BuildRequires: liblensfun-devel
|
||||
BuildRequires: libopenexr-devel
|
||||
BuildRequires: libpango-devel
|
||||
BuildRequires: libpng-devel
|
||||
BuildRequires: librsvg-devel
|
||||
BuildRequires: libSDL-devel
|
||||
BuildRequires: libSM-devel
|
||||
BuildRequires: libsqlite-devel
|
||||
BuildRequires: libstdc++6-devel
|
||||
BuildRequires: libtiff-devel
|
||||
BuildRequires: libX11-devel
|
||||
BuildRequires: libXext-devel
|
||||
BuildRequires: libxml2-devel
|
||||
BuildRequires: libz-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%debug_package
|
||||
|
||||
%description
|
||||
Darktable is an open source photography workflow application and RAW developer.
|
||||
A virtual lighttable and darkroom for photographers.
|
||||
It manages your digital negatives in a database, lets you view them through a zoomable lighttable and enables you to develop raw images and enhance them.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%build
|
||||
%cmake -d build
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall -C build
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
# remove unpackaged files
|
||||
rm -f %{buildroot}%{_defaultdocdir}/darktable/{AUTHORS,LICENSE,README,TRANSLATORS}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/darktable*
|
||||
%dir %{_libdir}/darktable
|
||||
%{_libdir}/darktable/libdarktable.so
|
||||
%dir %{_libdir}/darktable/plugins
|
||||
%{_libdir}/darktable/plugins/*.so
|
||||
%dir %{_libdir}/darktable/plugins/imageio
|
||||
%dir %{_libdir}/darktable/plugins/imageio/format
|
||||
%{_libdir}/darktable/plugins/imageio/format/*.so
|
||||
%dir %{_libdir}/darktable/plugins/imageio/storage
|
||||
%{_libdir}/darktable/plugins/imageio/storage/*.so
|
||||
%dir %{_libdir}/darktable/plugins/lighttable
|
||||
%{_libdir}/darktable/plugins/lighttable/*.so
|
||||
%dir %{_libdir}/darktable/views
|
||||
%{_libdir}/darktable/views/*.so
|
||||
%{_datadir}/appdata/darktable.appdata.xml
|
||||
%{_datadir}/applications/darktable.desktop
|
||||
%dir %{_datadir}/darktable
|
||||
%{_datadir}/darktable/*
|
||||
%{_datadir}/icons/hicolor/*/apps/darktable.png
|
||||
%{_datadir}/icons/hicolor/*/apps/darktable.svg
|
||||
%{_datadir}/icons/hicolor/scalable/apps/darktable-2.svg
|
||||
%dir %{_docdir}/darktable
|
||||
%{_docdir}/darktable/darktablerc.html
|
||||
%{_mandir}/man1/darktable.1*
|
||||
%{_mandir}/man1/darktable-cli.1*
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat May 03 2014 Automatic Build System <autodist@mambasoft.it> 1.4.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Mar 30 2014 Automatic Build System <autodist@mambasoft.it> 1.4.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Dec 28 2013 Automatic Build System <autodist@mambasoft.it> 1.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Sep 11 2013 Automatic Build System <autodist@mambasoft.it> 1.2.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jun 26 2013 Automatic Build System <autodist@mambasoft.it> 1.2.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue May 28 2013 Automatic Build System <autodist@mambasoft.it> 1.2.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Apr 14 2013 Automatic Build System <autodist@mambasoft.it> 1.2-1mamba
|
||||
- update to 1.2
|
||||
|
||||
* Mon Feb 11 2013 Automatic Build System <autodist@mambasoft.it> 1.1.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jan 14 2013 Automatic Build System <autodist@mambasoft.it> 1.1.2-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Dec 15 2012 Automatic Build System <autodist@mambasoft.it> 1.1.1-1mamba
|
||||
- update to 1.1.1
|
||||
|
||||
* Sun Dec 02 2012 Automatic Build System <autodist@mambasoft.it> 1.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Nov 10 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.0-2mamba
|
||||
- rebuilt with libkexiv2 4.9.3
|
||||
|
||||
* Fri Mar 23 2012 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 1.0-1mamba
|
||||
- update to version 1.0
|
||||
|
||||
|
||||
* Sat Jan 21 2012 Davide Madrisan <davide.madrisan@gmail.com> 0.9.3-1mamba
|
||||
- package created by autospec
|
Loading…
Reference in New Issue
Block a user