rebuilt with libgphoto2 2.5.5 [release 1.4.2-2mamba;Fri Dec 26 2014]
This commit is contained in:
parent
687b4f4639
commit
67fa900a44
22
darktable-1.4.2-build-fixes-x86.patch
Normal file
22
darktable-1.4.2-build-fixes-x86.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
diff -Nru darktable-1.4.2/src.orig/dtview/CMakeLists.txt darktable-1.4.2/src/dtview/CMakeLists.txt
|
||||||
|
--- darktable-1.4.2/src.orig/dtview/CMakeLists.txt 2014-12-28 02:13:49.522000000 +0100
|
||||||
|
+++ darktable-1.4.2/src/dtview/CMakeLists.txt 2014-12-28 02:12:47.511000000 +0100
|
||||||
|
@@ -18,5 +18,5 @@
|
||||||
|
set_target_properties(darktable-viewer PROPERTIES CMAKE_INSTALL_RPATH_USE_LINK_PATH FALSE)
|
||||||
|
set_target_properties(darktable-viewer PROPERTIES INSTALL_RPATH $ORIGIN/../${LIB_INSTALL}/darktable)
|
||||||
|
set_target_properties(darktable-viewer PROPERTIES LINKER_LANGUAGE C)
|
||||||
|
-target_link_libraries(darktable-viewer lib_darktable ${SDL_LIBRARY} ${OPENGL_LIBRARIES})
|
||||||
|
+target_link_libraries(darktable-viewer lib_darktable -lgs ${SDL_LIBRARY} ${OPENGL_LIBRARIES})
|
||||||
|
install(TARGETS darktable-viewer DESTINATION bin)
|
||||||
|
diff -Nru darktable-1.4.2/src.orig/dtview/main.c darktable-1.4.2/src/dtview/main.c
|
||||||
|
--- darktable-1.4.2/src.orig/dtview/main.c 2014-12-28 02:14:05.301000000 +0100
|
||||||
|
+++ darktable-1.4.2/src/dtview/main.c 2014-12-28 02:14:18.030000000 +0100
|
||||||
|
@@ -37,7 +37,7 @@
|
||||||
|
#include <inttypes.h>
|
||||||
|
|
||||||
|
int running;
|
||||||
|
-int width, height;
|
||||||
|
+long long width, height;
|
||||||
|
uint32_t random_state;
|
||||||
|
int32_t repeat;
|
||||||
|
int use_random;
|
@ -1,7 +1,7 @@
|
|||||||
%define majver %(echo %version | cut -d. -f1-2)
|
%define majver %(echo %version | cut -d. -f1-2)
|
||||||
Name: darktable
|
Name: darktable
|
||||||
Version: 1.4.2
|
Version: 1.4.2
|
||||||
Release: 1mamba
|
Release: 2mamba
|
||||||
Summary: An open source photography workflow application and RAW developer
|
Summary: An open source photography workflow application and RAW developer
|
||||||
Group: Graphical Desktop/Applications/Graphics
|
Group: Graphical Desktop/Applications/Graphics
|
||||||
Vendor: openmamba
|
Vendor: openmamba
|
||||||
@ -10,45 +10,51 @@ Packager: Davide Madrisan <davide.madrisan@gmail.com>
|
|||||||
URL: http://www.darktable.org/
|
URL: http://www.darktable.org/
|
||||||
Source: http://downloads.sourceforge.net/project/darktable/darktable/%{majver}/darktable-%{version}.tar.xz
|
Source: http://downloads.sourceforge.net/project/darktable/darktable/%{majver}/darktable-%{version}.tar.xz
|
||||||
Patch0: darktable-1.0-librsvg-2.36.4.patch
|
Patch0: darktable-1.0-librsvg-2.36.4.patch
|
||||||
|
Patch1: darktable-1.4.2-build-fixes-x86.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
## AUTOBUILDREQ-BEGIN
|
## AUTOBUILDREQ-BEGIN
|
||||||
BuildRequires: glibc-devel
|
BuildRequires: glibc-devel
|
||||||
BuildRequires: libatk-devel
|
|
||||||
BuildRequires: libcairo-devel
|
|
||||||
BuildRequires: libcurl-devel
|
|
||||||
BuildRequires: libdbus-devel
|
|
||||||
BuildRequires: libdbus-glib-devel
|
|
||||||
BuildRequires: libexiv2-devel
|
|
||||||
BuildRequires: libflickcurl-devel
|
|
||||||
BuildRequires: libfreetype-devel
|
|
||||||
BuildRequires: libgcc
|
|
||||||
BuildRequires: libgdk-pixbuf-devel
|
|
||||||
BuildRequires: libGL-devel
|
BuildRequires: libGL-devel
|
||||||
BuildRequires: libglib-devel
|
|
||||||
BuildRequires: libGLU-devel
|
BuildRequires: libGLU-devel
|
||||||
BuildRequires: libgnome-keyring-devel
|
|
||||||
BuildRequires: libgomp-devel
|
|
||||||
BuildRequires: libgphoto-devel
|
|
||||||
BuildRequires: libgtk2-devel
|
|
||||||
BuildRequires: libICE-devel
|
BuildRequires: libICE-devel
|
||||||
BuildRequires: libilmbase-devel
|
|
||||||
BuildRequires: libjpeg-devel
|
|
||||||
BuildRequires: liblcms2-devel
|
|
||||||
BuildRequires: liblensfun-devel
|
|
||||||
BuildRequires: libopenexr-devel
|
|
||||||
BuildRequires: libpango-devel
|
|
||||||
BuildRequires: libpng-devel
|
|
||||||
BuildRequires: librsvg-devel
|
|
||||||
BuildRequires: libSDL-devel
|
BuildRequires: libSDL-devel
|
||||||
BuildRequires: libSM-devel
|
BuildRequires: libSM-devel
|
||||||
|
BuildRequires: libX11-devel
|
||||||
|
BuildRequires: libXext-devel
|
||||||
|
BuildRequires: libatk-devel
|
||||||
|
BuildRequires: libcairo-devel
|
||||||
|
BuildRequires: libcolord-devel
|
||||||
|
BuildRequires: libcurl-devel
|
||||||
|
BuildRequires: libexiv2-devel
|
||||||
|
BuildRequires: libflickcurl-devel
|
||||||
|
BuildRequires: libgcc
|
||||||
|
BuildRequires: libgdk-pixbuf-devel
|
||||||
|
BuildRequires: libglib-devel
|
||||||
|
BuildRequires: libgnome-keyring-devel
|
||||||
|
BuildRequires: libgomp-devel
|
||||||
|
BuildRequires: libgphoto2-devel
|
||||||
|
BuildRequires: libgtk2-devel
|
||||||
|
BuildRequires: libilmbase-devel
|
||||||
|
BuildRequires: libjpeg-devel
|
||||||
|
BuildRequires: libjson-glib-devel
|
||||||
|
BuildRequires: liblcms2-devel
|
||||||
|
BuildRequires: liblensfun-devel
|
||||||
|
BuildRequires: liblua-devel
|
||||||
|
BuildRequires: libopenexr-devel
|
||||||
|
BuildRequires: libopenjpeg1-devel
|
||||||
|
BuildRequires: libpango-devel
|
||||||
|
BuildRequires: libpng-devel
|
||||||
|
BuildRequires: libreadline-devel
|
||||||
|
BuildRequires: librsvg-devel
|
||||||
|
BuildRequires: libsoup-devel
|
||||||
BuildRequires: libsqlite-devel
|
BuildRequires: libsqlite-devel
|
||||||
BuildRequires: libstdc++6-devel
|
BuildRequires: libstdc++6-devel
|
||||||
BuildRequires: libtiff-devel
|
BuildRequires: libtiff-devel
|
||||||
BuildRequires: libX11-devel
|
BuildRequires: libwebp-devel
|
||||||
BuildRequires: libXext-devel
|
|
||||||
BuildRequires: libxml2-devel
|
BuildRequires: libxml2-devel
|
||||||
BuildRequires: libz-devel
|
BuildRequires: libz-devel
|
||||||
## AUTOBUILDREQ-END
|
## AUTOBUILDREQ-END
|
||||||
|
BuildRequires: libgphoto2-devel >= 1:2.5
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
|
|
||||||
%debug_package
|
%debug_package
|
||||||
@ -60,6 +66,7 @@ It manages your digital negatives in a database, lets you view them through a zo
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch1 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%cmake -d build
|
%cmake -d build
|
||||||
@ -107,6 +114,9 @@ rm -f %{buildroot}%{_defaultdocdir}/darktable/{AUTHORS,LICENSE,README,TRANSLATOR
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 26 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 1.4.2-2mamba
|
||||||
|
- rebuilt with libgphoto2 2.5.5
|
||||||
|
|
||||||
* Sat May 03 2014 Automatic Build System <autodist@mambasoft.it> 1.4.2-1mamba
|
* Sat May 03 2014 Automatic Build System <autodist@mambasoft.it> 1.4.2-1mamba
|
||||||
- automatic version update by autodist
|
- automatic version update by autodist
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user