update to 0.18 [release 0.18-1mamba;Sat Nov 02 2024]
This commit is contained in:
parent
735e804d5b
commit
8d661842ff
@ -1,14 +0,0 @@
|
||||
--- killrpath.c 2010-11-28 23:58:20.000000000 +0100
|
||||
+++ killrpath.c.fix 2010-11-29 00:00:50.000000000 +0100
|
||||
@@ -74,7 +74,10 @@
|
||||
dynpos++;
|
||||
}
|
||||
for (; dynpos < i; dynpos++)
|
||||
- dyns[dynpos].d_tag = DT_NULL;
|
||||
+ {
|
||||
+ dyns[dynpos].d_tag = DT_NULL;
|
||||
+ dyns[dynpos].d_un.d_val = 0x0;
|
||||
+ }
|
||||
|
||||
if (lseek(fd, phdr.p_offset, SEEK_SET) == -1
|
||||
|| write(fd, dyns, phdr.p_filesz) != (int)phdr.p_filesz)
|
10
chrpath.spec
10
chrpath.spec
@ -1,15 +1,13 @@
|
||||
Name: chrpath
|
||||
Version: 0.17
|
||||
Version: 0.18
|
||||
Release: 1mamba
|
||||
Summary: Dynamic library load path (rpath) alterer
|
||||
Group: System/Tools
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: https://www.tux.org/pub/X-Windows/ftp.hungry.com/chrpath/
|
||||
URL: https://codeberg.org/pere/chrpath
|
||||
Source: https://codeberg.org/pere/chrpath.git/release-%{version}/chrpath-%{version}.tar.bz2
|
||||
#Source: https://alioth.debian.org/frs/download.php/file/3979/chrpath-%{version}.tar.gz
|
||||
Patch: %{name}-0.13-NULL-entry.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
@ -23,7 +21,6 @@ Currently, only removing and modifying the rpath is supported.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch -p0
|
||||
./bootstrap
|
||||
|
||||
%build
|
||||
@ -46,6 +43,9 @@ rm -fr %{buildroot}/usr/doc
|
||||
#ChangeLog NEWS README
|
||||
|
||||
%changelog
|
||||
* Sat Nov 02 2024 Silvan Calarco <silvan.calarco@mambasoft.it> 0.18-1mamba
|
||||
- update to 0.18
|
||||
|
||||
* Sun Dec 24 2023 Silvan Calarco <silvan.calarco@mambasoft.it> 0.17-1mamba
|
||||
- update to 0.17
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user