update to 1.3.59 [release 1.3.59-1mamba;Fri Aug 03 2012]
This commit is contained in:
parent
60c0d9b910
commit
984b4a2881
@ -1,2 +1,6 @@
|
||||
# chkconfig
|
||||
|
||||
Chkconfig is a basic system utility.
|
||||
It updates and queries runlevel information for system services.
|
||||
Chkconfig manipulates the numerous symbolic links in /etc/rc.d, to relieve system administrators of some of the drudgery of manually editing the symbolic links.
|
||||
|
||||
|
20
chkconfig-1.3.33-lang_it.patch
Normal file
20
chkconfig-1.3.33-lang_it.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- chkconfig-1.3.33/po/it.po 2007-02-04 01:20:18.000000000 +0100
|
||||
+++ chkconfig-1.3.33/po/it.po.fix 2007-03-23 09:04:05.000000000 +0100
|
||||
@@ -144,7 +144,7 @@
|
||||
#: ../ntsysv.c:252
|
||||
#, c-format
|
||||
msgid "error reading from directory %s: %s\n"
|
||||
-msgstr "errore durante la lettura dalla directory %s: %s\n"
|
||||
+msgstr "errore durante la lettura della directory %s: %s\n"
|
||||
|
||||
#: ../ntsysv.c:288
|
||||
#, c-format
|
||||
@@ -164,7 +164,7 @@
|
||||
#: ../leveldb.c:596
|
||||
#, c-format
|
||||
msgid "failed to glob pattern %s: %s\n"
|
||||
-msgstr "impossibile inglobare il modello %s: %s\n"
|
||||
+msgstr "impossibile utilizzare il glob pattern %s: %s\n"
|
||||
|
||||
#: ../leveldb.c:639
|
||||
#, c-format
|
65
chkconfig-1.3.34-alternatives_fixlinks.patch
Normal file
65
chkconfig-1.3.34-alternatives_fixlinks.patch
Normal file
@ -0,0 +1,65 @@
|
||||
diff -u chkconfig-1.3.34/alternatives.c chkconfig-1.3.34.patched/alternatives.c
|
||||
--- chkconfig-1.3.34/alternatives.c 2006-09-07 20:58:40.000000000 +0200
|
||||
+++ chkconfig-1.3.34.patched/alternatives.c 2007-08-03 18:26:31.000000000 +0200
|
||||
@@ -376,20 +376,47 @@
|
||||
}
|
||||
|
||||
static int makeLinks(struct linkSet * l, const char * altDir, int flags) {
|
||||
- char * sl;
|
||||
+ char * sl, * sol;
|
||||
struct stat sb;
|
||||
+ int stlen;
|
||||
+
|
||||
+ stlen = strlen(altDir) + strlen(l->title) + 2;
|
||||
+
|
||||
+ sl = alloca(stlen);
|
||||
+ sol = alloca(stlen+1);
|
||||
|
||||
- sl = alloca(strlen(altDir) + strlen(l->title) + 2);
|
||||
sprintf(sl, "%s/%s", altDir, l->title);
|
||||
- if (lstat(l->facility, &sb)) {
|
||||
+
|
||||
+ if (lstat(l->facility, &sb) || S_ISLNK(sb.st_mode)) {
|
||||
+
|
||||
if (FL_TEST(flags)) {
|
||||
printf(_("would link %s -> %s\n"), l->facility, sl);
|
||||
} else {
|
||||
-
|
||||
- if (symlink(sl, l->facility)) {
|
||||
+ if (S_ISLNK(sb.st_mode)) {
|
||||
+ if ((stlen=readlink(l->facility,sol,stlen)) == -1)
|
||||
+ fprintf(stderr, _("failed to read link %s: %s\n"),
|
||||
+ l->facility, strerror(errno));
|
||||
+ sol[stlen]='\0';
|
||||
+
|
||||
+ if (strcmp(sl,sol)) {
|
||||
+ /* symlink is not correct, reset it */
|
||||
+ if (unlink(l->facility) && errno != ENOENT){
|
||||
+ fprintf(stderr, _("failed to remove link %s: %s\n"),
|
||||
+ l->facility, strerror(errno));
|
||||
+ return 1;
|
||||
+ }
|
||||
+ if (symlink(sl, l->facility)) {
|
||||
fprintf(stderr, _("failed to link %s -> %s: %s\n"),
|
||||
l->facility, sl, strerror(errno));
|
||||
return 1;
|
||||
+ }
|
||||
+ }
|
||||
+ } else {
|
||||
+ if (symlink(sl, l->facility)) {
|
||||
+ fprintf(stderr, _("failed to link %s -> %s: %s\n"),
|
||||
+ l->facility, sl, strerror(errno));
|
||||
+ return 1;
|
||||
+ }
|
||||
}
|
||||
}
|
||||
}
|
||||
@@ -637,7 +664,7 @@
|
||||
set.numAlts++;
|
||||
}
|
||||
|
||||
- if (writeState(&set, altDir, stateDir, 0, flags)) return 2;
|
||||
+ if (writeState(&set, altDir, stateDir, 1, flags)) return 2;
|
||||
|
||||
return 0;
|
||||
}
|
101
chkconfig.spec
Normal file
101
chkconfig.spec
Normal file
@ -0,0 +1,101 @@
|
||||
Name: chkconfig
|
||||
Version: 1.3.59
|
||||
Release: 1mamba
|
||||
Summary: A system tool for maintaining the /etc/rc*.d hierarchy
|
||||
Group: System/Configuration
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://download.fedora.redhat.com
|
||||
Source: http://pkgs.fedoraproject.org/repo/pkgs/chkconfig/chkconfig-%{version}.tar.bz2/b2fe3a26aa0fbe89a1dae69805156b57/chkconfig-%{version}.tar.bz2
|
||||
Patch: %{name}-1.3.33-lang_it.patch
|
||||
Patch1: %{name}-1.3.34-alternatives_fixlinks.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libnewt-devel
|
||||
BuildRequires: libpopt-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: gettext-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Chkconfig is a basic system utility.
|
||||
It updates and queries runlevel information for system services.
|
||||
Chkconfig manipulates the numerous symbolic links in /etc/rc.d, to relieve system administrators of some of the drudgery of manually editing the symbolic links.
|
||||
|
||||
%package -n ntsysv
|
||||
Summary: A tool to set the stop/start of system services in a runlevel
|
||||
Group: System/Configuration
|
||||
Requires: %{name} = %{?epoch:%epoch:}%{version}-%{release}
|
||||
|
||||
%description -n ntsysv
|
||||
Ntsysv provides a simple interface for setting which system services are started or stopped in various runlevels (instead of directly manipulating the numerous symbolic links in /etc/rc.d).
|
||||
Unless you specify a runlevel or runlevels on the command line, ntsysv configures the current runlevel.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
%build
|
||||
%make CC=%{_host}-gcc \
|
||||
%if "%{_build}" != "%{_host}"
|
||||
LDFLAGS="-lslang -ldl -lm"
|
||||
%endif
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall MANDIR=%{_mandir} SBINDIR=%{_sbindir}
|
||||
|
||||
%find_lang %{name}
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
/sbin/chkconfig
|
||||
%{_sbindir}/alternatives
|
||||
%{_sbindir}/update-alternatives
|
||||
%{_sbindir}/ntsysv
|
||||
%dir %{_sysconfdir}/alternatives
|
||||
%dir /var/lib/alternatives
|
||||
%{_mandir}/man8/*
|
||||
%exclude %{_mandir}/man8/ntsysv.*
|
||||
|
||||
%files -n ntsysv
|
||||
%defattr(-,root,root)
|
||||
%{_sbindir}/ntsysv
|
||||
%{_mandir}/man8/ntsysv.*
|
||||
|
||||
%changelog
|
||||
* Fri Aug 03 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.59-1mamba
|
||||
- update to 1.3.59
|
||||
|
||||
* Sun Jul 12 2009 Automatic Build System <autodist@mambasoft.it> 1.3.34-4mamba
|
||||
- automatic rebuild by autodist
|
||||
|
||||
* Fri Aug 03 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.34-3mamba
|
||||
- alternatives: don't try to rewrite symlinks if they are correct
|
||||
|
||||
* Wed Jun 20 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 1.3.34-2mamba
|
||||
- alternatives:added a patch that fixes master link if wrong
|
||||
|
||||
* Mon Jun 04 2007 Aleph0 <aleph0@openmamba.org> 1.3.34-1mamba
|
||||
- update to 1.3.34
|
||||
|
||||
* Thu Mar 22 2007 Davide Madrisan <davide.madrisan@qilinux.it> 1.3.33-1qilnx
|
||||
- update to version 1.3.33 by autospec
|
||||
- new subpackage ntsysv
|
||||
- updated italian translations patch
|
||||
|
||||
* Mon Feb 27 2006 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.3.6-4qilnx
|
||||
- fixed italian translations patch
|
||||
|
||||
* Fri Nov 18 2005 Stefano Cotta Ramusino <stefano.cotta@qilinux.it> 1.3.6-3qilnx
|
||||
- italian translations patched
|
||||
|
||||
* Mon Sep 12 2005 Davide Madrisan <davide.madrisan@qilinux.it> 1.3.6-2qilnx
|
||||
- specfile updates
|
||||
|
||||
* Wed Apr 16 2003 Alessandro Ramazzina <alessandro.ramazzina@qinet.it> 1.3.6-1qilnx
|
||||
- creation of chkconfig package
|
Loading…
Reference in New Issue
Block a user