automatic version update by autodist [release 3.01a23-1mamba;Sat Mar 08 2014]
This commit is contained in:
parent
b15371d2c9
commit
d773103b6d
@ -1,2 +1,7 @@
|
||||
# cdrtools
|
||||
|
||||
Cdrtools supports many features including cdrecord, cdda2wav and mkisofs/mkhybrid in a single source tree.
|
||||
Cdrecord supports DVD-R and DVD-RW with all known DVD-writers on all UNIX-like OS and on Win32.
|
||||
DVD writing support is implemented in cdrecord since march 1998.
|
||||
Cdrecord writes DVD media similar to CD media.
|
||||
|
||||
|
15
cdrtools-2.01-CAN-2004-0806.patch
Normal file
15
cdrtools-2.01-CAN-2004-0806.patch
Normal file
@ -0,0 +1,15 @@
|
||||
--- cdrecord-2.01/librscg/scsi-remote.c.org 2004-08-30 16:09:33.000000000 -0600
|
||||
+++ cdrecord-2.01/librscg/scsi-remote.c 2004-08-30 16:11:06.000000000 -0600
|
||||
@@ -1071,9 +1071,9 @@
|
||||
/*
|
||||
* Become 'locuser' to tell the rsh program the local user id.
|
||||
*/
|
||||
- if (getuid() != pw->pw_uid &&
|
||||
- setuid(pw->pw_uid) == -1) {
|
||||
- errmsg("setuid(%lld) failed.\n",
|
||||
+ if ((pw->pw_uid) != geteuid() &&
|
||||
+ seteuid(pw->pw_uid) == -1) {
|
||||
+ errmsg("seteuid(%lld) failed.\n",
|
||||
(Llong)pw->pw_uid);
|
||||
_exit(EX_BAD);
|
||||
/* NOTREACHED */
|
61
cdrtools-2.01-gcc4.patch
Normal file
61
cdrtools-2.01-gcc4.patch
Normal file
@ -0,0 +1,61 @@
|
||||
--- cdrtools-2.01/mkisofs/write.c.jj 2005-08-27 10:16:33.000000000 +0200
|
||||
+++ cdrtools-2.01/mkisofs/write.c 2005-08-27 10:29:41.000000000 +0200
|
||||
@@ -1907,7 +1907,7 @@ pvd_write(outfile)
|
||||
/* Next we write out the primary descriptor for the disc */
|
||||
memset(&vol_desc, 0, sizeof (vol_desc));
|
||||
vol_desc.type[0] = ISO_VD_PRIMARY;
|
||||
- memcpy(vol_desc.id, ISO_STANDARD_ID, sizeof (ISO_STANDARD_ID));
|
||||
+ memcpy(vol_desc.id, ISO_STANDARD_ID, sizeof (ISO_STANDARD_ID) - 1);
|
||||
vol_desc.version[0] = 1;
|
||||
|
||||
memset(vol_desc.system_id, ' ', sizeof (vol_desc.system_id));
|
||||
@@ -2030,7 +2030,7 @@ evd_write(outfile)
|
||||
*/
|
||||
memset(&evol_desc, 0, sizeof (evol_desc));
|
||||
evol_desc.type[0] = (unsigned char) ISO_VD_END;
|
||||
- memcpy(evol_desc.id, ISO_STANDARD_ID, sizeof (ISO_STANDARD_ID));
|
||||
+ memcpy(evol_desc.id, ISO_STANDARD_ID, sizeof (ISO_STANDARD_ID) - 1);
|
||||
evol_desc.version[0] = 1;
|
||||
xfwrite(&evol_desc, SECTOR_SIZE, 1, outfile, 0, TRUE);
|
||||
last_extent_written += 1;
|
||||
--- cdrtools-2.01/mkisofs/eltorito.c.jj 2004-05-23 22:46:05.000000000 +0200
|
||||
+++ cdrtools-2.01/mkisofs/eltorito.c 2005-08-27 10:30:50.000000000 +0200
|
||||
@@ -270,7 +270,7 @@ get_torito_desc(boot_desc)
|
||||
|
||||
memset(boot_desc, 0, sizeof (*boot_desc));
|
||||
boot_desc->type[0] = 0;
|
||||
- memcpy(boot_desc->id, ISO_STANDARD_ID, sizeof (ISO_STANDARD_ID));
|
||||
+ memcpy(boot_desc->id, ISO_STANDARD_ID, sizeof (ISO_STANDARD_ID) - 1);
|
||||
boot_desc->version[0] = 1;
|
||||
|
||||
memcpy(boot_desc->system_id, EL_TORITO_ID, sizeof (EL_TORITO_ID));
|
||||
--- cdrtools-2.01/cdda2wav/toc.c.jj 2004-05-21 22:56:44.000000000 +0200
|
||||
+++ cdrtools-2.01/cdda2wav/toc.c 2005-08-27 10:25:04.000000000 +0200
|
||||
@@ -959,7 +959,12 @@ process_cddb_titles(sock_fd, inbuff, rea
|
||||
if (*target != NULL)
|
||||
**target = '\0';
|
||||
} else {
|
||||
- realloc(*target, strlen(*target) + clen - 1);
|
||||
+ char *newp = realloc(*target, strlen(*target) + clen - 1);
|
||||
+ if (newp == NULL) {
|
||||
+ free (*target);
|
||||
+ *target = NULL;
|
||||
+ } else
|
||||
+ *target = newp;
|
||||
}
|
||||
if (*target != NULL) {
|
||||
strcat((char *)*target, inbuff+ind+7);
|
||||
@@ -994,7 +999,12 @@ process_cddb_titles(sock_fd, inbuff, rea
|
||||
if (global.tracktitle[tno] != NULL)
|
||||
*(global.tracktitle[tno]) = '\0';
|
||||
} else {
|
||||
- realloc(global.tracktitle[tno], strlen((char *)global.tracktitle[tno]) + p - q + 1 );
|
||||
+ char *newp = realloc(global.tracktitle[tno], strlen((char *)global.tracktitle[tno]) + p - q + 1 );
|
||||
+ if (newp == NULL) {
|
||||
+ free (global.tracktitle[tno]);
|
||||
+ global.tracktitle[tno] = NULL;
|
||||
+ } else
|
||||
+ global.tracktitle[tno] = newp;
|
||||
}
|
||||
if (global.tracktitle[tno] != NULL) {
|
||||
strcat((char *)global.tracktitle[tno], q+1);
|
12
cdrtools-2.01-gcc_static.patch
Normal file
12
cdrtools-2.01-gcc_static.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -pur cdrtools-2.01/cdrecord/drv_mmc.c cdrtools-2.01-fix/cdrecord/drv_mmc.c
|
||||
--- cdrtools-2.01/cdrecord/drv_mmc.c 2006-03-16 14:33:59.000000000 +0100
|
||||
+++ cdrtools-2.01-fix/cdrecord/drv_mmc.c 2006-03-16 14:35:55.000000000 +0100
|
||||
@@ -1087,7 +1087,7 @@ check_writemodes_mmc(scgp, dp)
|
||||
return (0);
|
||||
}
|
||||
|
||||
-LOCAL int
|
||||
+EXPORT int
|
||||
check_writemodes_mdvd(scgp, dp)
|
||||
SCSI *scgp;
|
||||
cdr_t *dp;
|
11
cdrtools-2.01-warnings.patch
Normal file
11
cdrtools-2.01-warnings.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- cdrtools-2.01/RULES/mk-gmake.id 2004-09-08 18:10:02.000000000 +0200
|
||||
+++ cdrtools-2.01/RULES/mk-gmake.id.nowarn 2006-03-16 12:55:18.000000000 +0100
|
||||
@@ -37,7 +37,7 @@
|
||||
|
||||
ifndef ARCH_DONE
|
||||
|
||||
-__gmake_warn:= $(shell cat $(SRCROOT)/$(RULESDIR)/gmake.wrn 1>&2; sleep 5)
|
||||
+#__gmake_warn:= $(shell cat $(SRCROOT)/$(RULESDIR)/gmake.wrn 1>&2; sleep 5)
|
||||
|
||||
_MACHCMD= (mach || uname -p || true) 2> /dev/null
|
||||
_ARCHCMD= (arch || /usr/ucb/arch || true) 2> /dev/null
|
1031
cdrtools-2.01a32-ossdvd.patch
Normal file
1031
cdrtools-2.01a32-ossdvd.patch
Normal file
File diff suppressed because it is too large
Load Diff
225
cdrtools.spec
Normal file
225
cdrtools.spec
Normal file
@ -0,0 +1,225 @@
|
||||
%define cdrecording_group 12
|
||||
%define sourcever %(echo %version | cut -da -f1)
|
||||
Name: cdrtools
|
||||
Version: 3.01a23
|
||||
Release: 1mamba
|
||||
Summary: Tools for CD/DVD recorders
|
||||
Group: System/Tools
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.fokus.gmd.de/research/cc/glone/employees/joerg.schilling/private/cdrecord.html
|
||||
Source: ftp://ftp.berlios.de/pub/cdrecord/alpha/cdrtools-%{version}.tar.bz2
|
||||
Patch0: %{name}-2.01-CAN-2004-0806.patch
|
||||
Patch1: %{name}-2.01-warnings.patch
|
||||
Patch2: http://crashrecovery.org/oss-dvd/cdrtools-2.01a32-ossdvd.patch.bz2
|
||||
Patch3: %{name}-2.01-gcc4.patch
|
||||
Patch4: %{name}-2.01-gcc_static.patch
|
||||
License: GPL, Common Development and Distribution License
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: bash
|
||||
BuildRequires: glibc-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: libcap-devel
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
Cdrtools supports many features including cdrecord, cdda2wav and mkisofs/mkhybrid in a single source tree.
|
||||
Cdrecord supports DVD-R and DVD-RW with all known DVD-writers on all UNIX-like OS and on Win32.
|
||||
DVD writing support is implemented in cdrecord since march 1998.
|
||||
Cdrecord writes DVD media similar to CD media.
|
||||
|
||||
%package devel
|
||||
Summary: Development files for cdrtools
|
||||
Group: Development/Libraries
|
||||
Requires: %{name} = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Cdrtools supports many features including cdrecord, cdda2wav and mkisofs/mkhybrid in a single source tree.
|
||||
Cdrecord supports DVD-R and DVD-RW with all known DVD-writers on all UNIX-like OS and on Win32.
|
||||
DVD writing support is implemented in cdrecord since march 1998.
|
||||
Cdrecord writes DVD media similar to CD media.
|
||||
This is the development package.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}-%{sourcever}
|
||||
#%patch0 -p1 -b .CAN-2004-0806
|
||||
#%patch1 -p1 -b .warning
|
||||
#%patch2 -p1
|
||||
#%patch3 -p1 -b .gcc4
|
||||
#%patch4 -p1 -b .gcc_static
|
||||
|
||||
%build
|
||||
mandir=%{_mandir}
|
||||
%make \
|
||||
-j1 \
|
||||
INS_BASE=%{_prefix} \
|
||||
MANDIR=%{_mandir} \
|
||||
DEFINSUSR=root \
|
||||
DEFINSGRP=cdrecording
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
%makeinstall \
|
||||
INS_BASE=%{_prefix}
|
||||
|
||||
## fix permissions
|
||||
#chmod 644 %{buildroot}%{_libdir}/*.a
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf %{buildroot}
|
||||
|
||||
%pre
|
||||
/usr/sbin/groupadd cdrecording -g %{group_cdrecording} 2>/dev/null
|
||||
:
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%config(noreplace) %{_sysconfdir}/default/cdrecord
|
||||
%config(noreplace) %{_sysconfdir}/default/rscsi
|
||||
%{_bindir}/cdda2wav
|
||||
%attr(4710,root,cdrecording) %{_bindir}/cdrecord
|
||||
%{_bindir}/devdump
|
||||
%{_bindir}/isodebug
|
||||
%{_bindir}/isodump
|
||||
%{_bindir}/isoinfo
|
||||
%{_bindir}/isovfy
|
||||
%{_bindir}/mkhybrid
|
||||
%{_bindir}/mkisofs
|
||||
%{_bindir}/btcflash
|
||||
%{_bindir}/scgskeleton
|
||||
%{_bindir}/cdda2mp3
|
||||
%{_bindir}/cdda2ogg
|
||||
%{_libdir}/siconv/*
|
||||
%{_mandir}/man1/*
|
||||
%{_mandir}/man5/*
|
||||
%{_mandir}/man8/*
|
||||
%attr(0750,root,cdrecording) %{_bindir}/readcd
|
||||
%{_bindir}/scgcheck
|
||||
#%{_bindir}/skel
|
||||
%{_sbindir}/rscsi
|
||||
%{_docdir}/cdda2wav/README
|
||||
%{_docdir}/cdrecord/README*
|
||||
%{_docdir}/libparanoia/README.*
|
||||
%{_docdir}/mkisofs/README*
|
||||
%doc GPL-2.0.txt LGPL-2.1.txt
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/schily/*.h
|
||||
%{_includedir}/schily/*-linux-cc/*.h
|
||||
%{_includedir}/scg/*.h
|
||||
%{_libdir}/*.a
|
||||
%{_libdir}/profiled/*.a
|
||||
%{_docdir}/rscsi/default-rscsi.sample
|
||||
%doc AN-* Changelog
|
||||
%doc ABOUT CDDL.Schily.txt
|
||||
%doc README.linux-shm README.mkisofs
|
||||
|
||||
%changelog
|
||||
* Sat Mar 08 2014 Automatic Build System <autodist@mambasoft.it> 3.01a23-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Jan 21 2014 Automatic Build System <autodist@mambasoft.it> 3.01a22-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Jan 12 2014 Automatic Build System <autodist@mambasoft.it> 3.01a21-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Dec 31 2013 Automatic Build System <autodist@mambasoft.it> 3.01a20-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Nov 23 2013 Automatic Build System <autodist@mambasoft.it> 3.01a19-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Oct 20 2013 Automatic Build System <autodist@mambasoft.it> 3.01a18-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Aug 06 2013 Automatic Build System <autodist@mambasoft.it> 3.01a17-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Jul 11 2013 Automatic Build System <autodist@mambasoft.it> 3.01a16-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jun 03 2013 Automatic Build System <autodist@mambasoft.it> 3.01a15-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Apr 22 2013 Automatic Build System <autodist@mambasoft.it> 3.01a14-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Mar 01 2013 Automatic Build System <autodist@mambasoft.it> 3.01a13-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Feb 19 2013 Automatic Build System <autodist@mambasoft.it> 3.01a12-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Jan 13 2013 Automatic Build System <autodist@mambasoft.it> 3.01a11-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Dec 27 2012 Automatic Build System <autodist@mambasoft.it> 3.01a10-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Oct 17 2011 Silvan Calarco <silvan.calarco@mambasoft.it> 3.01a05-2mamba
|
||||
- set cdrecord suid 4710 root.cdrecording
|
||||
|
||||
* Sun Jun 19 2011 Automatic Build System <autodist@mambasoft.it> 3.01a05-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri May 20 2011 Automatic Build System <autodist@mambasoft.it> 3.01a04-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Mar 13 2011 Automatic Build System <autodist@mambasoft.it> 3.01a03-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Mon Dec 27 2010 Automatic Build System <autodist@mambasoft.it> 3.01a02-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Nov 25 2010 Automatic Build System <autodist@mambasoft.it> 3.01a01-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Sun Aug 15 2010 Automatic Build System <autodist@mambasoft.it> 2.01.01a80-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Wed Jun 02 2010 Silvan Calarco <silvan.calarco@mambasoft.it> 2.01.01a39-1mamba
|
||||
- set real package version
|
||||
- use globbing in files lists
|
||||
- updated license
|
||||
|
||||
* Wed Jun 02 2010 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 2.01.01-2mamba
|
||||
- update to 2.01.01a79
|
||||
|
||||
* Thu Nov 04 2009 Ercole 'ercolinux' Carpanetto <ercole69@gmail.com> 2.01.01a67
|
||||
- update to 2.01.01a67
|
||||
|
||||
* Thu Dec 06 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.01-6mamba
|
||||
- removed man page for missing cdda2ogg tool
|
||||
- removed makefiles and makefiles man pages
|
||||
|
||||
* Mon Nov 26 2007 Silvan Calarco <silvan.calarco@mambasoft.it> 2.01-5mamba
|
||||
- revert to previous patchlevel and version (2.01) due to problems in 2.0.1-4mamba
|
||||
|
||||
* Thu Nov 15 2007 Aleph0 <aleph0@openmamba.org> 2.01-4mamba
|
||||
- update to 2.01.01a05
|
||||
- updated patches from crashrecovery.org
|
||||
|
||||
* Thu Mar 16 2006 Davide Madrisan <davide.madrisan@qilinux.it> 2.01-3qilnx
|
||||
- create the cdrecording group
|
||||
- added (again?) patch to fix CAN-2004-0806
|
||||
- fixed gcc4 compilation errors
|
||||
|
||||
* Mon Feb 07 2005 Silvan Calarco <silvan.calarco@mambasoft.it> 2.01-2qilnx
|
||||
- make cdrecord and cdread not suid because of kernel 2.6 behaviour
|
||||
- added OSS DVD extensions patch from http://crashrecovery.org/oss-dvd.html
|
||||
|
||||
* Tue Sep 14 2004 Davide Madrisan <davide.madrisan@qilinux.it> 2.01-1qilnx
|
||||
- update to version 2.01 by autospec.
|
||||
fix a local root vulnerability: CAN-2004-0806
|
||||
|
||||
* Mon Dec 15 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 2.00.3-3qilnx
|
||||
- readcd suided
|
||||
|
||||
* Tue Oct 14 2003 Silvan Calarco <silvan.calarco@mambasoft.it> 2.00.3-2qilnx
|
||||
- changed group name from cdwriter to cdrecording
|
||||
|
||||
* Thu Jul 10 2003 Silvan Calarco <silvan.calarco@qinet.it> 2.00.3-1qilnx
|
||||
- first build for cdrtools
|
Loading…
Reference in New Issue
Block a user