update to 3.2.17.1

added a patch to remove making a backup of home dotfiles in case of partition reuse [release 3.2.17.1-1mamba;Sat Dec 21 2019]
This commit is contained in:
Silvan Calarco 2024-01-05 21:03:42 +01:00
parent d2a02bd5bb
commit 2250c69620
3 changed files with 53 additions and 7 deletions

View File

@ -0,0 +1,10 @@
--- calamares-3.2.17.1/src/libcalamares/CMakeLists.txt.orig 2019-12-22 17:08:29.322000000 +0100
+++ calamares-3.2.17.1/src/libcalamares/CMakeLists.txt 2019-12-22 17:07:28.115000000 +0100
@@ -125,6 +125,7 @@
Qt5::Core
KF5::CoreAddons
${OPTIONAL_PUBLIC_LIBRARIES}
+ boost_python36
)
install( TARGETS calamares

View File

@ -0,0 +1,24 @@
--- calamares-3.2.17.1/src/modules/users/CreateUserJob.cpp.orig 2019-12-21 18:59:25.196000000 +0100
+++ calamares-3.2.17.1/src/modules/users/CreateUserJob.cpp 2019-12-21 18:59:51.859000000 +0100
@@ -130,21 +130,6 @@
}
}
- // If we're looking to reuse the contents of an existing /home
- if ( gs->value( "reuseHome" ).toBool() )
- {
- QString shellFriendlyHome = "/home/" + m_userName;
- QDir existingHome( destDir.absolutePath() + shellFriendlyHome );
- if ( existingHome.exists() )
- {
- QString backupDirName = "dotfiles_backup_" + QDateTime::currentDateTime().toString( "yyyy-MM-dd_HH-mm-ss" );
- existingHome.mkdir( backupDirName );
-
- CalamaresUtils::System::instance()->targetEnvCall(
- { "sh", "-c", "mv -f " + shellFriendlyHome + "/.* " + shellFriendlyHome + "/" + backupDirName } );
- }
- }
-
cDebug() << "[CREATEUSER]: creating user";
QStringList useradd { "useradd", "-m", "-U" };

View File

@ -1,6 +1,6 @@
Name: calamares
Version: 3.2.15
Release: 2mamba
Version: 3.2.17.1
Release: 1mamba
Summary: Distribution-independent installer framework
Group: Graphical Desktop/Applications/Utilities
Vendor: openmamba
@ -19,6 +19,8 @@ Patch6: calamares-1.0.1-replace_chroot_call.patch
Patch7: calamares-1.1.2-openmamba_autopartitioning.patch
Patch8: calamares-3.2.2-python-3.3.patch
Patch9: calamares-3.2.15-skip-partition-if-minsize-less-than-available-size.patch
Patch10: calamares-3.2.17.1-dont-backup-dotfiles.patch
Patch11: calamares-3.2.17.1-boost-python36-link-fix.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -47,7 +49,7 @@ BuildRequires: libkxmlgui-devel
BuildRequires: libparted-devel
BuildRequires: libplasma-framework-devel
BuildRequires: libpwquality-devel
BuildRequires: libpython36-devel
BuildRequires: libpython3-devel
BuildRequires: libqt5-devel
BuildRequires: libsonnet-devel
BuildRequires: libstdc++6-devel
@ -57,6 +59,7 @@ BuildRequires: libyaml-cpp-devel
BuildRequires: cmake
BuildRequires: libpolkit-qt5-1-devel
BuildRequires: libboost-devel >= 1.57.0-3mamba
BuildRequires: python-boost-py36
#BuildRequires: libkpmcore-devel >= 4.0.0
BuildRequires: python36
BuildRequires: libPythonQt-devel
@ -69,6 +72,7 @@ Requires: squashfs
Requires: gptfdisk
Requires: ckbcomp
Requires: python36
Requires: python-boost-py36
Requires: lib%{name} = %{?epoch:%epoch:}%{version}-%{release}
BuildRoot: %{_tmppath}/%{name}-%{version}-root
@ -97,17 +101,20 @@ This package contains libraries and header files for developing applications tha
#-D -T
#:<< _EOF
%patch4 -p1
%patch8 -p1
#%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
sed -i "s|PYTHONLIBS_VERSION 3.3|PYTHONLIBS_VERSION 3.6|" CMakeLists.txt
#sed -i "s|PYTHONLIBS_VERSION 3.3|PYTHONLIBS_VERSION 3.6|" CMakeLists.txt
%build
#:<< _EOF
%cmake -d build \
-DWITH_PARTITIONMANAGER=ON \
-DKI18N_PYTHON_EXECUTABLE:FILEPATH=%{__python36} \
-DWITH_PYTHON=ON
-DWITH_PYTHON=ON \
-DWITH_PYTHONQT=ON
%make
@ -182,6 +189,8 @@ install -D -m0755 src/branding/default/squid.png %{buildroot}%{_datadir}/pixmaps
%{_libdir}/calamares/modules/fstab/*
%dir %{_libdir}/calamares/modules/grubcfg
%{_libdir}/calamares/modules/grubcfg/*
%dir %{_libdir}/calamares/modules/hostinfo
%{_libdir}/calamares/modules/hostinfo/*
%dir %{_libdir}/calamares/modules/hwclock
%{_libdir}/calamares/modules/hwclock/*
%dir %{_libdir}/calamares/modules/initcpio
@ -271,8 +280,11 @@ install -D -m0755 src/branding/default/squid.png %{buildroot}%{_datadir}/pixmaps
%{_libdir}/libcalamaresui.so
#%doc README.md
%changelog
* Sat Dec 21 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.17.1-1mamba
- update to 3.2.17.1
- added a patch to remove making a backup of home dotfiles in case of partition reuse
* Sat Oct 12 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.15-2mamba
- added a patch to skip creating a partition if minSize is less than available size (for /home)