added a patch to skip creating a partition if minSize is less than available size (for /home) [release 3.2.15-2mamba;Sat Oct 12 2019]

This commit is contained in:
Silvan Calarco 2024-01-05 21:03:42 +01:00
parent 071c4cb07e
commit d2a02bd5bb
2 changed files with 25 additions and 2 deletions

View File

@ -0,0 +1,15 @@
--- calamares-3.2.15/src/modules/partition/core/PartitionLayout.cpp.orig 2019-10-12 12:00:31.660000000 +0200
+++ calamares-3.2.15/src/modules/partition/core/PartitionLayout.cpp 2019-10-12 12:01:10.894000000 +0200
@@ -179,6 +179,12 @@
else
minSize = 0;
+ if ( availableSize < 5 * 1024 * 1024) {
+ cWarning() << "Partition" << part.partMountPoint << "available size"
+ << "is insufficient to add partition, skipping...";
+ continue;
+ }
+
if ( part.partMaxSize.isValid() )
maxSize = part.partMaxSize.toSectors( totalSize, dev->logicalSize() );
else

View File

@ -1,6 +1,6 @@
Name: calamares
Version: 3.2.14
Release: 1mamba
Version: 3.2.15
Release: 2mamba
Summary: Distribution-independent installer framework
Group: Graphical Desktop/Applications/Utilities
Vendor: openmamba
@ -18,6 +18,7 @@ Patch5: calamares-1.0.1-locale_use_LANG.patch
Patch6: calamares-1.0.1-replace_chroot_call.patch
Patch7: calamares-1.1.2-openmamba_autopartitioning.patch
Patch8: calamares-3.2.2-python-3.3.patch
Patch9: calamares-3.2.15-skip-partition-if-minsize-less-than-available-size.patch
License: GPL
## AUTOBUILDREQ-BEGIN
BuildRequires: glibc-devel
@ -97,6 +98,7 @@ This package contains libraries and header files for developing applications tha
#:<< _EOF
%patch4 -p1
%patch8 -p1
%patch9 -p1
sed -i "s|PYTHONLIBS_VERSION 3.3|PYTHONLIBS_VERSION 3.6|" CMakeLists.txt
@ -271,6 +273,12 @@ install -D -m0755 src/branding/default/squid.png %{buildroot}%{_datadir}/pixmaps
%changelog
* Sat Oct 12 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.15-2mamba
- added a patch to skip creating a partition if minSize is less than available size (for /home)
* Sat Oct 12 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.15-1mamba
- update to 3.2.15
* Sat Oct 05 2019 Silvan Calarco <silvan.calarco@mambasoft.it> 3.2.14-1mamba
- update to 3.2.14