renamed from bluez5 to bluez [release 5.47-2mamba;Sat Nov 04 2017]
This commit is contained in:
parent
9a41fd3c28
commit
baea4e99ef
@ -1,12 +0,0 @@
|
||||
diff --git a/scripts/bluetooth-serial.rules b/scripts/bluetooth-serial.rules
|
||||
index 072335f..f6284ff 100644
|
||||
--- a/scripts/bluetooth-serial.rules
|
||||
+++ b/scripts/bluetooth-serial.rules
|
||||
@@ -33,3 +33,7 @@ SUBSYSTEM=="tty", SUBSYSTEMS=="pcmcia", ATTRS{prod_id1}=="PCMCIA", ATTRS{prod_id
|
||||
|
||||
# CC&C BT0100M
|
||||
SUBSYSTEM=="tty", SUBSYSTEMS=="pcmcia", ATTRS{prod_id1}=="Bluetooth BT0100M", ENV{HCIOPTS}="bcsp 115200", RUN+="bluetooth_serial"
|
||||
+
|
||||
+# SocketMobile CF Connection Kit
|
||||
+SUBSYSTEM=="tty", SUBSYSTEMS=="pcmcia", ATTRS{prod_id1}=="Socket", ATTRS{prod_id2}=="CF+ Personal Network Card Rev 2.5", ENV{HCIOPTS}="socket", RUN+="bluetooth_serial"
|
||||
+
|
@ -1,33 +0,0 @@
|
||||
Index: src/oui.c
|
||||
===================================================================
|
||||
RCS file: /cvsroot/bluez/utils/common/oui.c,v
|
||||
retrieving revision 1.2
|
||||
diff -u -p -r1.2 oui.c
|
||||
--- src/oui.c 13 Jan 2007 17:48:12 -0000 1.2
|
||||
+++ src/oui.c 25 Jan 2008 12:16:58 -0000
|
||||
@@ -38,7 +38,7 @@
|
||||
|
||||
/* http://standards.ieee.org/regauth/oui/oui.txt */
|
||||
|
||||
-#define OUIFILE "/var/lib/misc/oui.txt"
|
||||
+#define OUIFILE "/usr/share/hwdata/oui.txt"
|
||||
|
||||
char *ouitocomp(const char *oui)
|
||||
{
|
||||
@@ -46,14 +46,9 @@ char *ouitocomp(const char *oui)
|
||||
char *str, *map, *off, *end;
|
||||
int fd;
|
||||
|
||||
- fd = open("oui.txt", O_RDONLY);
|
||||
+ fd = open(OUIFILE, O_RDONLY);
|
||||
if (fd < 0) {
|
||||
- fd = open(OUIFILE, O_RDONLY);
|
||||
- if (fd < 0) {
|
||||
- fd = open("/usr/share/misc/oui.txt", O_RDONLY);
|
||||
- if (fd < 0)
|
||||
- return NULL;
|
||||
- }
|
||||
+ return NULL;
|
||||
}
|
||||
|
||||
if (fstat(fd, &st) < 0) {
|
@ -1,23 +0,0 @@
|
||||
diff --git a/src/security.c b/src/security.c
|
||||
index 905cf61..67fd266 100644
|
||||
--- a/src/security.c
|
||||
+++ b/src/security.c
|
||||
@@ -705,8 +705,16 @@ static inline void remote_name_information(int dev, bdaddr_t *sba, void *ptr)
|
||||
memcpy(name, evt->name, MAX_NAME_LENGTH);
|
||||
/* It's ok to cast end between const and non-const since
|
||||
* we know it points to inside of name which is non-const */
|
||||
- if (!g_utf8_validate(name, -1, (const char **) &end))
|
||||
- *end = '\0';
|
||||
+ if (!g_utf8_validate(name, -1, (const char **) &end)) {
|
||||
+ char *utf8_name;
|
||||
+
|
||||
+ utf8_name = g_convert(name, -1, "UTF-8", "ISO-8859-1", NULL, NULL, NULL);
|
||||
+ if (utf8_name) {
|
||||
+ memcpy(name, utf8_name, 248);
|
||||
+ g_free(utf8_name);
|
||||
+ } else
|
||||
+ *end = '\0';
|
||||
+ }
|
||||
write_device_name(sba, &dba, name);
|
||||
}
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff --git a/input/device.c b/input/device.c
|
||||
index 0090bd4..8d65148 100644
|
||||
--- a/input/device.c
|
||||
+++ b/input/device.c
|
||||
@@ -658,6 +658,19 @@ static int hidp_add_connection(const struct input_device *idev,
|
||||
err = write(sk, buf, sizeof(buf));
|
||||
}
|
||||
|
||||
+ if (req->vendor == 0x056a && req->product == 0x81) {
|
||||
+ unsigned char buf[3];
|
||||
+ int sk = g_io_channel_unix_get_fd(iconn->ctrl_io);
|
||||
+
|
||||
+ buf[0] = 0x53; /* HIDP_TRANS_SET_REPORT | HIDP_DATA_RTYPE_FEATURE */
|
||||
+ buf[1] = 0x03; buf[2] = 0x00;
|
||||
+ write(sk, buf, sizeof(buf));
|
||||
+
|
||||
+ buf[0] = 0x71; /* HIDP_TRANS_SET_REPORT | HIDP_DATA_RTYPE_FEATURE */
|
||||
+ /* 0x06 - high reporting speed, 0x05 - low speed */
|
||||
+ buf[1] = 0x06; buf[2] = 0x00;
|
||||
+ write(sk, buf, sizeof(buf));
|
||||
+ }
|
||||
err = ioctl_connadd(req);
|
||||
|
||||
cleanup:
|
@ -1,60 +0,0 @@
|
||||
diff -ru bluez-utils-2.11.orig/hcid/hcid.conf bluez-utils-2.11/hcid/hcid.conf
|
||||
--- bluez-utils-2.11.orig/hcid/hcid.conf 2004-11-11 19:42:31.000000000 +0100
|
||||
+++ bluez-utils-2.11/hcid/hcid.conf 2004-12-01 09:30:57.000000000 +0100
|
||||
@@ -14,7 +14,7 @@
|
||||
# auto - Use local PIN for incoming connections
|
||||
# user - Always ask user for a PIN
|
||||
#
|
||||
- security auto;
|
||||
+ security user;
|
||||
|
||||
# Pairing mode
|
||||
# none - Pairing disabled
|
||||
@@ -23,7 +23,7 @@
|
||||
pairing multi;
|
||||
|
||||
# PIN helper
|
||||
- pin_helper /usr/bin/bluepin;
|
||||
+ pin_helper /usr/lib/kdebluetooth/kbluepin;
|
||||
|
||||
# D-Bus PIN helper
|
||||
#dbus_pin_helper;
|
||||
diff -ru bluez-utils-2.11.orig/scripts/bluetooth.init bluez-utils-2.11/scripts/bluetooth.init
|
||||
--- bluez-utils-2.11.orig/scripts/bluetooth.init 2004-05-08 00:57:34.000000000 +0200
|
||||
+++ bluez-utils-2.11/scripts/bluetooth.init 2004-12-01 09:32:35.000000000 +0100
|
||||
@@ -2,7 +2,10 @@
|
||||
#
|
||||
# Start/stop the Bluetooth daemons
|
||||
#
|
||||
-
|
||||
+# chkconfig: 2345 95 5
|
||||
+# processname: hcid spd hidd
|
||||
+# description: bluetooth service
|
||||
+#
|
||||
set -e
|
||||
|
||||
PATH=/sbin:/bin:/usr/sbin:/usr/bin
|
||||
@@ -40,7 +43,7 @@
|
||||
DUND_OPTIONS=""
|
||||
PAND_OPTIONS=""
|
||||
|
||||
-[ -e /etc/default/bluetooth ] && . /etc/default/bluetooth
|
||||
+[ -e /etc/sysconfig/bluetooth ] && . /etc/sysconfig/bluetooth
|
||||
|
||||
case "$1" in
|
||||
start)
|
||||
@@ -93,9 +96,13 @@
|
||||
echo -n " $HCID_NAME"
|
||||
echo "."
|
||||
;;
|
||||
+ restart)
|
||||
+ stop
|
||||
+ start
|
||||
+ ;;
|
||||
*)
|
||||
N=/etc/init.d/$NAME
|
||||
- echo "Usage: $N {start|stop}" >&2
|
||||
+ echo "Usage: $N {start|stop|restart}" >&2
|
||||
exit 1
|
||||
;;
|
||||
esac
|
@ -1,38 +0,0 @@
|
||||
diff -Nru bluez-utils-3.9.orig/scripts/bluetooth.init bluez-utils-3.9/scripts/bluetooth.init
|
||||
--- bluez-utils-3.9.orig/scripts/bluetooth.init 2007-01-28 21:16:47.000000000 +0100
|
||||
+++ bluez-utils-3.9/scripts/bluetooth.init 2007-03-06 13:57:46.000000000 +0100
|
||||
@@ -2,6 +2,10 @@
|
||||
#
|
||||
# Start/stop the Bluetooth daemons
|
||||
#
|
||||
+# chkconfig: 2345 98 5
|
||||
+# processname: hcid spd hidd
|
||||
+# description: bluetooth service
|
||||
+#
|
||||
|
||||
set -e
|
||||
|
||||
@@ -40,7 +44,7 @@
|
||||
DUND_OPTIONS=""
|
||||
PAND_OPTIONS=""
|
||||
|
||||
-[ -e /etc/default/bluetooth ] && . /etc/default/bluetooth
|
||||
+[ -e /etc/sysconfig/bluetooth ] && . /etc/sysconfig/bluetooth
|
||||
|
||||
case "$1" in
|
||||
start)
|
||||
@@ -97,9 +101,13 @@
|
||||
echo -n " $HCID_NAME"
|
||||
echo "."
|
||||
;;
|
||||
+ restart)
|
||||
+ $0 stop
|
||||
+ $0 start
|
||||
+ ;;
|
||||
*)
|
||||
N=/etc/init.d/$NAME
|
||||
- echo "Usage: $N {start|stop}" >&2
|
||||
+ echo "Usage: $N {start|stop|restart}" >&2
|
||||
exit 1
|
||||
;;
|
||||
esac
|
285
bluez.spec
285
bluez.spec
@ -1,41 +1,36 @@
|
||||
Name: bluez
|
||||
Version: 4.101
|
||||
Release: 3mamba
|
||||
Version: 5.47
|
||||
Release: 2mamba
|
||||
Summary: Userspace tools for the Bluetooth wireless library for Linux
|
||||
Group: Applications/Communication
|
||||
Vendor: openmamba
|
||||
Distribution: openmamba
|
||||
Packager: Silvan Calarco <silvan.calarco@mambasoft.it>
|
||||
URL: http://www.bluez.org
|
||||
Source: http://www.kernel.org/pub/linux/bluetooth/bluez-%{version}.tar.xz
|
||||
Patch0: bluez-utils-2.11-config.patch
|
||||
Patch1: bluez-utils-3.9-initscript.patch
|
||||
Patch2: bluez-4.59-oui.patch
|
||||
Patch3: bluez-4.59-utf8.patch
|
||||
Patch4: bluez-4.59-wacom.patch
|
||||
Patch5: bluez-4.59-cf.patch
|
||||
Source: http://www.kernel.org/pub/linux/bluetooth/bluez-%{version}.tar.gz
|
||||
Patch0: bluez5-5.41-mode-43xx-firmware-into-lib-firmware.patch
|
||||
Patch1: bluez5-5.41-bcm43xx-Add-bcm43xx-3wire-variant.patch
|
||||
Patch2: bluez5-5.41-bcm43xx-The-UART-speed-must-be-reset-after-the-firmw.patch
|
||||
Patch3: bluez5-5.41-Increase-firmware-load-timeout-to-30s.patch
|
||||
License: GPL
|
||||
## AUTOBUILDREQ-BEGIN
|
||||
BuildRequires: glibc-devel
|
||||
BuildRequires: libalsa-devel
|
||||
BuildRequires: libdbus-devel
|
||||
BuildRequires: libglib-devel
|
||||
%if "%{stage1}" != "1"
|
||||
BuildRequires: libgst-plugins-base010-devel
|
||||
BuildRequires: libgstreamer010-devel
|
||||
%endif
|
||||
BuildRequires: libical-devel
|
||||
BuildRequires: libreadline-devel
|
||||
BuildRequires: libtermcap-devel
|
||||
BuildRequires: libudev-devel
|
||||
BuildRequires: libusb-compat-devel
|
||||
BuildRequires: libxml2-devel
|
||||
## AUTOBUILDREQ-END
|
||||
BuildRequires: flex
|
||||
BuildRequires: bison
|
||||
BuildRequires: libcap-ng-devel
|
||||
BuildRequires: systemd-devel
|
||||
Requires: bluez-firmware
|
||||
Requires: libbluetooth = %{version}-%{release}
|
||||
Provides: bluez-utils
|
||||
Obsoletes: bluez-utils
|
||||
Conflicts: bluez4
|
||||
Provides: bluez5
|
||||
Obsoletes: bluez5
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
|
||||
%description
|
||||
@ -44,6 +39,9 @@ Userspace tools for the Bluetooth wireless library for Linux.
|
||||
%package -n libbluetooth
|
||||
Group: System/Libraries
|
||||
Summary: The Bluetooth wireless library for Linux
|
||||
Conflicts: libbluetooth4
|
||||
Provides: libbluetooth5
|
||||
Obsoletes: libbluetooth5
|
||||
|
||||
%description -n libbluetooth
|
||||
The Bluetooth wireless library for Linux.
|
||||
@ -52,8 +50,9 @@ The Bluetooth wireless library for Linux.
|
||||
Group: Development/Libraries
|
||||
Summary: Static libraries and headers for libbluetooth
|
||||
Requires: libbluetooth = %{version}-%{release}
|
||||
Provides: libbluez-devel
|
||||
Obsoletes: libbluez-devel
|
||||
Conflicts: libbluetooth4-devel
|
||||
Provides: libbluetooth5-devel
|
||||
Obsoletes: libbluetooth5-devel
|
||||
|
||||
%description -n libbluetooth-devel
|
||||
The Bluetooth wireless library for Linux.
|
||||
@ -61,65 +60,32 @@ The Bluetooth wireless library for Linux.
|
||||
This package contains static libraries and header files need for development.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch0 -p1
|
||||
#%patch1 -p1
|
||||
#%patch2 -p0
|
||||
#%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
%setup -q -n bluez-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--libexecdir=/lib \
|
||||
--enable-health \
|
||||
--enable-pnat \
|
||||
--enable-attrib \
|
||||
%if "%{stage1}" == "1"
|
||||
--disable-gstreamer \
|
||||
%else
|
||||
--enable-gstreamer \
|
||||
%endif
|
||||
--enable-alsa \
|
||||
--libexecdir=/%{_lib} \
|
||||
--enable-usb \
|
||||
--enable-tracer \
|
||||
--enable-tools \
|
||||
--enable-bccmd \
|
||||
--enable-pcmcia \
|
||||
--enable-hid2hci \
|
||||
--enable-dfutool \
|
||||
--enable-hidd \
|
||||
--enable-pand \
|
||||
--enable-dund \
|
||||
--enable-deprecated \
|
||||
--enable-cups \
|
||||
--enable-udevrules \
|
||||
--enable-configfiles \
|
||||
--disable-hal \
|
||||
--enable-capng \
|
||||
--enable-input \
|
||||
--enable-audio \
|
||||
--enable-serial \
|
||||
--enable-network
|
||||
--enable-library \
|
||||
LIBS="-ltermcap"
|
||||
|
||||
# --enable-initscripts \
|
||||
# --enable-pcmciarules
|
||||
|
||||
%make cupsdir=%{_prefix}/lib/cups/backend
|
||||
%make
|
||||
|
||||
%install
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
%makeinstall \
|
||||
cupsdir=%{_prefix}/lib/cups/backend \
|
||||
rulesdir=%{_sysconfdir}/udev/rules.d
|
||||
|
||||
install -D -m0644 audio/audio.conf %{buildroot}%{_sysconfdir}/bluetooth/audio.conf
|
||||
install -D -m0644 input/input.conf %{buildroot}%{_sysconfdir}/bluetooth/input.conf
|
||||
install -D -m0644 serial/serial.conf %{buildroot}%{_sysconfdir}/bluetooth/serial.conf
|
||||
|
||||
#install -D -m755 scripts/bluetooth.init \
|
||||
# %{buildroot}%{_initrddir}/bluetooth
|
||||
#install -D -m644 scripts/bluetooth.default \
|
||||
# %{buildroot}%{_sysconfdir}/sysconfig/bluetooth
|
||||
for f in network input; do
|
||||
install -D -m0644 profiles/$f/$f.conf %{buildroot}%{_sysconfdir}/bluetooth/$f.conf
|
||||
done
|
||||
|
||||
%clean
|
||||
[ "%{buildroot}" != / ] && rm -rf "%{buildroot}"
|
||||
@ -134,87 +100,156 @@ install -D -m0644 serial/serial.conf %{buildroot}%{_sysconfdir}/bluetooth/seria
|
||||
%post -n libbluetooth -p /sbin/ldconfig
|
||||
%postun -n libbluetooth -p /sbin/ldconfig
|
||||
|
||||
%preun
|
||||
if [ $1 -eq 0 ]; then
|
||||
systemctl -q stop bluetooth
|
||||
systemctl -q disable bluetooth
|
||||
fi
|
||||
:
|
||||
|
||||
%posttrans
|
||||
if [ $1 -ge 1 ]; then
|
||||
systemctl -q daemon-reload
|
||||
systemctl -q enable bluetooth
|
||||
systemctl -q start bluetooth
|
||||
fi
|
||||
:
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%config(noreplace) %{_sysconfdir}/bluetooth/*
|
||||
#%config(noreplace) %{_sysconfdir}/sysconfig/bluetooth
|
||||
%config %{_sysconfdir}/dbus-1/system.d/bluetooth.conf
|
||||
#%config %{_sysconfdir}/default/bluetooth
|
||||
#%{_sysconfdir}/udev/rules.d/97-bluetooth.rules
|
||||
%{_sysconfdir}/udev/rules.d/97-bluetooth-hid2hci.rules
|
||||
%{_sysconfdir}/udev/rules.d/97-bluetooth-serial.rules
|
||||
#%{_initrddir}/bluetooth
|
||||
/lib/udev/bluetooth_serial
|
||||
/lib/udev/hid2hci
|
||||
/lib/systemd/system/bluetooth.service
|
||||
%{_datadir}/dbus-1/system-services/org.bluez.service
|
||||
%{_sysconfdir}/udev/rules.d/97-hid2hci.rules
|
||||
%{_bindir}/*
|
||||
%{_sbindir}/*
|
||||
%{_datadir}/alsa/bluetooth.conf
|
||||
/lib/udev/hid2hci
|
||||
#/lib/udev/rules.d/97-hid2hci.rules
|
||||
/%{_lib}/bluetooth/bluetoothd
|
||||
/%{_lib}/bluetooth/obexd
|
||||
/lib/systemd/system/bluetooth.service
|
||||
%{_prefix}/lib/systemd/user/obex.service
|
||||
%{_libdir}/cups/backend/bluetooth
|
||||
%{_datadir}/dbus-1/services/org.bluez.obex.service
|
||||
%{_datadir}/dbus-1/system-services/org.bluez.service
|
||||
%{_mandir}/man1/*
|
||||
%{_mandir}/man8/*
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files -n libbluetooth
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libbluetooth.so.*
|
||||
#%{_libdir}/bluetooth/plugins/audio.la
|
||||
#%{_libdir}/bluetooth/plugins/audio.so
|
||||
#%{_libdir}/bluetooth/plugins/hal.la
|
||||
#%{_libdir}/bluetooth/plugins/hal.so
|
||||
#%{_libdir}/bluetooth/plugins/input.la
|
||||
#%{_libdir}/bluetooth/plugins/input.so
|
||||
#%{_libdir}/bluetooth/plugins/netlink.la
|
||||
#%{_libdir}/bluetooth/plugins/netlink.so
|
||||
#%{_libdir}/bluetooth/plugins/network.la
|
||||
#%{_libdir}/bluetooth/plugins/network.so
|
||||
#%{_libdir}/bluetooth/plugins/serial.la
|
||||
#%{_libdir}/bluetooth/plugins/serial.so
|
||||
#%{_libdir}/bluetooth/plugins/service.la
|
||||
#%{_libdir}/bluetooth/plugins/service.so
|
||||
%{_libdir}/alsa-lib/libasound_module_ctl_bluetooth.la
|
||||
%{_libdir}/alsa-lib/libasound_module_ctl_bluetooth.so
|
||||
%{_libdir}/alsa-lib/libasound_module_pcm_bluetooth.la
|
||||
%{_libdir}/alsa-lib/libasound_module_pcm_bluetooth.so
|
||||
%{_prefix}/lib/cups/backend/bluetooth
|
||||
%if "%{stage1}" != "1"
|
||||
%{_libdir}/gstreamer-0.10/libgstbluetooth.la
|
||||
%{_libdir}/gstreamer-0.10/libgstbluetooth.so
|
||||
%endif
|
||||
%doc ChangeLog README
|
||||
#%{_prefix}/libexec/udev/bluetooth_serial
|
||||
%doc AUTHORS COPYING
|
||||
|
||||
%files -n libbluetooth-devel
|
||||
%defattr(-,root,root)
|
||||
%dir %{_includedir}/bluetooth
|
||||
%{_includedir}/bluetooth/*.h
|
||||
%{_libdir}/libbluetooth.la
|
||||
%{_libdir}/libbluetooth.so
|
||||
%{_libdir}/pkgconfig/bluez.pc
|
||||
%doc ChangeLog README
|
||||
|
||||
%changelog
|
||||
* Wed Nov 26 2014 Silvan Calarco <silvan.calarco@mambasoft.it> 4.101-3mamba
|
||||
- x86_64: fix path of cups backend
|
||||
* Sat Nov 04 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 5.47-2mamba
|
||||
- renamed from bluez5 to bluez
|
||||
|
||||
* Mon Jul 15 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.101-2mamba
|
||||
- enable and start bluetooth service upon install
|
||||
* Fri Oct 06 2017 Automatic Build System <autodist@mambasoft.it> 5.47-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Jul 10 2013 Silvan Calarco <silvan.calarco@mambasoft.it> 4.101-1mamba
|
||||
- update to 4.101
|
||||
* Thu Sep 07 2017 Silvan Calarco <silvan.calarco@mambasoft.it> 5.46-2mamba
|
||||
- rebuilt with tools
|
||||
|
||||
* Sun Jul 30 2017 Automatic Build System <autodist@mambasoft.it> 5.46-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat May 06 2017 Automatic Build System <autodist@mambasoft.it> 5.45-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Feb 28 2017 Automatic Build System <autodist@mambasoft.it> 5.44-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Oct 29 2016 Automatic Build System <autodist@mambasoft.it> 5.43-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Sep 26 2016 Automatic Build System <autodist@mambasoft.it> 5.42-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Jul 19 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 5.41-2mamba
|
||||
- added patches for bcm43430 (rpi3)
|
||||
- libbluetooth5: conflict with libbluetooth
|
||||
|
||||
* Mon Jul 18 2016 Automatic Build System <autodist@mambasoft.it> 5.41-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Jun 05 2016 Automatic Build System <autodist@mambasoft.it> 5.40-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Apr 05 2016 Automatic Build System <autodist@mambasoft.it> 5.39-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Mar 18 2016 Automatic Build System <autodist@mambasoft.it> 5.38-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Jan 03 2016 Silvan Calarco <silvan.calarco@mambasoft.it> 5.37-2mamba
|
||||
- renamed from bluez to bluez5; added conflict with bluez
|
||||
|
||||
* Mon Dec 28 2015 Automatic Build System <autodist@mambasoft.it> 5.37-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Nov 05 2015 Automatic Build System <autodist@mambasoft.it> 5.36-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Sep 28 2015 Automatic Build System <autodist@mambasoft.it> 5.35-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Sep 04 2015 Automatic Build System <autodist@mambasoft.it> 5.34-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Aug 18 2015 Automatic Build System <autodist@mambasoft.it> 5.33-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Jun 29 2014 Automatic Build System <autodist@mambasoft.it> 5.20-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat May 24 2014 Automatic Build System <autodist@mambasoft.it> 5.19-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Apr 21 2014 Automatic Build System <autodist@mambasoft.it> 5.18-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Apr 04 2014 Automatic Build System <autodist@mambasoft.it> 5.17-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Mar 11 2014 Automatic Build System <autodist@mambasoft.it> 5.16-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Feb 22 2014 Automatic Build System <autodist@mambasoft.it> 5.15-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Feb 01 2014 Automatic Build System <autodist@mambasoft.it> 5.14-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Dec 28 2013 Automatic Build System <autodist@mambasoft.it> 5.13-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Wed Dec 11 2013 Automatic Build System <autodist@mambasoft.it> 5.12-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Fri Nov 22 2013 Automatic Build System <autodist@mambasoft.it> 5.11-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Thu Oct 17 2013 Automatic Build System <autodist@mambasoft.it> 5.10-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Fri Sep 20 2013 Automatic Build System <autodist@mambasoft.it> 5.9-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue Aug 27 2013 Automatic Build System <autodist@mambasoft.it> 5.8-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Thu Jul 04 2013 Automatic Build System <autodist@mambasoft.it> 5.7-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Jun 23 2013 Automatic Build System <autodist@mambasoft.it> 5.6-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Tue May 28 2013 Automatic Build System <autodist@mambasoft.it> 5.5-1mamba
|
||||
- automatic update by autodist
|
||||
|
||||
* Tue Apr 16 2013 Automatic Build System <autodist@mambasoft.it> 5.4-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sat Mar 02 2013 Automatic Build System <autodist@mambasoft.it> 5.3-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Jan 21 2013 Automatic Build System <autodist@mambasoft.it> 5.1-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Mon Aug 13 2012 Automatic Build System <autodist@mambasoft.it> 4.101-1mamba
|
||||
- automatic version update by autodist
|
||||
|
||||
* Sun Jun 03 2012 Silvan Calarco <silvan.calarco@mambasoft.it> 4.99-1mamba
|
||||
- update to 4.99
|
||||
|
25
bluez5-5.41-Increase-firmware-load-timeout-to-30s.patch
Normal file
25
bluez5-5.41-Increase-firmware-load-timeout-to-30s.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From d41dc2046dd08d8c95197f677e224506f5b39bdd Mon Sep 17 00:00:00 2001
|
||||
From: Phil Elwell <phil@raspberrypi.org>
|
||||
Date: Wed, 20 Jan 2016 16:00:37 +0000
|
||||
Subject: [PATCH 3/4] Increase firmware load timeout to 30s
|
||||
|
||||
---
|
||||
tools/hciattach.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tools/hciattach.c b/tools/hciattach.c
|
||||
index 5861d33..4141796 100644
|
||||
--- a/tools/hciattach.c
|
||||
+++ b/tools/hciattach.c
|
||||
@@ -1293,7 +1293,7 @@ int main(int argc, char *argv[])
|
||||
{
|
||||
struct uart_t *u = NULL;
|
||||
int detach, printpid, raw, opt, i, n, ld, err;
|
||||
- int to = 10;
|
||||
+ int to = 30;
|
||||
int init_speed = 0;
|
||||
int send_break = 0;
|
||||
pid_t pid;
|
||||
--
|
||||
1.9.1
|
||||
|
26
bluez5-5.41-bcm43xx-Add-bcm43xx-3wire-variant.patch
Normal file
26
bluez5-5.41-bcm43xx-Add-bcm43xx-3wire-variant.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From b4f2b77472aeb967d3a7595e8a965785c7a37c87 Mon Sep 17 00:00:00 2001
|
||||
From: Phil Elwell <phil@raspberrypi.org>
|
||||
Date: Tue, 16 Feb 2016 16:40:46 +0000
|
||||
Subject: [PATCH 1/4] bcm43xx: Add bcm43xx-3wire variant
|
||||
|
||||
---
|
||||
tools/hciattach.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/tools/hciattach.c b/tools/hciattach.c
|
||||
index 59a76a7..5861d33 100644
|
||||
--- a/tools/hciattach.c
|
||||
+++ b/tools/hciattach.c
|
||||
@@ -1144,6 +1144,9 @@ struct uart_t uart[] = {
|
||||
{ "bcm43xx", 0x0000, 0x0000, HCI_UART_H4, 115200, 3000000,
|
||||
FLOW_CTL, DISABLE_PM, NULL, bcm43xx, NULL },
|
||||
|
||||
+ { "bcm43xx-3wire", 0x0000, 0x0000, HCI_UART_3WIRE, 115200, 3000000,
|
||||
+ 0, DISABLE_PM, NULL, bcm43xx, NULL },
|
||||
+
|
||||
{ "ath3k", 0x0000, 0x0000, HCI_UART_ATH3K, 115200, 115200,
|
||||
FLOW_CTL, DISABLE_PM, NULL, ath3k_ps, ath3k_pm },
|
||||
|
||||
--
|
||||
1.9.1
|
||||
|
@ -0,0 +1,37 @@
|
||||
From e145c9621f976063e5c573db1f2053d906f63427 Mon Sep 17 00:00:00 2001
|
||||
From: Phil Elwell <phil@raspberrypi.org>
|
||||
Date: Tue, 16 Feb 2016 16:39:09 +0000
|
||||
Subject: [PATCH 2/4] bcm43xx: The UART speed must be reset after the firmware download
|
||||
|
||||
---
|
||||
tools/hciattach_bcm43xx.c | 6 ++----
|
||||
1 file changed, 2 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/tools/hciattach_bcm43xx.c b/tools/hciattach_bcm43xx.c
|
||||
index 81f38cb..0b792e0 100644
|
||||
--- a/tools/hciattach_bcm43xx.c
|
||||
+++ b/tools/hciattach_bcm43xx.c
|
||||
@@ -366,11 +366,8 @@ int bcm43xx_init(int fd, int def_speed, int speed, struct termios *ti,
|
||||
return -1;
|
||||
|
||||
if (bcm43xx_locate_patch(FIRMWARE_DIR, chip_name, fw_path)) {
|
||||
- fprintf(stderr, "Patch not found, continue anyway\n");
|
||||
+ fprintf(stderr, "Patch not found for %s, continue anyway\n", chip_name);
|
||||
} else {
|
||||
- if (bcm43xx_set_speed(fd, ti, speed))
|
||||
- return -1;
|
||||
-
|
||||
if (bcm43xx_load_firmware(fd, fw_path))
|
||||
return -1;
|
||||
|
||||
@@ -380,6 +377,7 @@ int bcm43xx_init(int fd, int def_speed, int speed, struct termios *ti,
|
||||
return -1;
|
||||
}
|
||||
|
||||
+ sleep(1);
|
||||
if (bcm43xx_reset(fd))
|
||||
return -1;
|
||||
}
|
||||
--
|
||||
1.9.1
|
||||
|
25
bluez5-5.41-mode-43xx-firmware-into-lib-firmware.patch
Normal file
25
bluez5-5.41-mode-43xx-firmware-into-lib-firmware.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 76681284b0ea49852041fdb97a35175089a08781 Mon Sep 17 00:00:00 2001
|
||||
From: Phil Elwell <phil@raspberrypi.org>
|
||||
Date: Tue, 23 Feb 2016 17:52:29 +0000
|
||||
Subject: [PATCH 4/4] Move the 43xx firmware into /lib/firmware
|
||||
|
||||
---
|
||||
tools/hciattach_bcm43xx.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/tools/hciattach_bcm43xx.c b/tools/hciattach_bcm43xx.c
|
||||
index 0b792e0..207f668 100644
|
||||
--- a/tools/hciattach_bcm43xx.c
|
||||
+++ b/tools/hciattach_bcm43xx.c
|
||||
@@ -43,7 +43,7 @@
|
||||
#include "hciattach.h"
|
||||
|
||||
#ifndef FIRMWARE_DIR
|
||||
-#define FIRMWARE_DIR "/etc/firmware"
|
||||
+#define FIRMWARE_DIR "/lib/firmware"
|
||||
#endif
|
||||
|
||||
#define FW_EXT ".hcd"
|
||||
--
|
||||
1.9.1
|
||||
|
Loading…
Reference in New Issue
Block a user